source: projects/specs/trunk/l/lam/lam-vl.spec @ 10764

Revision 10764, 6.7 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1#
2# Copyright (c) 2001-2003 The Trustees of Indiana University. 
3#                         All rights reserved.
4# Copyright (c) 1998-2001 University of Notre Dame.
5#                         All rights reserved.
6# Copyright (c) 1994-1998 The Ohio State University. 
7#                         All rights reserved.
8#
9# This file is part of the LAM/MPI software package.  For license
10# information, see the LICENSE file in the top level directory of the
11# LAM/MPI source distribution.
12#
13# $Id: lam-generic.spec,v 1.3 2003/05/30 22:08:07 jsquyres Exp $
14#
15%define _sysconfdir /etc/lam
16%define _romiodocdir /usr/share/lam/doc
17Summary: LAM/MPI (Local Area Multicomputer) programming environment
18Summary(ja): MPIメッセージパッシング形式の並列アプリケーション作成環境
19Name: lam
20Version: 7.1.4
21Release: 3%{?_dist_release}
22License: BSD
23Group: Development/Libraries
24Source: lam-%{version}.tar.gz
25Patch: lam-helppath.patch
26URL: http://www.lam-mpi.org/
27ExcludeArch: ia64
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: gcc-gfortran
30Provides: mpi
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35LAM (Local Area Multicomputer) is an MPI programming environment and
36development system for heterogeneous computers on a network. With
37LAM/MPI, a dedicated cluster or an existing network computing
38infrastructure can act as one parallel computer solving one problem.
39LAM/MPI is considered to be "cluster friendly", in that it offers
40daemon-based process startup/control as well as fast client-to-client
41message passing protocols.  LAM/MPI can use TCP/IP and/or shared
42memory for message passing (different RPMs are supplied for this --
43see the main LAM web site for details).
44
45LAM features a full implementation of MPI-1 (with the exception that
46LAM does not support cancelling of sends), and much of MPI-2.
47Compliant applications are source code portable between LAM/MPI and
48any other implementation of MPI.  In addition to providing a
49high-quality implementation of the MPI standard, LAM/MPI offers
50extensive monitoring capabilities to support debugging.  Monitoring
51happens on two levels.  First, LAM/MPI has the hooks to allow a
52snapshot of process and message status to be taken at any time during
53an application run.  This snapshot includes all aspects of
54synchronization plus datatype maps/signatures, communicator group
55membership, and message contents (see the XMPI application on the main
56LAM web site).  On the second level, the MPI library is instrumented
57to produce a cummulative record of communication, which can be
58visualized either at runtime or post-mortem.
59
60
61%prep
62%setup -q
63
64# Otherwise, this directory shows up on security reports
65chmod -R o-w $RPM_BUILD_DIR/lam-%{version}
66
67
68%build
69%configure \
70        --with-rpi=usysv \
71        --with-fc=gfortran \
72        --enable-shared \
73        --enable-static \
74        --sysconfdir=%{_sysconfdir} \
75
76make %{?_smp_mflags} all
77
78
79%install
80rm -rf $RPM_BUILD_ROOT
81%makeinstall
82
83rm -f $RPM_BUILD_ROOT/usr/include/mpi++.h
84ln -s mpi2c++/mpi++.h $RPM_BUILD_ROOT/usr/include/mpi++.h
85
86# Rename the ROMIO doc files so that we can install them in the same
87# doc root later, and not overwrite LAM's doc files.
88
89for file in README README_LAM COPYRIGHT; do
90        mv $RPM_BUILD_DIR/lam-%{version}/romio/$file \
91                $RPM_BUILD_DIR/lam-%{version}/romio/romio-$file
92done
93mv $RPM_BUILD_DIR/lam-%{version}/romio/doc/users-guide.ps.gz \
94        $RPM_BUILD_DIR/lam-%{version}/romio/doc/romio-users-guide.ps.gz
95
96# remove unused files
97rm -f $RPM_BUILD_ROOT/%{_libdir}/lib*.la
98
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root)
106%doc LICENSE HISTORY INSTALL README
107%doc examples
108%doc doc/*.pdf
109# Need to fix ROMIO install script to install its docs in the Right place
110%doc %{_romiodocdir}
111%config %{_sysconfdir}
112%{_bindir}/*
113%{_mandir}/*/*
114%{_includedir}/*
115%{_libdir}/lam
116%{_libdir}/*.a
117%{_libdir}/*.so
118%{_libdir}/*.so.*
119#%{_datadir}/lam/lam-shell-setup.*
120#%{_datadir}/lam/lam_module.tcl
121
122
123%changelog
124* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 7.1.4-3
125- rebuild with gcc-5.4.0
126
127* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.1.4-2
128- rebuild with VineSeed environment
129
130* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 7.1.4-1vl5
131- fixed typo of last changelog release number
132- removed lib*.la
133
134* Sun Aug 24 2008 Shu KONNO <owa@bg.wakwak.com> 7.1.4-0.1vl5
135- applied new versioning policy, spec in utf-8
136- updated lam to 7.1.4
137- added japanese summary
138
139* Sun Dec 30 2007 Shu KONNO <owa@bg.wakwak.com> 7.0-1vl2
140- updated gcc-g77 to gcc-gfortran in BuildRequires
141- added "--with-fc=gfortran" to %%configure
142
143* Thu Aug 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.0-1vl1
144- based on new upstream
145  (http://www.lam-mpi.org/download/files/lam-7.0-1.src.rpm)
146- rebuild with new toolchains
147
148* Thu Dec 21 2000 Jun Nishii <jun@vinelinux.org>
149- 6.3.3b47-1vl2
150- build with gcc
151
152* Thu Dec 21 2000 Jun Nishii <jun@vinelinux.org>
153- 6.3.3b47-1vl1
154- use macros for spec
155- correct path of helpfile
156
157* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
158- 6.3.3b47
159
160* Thu Aug 17 2000 Trond Eivind Glomsrød <teg@redhat.com>
161- 6.3.3b28, which should match the release. One known
162  problem on SCO, otherwise none. This includes
163  fixing some programs which didn't work in the
164  last build.
165 
166* Thu Jul 27 2000 Harald Hoyer <harald@redhat.com>
167- fixed the install process, that the lam tools have the
168  right path set. make all;make DESTDIR install is
169  our friend.
170
171* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
172- a new and better world without dirty tricks necesarry.
173  All hail the 6.3.3beta (beta 20 - all my requests and
174  patches seem to be in now :)
175
176* Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
177- substituted some old dirty tricks for new ones to make
178  it build. More needed.
179- Removed C++ (won't build) and ROMIO (who cares) support
180
181* Thu Jun 15 2000 Trond Eivind Glomsrød <teg@redhat.com>
182- ugly tricks to make it use %%{_mandir}
183- patch to make it build with current compiler and glibc
184- don't build on IA64
185
186* Tue Apr 25 2000 Trond Eivind Glomsrød <teg@redhat.com>
187- changed RPI to usysv - this should be good for
188  (clusters of) SMPs.
189
190* Wed Mar 28 2000 Harald Hoyer <harald@redhat.com>
191- patched scheme Makefile
192
193* Tue Mar 28 2000 Harald Hoyer <harald@redhat.com>
194- new subminor version
195- patched Makefile to build otb daemons, to satisfy conf.otb and build all
196  stuff
197
198* Sat Mar 04 2000 Cristian Gafton <gafton@redhat.com>
199- fixed the whole tree the hard way - get into each Makefile and fix
200  brokeness on a case by case basis. Traces of Buildroot should be
201  erradicated by now.
202
203* Thu Mar 02 2000 Cristian Gafton <gafton@redhat.com>
204- put back the mpi2c++ stuff.
205
206* Tue Feb 29 2000 Cristian Gafton <gafton@redhat.com>
207- take out the mpi2c++ in a separate package
208
209* Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
210- first version of the package
Note: See TracBrowser for help on using the repository browser.