source: projects/specs/trunk/l/ladspa/ladspa-vl.spec @ 10587

Revision 10587, 6.1 KB checked in by tomop, 8 years ago (diff)

mlt-6.2.0-3

Line 
1Name:           ladspa
2Version:        1.13
3Release:        17%{?_dist_release}
4
5Summary:        Linux Audio Developer's Simple Plug-in API, examples and tools
6
7Group:          System Environment/Libraries
8License:        LGPLv2+
9URL:            http://www.ladspa.org/
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14Source:         http://www.ladspa.org/download/%{name}_sdk_%{version}.tgz
15Patch1:         ladspa-1.13-plugindir.patch
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires:  perl
19BuildRequires:  gcc-c++
20
21%description
22There is a large number of synthesis packages in use or development on
23the Linux platform at this time. The Linux Audio Developer's Simple
24Plugin API (LADSPA) attempts to give programmers the ability to write
25simple `plugin' audio processors in C/C++ and link them dynamically
26against a range of host applications.
27
28This package contains the example plug-ins and tools from the LADSPA SDK.
29
30%package        devel
31Summary:        Linux Audio Developer's Simple Plug-in API
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34
35%description    devel
36ladspa-devel contains the ladspa.h header file.
37
38Definitive technical documentation on LADSPA plug-ins for both the host
39and plug-in is contained within copious comments within the ladspa.h
40header file.
41
42
43%prep
44%setup -q -n ladspa_sdk
45%patch1 -p0 -b .plugindir
46# respect RPM_OPT_FLAGS
47perl -pi -e 's/^(CFLAGS.*)-O3(.*)/$1\$\(RPM_OPT_FLAGS\)$2 -DPLUGINDIR=\$\(PLUGINDIR\)/' src/makefile
48# avoid X.org dependency
49perl -pi -e 's/-mkdirhier/-mkdir -p/' src/makefile
50
51# fix links to the header file in the docs
52cd doc
53perl -pi -e "s!HREF=\"ladspa.h.txt\"!href=\"file:///usr/include/ladspa.h\"!" *.html
54
55
56%build
57cd src
58PLUGINDIR=\\\"%{_libdir}/ladspa\\\" make targets %{?_smp_mflags} LD="ld --build-id"
59
60#make test
61#make check
62
63
64%install
65rm -rf $RPM_BUILD_ROOT
66
67cd src
68make install \
69  INSTALL_PLUGINS_DIR=$RPM_BUILD_ROOT%{_libdir}/ladspa \
70  INSTALL_INCLUDE_DIR=$RPM_BUILD_ROOT%{_includedir} \
71  INSTALL_BINARY_DIR=$RPM_BUILD_ROOT%{_bindir}
72
73## this is where plugins will install their rdf
74mkdir -p $RPM_BUILD_ROOT%{_datadir}/ladspa/rdf
75
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80
81%files
82%defattr(-,root,root,-)
83%license doc/COPYING
84%dir %{_libdir}/ladspa
85%{_libdir}/ladspa/*.so
86%{_bindir}/analyseplugin
87%{_bindir}/applyplugin
88%{_bindir}/listplugins
89%{_datadir}/ladspa
90
91%files devel
92%defattr(-,root,root,-)
93%doc doc/*.html
94%{_includedir}/ladspa.h
95
96
97%changelog
98* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.13-17
99- initial build for Vine Linux.
100
101* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.13-16
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
103
104* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-15
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
106
107* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 1.13-14
108- Rebuilt for GCC 5 C++11 ABI change
109
110* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-13
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
112
113* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-12
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
115
116* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-11
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
118
119* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-10
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
121
122* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-9
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
124
125* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-8
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
127
128* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-7
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
130
131* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-6
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
133
134* Sun Mar 22 2009 Robert Scheck <robert@fedoraproject.org> - 1.13-5
135- Really added the plugindir patch now (thanks to Karsten Hopp)
136- Avoid the make errors because of mkdirhier better than until now
137
138* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-4
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
140
141* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-3
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
143
144* Sun Nov 23 2008 Thomas Vander Stichele <thomas at apestaart dot org>
145- 1.13-2
146- updated summary
147- not rebuilt yet
148
149* Fri Sep  5 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 1.13-1
150- link with build-id to fix rawhide build
151- upgrade to 1.13 (GCC4 build-fix and string fixes) (#449542)
152- add -plugindir patch so listplugin and friends will work by default
153  (Anthony Green #324741)
154
155* Tue Aug  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.12-10
156- fix license tag
157
158* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org>
159- 1.12-9
160- Autorebuild for GCC 4.3
161
162* Mon Apr 23 2007 Thomas Vander Stichele <thomas at apestaart dot org>
163- 1.12-8
164- own the datadir.  Fixes #231706.
165
166* Sat Sep 16 2006 Thomas Vander Stichele <thomas at apestaart dot org>
167- 1.12-7
168- include gcc 4.1 patch from Mandriva
169
170* Sun Mar 05 2006 Thomas Vander Stichele <thomas at apestaart dot org>
171- 1.12-6
172- rebuilt for FE5
173
174* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.12-5
175- rebuild on all arches
176
177* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
178- rebuilt
179
180* Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
181- 0:1.12-0.fdr.3: readded epoch, fixed group
182
183* Fri Sep 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
184- 1.12-0.fdr.2: fixed RPM_OPT_FLAGS respect
185
186* Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
187- 0:1.12-0.fdr.1: initial RPM release
Note: See TracBrowser for help on using the repository browser.