source: projects/specs/trunk/k/kturtle/kturtle-vl.spec @ 8430

Revision 8430, 3.3 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.12.5

Line 
1Name: kturtle
2Summary: Logo educational programming environment for KDE
3Summary(ja): Logo の教育用プログラミング環境
4Version: 4.12.5
5Release: 1%{?_dist_release}
6
7License: GPLv2+
8Group: Applications/Edutainment
9URL: http://edu.kde.org/parley/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13## upstream patches
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: desktop-file-utils
17BuildRequires: kdelibs4-devel >= %{version}
18
19Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
20
21Conflicts: kdeedu4 < 4.6.50
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27KTurtle is an educational programming environment which uses the
28TurtleScript programming language (inspired by Logo) to make programming
29as easy and accessible as possible.
30
31The user issues TurtleScript language commands to control the "turtle",
32which draws on the canvas, making KTurtle suitable for teaching elementary
33mathematics, geometry and programming.
34
35This package is part of the KDE education module.
36
37
38%prep
39%setup -q
40
41%build
42mkdir -p %{_target_platform}
43pushd %{_target_platform}
44%cmake \
45    -DCMAKE_BUILD_TYPE=release \
46    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
47    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
48    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
49    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
50    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
51    ..
52popd
53
54make %{?_smp_mflags} -C %{_target_platform}
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%check
64for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
65    desktop-file-validate $f
66done
67
68
69%post
70touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
71
72%posttrans
73update-desktop-database -q &> /dev/null ||:
74gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
75
76%postun
77if [ $1 -eq 0 ] ; then
78    update-desktop-database -q &> /dev/null ||:
79    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
80    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
81fi
82
83%files
84%defattr(-,root,root)
85%doc COPYING COPYING.DOC
86%{_bindir}/kturtle
87%{_datadir}/applications/kde4/kturtle.desktop
88%{_datadir}/config/*.knsrc
89%{_datadir}/icons/hicolor/*/*/*
90%{_datadir}/kde4/apps/kturtle
91%doc %{_docdir}/HTML/en/kturtle/
92
93%changelog
94* Wed May 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
95- new upstream release
96
97* Thu Feb 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
98- new upstream release
99
100* Wed Dec 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
101- new upstream release
102
103* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
104- new upstream release
105
106* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
107- new upstream release
108
109* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
110- new upstream release
111
112* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
113- new upstream release
114
115* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
116- new upstream release
117
118* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
119- new upstream release
120
121* Tue Aug 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
122- new upstream release
123
124* Wed Aug 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
125- split from kdeedu
126
Note: See TracBrowser for help on using the repository browser.