source: projects/specs/trunk/k/ksh/ksh-vl.spec @ 5321

Revision 5321, 13.6 KB checked in by kudoh, 12 years ago (diff)

ksh-vl.spec

Line 
1%global       releasedate 2011-06-30
2
3Name:         ksh
4Summary:      The Original ATT Korn Shell
5Summary(ja):   オリジナルの ATT Korn Shell
6URL:          http://www.kornshell.com/
7Group:        System Environment/Shells
8License:      CPL
9Version:      20110630
10Release:      1%{?_dist_release}
11Source0:      http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
12Source1:      http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
13Source3:      kshrc.rhs
14Source4:      dotkshrc
15#expected results of test suite
16#Source5:      expectedresults.log
17
18#don't use not wanted/needed builtins - Fedora/RHEL specific
19Patch1:       ksh-20070328-builtins.patch
20
21#fix regression test suite to be usable during packagebuild - Fedora/RHEL specific
22Patch2:       ksh-20100826-fixregr.patch
23
24# for ksh < 2011-08-03
25Patch3:       ksh-20110630-ifsfix.patch
26
27# sent upstream, for ksh <= 2011-08-12
28Patch4:       ksh-20110630-fixkill.patch
29
30Patch5:       ksh-20110630-tmoutfix.patch
31
32Patch6:       ksh-20110630-joblimit.patch
33
34Patch7:       ksh-20110630-dontstop.patch
35
36Patch8:       ksh-20110630-ddotfix.patch
37
38Patch9:       ksh-20110630-histfix.patch
39
40BuildRoot:    %{_tmppath}/%{name}-%{version}-root
41Conflicts:    pdksh
42Requires: coreutils, glibc-common, diffutils
43BuildRequires: bison
44# regression test suite uses 'ps' from procps
45BuildRequires: procps
46Requires(post): grep, coreutils
47Requires(preun): grep, coreutils
48
49%description
50KSH-93 is the most recent version of the KornShell by David Korn of
51AT&T Bell Laboratories.
52KornShell is a shell programming language, which is upward compatible
53with "sh" (the Bourne Shell).
54
55%prep
56%setup -q -c
57%setup -q -T -D -a 1
58%patch1 -p1 -b .builtins
59%patch2 -p1 -b .fixregr
60%patch3 -p1 -b .ifsfix
61%patch4 -p1 -b .fixkill
62%patch5 -p1 -b .tmoutfix
63%patch6 -p1 -b .joblimit
64%patch7 -p1 -b .dontstop
65%patch8 -p1 -b .ddotfix
66%patch9 -p1 -b .histfix
67
68#/dev/fd test does not work because of mock
69sed -i 's|ls /dev/fd|ls /proc/self/fd|' src/cmd/ksh93/features/options
70
71%build
72./bin/package
73./bin/package make mamake ||:
74./bin/package make mamake ||:
75export CCFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
76export CC=gcc
77./bin/package "make"
78
79cp lib/package/LICENSES/cpl LICENSE
80
81%install
82rm -rf $RPM_BUILD_ROOT
83mkdir -p $RPM_BUILD_ROOT{/bin,%{_bindir},%{_mandir}/man1}
84install -c -m 755 arch/*/bin/ksh $RPM_BUILD_ROOT/bin/ksh
85install -c -m 755 arch/*/bin/shcomp $RPM_BUILD_ROOT%{_bindir}/shcomp
86install -c -m 644 arch/*/man/man1/sh.1 $RPM_BUILD_ROOT%{_mandir}/man1/ksh.1
87mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/skel
88install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/skel/.kshrc
89install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/kshrc
90
91%post
92if [ ! -f /etc/shells ]; then
93        echo "/bin/ksh" > /etc/shells
94else
95        if ! grep -q '^/bin/ksh$' /etc/shells ; then
96                echo "/bin/ksh" >> /etc/shells
97        fi
98fi
99
100%postun
101if [ ! -f /bin/ksh ]; then
102        sed -i '/^\/bin\/ksh$/ d' /etc/shells
103fi
104
105%verifyscript
106echo -n "Looking for ksh in /etc/shells... "
107if ! grep '^/bin/ksh$' /etc/shells > /dev/null; then
108    echo "missing"
109    echo "ksh missing from /etc/shells" >&2
110else
111    echo "found"
112fi
113
114%files
115%defattr(-, root, root,-)
116%doc src/cmd/ksh93/COMPATIBILITY src/cmd/ksh93/RELEASE src/cmd/ksh93/TYPES LICENSE
117/bin/ksh
118/usr/bin/shcomp
119%{_mandir}/man1/*
120%config(noreplace) %{_sysconfdir}/skel/.kshrc
121%config(noreplace) %{_sysconfdir}/kshrc
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%changelog
127* Sat Dec 24 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 20110630-1
128- initial build for VineSeed
129
130* Wed Dec 07 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110630-9
131- do not crash when browsing through history containing comment (#733813)
132
133* Wed Dec 07 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110630-8
134- do not crash when two subseguent dots are used in variable or command name (#733544)
135
136* Mon Dec 05 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110630-7
137- fix: ksh can prematurely exit without crash or any error
138- make spec work in epel
139
140* Thu Nov 10 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110630-6
141- add files to %%doc
142
143* Thu Oct 06 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110630-5
144- ksh sometimes returns wrong exit code when pid numbers are being recycled
145
146* Tue Oct 04 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110630-4
147- restore tty settings after timed out read (#572291)
148
149* Fri Aug 12 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110630-3
150- do not crash when killing last bg job when there is not any
151
152* Wed Aug 03 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110630-2
153- fix: IFS manipulation in a function can cause crash
154
155* Fri Jul 01 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110630-1
156- ksh updated to 2011-06-30
157
158* Wed Jun 08 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110505-2
159- fix: resume of suspended process using pipes does not work (#708909)
160
161* Mon May 09 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110505-1
162- ksh updated to 2011-05-05
163
164* Fri Apr 29 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110428-1
165- ksh updated to 2011-04-28
166
167* Mon Apr 18 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110415-1
168- ksh updated to 2011-04-15
169
170* Tue Mar 29 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110208-3
171- fix array definition being treated as fixed array
172- fix suspend crashing ksh
173
174* Mon Mar 07 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110208-2
175- fix ( ) compound list altering environment
176
177* Wed Feb 09 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110208-1
178- ksh updated to 2011-02-08
179
180* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 20110202-2
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
182
183* Fri Feb 04 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110202-1
184- ksh updated to 2011-02-02
185
186* Wed Feb 02 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110131-1
187- ksh updated to 2011-01-31
188
189* Fri Jan 28 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110127-1
190- ksh updated to 2011-01-27
191
192* Thu Jan 20 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110118-1
193- ksh updated to 2011-01-18
194
195* Mon Jan 17 2011 Michal Hlavinka <mhlavink@redhat.com> - 20110104-1
196- ksh updated to 2011-01-04
197
198* Thu Dec 23 2010 Michal Hlavinka <mhlavink@redhat.com> - 20101212-2.20101122
199- found ugly regression, reverting to 2010-11-22 (with io race patch) for now
200
201* Thu Dec 16 2010 Michal Hlavinka <mhlavink@redhat.com> - 20101212-1
202- ksh updated to 2010-12-12
203
204* Mon Dec 06 2010 Michal Hlavinka <mhlavink@redhat.com> - 20101201-2
205- fix file io race condition when file was created, but still does not exist
206
207* Fri Dec 03 2010 Michal Hlavinka <mhlavink@redhat.com> - 20101201-1
208- ksh updated to 2010-12-01
209
210* Tue Nov 23 2010 Michal Hlavinka <mhlavink@redhat.com> - 20101122-1
211- ksh updated to 2010-11-22
212
213* Mon Nov 01 2010 Michal Hlavinka <mhlavink@redhat.com> - 20101026-1
214- ksh updated to 2010-10-26
215
216* Tue Oct 12 2010 Michal Hlavinka <mhlavink@redhat.com> - 20101010-1
217- ksh updated to 2010-10-10
218
219* Fri Oct 08 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100924-2
220- disable only known to be broken builtins, let other enabled
221- skip regression tests if /dev/fd is missing
222
223* Tue Sep 28 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100924-1
224- ksh updated to 2010-09-24
225
226* Mon Aug 30 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100826-1
227- ksh updated to 2010-08-26
228- make regression test suite usable during package build
229
230* Fri Aug 13 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100811-1
231- ksh updated to 2010-08-11
232
233* Thu Jul 08 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100701-1
234- updated to 2010-07-01
235
236* Fri Jun 25 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100621-1
237- updated to 2010-06-21
238
239* Tue Jun 15 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100527-2
240- add shcomp for shell compiling
241
242* Thu Jun 10 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100527-1
243- updated to 2010-05-27
244
245* Mon May 31 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100309-6
246- add pathmunge to /etc/kshrc
247
248* Wed May 05 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100309-5
249- fix rare cd builtin crash (#578582)
250
251* Wed May 05 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100309-4
252- fix infinite loop when whence builtin is used with -q option (#587127)
253- fix stdin for double command substitution (#584007)
254
255* Mon Mar 29 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100309-3
256- fix typo in last patch
257
258* Fri Mar 26 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100309-2
259- restore tty settings after timed out read for utf-8 locale
260
261* Wed Mar 10 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100309-1
262- updated to 2010-03-09
263- fix mock building - detection of /dev/fd/X
264
265* Mon Jan 04 2010 Michal Hlavinka <mhlavink@redhat.com> - 20100202-1
266- updated to 2010-02-02
267
268* Mon Jan 04 2010 Michal Hlavinka <mhlavink@redhat.com> - 20091224-1
269- updated to 2009-12-24
270
271* Mon Dec 07 2009 Michal Hlavinka <mhlavink@redhat.com> - 20091206-1
272- updated to 2009-12-06
273
274* Fri Dec 04 2009 Michal Hlavinka <mhlavink@redhat.com> - 20091130-1
275- updated to 2009-11-30
276
277* Wed Nov 18 2009 Michal Hlavinka <mhlavink@redhat.com> - 20091021-1
278- updated to 2009-10-21
279
280* Thu Aug 27 2009 Michal Hlavinka <mhlavink@redhat.com> - 20090630-1
281- updated to 2009-06-30
282
283* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 20090505-2
284- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
285
286* Mon May 11 2009 Michal Hlavinka <mhalvink@redhat.com> - 20090505-1
287- updated to 2009-05-05
288
289* Tue May 05 2009 Michal Hlavinka <mhalvink@redhat.com> - 20090501-1
290- updated to 2009-05-01
291
292* Tue Mar 10 2009 Michal Hlavinka <mhlavink@redhat.com> - 20081104-3
293- fix typos in spec file
294
295* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 20081104-2
296- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
297
298* Tue Jan 21 2009 Michal Hlavinka <mhlavink@redhat.com> 20081104-1
299- update to 2008-11-04
300- ast-ksh-locales are not useable remove them
301
302* Tue Oct 21 2008 Michal Hlavinka <mhlavink@redhat.com> 20080725-4
303- fix #467025 - Ksh fails to initialise environment when login from graphic console
304
305* Wed Aug 06 2008 Tomas Smetana <tsmetana@redhat.com> 20080725-3
306- fix BuildRequires, rebuild
307
308* Tue Aug  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 20080725-2
309- fix license tag
310
311* Mon Jul 28 2008 Tomas Smetana <tsmetana@redhat.com> 20080725-1
312- new upstream version
313
314* Thu Jun 26 2008 Tomas Smetana <tsmetana@redhat.com> 20080624-1
315- new upstream version
316
317* Mon Feb 11 2008 Tomas Smetana <tsmetana@redhat.com> 20080202-1
318- new upstream version
319
320* Wed Jan 30 2008 Tomas Smetana <tsmetana@redhat.com> 20071105-3
321- fix #430602 - ksh segfaults after unsetting OPTIND
322
323* Mon Jan 07 2008 Tomas Smetana <tsmetana@redhat.com> 20071105-2
324- fix #405381 - ksh will not handle $(xxx) when typeset -r IFS
325- fix #386501 - bad group in spec file
326
327* Wed Nov 07 2007 Tomas Smetana <tsmetana@redhat.com> 20071105-1
328- new upstream version
329
330* Wed Aug 22 2007 Tomas Smetana <tsmetana@redhat.com> 20070628-1.1
331- rebuild
332
333* Thu Jul 12 2007 Tomas Smetana <tsmetana@redhat.com> 20070628-1
334- new upstream version
335- fix unaligned access messages (Related: #219420)
336
337* Tue May 22 2007 Tomas Smetana <tsmetana@redhat.com> 20070328-2
338- fix wrong exit status of spawned process after SIGSTOP
339- fix building of debuginfo package, add %%{?dist} to release
340- fix handling of SIGTTOU in non-interactive shell
341- remove useless builtins
342
343* Thu Apr 19 2007 Tomas Smetana <tsmetana@redhat.com> 20070328-1
344- new upstream source
345- fix login shell invocation (#182397)
346- fix memory leak
347
348* Wed Feb 21 2007 Karsten Hopp <karsten@redhat.com> 20070111-1
349- new upstream version
350- fix invalid write in uname function
351
352* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 20060214-1.1
353- rebuild
354
355* Thu Jun 01 2006 Karsten Hopp <karsten@redhat.de> 20060214-1
356- new upstream source
357
358* Mon Feb 27 2006 Karsten Hopp <karsten@redhat.de> 20060124-3
359- PreReq grep, coreutils (#182835)
360
361* Tue Feb 14 2006 Karsten Hopp <karsten@redhat.de> 20060124-2
362- make it build in chroots (#180561)
363
364* Mon Feb 13 2006 Karsten Hopp <karsten@redhat.de> 20060124-1
365- version 20060124
366
367* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 20050202-5.1
368- bump again for double-long bug on ppc(64)
369
370* Fri Feb 10 2006 Karsten Hopp <karsten@redhat.de> 20050202-5
371- rebuild
372
373* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 20050202-4.1
374- rebuilt for new gcc4.1 snapshot and glibc changes
375
376* Thu Feb 02 2006 Karsten Hopp <karsten@redhat.de> 20050202-4
377- fix uname -i output
378- fix loop (*-path.patch)
379- conflict pdksh instead of obsoleting it
380
381* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com> 20050202-3.1
382- rebuilt for new gcj
383
384* Tue May 10 2005 Karsten Hopp <karsten@redhat.de> 20050202-3
385- enable debuginfo
386
387* Tue Mar 15 2005 Karsten Hopp <karsten@redhat.de> 20050202-2
388- add /usr/bin/ksh link for compatibility with pdksh scripts (#151134)
389
390* Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 20050202-1
391- update and rebuild with gcc-4
392
393* Tue Mar 01 2005 Karsten Hopp <karsten@redhat.de> 20041225-2
394- fix gcc4 build
395
396* Fri Jan 21 2005 Karsten Hopp <karsten@redhat.de> 20041225-1
397- rebuild with new ksh tarball (license change)
398
399* Tue Nov 02 2004 Karsten Hopp <karsten@redhat.de> 20040229-11
400- disable ia64 for now
401
402* Fri Oct 15 2004 Karsten Hopp <karsten@redhat.de> 20040229-9
403- rebuild
404
405* Thu Sep 02 2004 Nalin Dahyabhai <nalin@redhat.com> 20040229-8
406- remove '&' from summary
407
408* Thu Sep 02 2004 Bill Nottingham <notting@redhat.com> 20040229-7
409- obsolete pdksh (#131303)
410
411* Mon Aug 02 2004 Karsten Hopp <karsten@redhat.de> 20040229-6
412- obsolete ksh93, provide ksh93
413
414* Mon Jul 05 2004 Karsten Hopp <karsten@redhat.de> 20040229-3
415- add /bin/ksh to /etc/shells
416
417* Wed Jun 16 2004 Karsten Hopp <karsten@redhat.de> 20040229-2
418- add ppc64 patch to avoid ppc64 dot symbol problem
419
420* Fri May 28 2004 Karsten Hopp <karsten@redhat.de> 20040229-1
421- initial version
422
Note: See TracBrowser for help on using the repository browser.