source: projects/specs/trunk/k/kremotecontrol/kremotecontrol-vl.spec @ 10563

Revision 10563, 2.5 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:    kremotecontrol
2Summary: Remote control utility for KDE
3Summary(ja): KDE用リモート・コントロールユーティリティー
4Version: 4.14.3
5Release: 2%{?_dist_release}
6
7License: GPLv2
8Group:   Applications/Accessories
9URL:     https://www.kde.org/
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: kdelibs-devel >= %{version}
16BuildRequires: soprano-devel
17
18# when split occurred
19Conflicts: kdeutils < 4.8.0
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25This module allows you to configure your remote controls.
26You can assign actions that are executed on button presses.
27Actions can start applications, control them or execute
28system commands, such as powering off your computer.
29
30
31%prep
32%setup -q
33
34
35%build
36mkdir -p %{_target_platform}
37pushd %{_target_platform}
38%cmake \
39    -DCMAKE_BUILD_TYPE=release \
40    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
41    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
42    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
43    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
44    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
45    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
46    ..
47popd
48
49make %{?_smp_mflags} -C %{_target_platform}
50
51
52%install
53rm -rf %{buildroot}
54
55make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
56
57
58%post
59/sbin/ldconfig
60touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
61
62%posttrans
63update-desktop-database -q &> /dev/null ||:
64gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
65
66%postun
67if [ $1 -eq 0 ] ; then
68  /sbin/ldconfig
69  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
70  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
71  update-desktop-database -q &> /dev/null ||:
72fi
73
74
75%files
76%doc COPYING COPYING.LIB README
77%{_bindir}/krcdnotifieritem
78%{_libdir}/liblibkremotecontrol.so.*
79%{_libdir}/kde4/*.so
80%{_datadir}/applications/kde4/krcdnotifieritem.desktop
81%{_datadir}/icons/hicolor/*/*/*
82%{_datadir}/kde4/apps/%{name}
83%{_datadir}/kde4/apps/%{name}daemon/
84%{_datadir}/kde4/services/*.desktop
85%{_datadir}/kde4/services/kded/kremotecontroldaemon.desktop
86%{_datadir}/kde4/services/kremotecontrolbackends/kremotecontrol_lirc.desktop
87%{_datadir}/kde4/servicetypes/*.desktop
88%{_docdir}/HTML/en/kcontrol
89%exclude %{_libdir}/liblibkremotecontrol.so
90
91%changelog
92* Fri Jul 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
93- rebuild with gcc-5.4.0
94
95* Fri Jan 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
96- initila build
Note: See TracBrowser for help on using the repository browser.