source: projects/specs/trunk/k/korundum/korundum-vl.spec @ 9079

Revision 9079, 7.7 KB checked in by inagaki, 9 years ago (diff)

2014-11-12 Ryoichi INAGAKI <ryo1@…>

  • QtRuby?, korundum: fixed install location


Line 
1%global ruby_vendorlib %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorlibdir"]')
2%global ruby_vendorarch %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorarchdir"]')
3
4Name:    korundum
5Summary:  Ruby bindings for KDE
6Summary(ja): KDE の Ruby バインディング
7Version: 4.12.5
8Release: 2%{?_dist_release}
9
10License: LGPLv2+ and GPLv2+
11Group:   System Environment/Libraries
12URL:     https://techbase.kde.org/Development/Languages/Ruby
13
14Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: cmake
18BuildRequires: akonadi-devel
19BuildRequires: kate-devel >= %{version}
20BuildRequires: kdelibs4-devel >= %{version}
21BuildRequires: kdepimlibs-devel >= %{version}
22BuildRequires: okular-devel >= %{version}
23BuildRequires: QtRuby-devel >= %{version}
24BuildRequires: ruby-devel >= 1.8
25BuildRequires: shared-desktop-ontologies-devel
26BuildRequires: smokekde-devel >= %{version}
27BuildRequires: smokeqt-devel >= %{version}
28BuildRequires: soprano-devel
29
30Requires: QtRuby >= %{version}
31Requires: smokekde >= %{version}
32Requires: smokeqt >= %{version}
33
34%description
35%{summary}.
36
37%package devel
38Summary: Development libraries for %{name}
39Summary(ja): %{name} の開発用ファイル
40Group:   Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44%{summary}.
45
46
47%prep
48%setup -q
49
50
51%build
52mkdir -p %{_target_platform}
53pushd %{_target_platform}
54
55%cmake \
56    -DCMAKE_BUILD_TYPE=release \
57    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
58    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
59    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
60    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
61    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
62    -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_vendorarch} \
63    -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_vendorlib} \
64    ..
65popd
66
67make %{?_smp_mflags} -C %{_target_platform}
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
73
74
75%post -p /sbin/ldconfig
76%postun -p /sbin/ldconfig
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(-,root,root,-)
83%doc AUTHORS COPYING COPYING.LIB README
84%{_bindir}/krubyapplication
85%{ruby_vendorlib}/KDE/
86%{ruby_vendorlib}/akonadi/
87%{ruby_vendorlib}/khtml/
88%{ruby_vendorlib}/kio/
89%{ruby_vendorlib}/ktexteditor/
90%{ruby_vendorlib}/okular/
91%{ruby_vendorlib}/solid/
92%{ruby_vendorlib}/soprano/
93%{ruby_vendorlib}/nepomuk/
94%{ruby_vendorarch}/akonadi.so
95%{ruby_vendorarch}/kate.so
96%{ruby_vendorarch}/khtml.so
97%{ruby_vendorarch}/kio.so
98%{ruby_vendorarch}/korundum4.so
99%{ruby_vendorarch}/ktexteditor.so
100%{ruby_vendorarch}/okular.so
101%{ruby_vendorarch}/plasma_applet.so
102%{ruby_vendorarch}/solid.so
103%{ruby_vendorarch}/soprano.so
104%{ruby_vendorarch}/nepomuk.so
105%{_libdir}/kde4/krubypluginfactory.so
106%{_datadir}/applications/kde4/dbpedia_references.desktop
107%{_datadir}/kde4/apps/dbpedia_references
108%{_datadir}/kde4/apps/plasma_applet_ruby_clock/
109%{_datadir}/kde4/apps/plasma_ruby_digital_clock/
110%{_datadir}/kde4/services/*.desktop
111
112%files devel
113%defattr(-,root,root,-)
114%{_bindir}/rbkconfig_compiler4
115
116%changelog
117* Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-2
118- installed modules to vendor_ruby
119
120* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-1
121- splitted from kdebindings
122
123* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
124- new upstream release
125
126* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
127- updated to 4.6.1
128- added BR: kdesdk-devel
129- disabled attica plugins temporaly
130- rebuilt with mono-2.10.1
131
132* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
133- rebuilt with rpm-4.8.1 for pkg-config
134
135* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
136- new upstream release
137- added Patch50
138- added more japanese summaries
139
140* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
141- new upstream release
142
143* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
144- new upstream release
145
146* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
147- new upstream release
148
149* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
150- new upstream release
151
152* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
153- new upstream release
154- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
155  (see https://bugs.kde.org/show_bug.cgi?id=214824)
156- built with new toolchain
157
158* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
159- new upstream release
160
161* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
162- merged 4.3.1-2 %changelog
163- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
164
165* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
166- use %%{_prefix}/lib for mono-dll (for x86_64)
167
168* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
169- new upstream release
170- built with PyQt4-4.6
171
172* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
173- define %%{mono_dir} to specify mono library install path
174
175* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
176- new upstream release
177- fixed ruby modules installation path
178
179* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
180- new upstream release
181- spilt sub package based on Fedora
182
183* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
184- applied new versioning policy
185- added Patch1
186  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
187
188* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
189- added --with-qt-libraries option
190
191* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
192- rebuild for VineSeed
193
194* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
195- new upstream release
196
197* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
198- rebuild for VineSeed
199
200* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
201- new upstream release
202- update Patch0
203- drop Patch1
204
205* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
206- new upstream release
207- add Patch1
208- add --enable-libsuffix option
209
210* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
211- rebuild for VineSeed
212
213* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
214- new upstream release
215
216* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
217- rebuild for VineSeed
218
219* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
220- new upstream release
221
222* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
223- rebuild for VineSeed
224
225* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
226- new upstream release
227
228* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
229- rebuild for VineSeed
230
231* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
232- new upstream release
233
234* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
235- rebuild for VineSeed
236
237* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
238- new upstream release
239- renew BuildPrereq and build section
240- renew %%files
241- enable python
242- change spec to make main and devel package
243- add BuildPrereq: ruby ruby-devel
244- add Patch0 to install ruby-bindings under /usr/lib/ruby
245
246* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
247- build for VineSeed
248- disable python and mozilla
249- objprelink (i386 only)
250
251* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
252- 2.2.2
253- build kmozilla binding only on x86/alpha
254
255* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
256- Make sure %%{name}-kmozilla isn't built on ia64
257
258* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
259- Move python bindings to separate package
260- Add perl bindings
261- Shut up rpmlint
262
263* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
264- 2.1
265
266* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
267- initial RPM
Note: See TracBrowser for help on using the repository browser.