source: projects/specs/trunk/k/korundum/korundum-vl.spec @ 9075

Revision 9075, 7.5 KB checked in by inagaki, 10 years ago (diff)

2014-11-09 Ryoichi INAGAKI <ryo1@…>

  • QtRuby?, kimono, korundum, qwt, qyoto, smokegen, smokekde, smokeqt: NEW
  • kdebindings: updated


Line 
1%global ruby_lib %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["rubylibdir"]')
2%global ruby_arch %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["archdir"]')
3
4Name:    korundum
5Summary:  Ruby bindings for KDE
6Summary(ja): KDE の Ruby バインディング
7Version: 4.12.5
8Release: 1%{?_dist_release}
9
10License: LGPLv2+ and GPLv2+
11Group:   System Environment/Libraries
12URL:     https://techbase.kde.org/Development/Languages/Ruby
13
14Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: cmake
18BuildRequires: akonadi-devel
19BuildRequires: kate-devel >= %{version}
20BuildRequires: kdelibs4-devel >= %{version}
21BuildRequires: kdepimlibs-devel >= %{version}
22BuildRequires: okular-devel >= %{version}
23BuildRequires: QtRuby-devel >= %{version}
24BuildRequires: ruby-devel >= 1.8
25BuildRequires: shared-desktop-ontologies-devel
26BuildRequires: smokekde-devel >= %{version}
27BuildRequires: smokeqt-devel >= %{version}
28BuildRequires: soprano-devel
29
30Requires: QtRuby >= %{version}
31Requires: smokekde >= %{version}
32Requires: smokeqt >= %{version}
33
34%description
35%{summary}.
36
37%package devel
38Summary: Development libraries for %{name}
39Summary(ja): %{name} の開発用ファイル
40Group:   Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44%{summary}.
45
46
47%prep
48%setup -q
49
50
51%build
52mkdir -p %{_target_platform}
53pushd %{_target_platform}
54
55%cmake \
56    -DCMAKE_BUILD_TYPE=release \
57    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
58    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
59    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
60    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
61    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
62    -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_arch} \
63    -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_lib} \
64    ..
65popd
66
67make %{?_smp_mflags} -C %{_target_platform}
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
73
74
75%post -p /sbin/ldconfig
76%postun -p /sbin/ldconfig
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(-,root,root,-)
83%doc AUTHORS COPYING COPYING.LIB README
84%{_bindir}/krubyapplication
85%{ruby_lib}/KDE/
86%{ruby_lib}/akonadi/
87%{ruby_lib}/khtml/
88%{ruby_lib}/kio/
89%{ruby_lib}/ktexteditor/
90%{ruby_lib}/okular/
91%{ruby_lib}/solid/
92%{ruby_lib}/soprano/
93%{ruby_lib}/nepomuk/
94%{ruby_arch}/akonadi.so
95%{ruby_arch}/kate.so
96%{ruby_arch}/khtml.so
97%{ruby_arch}/kio.so
98%{ruby_arch}/korundum4.so
99%{ruby_arch}/ktexteditor.so
100%{ruby_arch}/okular.so
101%{ruby_arch}/plasma_applet.so
102%{ruby_arch}/solid.so
103%{ruby_arch}/soprano.so
104%{ruby_arch}/nepomuk.so
105%{_libdir}/kde4/krubypluginfactory.so
106%{_datadir}/applications/kde4/dbpedia_references.desktop
107%{_datadir}/kde4/apps/dbpedia_references
108%{_datadir}/kde4/apps/plasma_applet_ruby_clock/
109%{_datadir}/kde4/apps/plasma_ruby_digital_clock/
110%{_datadir}/kde4/services/*.desktop
111
112%files devel
113%defattr(-,root,root,-)
114%{_bindir}/rbkconfig_compiler4
115
116%changelog
117* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-1
118- splitted from kdebindings
119
120* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
121- new upstream release
122
123* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
124- updated to 4.6.1
125- added BR: kdesdk-devel
126- disabled attica plugins temporaly
127- rebuilt with mono-2.10.1
128
129* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
130- rebuilt with rpm-4.8.1 for pkg-config
131
132* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
133- new upstream release
134- added Patch50
135- added more japanese summaries
136
137* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
138- new upstream release
139
140* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
141- new upstream release
142
143* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
144- new upstream release
145
146* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
147- new upstream release
148
149* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
150- new upstream release
151- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
152  (see https://bugs.kde.org/show_bug.cgi?id=214824)
153- built with new toolchain
154
155* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
156- new upstream release
157
158* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
159- merged 4.3.1-2 %changelog
160- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
161
162* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
163- use %%{_prefix}/lib for mono-dll (for x86_64)
164
165* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
166- new upstream release
167- built with PyQt4-4.6
168
169* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
170- define %%{mono_dir} to specify mono library install path
171
172* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
173- new upstream release
174- fixed ruby modules installation path
175
176* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
177- new upstream release
178- spilt sub package based on Fedora
179
180* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
181- applied new versioning policy
182- added Patch1
183  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
184
185* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
186- added --with-qt-libraries option
187
188* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
189- rebuild for VineSeed
190
191* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
192- new upstream release
193
194* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
195- rebuild for VineSeed
196
197* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
198- new upstream release
199- update Patch0
200- drop Patch1
201
202* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
203- new upstream release
204- add Patch1
205- add --enable-libsuffix option
206
207* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
208- rebuild for VineSeed
209
210* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
211- new upstream release
212
213* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
214- rebuild for VineSeed
215
216* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
217- new upstream release
218
219* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
220- rebuild for VineSeed
221
222* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
223- new upstream release
224
225* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
226- rebuild for VineSeed
227
228* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
229- new upstream release
230
231* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
232- rebuild for VineSeed
233
234* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
235- new upstream release
236- renew BuildPrereq and build section
237- renew %%files
238- enable python
239- change spec to make main and devel package
240- add BuildPrereq: ruby ruby-devel
241- add Patch0 to install ruby-bindings under /usr/lib/ruby
242
243* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
244- build for VineSeed
245- disable python and mozilla
246- objprelink (i386 only)
247
248* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
249- 2.2.2
250- build kmozilla binding only on x86/alpha
251
252* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
253- Make sure %%{name}-kmozilla isn't built on ia64
254
255* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
256- Move python bindings to separate package
257- Add perl bindings
258- Shut up rpmlint
259
260* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
261- 2.1
262
263* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
264- initial RPM
Note: See TracBrowser for help on using the repository browser.