source: projects/specs/trunk/k/korundum/korundum-vl.spec @ 9748

Revision 9748, 7.9 KB checked in by Takemikaduchi, 9 years ago (diff)

rebuild with ruby-2.2.3

Line 
1%global ruby_vendorlib %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorlibdir"]')
2%global ruby_vendorarch %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorarchdir"]')
3
4Name:    korundum
5Summary:  Ruby bindings for KDE
6Summary(ja): KDE の Ruby バインディング
7Version: 4.14.3
8Release: 2%{?_dist_release}
9
10License: LGPLv2+ and GPLv2+
11Group:   System Environment/Libraries
12URL:     https://techbase.kde.org/Development/Languages/Ruby
13
14Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: cmake
18BuildRequires: akonadi-devel
19BuildRequires: kate-devel >= %{version}
20BuildRequires: kdelibs4-devel >= %{version}
21BuildRequires: kdepimlibs-devel >= %{version}
22BuildRequires: okular-devel >= %{version}
23BuildRequires: QtRuby-devel >= %{version}
24BuildRequires: ruby-devel >= 1.8
25BuildRequires: shared-desktop-ontologies-devel
26BuildRequires: smokekde-devel >= %{version}
27BuildRequires: smokeqt-devel >= %{version}
28BuildRequires: soprano-devel
29
30Requires: QtRuby >= %{version}
31Requires: smokekde >= %{version}
32Requires: smokeqt >= %{version}
33
34%description
35%{summary}.
36
37%package devel
38Summary: Development libraries for %{name}
39Summary(ja): %{name} の開発用ファイル
40Group:   Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44%{summary}.
45
46
47%prep
48%setup -q
49
50
51%build
52mkdir -p %{_target_platform}
53pushd %{_target_platform}
54
55%cmake \
56    -DCMAKE_BUILD_TYPE=release \
57    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
58    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
59    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
60    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
61    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
62    -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_vendorarch} \
63    -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_vendorlib} \
64    ..
65popd
66
67make %{?_smp_mflags} -C %{_target_platform}
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
73
74
75%post -p /sbin/ldconfig
76%postun -p /sbin/ldconfig
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(-,root,root,-)
83%doc AUTHORS COPYING COPYING.LIB README
84%{_bindir}/krubyapplication
85%{ruby_vendorlib}/KDE/
86%{ruby_vendorlib}/akonadi/
87%{ruby_vendorlib}/khtml/
88%{ruby_vendorlib}/kio/
89%{ruby_vendorlib}/ktexteditor/
90%{ruby_vendorlib}/okular/
91%{ruby_vendorlib}/solid/
92%{ruby_vendorlib}/soprano/
93%{ruby_vendorlib}/nepomuk/
94%{ruby_vendorarch}/akonadi.so
95%{ruby_vendorarch}/kate.so
96%{ruby_vendorarch}/khtml.so
97%{ruby_vendorarch}/kio.so
98%{ruby_vendorarch}/korundum4.so
99%{ruby_vendorarch}/ktexteditor.so
100%{ruby_vendorarch}/okular.so
101%{ruby_vendorarch}/plasma_applet.so
102%{ruby_vendorarch}/solid.so
103%{ruby_vendorarch}/soprano.so
104%{ruby_vendorarch}/nepomuk.so
105%{_libdir}/kde4/krubypluginfactory.so
106%{_datadir}/applications/kde4/dbpedia_references.desktop
107%{_datadir}/kde4/apps/dbpedia_references
108%{_datadir}/kde4/apps/plasma_applet_ruby_clock/
109%{_datadir}/kde4/apps/plasma_ruby_digital_clock/
110%{_datadir}/kde4/services/*.desktop
111
112%files devel
113%defattr(-,root,root,-)
114%{_bindir}/rbkconfig_compiler4
115
116%changelog
117* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
118- rebuild with ruby-2.2.3
119
120* Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-1
121- updated to 4.14.3
122- built with okluar-libs 4.14.3
123
124* Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-2
125- installed modules to vendor_ruby
126
127* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-1
128- splitted from kdebindings
129
130* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
131- new upstream release
132
133* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
134- updated to 4.6.1
135- added BR: kdesdk-devel
136- disabled attica plugins temporaly
137- rebuilt with mono-2.10.1
138
139* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
140- rebuilt with rpm-4.8.1 for pkg-config
141
142* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
143- new upstream release
144- added Patch50
145- added more japanese summaries
146
147* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
148- new upstream release
149
150* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
151- new upstream release
152
153* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
154- new upstream release
155
156* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
157- new upstream release
158
159* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
160- new upstream release
161- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
162  (see https://bugs.kde.org/show_bug.cgi?id=214824)
163- built with new toolchain
164
165* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
166- new upstream release
167
168* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
169- merged 4.3.1-2 %changelog
170- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
171
172* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
173- use %%{_prefix}/lib for mono-dll (for x86_64)
174
175* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
176- new upstream release
177- built with PyQt4-4.6
178
179* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
180- define %%{mono_dir} to specify mono library install path
181
182* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
183- new upstream release
184- fixed ruby modules installation path
185
186* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
187- new upstream release
188- spilt sub package based on Fedora
189
190* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
191- applied new versioning policy
192- added Patch1
193  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
194
195* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
196- added --with-qt-libraries option
197
198* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
199- rebuild for VineSeed
200
201* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
202- new upstream release
203
204* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
205- rebuild for VineSeed
206
207* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
208- new upstream release
209- update Patch0
210- drop Patch1
211
212* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
213- new upstream release
214- add Patch1
215- add --enable-libsuffix option
216
217* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
218- rebuild for VineSeed
219
220* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
221- new upstream release
222
223* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
224- rebuild for VineSeed
225
226* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
227- new upstream release
228
229* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
230- rebuild for VineSeed
231
232* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
233- new upstream release
234
235* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
236- rebuild for VineSeed
237
238* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
239- new upstream release
240
241* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
242- rebuild for VineSeed
243
244* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
245- new upstream release
246- renew BuildPrereq and build section
247- renew %%files
248- enable python
249- change spec to make main and devel package
250- add BuildPrereq: ruby ruby-devel
251- add Patch0 to install ruby-bindings under /usr/lib/ruby
252
253* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
254- build for VineSeed
255- disable python and mozilla
256- objprelink (i386 only)
257
258* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
259- 2.2.2
260- build kmozilla binding only on x86/alpha
261
262* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
263- Make sure %%{name}-kmozilla isn't built on ia64
264
265* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
266- Move python bindings to separate package
267- Add perl bindings
268- Shut up rpmlint
269
270* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
271- 2.1
272
273* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
274- initial RPM
Note: See TracBrowser for help on using the repository browser.