source: projects/specs/trunk/k/koffice/koffice-vl.spec @ 1987

Revision 1987, 15.3 KB checked in by inagaki, 14 years ago (diff)

update: ImageMagick?, calibre, dvdauthor, inkscape, koffice, pstoedit, xine-lib, self-build-xine-lib-extras

Line 
1%define sourcedir stable/koffice-%{version}/src
2
3Name: koffice
4URL: http://koffice.kde.org/
5Summary: Integrated office suite for KDE
6Summary(ja): KDE 向け統合オフィススイート
7Version: 1.6.3
8Release: 4%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPL
12Source: ftp://ftp.kde.org/pub/kde/{sourcedir}/%{name}-%{version}.tar.bz2
13Source1: %{name}-l10n-ja-%{version}.tar.bz2
14Patch0: koffice-1.6.3-gcc43.patch
15Patch1: koffice-1.6.3-gcc44-elif.patch
16Patch2: koffice-1.6.3-gcc44-glibc210.patch
17
18# security fix
19Patch100: koffice-xpdf-CVE-2007-3387.diff
20Patch101: koffice-1.6.3-xpdf2-CVE-2007-4352-5392-5393.diff
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: qt-devel >= 3.3.2, kdelibs3-devel >= 3.3, arts-devel >= 1:1.3
24BuildRequires: aspell-devel >= 0.50.2, wv2-devel >= 0.1.8
25BuildRequires: libjpeg-turbo-devel libmng-devel libtiff-devel zlib-devel
26BuildRequires: libxml2-devel libxslt-devel freetype2-devel libart_lgpl-devel
27BuildRequires: jasper-devel doxygen ImageMagick-devel pkgconfig
28BuildRequires: libpng-devel libgsf-devel lcms-devel libexif-devel
29BuildRequires: MySQL-devel postgresql-devel
30BuildRequires: poppler-qt-devel
31BuildRequires: python-devel
32BuildRequires: libwpd-devel >= 0.8.0
33#if %{?_dist_release}
34#BuildConflicts: ruby-devel
35#else
36BuildRequires: libpqxx-devel libtool-ltdl-devel ruby-devel
37#endif
38Requires: qt >= 3.3.2, kdelibs3 >= 3.3, arts >= 1:1.3
39Requires: freetype2 libjpeg libtiff libmng libpng
40Requires: zlib audiofile libxml2 libxslt
41Requires: libart_lgpl aspell wv2
42Requires(post): kdelibs3
43
44Obsoletes: killustrator kivio
45
46
47%description
48KOffice is a collection of office applications linked together by a common
49basis. This common basis assures that all office application can work
50together. You can, for instance, insert a spreadsheet in your thesis without
51leaving your document. Editing the spreadsheet happens _inside_ your thesis.
52
53The applications currently included in KOffice are:
54- KWord (Professional text editing)
55- KSpread (Professional number cruncher/spreadsheet)
56- KPresenter (Professional presentation program)
57- KChart (Graphing of your abstract data)
58- Karbon (Vector graphics tool)
59- Kugar (Database report creation)
60- Kivio (Flowcharting program)
61- Kexi (a database management tool)
62- KOffice Workspace (A combination of all of the above)
63
64%prep
65%setup -q -n %{name}-%{version}
66%if %{?_dist_release} == "vl6"
67%patch0 -p1 -b .gcc43
68%patch1 -p1 -b .elif
69%patch2 -p3 -b .glibc210
70%endif
71
72%patch100 -p0 -b .CVE-2007-3387
73%patch101 -p0 -b .xpdf
74
75# for Python 2.6
76%if %{?_dist_release} == "vl6"
77sed -i -e 's|""2\.5""|""2\.6""|g' configure
78%endif
79
80
81%build
82#only for beta
83#make -f Makefile.cvs
84
85unset QTDIR || : ; . /etc/profile.d/qt.sh
86export KDEDIR=%{_prefix}
87
88./configure --prefix=%{_prefix} \
89  --includedir=%{_includedir}/kde \
90  --with-qt-libraries=$QTDIR/lib \
91  --disable-rpath --disable-dependency-tracking \
92  --enable-new-ldflags \
93  --disable-debug --disable-warnings \
94  --with-pic --enable-shared --disable-static \
95  --with-extra-libs=%{_libdir} \
96  --with-pgsqllibdir=%{_libdir} --with-pgsqlincdir=%{_includedir} \
97  --with-pqxxlibdir=%{_libdir} --with-pqxxincdir=%{_includedir} \
98  --disable-final
99
100make %{?_smp_mflags}
101
102tar xjf %{SOURCE1}
103cd %{name}-l10n-ja-%{version}
104./configure --prefix=%{_prefix}
105make %{?_smp_mflags}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109make RUN_KAPPFINDER=no DESTDIR=$RPM_BUILD_ROOT install
110
111# Drop -x
112chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/kross/python/kexiapp/*
113chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/copycenter/*
114chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/exportxhtml/*
115chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/importxhtml/*
116chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kexi/scripts/projectdocumentor/*
117chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/changecs/*
118chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/filterstest/*
119chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertpython/*
120chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/invertruby/*
121chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/randompaint/*
122chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/reshapehisto/*
123chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturefilters/*
124chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/krita/scripts/torturepainting/*
125chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/*.py
126chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kross/python/RestrictedPython/*.py
127chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/exporthtml/*
128chmod -x $RPM_BUILD_ROOT%{_datadir}/apps/kspread/scripts/scripteditor/*
129
130# Replace absolute symlinks with relative ones
131pushd $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en
132for i in *; do
133    if [ -d $i -a -L $i/common ]; then
134        rm -f $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i/common
135        ln -s ../common $RPM_BUILD_ROOT%{_prefix}/share/doc/HTML/en/$i
136    fi
137done
138popd
139
140cd %{name}-l10n-ja-%{version}
141make DESTDIR=$RPM_BUILD_ROOT install
142
143rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/pl
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post
149/sbin/ldconfig
150kbuildsycoca &>/dev/null || :
151
152%postun -p /sbin/ldconfig
153
154%files
155%defattr(-,root,root)
156%doc AUTHORS COPYING INSTALL README
157%doc %{_datadir}/doc/HTML/en/*
158%{_bindir}/*
159%{_includedir}/kde/*
160%{_libdir}/*
161%{_datadir}/applications
162%{_datadir}/applnk
163%{_datadir}/apps
164%config %{_datadir}/config
165%{_datadir}/config.kcfg
166%{_datadir}/icons
167%{_datadir}/locale/ja/LC_MESSAGES/*
168%{_datadir}/mimelnk
169%{_datadir}/services
170%{_datadir}/servicetypes
171%{_datadir}/templates
172
173%changelog
174* Sun Oct  3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-4
175- rebuilt with ImageMagick-6.6.4.8
176
177* Tue May  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-3
178- rebuilt with new toolchain and ImageMagick-6.6.1.5
179- fixed configure for building with python-2.6
180- added Patch0-2 for building new toolchain
181  (Gentoo#228839, Debian#504870, Gentoo#270960)
182
183* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.3-2
184- added libtiff(-devel) to dependency.
185- rebuilt with MySQL-5.1.34.
186
187* Sat May  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-1
188- applied new versioning policy
189- spec in UTF-8
190
191* Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl6
192- rebuild for VineSeed
193
194* Mon Nov 12 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl5
195- add Patch1 (CVE-2007-4352, 5392, 5393)
196
197* Thu Aug  2 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl4
198- add Patch0 (CVE-2007-3387)
199
200* Sat Jul 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.3-0vl3
201- added --with-qt-libraries configure option
202
203* Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl2
204- rebuild for VineSeed
205
206* Wed Jun 27 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.3-0vl1
207- new upstream release
208
209* Tue Oct 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.0-0vl1
210- new upstream release
211
212* Mon Sep 11 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.91-0vl1
213- new upstream release
214
215* Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
216- rebuild for VineSeed
217
218* Mon Jul 10 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
219- new upstream release
220- drop obsolete patches
221
222* Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
223- rebuild for VineSeed
224
225* Mon May 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
226- new upstream release
227- drop obsolete patches
228- add BuildPrereq: libexif-devel
229- add --disable-final to configure option
230- add Patch0 and Patch1
231
232* Tue Apr 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl3
233- build with ruby-1.8.4-0vl1 on VineSeed
234- add Buildprereq: ruby-devel for VineSeed
235
236* Thu Apr  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
237- rebuild for VineSeed
238
239* Thu Apr  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
240- new upstream release
241- drop Patch1
242
243* Fri Mar 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
244- new upstream release
245- drop Patch0
246- add --disable-pie and --includedir=%%{_includedir}/kde to configure option
247- add BuildConflicts: ruby-devel
248- add Patch1
249- update %%files
250
251* Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl4
252- rebuild with libgsf-1.14.0-0vl1
253- add Japanese summary
254
255* Thu Jan  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl3
256- add Patch0 (CAN-2005-3193)
257
258* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
259- rebuild with libgsf-1.13.3-0vl1 and python-2.4.2-0vl4
260
261* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
262- new upstream release
263- remove all patches
264- add SOURCE1 from snapshot
265
266* Mon Sep 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
267- add Patch0 - Patch8 to build with qt-3.3.5
268- add BuildPrereq: libtool-ltdl-devel
269
270* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
271- new upstream release
272
273* Thu Jul  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0a-0vl1
274- new upstream release
275- remove i18n files
276- add BuildPrereq: automake17
277- add --disable-rpath to configure option
278
279* Tue Apr 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
280- new upstream release
281- remove all patches
282- add BuildPrereq: lcms-devel MySQL-devel postgresql-devel libpqxx-devel
283- change Group to Applications/Productivity
284- update Summary and description
285
286* Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl8
287- rebuild with KDE-3.4.0 (VineSeed)
288
289* Mon Mar 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl7
290- rebuild with KDE-3.4.0 (Vine3.1)
291- clean up changelog to use (double-percent) everywhere
292
293* Sat Jan 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl6
294- rebuild for VineSeed
295
296* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl5
297- add Patch1 (CAN-2005-0064)
298
299* Fri Jan  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl4
300- rebuild for VineSeed
301
302* Fri Jan  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl3
303- add patch0 (http://www.koffice.org/security/2004_xpdf_integer_overflow_2.php)
304
305* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl2
306- rebuild for VineSeed
307
308* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.5-0vl1
309- new upstream release
310- remove about ia64
311- remove patch0
312
313* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.4-0vl1
314- source upgrade
315- add Patch0 (security patch)
316
317* Thu Aug 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
318- source upgrade
319- remove lines about vine26
320- add BuildPrereq: libgsf-devel
321
322* Thu May  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
323- source upgrade
324
325* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl3
326- rebuild with kde-3.2.2
327
328* Wed Mar 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl2
329- rebuild with kde-3.2.1
330
331* Wed Jan 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
332- source upgrade
333
334* Mon Dec 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.95-0vl1
335- source upgrade
336- add BuildPrereq: jasper-devel doxygen ImageMagick-devel pkgconfig
337
338* Mon Sep 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.93-0vl1
339- source upgrade
340
341* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl2
342- rebuild with kdelibs-3.1.4 and gcc-3.2.3
343
344* Fri Aug 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.92-0vl1
345- source upgrade
346- BuildPrereq: wv2-devel >= 0.1.8 and add Requires: wv2
347
348* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.91-0vl1
349- source upgrade
350- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
351- change spec to build with gcc295
352- remove patch
353- add BuildPrereq: aspell-devel >= 0.50.2 and Requires: aspell
354- add BuildPrereq: wv2-devel
355
356* Mon May 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl4
357- rebuild with kdelibs-3.1.2
358
359* Thu Apr  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl3
360- rebuild with kdelibs-3.1.1
361
362* Sat Feb  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl2
363- add patch
364
365* Fri Feb  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
366- source upgrade
367- change spec to build both VineSeed and Vine2.5/2.6
368
369* Wed Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl3
370- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
371
372* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl2
373- rebuild with qt-3.0.5-0vl1
374- BuildPrereq: autoconf253
375
376* Mon Sep 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2-0vl1
377- source upgrade
378- no file conflicts from other package (maybe)
379- add BuildPrereq: objprelink2 instead of objprelink (obsolete)
380- add BuildPrereq: libart_lgpl-devel and Requires: libart_lgpl
381- add %%doc section
382
383* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl3
384- add koffice-i18n-ja-1.1.1
385
386* Thu May  2 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl2
387- source upgrade to 1.1.1
388- delete some .desktop files (they conflict files from kdelibs)
389
390* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1.1-1vl1
391- merged with rawhide 1.1-0.cvs20010725.1
392- source update to cvs-20020329
393- add BuildPrereq: autoconf252 automake15
394- add Epoch:1
395- There is Vine's previous changes, hacked for Vine
396 -- Wed Dec 5 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.1-6vl1
397  - Delete Epoch
398  - Change BuildRequires and Requires
399  - Build for VineSeed
400
401* Wed Jul 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010725.1
402- Increase Epoch
403
404* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.1-0.cvs20010724.1
405- Don't build kivio on ia64 ATM (compiler bug)
406
407* Tue Feb 20 2001 Than Ngo <than@redhat.com>
408- update 2.1
409- fix dangling symlinks
410
411* Fri Feb  2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
412- Add ldconfig in %%post and %%postun, replace absolute symlinks
413  with relative symlinks (#24878)
414
415* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
416- Update
417
418* Thu Jan 11 2001 Bernhard Rosenkraenzer <bero@redhat.com>
419- Update
420- Don't build on sparc and ia64 (Bug #23809)
421
422* Sun Dec  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
423- 2.0.1
424
425* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
426- Update to KDE_2_0_BRANCH
427
428* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
429- 2.0 final
430
431* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
432- 2.0
433
434* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
435- new CVS
436- fix compilation
437
438* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
439- kill dupes from kdelibs
440
441* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
442- 1.93
443
444* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
445- update (fixed compilation with gcc 2.96 in CVS)
446- work around compiler bugs on alpha
447
448* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
449- new snapshot
450- move to /usr/lib/kde2
451
452* Thu Jul 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
453- rebuild
454
455* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
456- new snapshot
457
458* Sun Jul 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
459- new snapshot, new Qt
460
461* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
462- Don't hardcode Qt version
463- obsolete killustrator (powertools 6.x)
464- SMPify
465
466* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
467- use gcc 2.96
468- new snapshot
469
470* Mon Jul  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
471- use kernelcc
472- new snapshot
473
474* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
475- new snapshot
476- ExcludeArch ia64
477
478* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
479- new snapshot
480- move it to /usr, where it belongs
481
482* Sat Oct 23 1999 Bernhard Rosenkraenzer <bero@redhat.de>
483- Initial RPM
Note: See TracBrowser for help on using the repository browser.