source: projects/specs/trunk/k/knemo/knemo-vl.spec @ 10763

Revision 10763, 5.6 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:             knemo
2Summary:          A KDE network monitoring tool
3Summary(ja):      KDE ネットワーク監視ツール
4Version:          0.7.6
5Release:          2%{?_dist_release}
6
7Group:            Applications/Internet
8License:          GPLv2+
9URL:              http://extragear.kde.org/apps/knemo/
10Source0:          http://kde-apps.org/CONTENT/content-files/12956-%{name}-%{version}.tar.bz2
11
12BuildRoot:        %{_tmppath}/%{name}-%{version}-root
13BuildRequires:    cmake
14BuildRequires:    desktop-file-utils
15BuildRequires:    gettext
16BuildRequires:    kdebase-workspace-devel
17BuildRequires:    libnl3-devel
18BuildRequires:    wireless-tools-devel
19
20%description
21KNemo displays for every network interface an icon in the systray. Tooltips
22and an info dialog provide further information about the interface. Passive
23popups inform about interface changes. A traffic plotter is also integrated.
24It polls the network interface status every second using the ifconfig, route
25and iwconfig tools.
26
27%prep
28%setup -q
29
30%build
31mkdir -p %{_target_platform}
32pushd %{_target_platform}
33%{cmake} \
34    -DCMAKE_BUILD_TYPE=release \
35    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
36    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
37    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
38    -DLEGACY_TRAY_ICON=true \
39    ..
40popd
41
42make %{?_smp_mflags} -C %{_target_platform}
43
44%install
45rm -rf $RPM_BUILD_ROOT
46make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
47
48%find_lang %{name}
49%find_lang kcm_%{name}
50cat kcm_%{name}.lang >> %{name}.lang
51
52%check
53desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/%{name}.desktop
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%post
59touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
60
61%postun
62if [ $1 -eq 0 ] ; then
63  touch --no-create %{_datadir}/icons/hicolor &> /dev/null
64  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
65fi
66
67%posttrans
68gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
69
70
71%files -f %{name}.lang
72%defattr(-,root,root,-)
73%doc AUTHORS ChangeLog COPYING README
74%{_bindir}/%{name}
75%{_libdir}/kde4/kcm_knemo.so
76%{_datadir}/applications/kde4/%{name}.desktop
77%{_datadir}/autostart/%{name}.desktop
78%{_datadir}/kde4/apps/%{name}
79%{_datadir}/kde4/apps/kconf_update/%{name}*
80%{_datadir}/kde4/services/kcm_knemo.desktop
81%{_datadir}/icons/hicolor/*/apps/%{name}*
82%{_datadir}/icons/hicolor/*/status/%{name}*
83
84%changelog
85* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 0.7.6-2
86- rebuild with gcc-5.4.0
87
88* Sat Jan 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.7.6-1
89- updated to 0.7.6
90- built on current VineSeed
91
92* Tue Jul 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.3-2
93- Initial build for Vine Linux
94
95* Tue Jun 15 2010 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.3-1
96- update to 0.6.3
97
98* Sat Apr 10 2010 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.2-2
99- disabled new KStatusNotifierItem for now (kde#226650)
100
101* Fri Apr  9 2010 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.2-1
102- update to 0.6.2
103
104* Mon Jan 18 2010 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.1-2
105- update to 0.6.1
106
107* Fri Dec  4 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.6.0-1
108- update to 0.6.0
109
110* Thu Nov 19 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.80-2
111- rebuild (qt-4.6.0-rc1, fc13+)
112
113* Fri Nov  6 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.80-1
114- update to 0.5.80 (0.6.0 beta1)
115- drop xdg-utils references
116- removed Requires net-tools wireless-tools
117
118* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-2
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
120
121* Wed Apr  1 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.2-1
122- Update to version 0.5.2
123- Fixed spec License and URL fields
124
125* Tue Mar 17 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.1-5
126- Upstream update from git.mehercule.net
127
128* Thu Mar  5 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.1-1
129- Update to version 0.5.1
130
131* Wed Feb 25 2009 Alexey Kurov <nucleo@fedoraproject.org> - 0.5.0-3
132- Update to version 0.5.0 for KDE4
133
134* Tue Apr 17 2007 Francois Aucamp <faucamp@csir.co.za> - 0.4.7-1
135- Update to version 0.4.7
136- Removed unnecessary desktop-file-install statements (KDE-specific desktop
137  files)
138- Removed desktop file patch - desktop file "Keywords" keys used internally
139  by KDE
140- Added "OnlyShowIn=KDE" to kcm desktop file
141- Removed unnecessary BuildRequires: qt-devel desktop-file-utils
142- Simplified %%post and %%postun scriplets
143- Use RPM_BUILD_ROOT variable format consistently
144
145* Wed Sep 13 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.3-2
146- Rebuilt for FC6
147
148* Sun Aug  6 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.3-1
149- New upstream version
150
151* Mon Jun 26 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.2-1
152- Upstream update
153- Fixes crashing when you click in panel icon (bz #196576)
154- ifconfig and iwconfig are now in both Requires and
155  BuildRequires (it checks while building too)
156
157* Tue Jun 13 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.1-2
158- ifconfig and iwconfig are now in Requires section instead
159  of BuildRequires. They are runtime dependencies. Thanks to
160  Kevin Kofler for pointing this.
161
162* Mon Jun 12 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.1-1
163- Upstream update
164
165* Tue May 30 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.0-4
166- Created BuildRequires for the ifconfig and iwconfig commands,
167  as knemo utilizes it for monitoring.
168- Removed addition of categories in desktop-file-install command
169
170* Thu May 25 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.0-3
171- Removed vendor option from desktop-file-install (no renaming)
172
173* Sat May 20 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.0-2
174- Installed .desktop files now use desktop-file-install
175
176* Sat May 20 2006 Hugo Cisneiros <hugo@devin.com.br> 0.4.0-1
177- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.