source: projects/specs/trunk/k/kmousetool/kmousetool-vl.spec @ 6725

Revision 6725, 2.0 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.0

Line 
1Name: kmousetool
2Summary: KDE
3Summary(ja): KDE 向けマウス用ツール
4Version: 4.9.0
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Accessories
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: desktop-file-utils
16BuildRequires: kdelibs4-devel >= %{version}
17BuildRequires: libXtst-devel
18
19%description
20MouseTool is a program that clicks the mouse for you.
21
22
23%prep
24%setup -q
25
26%build
27mkdir -p %{_target_platform}
28pushd %{_target_platform}
29%cmake \
30    -DCMAKE_BUILD_TYPE=release \
31    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
32    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
33    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
34    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
35    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
36    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
37    ..
38popd
39
40make %{?_smp_mflags} -C %{_target_platform}
41
42
43%install
44rm -rf $RPM_BUILD_ROOT
45make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
46
47pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en/%{name}
48bunzip2 index.cache.bz2
49sed -i -e 's!<a name="id[0-9]*"></a>!!g' index.cache
50bzip2 -9 index.cache
51popd
52
53
54%check
55for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
56    desktop-file-validate $f
57done
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%post
63/sbin/ldconfig
64touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
65
66%posttrans
67gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
68
69%postun
70/sbin/ldconfig
71if [ $1 -eq 0 ] ; then
72    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
73    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null
74fi
75
76
77%files
78%defattr(-,root,root)
79%doc COPYING COPYING.DOC
80%{_bindir}/%{name}
81%{_datadir}/applications/kde4/%{name}.desktop
82%{_datadir}/icons/hicolor/*/*/*
83%{_datadir}/kde4/apps/%{name}
84%doc %{_docdir}/HTML/en/%{name}/
85%{_mandir}/man1/%{name}.1.gz
86
87
88%changelog
89* Sat Aug 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
90- initial build
Note: See TracBrowser for help on using the repository browser.