source: projects/specs/trunk/k/kmod/kmod-vl.spec @ 6449

Revision 6449, 6.0 KB checked in by daisuke, 12 years ago (diff)

new package, replaces module-init-tools

Line 
1Name:           kmod
2Version:        8
3Release:        1%{?_dist_release}
4Summary:        Linux kernel module management utilities
5Summary(ja):    Linux カーネルモジュール管理ユーティリティ
6
7Group:          System Environment/Kernel
8License:        GPLv2+
9URL:            http://git.kernel.org/?p=utils/kernel/kmod/kmod.git;a=summary
10Source0:        ftp://ftp.kernel.org/pub/linux/utils/kernel/kmod/%{name}-%{version}.tar.xz
11Exclusiveos:    Linux
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildRequires:  chrpath
15BuildRequires:  zlib-devel
16BuildRequires:  xz-devel
17
18Provides:       module-init-tools = 4.0-1
19Obsoletes:      module-init-tools < 4.0-1
20Provides:       modutils = 4.0-1
21Obsoletes:      modutils < 4.0-1
22Provides:       /sbin/modprobe
23
24Distribution: Vine Linux
25Vendor: Project Vine
26Packager: daisuke
27
28%description
29The kmod package provides various programs needed for automatic
30loading and unloading of modules under 2.6, 3.x, and later kernels, as well
31as other module management programs. Device drivers and filesystems are two
32examples of loaded and unloaded modules.
33
34%package libs
35Summary:        Libraries to handle kernel module loading and unloading
36Summary(ja):    Libraries to handle kernel module loading and unloading
37License:        LGPLv2+
38Group:          System Environment/Libraries
39
40%description libs
41The kmod-libs package provides runtime libraries for any application that
42wishes to load or unload Linux kernel modules from the running system.
43
44%package devel
45Summary:        Header files for kmod development
46Summary(ja):    Header files for kmod development
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49
50%description devel
51The kmod-devel package provides header files used for development of
52applications that wish to load or unload Linux kernel modules.
53
54%prep
55%setup -q
56
57%build
58export V=1
59%configure \
60  --bindir=%{_sysbindir} \
61  --sbindir=%{_syssbindir} \
62  --with-zlib \
63  --with-xz
64make %{?_smp_mflags}
65
66%install
67[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
68
69make install DESTDIR=$RPM_BUILD_ROOT
70pushd $RPM_BUILD_ROOT/%{_mandir}/man5
71ln -s modprobe.d.5.gz modprobe.conf.5.gz
72popd
73
74install -m755 tools/kmod-nolib $RPM_BUILD_ROOT%{_sysbindir}/
75
76mkdir -p $RPM_BUILD_ROOT/%{_lib}
77mv $RPM_BUILD_ROOT/%{_libdir}/*.so* $RPM_BUILD_ROOT/%{_lib}/
78ln -sf ../../%{_lib}/libkmod.so $RPM_BUILD_ROOT/%{_libdir}/libkmod.so
79
80rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
81mkdir -p $RPM_BUILD_ROOT%{_syssbindir}
82ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/modprobe
83ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/modinfo
84ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/insmod
85ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/rmmod
86ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/depmod
87ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/lsmod
88
89mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d
90mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/depmod.d
91mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/modprobe.d
92
93%clean
94[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
95
96%post libs
97/sbin/ldconfig
98
99%postun libs
100/sbin/ldconfig
101
102%files
103%defattr(-,root,root,-)
104%dir %{_sysconfdir}/depmod.d
105%dir %{_sysconfdir}/modprobe.d
106%dir %{_prefix}/lib/modprobe.d
107%{_sysbindir}/kmod
108%{_sysbindir}/kmod-nolib
109%{_syssbindir}/modprobe
110%{_syssbindir}/modinfo
111%{_syssbindir}/insmod
112%{_syssbindir}/rmmod
113%{_syssbindir}/lsmod
114%{_syssbindir}/depmod
115%attr(0644,root,root) %{_mandir}/man5/*.5*
116%attr(0644,root,root) %{_mandir}/man8/*.8*
117%doc NEWS README TODO COPYING
118
119%files libs
120/%{_lib}/libkmod.so.*
121
122%files devel
123%{_includedir}/libkmod.h
124%{_libdir}/pkgconfig/libkmod.pc
125%{_libdir}/libkmod.so
126/%{_lib}/libkmod.so
127
128%changelog
129* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp>  8-1
130- initial build for Vine Linux
131
132* Wed May 23 2012 Josh Boyer <jwboyer@redhat.com> - 8-2
133- Provide modprobe.conf(5) (rhbz 824552)
134
135* Tue May 08 2012 Josh Boyer <jwboyer@redhat.com> - 8-1
136- Update to version 8
137
138* Mon Mar 19 2012 Kay Sievers <kay@redhat.com> - 7-1
139- update to version 7
140  - fix issue with --show-depends, where built-in
141    modules of the running kernel fail to include
142    loadable modules of the kernel specified
143
144* Sun Mar 04 2012 Kay Sievers <kay@redhat.com> - 6-1
145- update to version 6
146- remove all patches, they are included in the release
147
148* Fri Feb 24 2012 Kay Sievers <kay@redhat.com> - 5-8
149- try to address brc#771285
150
151* Sun Feb 12 2012 Kay Sievers <kay@redhat.com> - 5-7
152- fix infinite loop with softdeps
153
154* Thu Feb 09 2012 Harald Hoyer <harald@redhat.com> 5-6
155- add upstream patch to fix "modprobe --ignore-install --show-depends"
156  otherwise dracut misses a lot of modules, which are already loaded
157
158* Wed Feb 08 2012 Harald Hoyer <harald@redhat.com> 5-5
159- add "lsmod"
160
161* Tue Feb  7 2012 Kay Sievers <kay@redhat.com> - 5-4
162- remove temporarily added fake-provides
163
164* Tue Feb  7 2012 Kay Sievers <kay@redhat.com> - 5-3
165- temporarily add fake-provides to be able to bootstrap
166  the new udev which pulls the old udev into the buildroot
167
168* Tue Feb  7 2012 Kay Sievers <kay@redhat.com> - 5-1
169- Update to version 5
170- replace the module-init-tools package and provide all tools
171  as compatibility symlinks
172
173* Mon Jan 16 2012 Kay Sievers <kay@redhat.com> - 4-1
174- Update to version 4
175- set --with-rootprefix=
176- enable zlib and xz support
177
178* Thu Jan 05 2012 Jon Masters <jcm@jonmasters.org> - 3-1
179- Update to latest upstream (adds new depmod replacement utility)
180- For the moment, use the "kmod" utility to test the various functions
181
182* Fri Dec 23 2011 Jon Masters <jcm@jonmasters.org> - 2-6
183- Update kmod-2-with-rootlibdir patch with rebuild automake files
184
185* Fri Dec 23 2011 Jon Masters <jcm@jonmasters.org> - 2-5
186- Initial build for Fedora following package import
187
188* Thu Dec 22 2011 Jon Masters <jcm@jonmasters.org> - 2-4
189- There is no generic macro for non-multilib "/lib", hardcode like others
190
191* Thu Dec 22 2011 Jon Masters <jcm@jonmasters.org> - 2-3
192- Update package incorporating fixes from initial review feedback
193- Cleaups to SPEC, rpath, documentation, library and binary locations
194
195* Thu Dec 22 2011 Jon Masters <jcm@jonmasters.org> - 2-2
196- Update package for posting to wider test audience (initial review submitted)
197
198* Thu Dec 22 2011 Jon Masters <jcm@jonmasters.org> - 2-1
199- Initial Fedora package for module-init-tools replacement (kmod) library
Note: See TracBrowser for help on using the repository browser.