source: projects/specs/trunk/k/kmod/kmod-vl.spec @ 9823

Revision 9823, 6.4 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1Name:           kmod
2Version:        22
3Release:        1%{?_dist_release}
4Summary:        Linux kernel module management utilities
5Summary(ja):    Linux カーネルモジュール管理ユーティリティ
6
7Group:          System Environment/Kernel
8License:        GPLv2+
9URL:            http://git.kernel.org/?p=utils/kernel/kmod/kmod.git;a=summary
10Source0:        ftp://ftp.kernel.org/pub/linux/utils/kernel/kmod/%{name}-%{version}.tar.xz
11Exclusiveos:    Linux
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildRequires:  chrpath
15BuildRequires:  zlib-devel
16BuildRequires:  xz-devel
17BuildRequires:  libxslt
18
19Provides:       module-init-tools = 4.0-1
20Obsoletes:      module-init-tools < 4.0-1
21Provides:       modutils = 4.0-1
22Obsoletes:      modutils < 4.0-1
23Provides:       /sbin/modprobe
24
25Distribution: Vine Linux
26Vendor: Project Vine
27Packager: daisuke
28
29%description
30The kmod package provides various programs needed for automatic
31loading and unloading of modules under 2.6, 3.x, and later kernels, as well
32as other module management programs. Device drivers and filesystems are two
33examples of loaded and unloaded modules.
34
35%package libs
36Summary:        Libraries to handle kernel module loading and unloading
37Summary(ja):    kernelモジュールのロード/アンロードを扱うライブラリ
38License:        LGPLv2+
39Group:          System Environment/Libraries
40
41%description libs
42The kmod-libs package provides runtime libraries for any application that
43wishes to load or unload Linux kernel modules from the running system.
44
45%package devel
46Summary:        Header files for kmod development
47Summary(ja):    kmodを使うアプリケーション開発のためのヘッダファイル
48Group:          Development/Libraries
49Requires:       %{name} = %{version}-%{release}
50
51%description devel
52The kmod-devel package provides header files used for development of
53applications that wish to load or unload Linux kernel modules.
54
55%prep
56%setup -q
57
58%build
59export V=1
60%configure \
61  --bindir=%{_sysbindir} \
62  --sbindir=%{_syssbindir} \
63  --with-zlib \
64  --with-xz
65make %{?_smp_mflags}
66
67%install
68[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
69
70make install DESTDIR=$RPM_BUILD_ROOT
71pushd $RPM_BUILD_ROOT/%{_mandir}/man5
72ln -s modprobe.d.5.gz modprobe.conf.5.gz
73popd
74
75mkdir -p $RPM_BUILD_ROOT/%{_lib}
76mv $RPM_BUILD_ROOT/%{_libdir}/*.so* $RPM_BUILD_ROOT/%{_lib}/
77ln -sf ../../%{_lib}/libkmod.so $RPM_BUILD_ROOT/%{_libdir}/libkmod.so
78
79rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
80mkdir -p $RPM_BUILD_ROOT%{_syssbindir}
81ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/modprobe
82ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/modinfo
83ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/insmod
84ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/rmmod
85ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/depmod
86ln -sf ../bin/kmod $RPM_BUILD_ROOT%{_syssbindir}/lsmod
87
88mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d
89mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/depmod.d
90mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/modprobe.d
91
92%clean
93[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
94
95%post libs
96/sbin/ldconfig
97
98%postun libs
99/sbin/ldconfig
100
101%files
102%defattr(-,root,root,-)
103%dir %{_sysconfdir}/depmod.d
104%dir %{_sysconfdir}/modprobe.d
105%dir %{_prefix}/lib/modprobe.d
106%{_sysbindir}/kmod
107%{_syssbindir}/modprobe
108%{_syssbindir}/modinfo
109%{_syssbindir}/insmod
110%{_syssbindir}/rmmod
111%{_syssbindir}/lsmod
112%{_syssbindir}/depmod
113%attr(0644,root,root) %{_mandir}/man5/*.5*
114%attr(0644,root,root) %{_mandir}/man8/*.8*
115%doc NEWS README TODO COPYING
116%exclude %{_datadir}/bash-completion/completions/kmod
117
118%files libs
119/%{_lib}/libkmod.so.*
120
121%files devel
122%{_includedir}/libkmod.h
123%{_libdir}/pkgconfig/libkmod.pc
124%{_libdir}/libkmod.so
125/%{_lib}/libkmod.so
126
127%changelog
128* Sat Nov 21 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 22-1
129- update to 22
130
131* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 21-1
132- update to 21
133
134* Sun May 24 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 20-1
135- update to 20
136
137* Wed Nov 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 11-1
138- update to 11
139- add BR: libxslt
140
141* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp>  8-1
142- initial build for Vine Linux
143
144* Wed May 23 2012 Josh Boyer <jwboyer@redhat.com> - 8-2
145- Provide modprobe.conf(5) (rhbz 824552)
146
147* Tue May 08 2012 Josh Boyer <jwboyer@redhat.com> - 8-1
148- Update to version 8
149
150* Mon Mar 19 2012 Kay Sievers <kay@redhat.com> - 7-1
151- update to version 7
152  - fix issue with --show-depends, where built-in
153    modules of the running kernel fail to include
154    loadable modules of the kernel specified
155
156* Sun Mar 04 2012 Kay Sievers <kay@redhat.com> - 6-1
157- update to version 6
158- remove all patches, they are included in the release
159
160* Fri Feb 24 2012 Kay Sievers <kay@redhat.com> - 5-8
161- try to address brc#771285
162
163* Sun Feb 12 2012 Kay Sievers <kay@redhat.com> - 5-7
164- fix infinite loop with softdeps
165
166* Thu Feb 09 2012 Harald Hoyer <harald@redhat.com> 5-6
167- add upstream patch to fix "modprobe --ignore-install --show-depends"
168  otherwise dracut misses a lot of modules, which are already loaded
169
170* Wed Feb 08 2012 Harald Hoyer <harald@redhat.com> 5-5
171- add "lsmod"
172
173* Tue Feb  7 2012 Kay Sievers <kay@redhat.com> - 5-4
174- remove temporarily added fake-provides
175
176* Tue Feb  7 2012 Kay Sievers <kay@redhat.com> - 5-3
177- temporarily add fake-provides to be able to bootstrap
178  the new udev which pulls the old udev into the buildroot
179
180* Tue Feb  7 2012 Kay Sievers <kay@redhat.com> - 5-1
181- Update to version 5
182- replace the module-init-tools package and provide all tools
183  as compatibility symlinks
184
185* Mon Jan 16 2012 Kay Sievers <kay@redhat.com> - 4-1
186- Update to version 4
187- set --with-rootprefix=
188- enable zlib and xz support
189
190* Thu Jan 05 2012 Jon Masters <jcm@jonmasters.org> - 3-1
191- Update to latest upstream (adds new depmod replacement utility)
192- For the moment, use the "kmod" utility to test the various functions
193
194* Fri Dec 23 2011 Jon Masters <jcm@jonmasters.org> - 2-6
195- Update kmod-2-with-rootlibdir patch with rebuild automake files
196
197* Fri Dec 23 2011 Jon Masters <jcm@jonmasters.org> - 2-5
198- Initial build for Fedora following package import
199
200* Thu Dec 22 2011 Jon Masters <jcm@jonmasters.org> - 2-4
201- There is no generic macro for non-multilib "/lib", hardcode like others
202
203* Thu Dec 22 2011 Jon Masters <jcm@jonmasters.org> - 2-3
204- Update package incorporating fixes from initial review feedback
205- Cleaups to SPEC, rpath, documentation, library and binary locations
206
207* Thu Dec 22 2011 Jon Masters <jcm@jonmasters.org> - 2-2
208- Update package for posting to wider test audience (initial review submitted)
209
210* Thu Dec 22 2011 Jon Masters <jcm@jonmasters.org> - 2-1
211- Initial Fedora package for module-init-tools replacement (kmod) library
Note: See TracBrowser for help on using the repository browser.