source: projects/specs/trunk/k/kmid2/kmid2-vl.spec @ 10763

Revision 10763, 6.3 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%if %{?_dist_release} == "vl5"
2%define kde KDE4
3%else
4%define kde KDE
5%endif
6
7Name:           kmid2
8Summary:        A MIDI/karaoke player for %{kde}
9Summary(ja):    %{kde} 向け MIDI/カラオケプレーヤー
10Version:        2.4.0
11Release:        2%{?_dist_release}
12
13Group:          Applications/Multimedia
14# GPLv2+ for the code and the MMA examples, CC-BY-SA for the MIDI examples
15License:        GPLv2+ and CC-BY-SA
16URL:            http://userbase.kde.org/KMid2
17
18Source0:        http://downloads.sourceforge.net/project/%{name}/%{version}/kmid-%{version}.tar.bz2
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  kdelibs4-devel
23#BuildRequires:  kde-filesystem
24BuildRequires:  cmake
25BuildRequires:  alsa-lib-devel
26BuildRequires:  drumstick-devel >= 0.3
27BuildRequires:  soprano-devel
28BuildRequires:  gettext
29BuildRequires:  desktop-file-utils
30
31#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api}}
32#{?_kde4_version:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}
33Requires:       oxygen-icon-theme
34Requires:       drumstick >= 0.3
35Requires:       %{name}-libs = %{version}-%{release}
36
37Obsoletes:      kmid < 2.0-1
38Provides:       kmid = %{version}-%{release}
39
40%description
41KMid2 is a MIDI/karaoke file player, with configurable midi mapper, real
42Session Management, drag & drop, customizable fonts, etc. It has a very
43nice interface which let you easily follow the tune while changing the
44color of the lyrics.
45It supports output through external synthesizers, AWE, FM and GUS cards.
46It also has a keyboard view to see the notes played by each instrument.
47
48%package libs
49Summary:        Runtime libraries for %{name}
50Summary(ja):    %{name} のランタイムライブラリ
51Group:          System Environment/Libraries
52License:        GPLv2+
53
54#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api}}
55#{?_kde4_version:Requires: kdelibs4%{?_isa} >= %{_kde4_version}}
56
57%description libs
58%{summary}.
59
60%package devel
61Summary:        Development files for %{name}
62Summary(ja):    %{name} の開発用ファイル
63Group:          Development/Libraries
64License:        GPLv2+
65
66Requires:       %{name}-libs = %{version}-%{release}
67
68Obsoletes:      kmid-devel < 2.0-1
69Provides:       kmid-devel = %{version}-%{release}
70
71%description devel
72%{summary}.
73
74%prep
75%setup -q -n kmid-%{version}
76# zap bundled copy of drumstick to guarantee it's never used
77rm -rf drumstick
78
79
80%build
81mkdir -p %{_target_platform}
82pushd %{_target_platform}
83%cmake \
84    -DCMAKE_BUILD_TYPE=release \
85    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
86    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
87    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
88    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
89    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
90    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
91    ..
92popd
93
94make %{?_smp_mflags} -C %{_target_platform}
95
96
97%install
98rm -rf %{buildroot}
99make install DESTDIR=%{buildroot} -C %{_target_platform}
100desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/kmid.desktop
101%find_lang kmid
102
103%clean
104rm -rf %{buildroot}
105
106
107%post
108touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
109update-desktop-database &> /dev/null || :
110
111%postun
112update-desktop-database &> /dev/null || :
113if [ $1 -eq 0 ] ; then
114    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
115    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
116fi
117
118%posttrans
119gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
120
121%post libs -p /sbin/ldconfig
122%postun libs -p /sbin/ldconfig
123
124
125%files -f kmid.lang
126%defattr(-,root,root,-)
127%doc ChangeLog COPYING README TODO
128%{_bindir}/kmid
129%{_datadir}/dbus-1/interfaces/*.xml
130%{_datadir}/kde4/apps/kmid/
131%{_datadir}/kde4/apps/kmid_part/kmid_part.rc
132%{_datadir}/applications/kde4/kmid.desktop
133%{_datadir}/config.kcfg/*
134%{_datadir}/kde4/services/*
135%{_datadir}/kde4/servicetypes/*
136%{_datadir}/icons/hicolor/*/apps/*
137%{_libdir}/kde4/*
138%doc %{_docdir}/HTML/*/kmid/
139
140%files libs
141%defattr(-,root,root,-)
142%{_libdir}/libkmidbackend.so.*
143
144%files devel
145%defattr(-,root,root,-)
146%{_libdir}/libkmidbackend.so
147%{_includedir}/kde4/kmid/
148
149
150%changelog
151* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.0-2
152- rebuild with gcc-5.4.0
153
154* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
155- update to 2.4.0
156- remove Patch0 (kmid-2.3.0-kde#240394.patch)
157- add BuildRequires: soprano-devel
158
159* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3.0-4
160- removed --with-kde from %%find_lang
161
162* Sun Jan 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3.0-3
163- Initial build for Vine Linux
164
165* Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.3.0-2
166- Fix crash in ALSA backend due to reloadDeviceList (kde#240394, upstream patch)
167
168* Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.3.0-1
169- Update to 2.3.0 (new versioning scheme)
170- BR drumstick-devel >= 0.3
171- Requires: drumstick >= 0.3
172- Drop obsolete drumstick-version patch
173- Examples now partly CC-BY-SA, partly GPLv2+ (instead of CC-BY)
174- Use _kde4_version macro
175- Add -devel and -libs subpackages
176- Package COPYING
177
178* Tue Feb 09 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.1-2
179- Requires: drumstick >= 0.2.99-0.3
180
181* Tue Feb 09 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.1-1
182- Update to 0.2.1
183- Drop upstreamed timidity-pulseaudio patch
184- Drop dont-translate-output-names patch, should not be needed anymore
185- BR drumstick-devel >= 0.2.99-0.3 (0.2.1 needs the 20100208 snapshot)
186- relax drumstick version check in CMakeLists.txt as 0.3 is not out yet
187
188* Fri Feb 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-3
189- Don't translate output names, breaks autospawning sequencers
190
191* Sun Jan 31 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-2
192- Support PulseAudio when autospawning TiMidity++ (-OO -opulse switches)
193
194* Sun Jan 31 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-1
195- Update to 0.2.0
196- The examples with copyright issues have been dropped by upstream
197- BR drumstick-devel instead of aseqmm-devel
198
199* Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-4
200- Fix the kde4-config output parsing for 4.4 ("KDE Development Platform:")
201
202* Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-3
203- Correctly require at least the kdelibs version used for building
204
205* Wed Jan 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-2
206- Remove nonsense Requires: kdelibs4 >= %%{version}, as %%{version} is 0.1.1
207
208* Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-1
209- First Fedora package, replaces kmid
Note: See TracBrowser for help on using the repository browser.