source: projects/specs/trunk/k/kig/kig-vl.spec @ 4743

Revision 4743, 2.5 KB checked in by inagaki, 13 years ago (diff)

NEW: KDE Educational packages
update: kdeplasma-addons

Line 
1Name: kig
2Summary: Interactive geometry tool for KDE
3Version: 4.7.0
4Release: 1%{?_dist_release}
5
6License: GPLv2+
7Group: Applications/Edutainment
8URL: http://edu.kde.org/kig/
9
10Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
11
12## upstream patches
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: desktop-file-utils
16BuildRequires: kdelibs4-devel >= %{version}
17BuildRequires: libboost-devel libboost-python
18BuildRequires: python-devel
19BuildRequires: soprano-devel
20
21Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
22
23Conflicts: kdeedu4 < 4.6.50
24
25%description
26Kig is an application for interactive geometric construction, allowing
27students to draw and explore mathematical figures and concepts using
28the computer.
29
30Kig supports macros and is scriptable using Python. It can import and
31export files in various formats, including SVG, Cabri, Dr. Geo, KGeo,
32KSeg, and XFig.
33
34This package is part of the KDE education module.
35
36%prep
37%setup -q
38
39%build
40mkdir -p %{_target_platform}
41pushd %{_target_platform}
42unset QTDIR || : ; . /etc/profile.d/qt4.sh
43%cmake \
44    -DCMAKE_BUILD_TYPE=release \
45    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
46    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
47    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
48    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
49    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
50    ..
51popd
52
53make %{?_smp_mflags} -C %{_target_platform}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%check
63for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
64    desktop-file-validate $f
65done
66
67
68%post
69touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
70
71%posttrans
72update-desktop-database -q &> /dev/null ||:
73gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
74
75%postun
76if [ $1 -eq 0 ] ; then
77    update-desktop-database -q &> /dev/null ||:
78    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
79    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
80fi
81
82%files
83%defattr(-,root,root)
84%doc COPYING COPYING.DOC
85%{_bindir}/kig
86%{_bindir}/pykig.py
87%{_libdir}/kde4/kigpart.so
88%{_datadir}/applications/kde4/kig.desktop
89%{_datadir}/icons/hicolor/*/*/*
90%{_datadir}/kde4/apps/katepart/*
91%{_datadir}/kde4/apps/kig
92%{_datadir}/kde4/services/kig_part.desktop
93%{_mandir}/man1/kig*
94%doc %{_docdir}/HTML/en/kig/
95
96%changelog
97* Thu Sep  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
98- split from kdeedu
99
Note: See TracBrowser for help on using the repository browser.