source: projects/specs/trunk/k/kig/kig-vl.spec @ 10563

Revision 10563, 3.9 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name: kig
2Summary: Interactive geometry tool for KDE
3Version: 4.14.3
4Release: 3%{?_dist_release}
5
6License: GPLv2+
7Group: Applications/Edutainment
8URL: http://edu.kde.org/kig/
9
10Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
11
12## upstream patches
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: desktop-file-utils
16BuildRequires: kdelibs4-devel >= %{version}
17BuildRequires: libboost-devel libboost-python
18BuildRequires: python-devel
19BuildRequires: soprano-devel
20
21Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
22
23Conflicts: kdeedu4 < 4.6.50
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29Kig is an application for interactive geometric construction, allowing
30students to draw and explore mathematical figures and concepts using
31the computer.
32
33Kig supports macros and is scriptable using Python. It can import and
34export files in various formats, including SVG, Cabri, Dr. Geo, KGeo,
35KSeg, and XFig.
36
37This package is part of the KDE education module.
38
39%prep
40%setup -q
41
42%build
43mkdir -p %{_target_platform}
44pushd %{_target_platform}
45%cmake \
46    -DCMAKE_BUILD_TYPE=release \
47    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
48    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
49    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
50    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
51    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
52    ..
53popd
54
55make %{?_smp_mflags} -C %{_target_platform}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%check
65for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
66    desktop-file-validate $f
67done
68
69
70%post
71touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
72
73%posttrans
74update-desktop-database -q &> /dev/null ||:
75gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
76
77%postun
78if [ $1 -eq 0 ] ; then
79    update-desktop-database -q &> /dev/null ||:
80    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
81    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
82fi
83
84%files
85%defattr(-,root,root)
86%doc COPYING COPYING.DOC
87%{_bindir}/kig
88%{_bindir}/pykig.py
89%{_libdir}/kde4/kigpart.so
90%{_datadir}/appdata/kig.appdata.xml
91%{_datadir}/applications/kde4/kig.desktop
92%{_datadir}/icons/hicolor/*/*/*
93%{_datadir}/kde4/apps/katepart/*
94%{_datadir}/kde4/apps/kig
95%{_datadir}/kde4/services/kig_part.desktop
96%{_mandir}/man1/kig*
97%doc %{_docdir}/HTML/en/kig/
98
99%changelog
100* Fri Jul 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-3
101- rebuild with gcc-5.4.0
102
103* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
104- rebuild with libboost-1.60.0
105
106* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
107- new upstream release
108
109* Wed May 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
110- new upstream release
111
112* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
113- new upstream release
114
115* Wed Dec 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
116- new upstream release
117
118* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-2
119- rebuild with libboost-1.54.0
120
121* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
122- new upstream release
123
124* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
125- new upstream release
126
127* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
128- new upstream release
129
130* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
131- new upstream release
132
133* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
134- new upstream release
135
136* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
137- new upstream release
138
139* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
140- new upstream release
141
142* Sun Feb 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.0-2
143- rebuild with python-2.7.2
144
145* Thu Sep  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
146- split from kdeedu
147
Note: See TracBrowser for help on using the repository browser.