source: projects/specs/trunk/k/khangman/khangman-vl.spec @ 10563

Revision 10563, 4.3 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name: khangman
2Summary: Hangman word puzzle for KDE
3Summary(ja): Hangman 単語パズル
4Version: 4.14.3
5Release: 2%{?_dist_release}
6
7License: GPLv2+
8Group: Applications/Edutainment
9URL: http://edu.kde.org/khangman/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13## upstream patches
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17Requires:  %{name}-libs = %{version}-%{release}
18BuildRequires: desktop-file-utils
19BuildRequires: kdelibs4-devel >= %{version}
20BuildRequires: libkdeedu-devel >= %{version}
21
22Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
23
24Conflicts: kdeedu4 < 4.6.50
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30KHangMan is the well-known Hangman game, aimed towards children
31aged 6 and above.
32
33It picks a random word which the player must reveal by guessing
34if it contains certain letters. As the player guesses letters,
35the word is gradually revealed, but 10 wrong guesses will end the
36game.
37
38This package is part of the KDE education module.
39
40
41%package libs
42Summary: Runtime libraries for %{name}
43Summary(ja): %{name} のランタイムライブラリ
44Group:   System Environment/Libraries
45Requires: kdelibs4 >= %{version}
46
47%description libs
48%{summary}.
49
50%description -l ja libs
51%{name} のランタイムライブラリです.
52
53
54%package devel
55Summary:   Development files for %{name}
56Summary(ja): %{name} の開発用ファイル
57Group:     Development/Libraries
58Requires:  %{name}-libs = %{version}-%{release}
59Requires:  kdelibs4-devel
60
61%description devel
62%{summary}.
63
64%description -l ja devel
65%{name} の開発用ファイルです.
66
67
68
69%prep
70%setup -q
71
72%build
73mkdir -p %{_target_platform}
74pushd %{_target_platform}
75%cmake \
76    -DCMAKE_BUILD_TYPE=release \
77    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
78    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
79    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
80    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
81    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
82    ..
83popd
84
85make %{?_smp_mflags} -C %{_target_platform}
86
87%install
88rm -rf $RPM_BUILD_ROOT
89make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%check
95for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
96    desktop-file-validate $f
97done
98
99
100%post
101touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
102
103%posttrans
104update-desktop-database -q &> /dev/null ||:
105gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
106
107%postun
108if [ $1 -eq 0 ] ; then
109    update-desktop-database -q &> /dev/null ||:
110    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
111    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
112fi
113
114%files
115%defattr(-,root,root,-)
116%doc COPYING COPYING.DOC
117%{_bindir}/%{name}
118%{_datadir}/appdata/%{name}.appdata.xml
119%{_datadir}/applications/kde4/%{name}.desktop
120%{_datadir}/config/%{name}.knsrc
121%{_datadir}/config.kcfg/%{name}.kcfg
122%{_datadir}/icons/hicolor/*/*/*
123%{_datadir}/kde4/apps/%{name}
124%{_mandir}/man6/khangman*
125%doc %{_docdir}/HTML/en/%{name}/
126
127%files libs
128%defattr(-,root,root,-)
129%{_libdir}/libkhangmanengine.so.*
130
131%files devel
132%defattr(-,root,root,-)
133%{_includedir}/%{name}
134%{_libdir}/libkhangmanengine.so
135
136%changelog
137* Fri Jul 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
138- rebuild with gcc-5.4.0
139
140* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
141- new upstream release
142
143* Wed May 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
144- new upstream release
145
146* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
147- new upstream release
148
149* Wed Dec 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
150- new upstream release
151
152* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
153- new upstream release
154
155* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
156- new upstream release
157
158* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
159- new upstream release
160
161* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
162- new upstream release
163
164* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
165- new upstream release
166
167* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
168- new upstream release
169
170* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
171- new upstream release
172- create -devel and -libs subpackages
173
174* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
175- split from kdeedu
176
Note: See TracBrowser for help on using the repository browser.