source: projects/specs/trunk/k/kgrab/kgrab-vl.spec @ 10581

Revision 10581, 4.7 KB checked in by Takemikaduchi, 8 years ago (diff)

xlockmore: new upstream release
others: rebuild with gcc-5.4.0

Line 
1%define kdeversion 4.4.0
2
3Name:           kgrab
4Summary:        A screen grabbing utility
5Summary(ja):    スクリーンキャプチャユーティリティ
6Version:        0.1.1
7Release:        25%{?_dist_release}
8
9Group:          Applications/Accessories
10License:        GPLv2+
11URL:            http://extragear.kde.org
12
13Source0:        ftp://ftp.kde.org/pub/kde/stable/%{kdeversion}/src/extragear/%{name}-%{version}-kde%{kdeversion}.tar.bz2
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  kdelibs4-devel >= 4
17BuildRequires:  cmake
18BuildRequires:  desktop-file-utils
19BuildRequires:  gettext
20
21#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
22
23%description
24kgrab is a screen grabbing utility for KDE4.
25
26%description -l ja
27KDE4 向けのスクリーンキャプチャユーティリティです.
28
29%prep
30%setup -qn %{name}-%{version}-kde%{kdeversion}
31
32
33%build
34mkdir -p %{_target_platform}
35pushd %{_target_platform}
36%cmake \
37    -DCMAKE_BUILD_TYPE=release \
38    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
39    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
40    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
41    ..
42popd
43
44make %{?_smp_mflags} -C %{_target_platform}
45
46
47%install
48rm -rf $RPM_BUILD_ROOT
49make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
50
51# validate desktop file
52desktop-file-install --vendor ""                          \
53        --dir $RPM_BUILD_ROOT%{_datadir}/applications/kde4   \
54        $RPM_BUILD_ROOT%{_datadir}/applications/kde4/%{name}.desktop
55
56%find_lang %{name}
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61
62%post
63touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
64
65%postun
66if [ $1 -eq 0 ] ; then
67  update-desktop-database -q &> /dev/null
68  touch --no-create %{_datadir}/icons/hicolor &> /dev/null
69  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
70fi
71
72%posttrans
73update-desktop-database -q &> /dev/null
74gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
75
76
77%files -f %{name}.lang
78%defattr(-,root,root,-)
79%doc COPYING COPYING.DOC COPYING.LIB
80%{_bindir}/kgrab
81%{_datadir}/applications/kde4/kgrab.desktop
82%{_datadir}/dbus-1/interfaces/org.kde.kgrab.xml
83%{_datadir}/icons/hicolor/*/apps/kgrab.*
84%{_datadir}/kde4/apps/kgrab/
85
86
87%changelog
88* Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.1.1-25
89- rebuild with gcc-5.4.0
90
91* Fri Jan 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.1.1-24
92- rebuilt on current VineSeed
93
94* Sat Jan 15 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.1.1-23
95- initial build for Vine Linux
96- added Japanese summary
97
98* Fri Feb 12 2010 Sebastian Vahl <svahl@fedoraproject.org> - 0.1.1-22
99- 4.4.0
100- drop kgrab-0.1.1-X11_libs.patch (already included)
101
102* Tue Nov 24 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-21
103- rebuild for Qt 4.6.0 RC1 in F13 (was built against Beta 1 with unstable ABI)
104
105* Thu Nov 05 2009 Sebastian Vahl <svahl@fedoraproject.org> - 0.1.1-20
106- 4.3.3
107- optimize scriptlets
108
109* Tue Sep 01 2009 Sebastian Vahl <svahl@fedoraproject.org> - 0.1.1-19
110- 4.3.1
111
112* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 0.1.1-18
113- 4.3.0
114
115* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-17
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
117
118* Tue Jun 10 2009 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-16
119- 4.2.4
120
121* Tue May 12 2009 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-15
122- 4.2.3
123
124* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-14
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Fri Jan 23 2009 Than Ngo <than@redhat.com> - 0.1.1-13
128- 4.2.0
129
130* Fri Dec 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.1.1-12
131- rebuild for fixed kde-filesystem (macros.kde4) (get rid of rpaths)
132
133* Thu Dec  4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.1.1-11
134- Include /usr/share/kde4/apps/kgrab directory.
135
136* Sat Oct 04 2008 Than Ngo <than@redhat.com> 0.1.1-10
137- 4.1.2
138
139* Fri Aug 29 2008 Than Ngo <than@redhat.com> 0.1.1-9
140- 4.1.1
141
142* Thu Aug 28 2008 Sebastian Vahl <fedora@deadbabylon.de> 0.1.1-8
143- 4.1 (final)
144
145* Mon May 26 2008 Than Ngo <than@redhat.com> 0.1.1-7.kde4.0.80
146- 4.1 beta1
147
148* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-6
149- rebuild (again) for the fixed %%{_kde4_buildtype}
150
151* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-5
152- rebuild for NDEBUG and _kde4_libexecdir
153
154* Thu Feb 14 2008 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-4
155- remove reference to KDE 4 in summary and description
156
157* Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-3
158- added Requires: kdelibs4 >= 4
159- added Requires: oxygen-icon-theme
160
161* Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-2
162- added requires xdg-utils, kde4-macros(api)
163
164* Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-1
165- initial version
Note: See TracBrowser for help on using the repository browser.