source: projects/specs/trunk/k/keyutils/keyutils-vl.spec @ 12336

Revision 12336, 7.1 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

gawk-5.0.1-1

grep-3.4-1

keyutils-1.6-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define vermajor 1
4%define verminor 6
5%define version %{vermajor}.%{verminor}
6%define libapivermajor 1
7%define libapiversion %{libapivermajor}.6
8
9%define libdir /%{_lib}
10%define usrlibdir %{_prefix}/%{_lib}
11
12Summary: Linux Key Management Utilities
13Summary(ja): Linux 鍵管理ユーティリティ
14Name: keyutils
15Version: %{version}
16Release: 1%{?_dist_release}
17Group: System Environment/Base
18License: GPLv2+ and LGPLv2+
19Distribution: Vine Linux
20Vendor: Project Vine
21
22URL: http://people.redhat.com/~dhowells/keyutils/
23Source0: http://people.redhat.com/~dhowells/keyutils/keyutils-%{version}.tar.bz2
24
25ExclusiveOS: Linux
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: glibc-kernheaders >= 2.4-9.1.92
28Requires: %{name}-libs = %{version}-%{release}
29
30
31%description
32Utilities to control the kernel key management facility and to provide
33a mechanism by which the kernel call back to userspace to get a key
34instantiated.
35
36%package libs
37Summary: Key utilities library
38Summary(ja): 鍵管理ユーティリティのライブラリ
39Group: System Environment/Libraries
40
41%description libs
42This package provides a wrapper library for the key management facility system
43calls.
44
45%package libs-devel
46Summary: Development package for building linux key management utilities
47Summary(ja): Linux 鍵管理ユーティリティの開発ファイル
48Group: Development/Libraries
49Requires: %{name}-libs = %{version}-%{release}
50
51%description libs-devel
52This package provides headers and libraries for building key utilities.
53
54%package -n compat32-%{name}-libs
55Summary: Key utilities library
56Summary(ja): 鍵管理ユーティリティのライブラリ
57Group: System Environment/Libraries
58Requires: %{name}-libs = %{version}-%{release}
59
60%description -n compat32-%{name}-libs
61This package provides a wrapper library for the key management facility system
62calls.
63
64%package -n compat32-%{name}-libs-devel
65Summary: Development package for building linux key management utilities
66Summary(ja): Linux 鍵管理ユーティリティの開発ファイル
67Group: Development/Libraries
68Requires: compat32-%{name}-libs = %{version}-%{release}
69Requires: %{name}-libs-devel = %{version}-%{release}
70
71%description -n compat32-%{name}-libs-devel
72This package provides headers and libraries for building key utilities.
73
74%prep
75%setup -q
76
77%build
78make \
79        NO_ARLIB=1 \
80        LIBDIR=%{libdir} \
81        USRLIBDIR=%{usrlibdir} \
82        BINDIR=%{_bindir} \
83        SBINDIR=%{_sbindir} \
84        RELEASE=.%{release} \
85        NO_GLIBC_KEYERR=1 \
86        CFLAGS="-Wall $RPM_OPT_FLAGS -Werror"
87
88%install
89rm -rf $RPM_BUILD_ROOT
90make \
91        NO_ARLIB=1 \
92        DESTDIR=$RPM_BUILD_ROOT \
93        LIBDIR=%{libdir} \
94        USRLIBDIR=%{usrlibdir} \
95        BINDIR=%{_bindir} \
96        SBINDIR=%{_sbindir} \
97        install
98
99mkdir -p %{buildroot}%{_libdir}
100mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post libs -p /sbin/ldconfig
106%postun libs -p /sbin/ldconfig
107
108%if %{build_compat32}
109%post -n compat32-%{name}-libs -p /sbin/ldconfig
110%postun -n compat32-%{name}-libs -p /sbin/ldconfig
111
112%endif
113
114%files
115%defattr(-,root,root,-)
116%license LICENCE.GPL
117%doc README
118%{_sbindir}/*
119%{_bindir}/*
120%{_datadir}/keyutils
121%{_mandir}/man1/*
122%{_mandir}/man5/*
123%{_mandir}/man8/*
124%config(noreplace) %{_sysconfdir}/*
125
126%files libs
127%defattr(-,root,root,-)
128%license LICENCE.LGPL
129%{_mandir}/man7/*
130%{libdir}/libkeyutils.so.*
131
132%files libs-devel
133%defattr(-,root,root,-)
134%{usrlibdir}/libkeyutils.so
135%{usrlibdir}/pkgconfig/*
136%{_includedir}/*
137%{_mandir}/man3/*
138
139# compat32
140%if %{build_compat32}
141%files -n compat32-%{name}-libs
142%defattr(-,root,root,-)
143%{libdir}/libkeyutils.so.*
144
145%files -n compat32-%{name}-libs-devel
146%defattr(-,root,root,-)
147%{usrlibdir}/libkeyutils.so
148%{usrlibdir}/pkgconfig/*
149%endif
150
151%changelog
152* Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6-1
153- new upstream release.
154
155* Mon Dec 22 2014 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.9-1
156- updated to 1.5.9
157- rebuilt on current VineSeed
158
159* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2-4
160- rebuilt with new toolchains
161
162* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-3
163- added compat32 package for x86_64 arch support
164
165* Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2-2
166- changed libs subpackage's Group to System Environment/Libraries
167- changed devel subpackage's Group to Development/Libraries
168
169* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
170- initial build for Vine Linux
171
172* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2-3
173- Autorebuild for GCC 4.3
174
175* Tue Aug 22 2006 David Howells <dhowells@redhat.com> - 1.2-1
176- Remove syscall manual pages (section 2) to man-pages package [BZ 203582]
177- Don't write to serial port in debugging script
178
179* Mon Jun 5 2006 David Howells <dhowells@redhat.com> - 1.1-4
180- Call ldconfig during (un)installation.
181
182* Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-3
183- Don't include the release number in the shared library filename
184- Don't build static library
185
186* Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-2
187- More bug fixes from Fedora reviewer.
188
189* Thu May 4 2006 David Howells <dhowells@redhat.com> - 1.1-1
190- Fix rpmlint errors
191
192* Mon Dec 5 2005 David Howells <dhowells@redhat.com> - 1.0-2
193- Add build dependency on glibc-kernheaders with key management syscall numbers
194
195* Tue Nov 29 2005 David Howells <dhowells@redhat.com> - 1.0-1
196- Add data pipe-in facility for keyctl request2
197
198* Mon Nov 28 2005 David Howells <dhowells@redhat.com> - 1.0-1
199- Rename library and header file "keyutil" -> "keyutils" for consistency
200- Fix shared library version naming to same way as glibc.
201- Add versioning for shared library symbols
202- Create new keyutils-libs package and install library and main symlink there
203- Install base library symlink in /usr/lib and place in devel package
204- Added a keyutils archive library
205- Shorten displayed key permissions list to just those we actually have
206
207* Thu Nov 24 2005 David Howells <dhowells@redhat.com> - 0.3-4
208- Add data pipe-in facilities for keyctl add, update and instantiate
209
210* Fri Nov 18 2005 David Howells <dhowells@redhat.com> - 0.3-3
211- Added stdint.h inclusion in keyutils.h
212- Made request-key.c use request_key() rather than keyctl_search()
213- Added piping facility to request-key
214
215* Thu Nov 17 2005 David Howells <dhowells@redhat.com> - 0.3-2
216- Added timeout keyctl option
217- request_key auth keys must now be assumed
218- Fix keyctl argument ordering for debug negate line in request-key.conf
219
220* Thu Jul 28 2005 David Howells <dhowells@redhat.com> - 0.3-1
221- Must invoke initialisation from perror() override in libkeyutils
222- Minor UI changes
223
224* Wed Jul 20 2005 David Howells <dhowells@redhat.com> - 0.2-2
225- Bump version to permit building in main repositories.
226
227* Tue Jul 12 2005 David Howells <dhowells@redhat.com> - 0.2-1
228- Don't attempt to define the error codes in the header file.
229- Pass the release ID through to the makefile to affect the shared library name.
230
231* Tue Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-3
232- Build in the perror() override to get the key error strings displayed.
233
234* Tue Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-2
235- Need a defattr directive after each files directive.
236
237* Tue Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-1
238- Package creation.
Note: See TracBrowser for help on using the repository browser.