source: projects/specs/trunk/k/keyutils/keyutils-vl.spec @ 9182

Revision 9182, 7.0 KB checked in by inagaki, 9 years ago (diff)

2014-12-22 Ryoichi INAGAKI <ryo1@…>

  • MySQL-ruby, gtkimageview: fixed spec
  • grep, keyutils, ruby-uconv: updated
  • icon-naming-utils: rebuilt


Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define vermajor 1
4%define verminor 5.9
5%define version %{vermajor}.%{verminor}
6%define libapivermajor 1
7%define libapiversion %{libapivermajor}.5
8
9%define libdir /%{_lib}
10%define usrlibdir %{_prefix}/%{_lib}
11
12Summary: Linux Key Management Utilities
13Summary(ja): Linux 鍵管理ユーティリティ
14Name: keyutils
15Version: %{version}
16Release: 1%{?_dist_release}
17License: GPLv2+ and LGPLv2+
18Group: System Environment/Base
19ExclusiveOS: Linux
20URL: http://people.redhat.com/~dhowells/keyutils/
21
22Source0: http://people.redhat.com/~dhowells/keyutils/keyutils-%{version}.tar.bz2
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: glibc-kernheaders >= 2.4-9.1.92
26Requires: %{name}-libs = %{version}-%{release}
27
28Distribution: Vine Linux
29Vendor: Project Vine
30
31%description
32Utilities to control the kernel key management facility and to provide
33a mechanism by which the kernel call back to userspace to get a key
34instantiated.
35
36%package libs
37Summary: Key utilities library
38Summary(ja): 鍵管理ユーティリティのライブラリ
39Group: System Environment/Libraries
40
41%description libs
42This package provides a wrapper library for the key management facility system
43calls.
44
45%package libs-devel
46Summary: Development package for building linux key management utilities
47Summary(ja): Linux 鍵管理ユーティリティの開発ファイル
48Group: Development/Libraries
49Requires: %{name}-libs = %{version}-%{release}
50
51%description libs-devel
52This package provides headers and libraries for building key utilities.
53
54%package -n compat32-%{name}-libs
55Summary: Key utilities library
56Summary(ja): 鍵管理ユーティリティのライブラリ
57Group: System Environment/Libraries
58Requires: %{name}-libs = %{version}-%{release}
59
60%description -n compat32-%{name}-libs
61This package provides a wrapper library for the key management facility system
62calls.
63
64%package -n compat32-%{name}-libs-devel
65Summary: Development package for building linux key management utilities
66Summary(ja): Linux 鍵管理ユーティリティの開発ファイル
67Group: Development/Libraries
68Requires: compat32-%{name}-libs = %{version}-%{release}
69Requires: %{name}-libs-devel = %{version}-%{release}
70
71%description -n compat32-%{name}-libs-devel
72This package provides headers and libraries for building key utilities.
73
74%prep
75%setup -q
76
77%build
78make \
79        NO_ARLIB=1 \
80        LIBDIR=%{libdir} \
81        USRLIBDIR=%{usrlibdir} \
82        BINDIR=%{_bindir} \
83        SBINDIR=%{_sbindir} \
84        RELEASE=.%{release} \
85        NO_GLIBC_KEYERR=1 \
86        CFLAGS="-Wall $RPM_OPT_FLAGS -Werror"
87
88%install
89rm -rf $RPM_BUILD_ROOT
90make \
91        NO_ARLIB=1 \
92        DESTDIR=$RPM_BUILD_ROOT \
93        LIBDIR=%{libdir} \
94        USRLIBDIR=%{usrlibdir} \
95        BINDIR=%{_bindir} \
96        SBINDIR=%{_sbindir} \
97        install
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post libs -p /sbin/ldconfig
103%postun libs -p /sbin/ldconfig
104
105%if %{build_compat32}
106%post -n compat32-%{name}-libs -p /sbin/ldconfig
107%postun -n compat32-%{name}-libs -p /sbin/ldconfig
108
109%endif
110
111%files
112%defattr(-,root,root,-)
113%doc README LICENCE.GPL
114%{_sbindir}/*
115%{_bindir}/*
116%{_datadir}/keyutils
117%{_mandir}/man1/*
118%{_mandir}/man5/*
119%{_mandir}/man8/*
120%config(noreplace) %{_sysconfdir}/*
121
122%files libs
123%defattr(-,root,root,-)
124%doc LICENCE.LGPL
125%{_mandir}/man7/*
126%{libdir}/libkeyutils.so.%{libapiversion}
127%{libdir}/libkeyutils.so.%{libapivermajor}
128
129%files libs-devel
130%defattr(-,root,root,-)
131%{usrlibdir}/libkeyutils.so
132%{_includedir}/*
133%{_mandir}/man3/*
134
135# compat32
136%if %{build_compat32}
137%files -n compat32-%{name}-libs
138%defattr(-,root,root,-)
139%{libdir}/libkeyutils.so.%{libapiversion}
140%{libdir}/libkeyutils.so.%{libapivermajor}
141
142%files -n compat32-%{name}-libs-devel
143%defattr(-,root,root,-)
144%{usrlibdir}/libkeyutils.so
145%endif
146
147%changelog
148* Mon Dec 22 2014 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.9-1
149- updated to 1.5.9
150- rebuilt on current VineSeed
151
152* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2-4
153- rebuilt with new toolchains
154
155* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-3
156- added compat32 package for x86_64 arch support
157
158* Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2-2
159- changed libs subpackage's Group to System Environment/Libraries
160- changed devel subpackage's Group to Development/Libraries
161
162* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
163- initial build for Vine Linux
164
165* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2-3
166- Autorebuild for GCC 4.3
167
168* Tue Aug 22 2006 David Howells <dhowells@redhat.com> - 1.2-1
169- Remove syscall manual pages (section 2) to man-pages package [BZ 203582]
170- Don't write to serial port in debugging script
171
172* Mon Jun 5 2006 David Howells <dhowells@redhat.com> - 1.1-4
173- Call ldconfig during (un)installation.
174
175* Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-3
176- Don't include the release number in the shared library filename
177- Don't build static library
178
179* Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-2
180- More bug fixes from Fedora reviewer.
181
182* Thu May 4 2006 David Howells <dhowells@redhat.com> - 1.1-1
183- Fix rpmlint errors
184
185* Mon Dec 5 2005 David Howells <dhowells@redhat.com> - 1.0-2
186- Add build dependency on glibc-kernheaders with key management syscall numbers
187
188* Tue Nov 29 2005 David Howells <dhowells@redhat.com> - 1.0-1
189- Add data pipe-in facility for keyctl request2
190
191* Mon Nov 28 2005 David Howells <dhowells@redhat.com> - 1.0-1
192- Rename library and header file "keyutil" -> "keyutils" for consistency
193- Fix shared library version naming to same way as glibc.
194- Add versioning for shared library symbols
195- Create new keyutils-libs package and install library and main symlink there
196- Install base library symlink in /usr/lib and place in devel package
197- Added a keyutils archive library
198- Shorten displayed key permissions list to just those we actually have
199
200* Thu Nov 24 2005 David Howells <dhowells@redhat.com> - 0.3-4
201- Add data pipe-in facilities for keyctl add, update and instantiate
202
203* Fri Nov 18 2005 David Howells <dhowells@redhat.com> - 0.3-3
204- Added stdint.h inclusion in keyutils.h
205- Made request-key.c use request_key() rather than keyctl_search()
206- Added piping facility to request-key
207
208* Thu Nov 17 2005 David Howells <dhowells@redhat.com> - 0.3-2
209- Added timeout keyctl option
210- request_key auth keys must now be assumed
211- Fix keyctl argument ordering for debug negate line in request-key.conf
212
213* Thu Jul 28 2005 David Howells <dhowells@redhat.com> - 0.3-1
214- Must invoke initialisation from perror() override in libkeyutils
215- Minor UI changes
216
217* Wed Jul 20 2005 David Howells <dhowells@redhat.com> - 0.2-2
218- Bump version to permit building in main repositories.
219
220* Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.2-1
221- Don't attempt to define the error codes in the header file.
222- Pass the release ID through to the makefile to affect the shared library name.
223
224* Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-3
225- Build in the perror() override to get the key error strings displayed.
226
227* Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-2
228- Need a defattr directive after each files directive.
229
230* Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-1
231- Package creation.
Note: See TracBrowser for help on using the repository browser.