source: projects/specs/trunk/k/keybinder/keybinder-vl.spec @ 4804

Revision 4804, 2.8 KB checked in by kudoh, 13 years ago (diff)

%{!?python_sitearch: %global python_sitearch %(%{python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}

Name: keybinder
Version: 0.2.2
Release: 2%{?_dist_release}
Summary: library for registering global keyboard shortcuts

Group: System Environment/Libraries?
License: GPLv2
URL:  http://kaizer.se/wiki/keybinder/
Source0:  http://kaizer.se/publicfiles/keybinder/%{name}-%{version}.tar.gz
BuildRoot?: %{_tmppath}/%{name}-%{version}-root

#BuildArch?:
BuildRequires?: gtk2-devel >= 2.20
BuildRequires?: lua-devel
BuildRequires?: pygtk2-devel >= 2.12
BuildRequires?: pygobject-devel >= 2.15.3
BuildRequires?: python-devel

#Requires: lua python

%description
keybinder is a library for registering global keyboard shortcuts.
Keybinder works with GTK-based applications using the X Window System.

%package devel
Summary: Development files for %{name}
Summary(ja): %{name} の開発ファイル
Group: Development/Libraries?
Requires: %{name} = %{version}-%{release}

%description devel
The %{name}-devel package contains libraries and header files for
developing extensions for %{name}.

%package -n python-%{name}
Group: Development/Libraries?
License: GPLv2+
Summary: Keybinder python bindings
Summary(ja): Keybinder の python バインディング
Requires: %{name} = %{version}-%{release}
Requires: pygtk2 pygobject

%description -n python-%{name}
This package contains python bindings for keybinder.

%package -n lua-%{name}
Group: Development/Libraries?
Summary: Keybinder lua bindings
Summary(ja): Keybinder の lua バインディング
Requires: %{name} = %{version}-%{release}
Requires: lua

%description -n lua-%{name}
This package contains lua bindings for keybinder.

%prep
%setup -q

%build
%configure --enable-static=no --enable-python
make %{?_smp_mflags}

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT

rm -rf $RPM_BUILD_ROOT%{_libdir}/lib%{name}.la
rm -rf $RPM_BUILD_ROOT%{_libdir}/lua/5.?/%{name}.la

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig

%files
%defattr(-,root,root)
%{_libdir}/libkeybinder.so.*
%doc NEWS AUTHORS README

%files devel
%defattr(-,root,root)
%{_includedir}/keybinder.h
%{_libdir}/pkgconfig/keybinder.pc
%{_libdir}/libkeybinder.so

%files -n python-%{name}
%defattr(-,root,root)
%{python_sitearch}/%{name}
%doc COPYING

%files -n lua-%{name}
%defattr(-,root,root)
%{_libdir}/lua/5.?/keybinder.so

%changelog

  • Fri Sep 23 2011 Toshiharu Kudoh <toshi.kd2@…> - 0.2.2-2
  • splitted python-keybinder, lua-keybinder
  • added configure option
    • --enable-static=no --enable-python
  • Sat Jul 23 2011 Toshiharu Kudoh <toshi.kd2@…> - 0.2.2
  • initial build for Vine Linux
  • Thu Nov 6 2010 Radek Ryckowski <radek@…> - 0.2.2
  • Initial RPM release
Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name:           keybinder
4Version:        0.2.2
5Release:        2%{?_dist_release}
6Summary:        library for registering global keyboard shortcuts
7
8Group:          System Environment/Libraries
9License:        GPLv2
10URL:            http://kaizer.se/wiki/keybinder/
11Source0:        http://kaizer.se/publicfiles/keybinder/%{name}-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#BuildArch:
15BuildRequires:  gtk2-devel >= 2.20
16BuildRequires:  lua-devel
17BuildRequires:  pygtk2-devel >= 2.12
18BuildRequires:  pygobject-devel >= 2.15.3
19BuildRequires:  python-devel
20
21#Requires:       lua python
22
23
24%description
25keybinder is a library for registering global keyboard shortcuts.
26Keybinder works with GTK-based applications using the X Window System.
27
28%package        devel
29Summary:        Development files for %{name}
30Summary(ja):    %{name} の開発ファイル
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33
34%description    devel
35The %{name}-devel package contains libraries and header files for
36developing extensions for %{name}.
37
38%package -n python-%{name}
39Group:          Development/Libraries
40License:        GPLv2+
41Summary:        Keybinder python bindings
42Summary(ja):    Keybinder の python バインディング
43Requires:       %{name} = %{version}-%{release}
44Requires:       pygtk2 pygobject
45
46%description -n python-%{name}
47This package contains python bindings for keybinder.
48
49%package -n lua-%{name}
50Group:          Development/Libraries
51Summary:        Keybinder lua bindings
52Summary(ja):    Keybinder の lua バインディング
53Requires:       %{name} = %{version}-%{release}
54Requires:       lua
55
56%description -n lua-%{name}
57This package contains lua bindings for keybinder.
58
59%prep
60%setup -q
61
62%build
63%configure --enable-static=no --enable-python
64make %{?_smp_mflags}
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make install DESTDIR=$RPM_BUILD_ROOT
69
70rm -rf $RPM_BUILD_ROOT%{_libdir}/lib%{name}.la
71rm -rf $RPM_BUILD_ROOT%{_libdir}/lua/5.?/%{name}.la
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post -p /sbin/ldconfig
77%postun -p /sbin/ldconfig
78
79%files
80%defattr(-,root,root)
81%{_libdir}/libkeybinder.so.*
82%doc NEWS AUTHORS README
83
84%files devel
85%defattr(-,root,root)
86%{_includedir}/keybinder.h
87%{_libdir}/pkgconfig/keybinder.pc
88%{_libdir}/libkeybinder.so
89
90%files -n python-%{name}
91%defattr(-,root,root)
92%{python_sitearch}/%{name}
93%doc COPYING
94
95%files -n lua-%{name}
96%defattr(-,root,root)
97%{_libdir}/lua/5.?/keybinder.so
98
99
100%changelog
101* Fri Sep 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.2-2
102- splitted python-keybinder, lua-keybinder
103- added configure option
104  - --enable-static=no --enable-python
105
106* Sat Jul 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.2
107- initial build for Vine Linux
108
109* Thu Nov 6 2010 Radek Ryckowski <radek@ebi.ac.uk> - 0.2.2
110- Initial RPM release
Note: See TracBrowser for help on using the repository browser.