source: projects/specs/trunk/k/keepnote/keepnote-vl.spec @ 6359

Revision 6359, 4.8 KB checked in by kudoh, 12 years ago (diff)

keepnote-vl.spec

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:        A note taking application
4Summary(ja):    ノート作成アプリケーション
5Name:           keepnote
6Version:        0.7.8
7Release:        1%{?_dist_release}
8Group:          Applications/Editors
9License:        GPLv2+
10URL:            http://rasm.ods.org/keepnote/
11Source0:        %{name}/%{name}-%{version}.tar.gz
12Source1:        ja_JP.UTF8.po
13
14Patch1:         Makefile_gettetxt.patch
15Patch2:         fix_desktop.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildArch:      noarch
19
20BuildRequires:  python-devel
21BuildRequires:  python-setuptools
22BuildRequires:  gtkspell-devel
23BuildRequires:  desktop-file-utils
24# for Japanese language file build
25BuildRequires:  gettext
26BuildRequires:  intltool
27
28Requires:       pygtk2
29Requires:       gnome-python-extras
30Requires:       sqlite3 >= 3.5.0
31
32%description
33KeepNote is a note taking application that works on Windows, Linux, and Mac OS X.
34With KeepNote, you can store your class notes, TODO lists, research notes,
35journal entries, paper outlines, etc in a simple notebook hierarchy with
36rich-text formatting, images, and more. Using full-text search, you can
37retrieve any note for later reference.
38
39%description -l ja     
40KeepNote は Windows、Linux、Mac OS X で動作するノート作成アプリケーションです。
41KeepNote では、あなたの分類ノート、TODO リスト、研究ノート、
42日記のエントリ、新聞の概略などを階層化したリッチテキストフォーマットや
43画像付きなどのシンプルなノートとして保存することができます。
44フルテキスト検索を使い、後で参照するために取ったメモを検索できます。
45
46%prep
47%setup -q
48%patch1 -p1
49%patch2 -p1
50
51%{__cp} -f %{SOURCE1} gettext/ja_JP.UTF8.po
52make -f Makefile.gettext make LANG=ja_JP.UTF8
53
54%build
55python setup.py build
56
57
58%install
59rm -rf %{buildroot}
60python setup.py install --skip-build --root %{buildroot}
61
62desktop-file-install --vendor="" \
63     --delete-original \
64     --add-category="Office;" \
65     --dir=%{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/*
66
67
68
69%clean
70rm -rf %{buildroot}
71
72%post
73touch --no-create %{_datadir}/icons/hicolor || :
74%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
75update-desktop-database > /dev/null 2>&1 || :
76
77%postun
78touch --no-create %{_datadir}/icons/hicolor || :
79%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
80update-desktop-database > /dev/null 2>&1 || :
81
82
83%files
84%defattr(-,root,root,-)
85%doc LICENSE README
86%{_bindir}/%{name}
87%{_datadir}/applications/%{name}.desktop
88%{_datadir}/icons/hicolor/48x48/apps/keepnote.png
89%{python_sitelib}/*
90
91
92%changelog
93* Sun Jun 17 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.8-1
94- new upstream release
95- added Requires: sqlite3 >= 3.5.0
96- re-added source1
97
98* Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.7-1
99- new upstream release
100
101* Wed Nov 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.6-1
102- new upstream release
103- added patch2 to fix desktop file
104
105* Mon Sep 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.5-1
106- new upstream release
107
108* Thu Jul 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.4-1
109- new upstream release
110
111* Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
112- new upstream release
113- dropt source1
114  - merged upstream
115
116* Tue Jan 25 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.8-1
117- new upstream release
118
119* Tue Dec 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.7-1
120- new upstream release
121- re-added source1
122- fixed .desktop file a little
123- used python macro
124
125* Sat Oct 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.5-1
126- new upstream release
127- added BuildRequires:  gettext, intltool
128
129* Sun Aug 1 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-1
130- new upstream release
131
132* Wed Jul 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-1
133- new upstream release
134- dropt source1
135  - merged upstream
136
137* Thu May 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.2-2
138- updated Source1
139- fixed desktop-file-install --add-category section
140
141* Tue Feb 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.2-1
142- new upstream release
143- updated Source1 and Patch1
144
145* Sat Feb 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-2
146- updated Source1
147
148* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
149- new upstream release
150
151* Sat Nov 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6-2
152- added BuildRequires:  gtkspell-devel
153- updated Source1
154
155* Sat Nov 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6-1
156- initial build for VineSeed
157
158* Fri Jul 31 2009 Texstar <texstar@gmail.com> 0.5.3-1pclos2009
159- create
160file:///home/toshi/rpm/SOURCES/keepnote/keepnote-0.7.2/desktop/keepnote.desktop
Note: See TracBrowser for help on using the repository browser.