source: projects/specs/trunk/k/keepassx/keepassx-vl.spec @ 7308

Revision 7308, 7.0 KB checked in by iwaim, 11 years ago (diff)

keepassx 0.4.3-1

Line 
1%define ver 0.4.3
2%define rel 1
3
4Name:           keepassx
5Version:        %{ver}
6Release:        %{rel}%{_dist_release}
7Summary:        Cross-platform password manager
8Summary(ja):    クロスプラットフォーム パスワードマネージャー
9Group:          User Interface/Desktops
10License:        GPLv2+
11URL:            http://www.keepassx.org/
12Source0:        http://download.sf.net/keepassx/keepassx-%{version}.tar.gz
13Patch1:         keepassx-0.3.3-gcc43.patch
14Patch2:         keepassx-0.4.3-gcc47.patch
15BuildRequires:  qt4-devel > 4.1, libXtst-devel, ImageMagick, desktop-file-utils
16Requires:       hicolor-icon-theme
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: iwaim
21
22%description
23KeePassX is an application for people with extremly high demands on secure
24personal data management.
25KeePassX saves many different information e.g. user names, passwords, urls,
26attachemts and comments in one single database. For a better management
27user-defined titles and icons can be specified for each single entry.
28Furthermore the entries are sorted in groups, which are customizable as well.
29The integrated search function allows to search in a single group or the
30complete database.
31KeePassX offers a little utility for secure password generation. The password
32generator is very customizable, fast and easy to use. Especially someone who
33generates passwords frequently will appreciate this feature.
34The complete database is always encrypted either with AES (alias Rijndael) or
35Twofish encryption algorithm using a 256 bit key. Therefore the saved
36information can be considered as quite safe. KeePassX uses a database format
37that is compatible with KeePass Password Safe for MS Windows.
38
39%prep
40%setup -q
41%patch1 -p0 -b .gcc43
42%patch2 -p1 -b .gcc47
43
44%build
45export CFLAGS=$RPM_OPT_FLAGS
46export CXXFLAGS=$RPM_OPT_FLAGS
47qmake PREFIX=%{_prefix}
48make %{?_smp_mflags}
49
50%install
51make install INSTALL_ROOT=%{buildroot}
52
53# Use png in _datadir/icons/hicolor instead of xpm in pixmaps
54mkdir -p %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/
55convert %{buildroot}%{_datadir}/pixmaps/keepassx.xpm \
56        %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/keepassx.png
57rm -f %{buildroot}%{_datadir}/pixmaps/keepassx.xpm
58
59# Menu
60sed -i -e 's/^Exec=keepassx$/Exec=keepassx %f/g' \
61        %{buildroot}%{_datadir}/applications/%{name}.desktop
62desktop-file-install  --vendor vine\
63        --dir %{buildroot}%{_datadir}/applications \
64        --delete-original \
65        --add-mime-type application/x-keepass \
66        %{buildroot}%{_datadir}/applications/%{name}.desktop
67
68# Associate KDB files
69cat > x-keepass.desktop << EOF
70[Desktop Entry]
71Comment=
72Hidden=false
73Icon=keepassx.png
74MimeType=application/x-keepass
75Patterns=*.kdb;*.KDB
76Type=MimeType
77EOF
78install -D -m 644 -p x-keepass.desktop \
79  %{buildroot}%{_datadir}/mimelnk/application/x-keepass.desktop
80
81%check
82make check
83%{_bindir}/desktop-file-validate %{buildroot}%{_datadir}/applications/vine-%{name}.desktop
84
85%post
86touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
87if [ -x %{_bindir}/update-desktop-database ] ; then
88    %{_bindir}/update-desktop-database &> /dev/null ||:
89fi
90if [ -x %{_bindir}/update-mime-database ] ; then
91    %{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null || :
92fi
93
94%postun
95if [ $1 -eq 0 ] ; then
96    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
97    if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
98        %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
99    fi
100fi
101if [ -x %{_bindir}/update-desktop-database ] ; then
102    %{_bindir}/update-desktop-database &> /dev/null ||:
103fi
104if [ -x %{_bindir}/update-mime-database ] ; then
105    %{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null || :
106fi
107
108%posttrans
109if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
110    %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
111fi
112
113%files
114%doc share/keepassx/license.html
115%{_bindir}/keepassx
116%{_datadir}/keepassx
117%{_datadir}/applications/*.desktop
118%{_datadir}/mimelnk/application/*.desktop
119%{_datadir}/mime/packages/*.xml
120%{_datadir}/icons/hicolor/*/apps/keepassx.png
121
122%changelog
123* Wed Dec 19 2012 IWAI, Masaharu <iwai@alib.jp> 0.4.3-1
124- initial build for Vine Linux
125
126* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-6
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
128
129* Fri Mar 30 2012 Tom Callaway <spot@fedoraproject.org> - 0.4.3-5
130- fix FTBFS on gcc 4.7
131
132* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-4
133- Rebuilt for c++ ABI breakage
134
135* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-3
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
137
138* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-2
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
140
141* Sun Mar 14 2010 Aurelien Bompard <abompard@fedoraproject.org> -  0.4.3-1
142- version 0.4.3
143
144* Sun Jan 03 2010 Aurelien Bompard <abompard@fedoraproject.org> -  0.4.1-1
145- version 0.4.1
146
147* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-3
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
149
150* Sat Apr 18 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.4.0-2
151- add patch0 to fix bug 496035
152
153* Thu Mar 26 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.4.0-1
154- version 0.4.0
155- drop patch0 (upstream)
156
157* Thu Mar 12 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.3.4-3
158- backport fix from upstream for bug #489820
159
160* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.4-2
161- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
162
163* Tue Nov 11 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.4-1
164- version 0.3.4
165
166* Sat Aug 23 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.3-2
167- rebase patch for version 0.3.3
168
169* Tue Aug 12 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.3-1
170- version 0.3.3
171
172* Mon Jul 21 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.2-1
173- version 0.3.2
174
175* Sun Mar 16 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.1-1
176- version 0.3.1
177- drop xdg patch, keepassx now uses QDesktopServices
178
179* Wed Mar 05 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-3.a
180- version 0.3.0a
181
182* Wed Mar 05 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-2
183- patch for gcc 4.3
184
185* Sun Mar 02 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-1
186- version 0.3.0
187- drop helpwindow patch (feature dropped upstream)
188
189* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.2-5
190- Autorebuild for GCC 4.3
191
192* Sun Oct 07 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-4
193- use xdg-open instead of htmlview
194
195* Sat Aug 25 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-3
196- fix license tag
197- rebuild for BuildID
198
199* Wed Jun 27 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-2
200- fix help button
201- use htmlview instead of the hardcoded konqueror
202
203* Sun Mar 04 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-1
204- initial package
Note: See TracBrowser for help on using the repository browser.