source: projects/specs/trunk/k/keepassx/keepassx-vl.spec @ 9895

Revision 9895, 7.3 KB checked in by iwaim, 8 years ago (diff)

keepassx 0.4.4-1

Line 
1%define ver 0.4.4
2%define rel 1
3
4Name:           keepassx
5Version:        %{ver}
6Release:        %{rel}%{_dist_release}
7Summary:        Cross-platform password manager
8Summary(ja):    クロスプラットフォーム パスワードマネージャー
9Group:          Applications/Accessories
10License:        GPLv2+
11URL:            http://www.keepassx.org/
12Source0:        http://download.sf.net/keepassx/keepassx-%{version}.tar.gz
13Patch1:         keepassx-0.3.3-gcc43.patch
14Patch2:         keepassx-0.4.3-gcc47.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  qt4-devel > 4.1
18BuildRequires:  libXtst-devel
19BuildRequires:  ImageMagick
20BuildRequires:  desktop-file-utils
21Requires:       hicolor-icon-theme
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: iwaim
26
27%description
28KeePassX is an application for people with extremly high demands on secure personal data management.
29KeePassX saves many different information e.g. user names, passwords, urls, attachemts and comments in one single database. For a better management user-defined titles and icons can be specified for each single entry.
30Furthermore the entries are sorted in groups, which are customizable as well.
31The integrated search function allows to search in a single group or the complete database.
32KeePassX offers a little utility for secure password generation. The password generator is very customizable, fast and easy to use. Especially someone who generates passwords frequently will appreciate this feature.
33The complete database is always encrypted either with AES (alias Rijndael) or Twofish encryption algorithm using a 256 bit key. Therefore the saved information can be considered as quite safe. KeePassX uses a database format that is compatible with KeePass Password Safe for MS Windows.
34
35%prep
36%setup -q
37%patch1 -p0 -b .gcc43
38%patch2 -p1 -b .gcc47
39
40%build
41export CFLAGS=$RPM_OPT_FLAGS
42export CXXFLAGS=$RPM_OPT_FLAGS
43qmake PREFIX=%{_prefix}
44make %{?_smp_mflags}
45
46%install
47make install INSTALL_ROOT=%{buildroot}
48
49# Use png in _datadir/icons/hicolor instead of xpm in pixmaps
50mkdir -p %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/
51convert %{buildroot}%{_datadir}/pixmaps/keepassx.xpm \
52        %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/keepassx.png
53rm -f %{buildroot}%{_datadir}/pixmaps/keepassx.xpm
54
55# Menu
56sed -i -e 's/^Exec=keepassx$/Exec=keepassx %f/g' \
57        %{buildroot}%{_datadir}/applications/%{name}.desktop
58desktop-file-install \
59        --dir %{buildroot}%{_datadir}/applications \
60        --delete-original \
61        --add-mime-type application/x-keepass \
62        %{buildroot}%{_datadir}/applications/%{name}.desktop
63
64# Associate KDB files
65cat > x-keepass.desktop << EOF
66[Desktop Entry]
67Comment=
68Hidden=false
69Icon=keepassx.png
70MimeType=application/x-keepass
71Patterns=*.kdb;*.KDB
72Type=MimeType
73EOF
74install -D -m 644 -p x-keepass.desktop \
75  %{buildroot}%{_datadir}/mimelnk/application/x-keepass.desktop
76
77%check
78make check
79%{_bindir}/desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
80
81%post
82touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
83if [ -x %{_bindir}/update-desktop-database ] ; then
84    %{_bindir}/update-desktop-database &> /dev/null ||:
85fi
86if [ -x %{_bindir}/update-mime-database ] ; then
87    %{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null || :
88fi
89
90%postun
91if [ $1 -eq 0 ] ; then
92    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
93    if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
94        %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
95    fi
96fi
97if [ -x %{_bindir}/update-desktop-database ] ; then
98    %{_bindir}/update-desktop-database &> /dev/null ||:
99fi
100if [ -x %{_bindir}/update-mime-database ] ; then
101    %{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null || :
102fi
103
104%posttrans
105if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
106    %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
107fi
108
109%files
110%doc share/keepassx/license.html
111%{_bindir}/keepassx
112%{_datadir}/keepassx
113%{_datadir}/applications/*.desktop
114%{_datadir}/mimelnk/application/*.desktop
115%{_datadir}/mime/packages/*.xml
116%{_datadir}/icons/hicolor/*/apps/keepassx.png
117
118%changelog
119* Thu Dec 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.4.4-1
120- update to 0.4.4
121
122* Sat Feb  7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.3-2
123- rebuilt on current VineSeed
124- moved to Applications/Accessories Group
125
126* Wed Dec 19 2012 IWAI, Masaharu <iwai@alib.jp> 0.4.3-1
127- initial build for Vine Linux
128
129* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-6
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
131
132* Fri Mar 30 2012 Tom Callaway <spot@fedoraproject.org> - 0.4.3-5
133- fix FTBFS on gcc 4.7
134
135* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-4
136- Rebuilt for c++ ABI breakage
137
138* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-3
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
140
141* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-2
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
143
144* Sun Mar 14 2010 Aurelien Bompard <abompard@fedoraproject.org> -  0.4.3-1
145- version 0.4.3
146
147* Sun Jan 03 2010 Aurelien Bompard <abompard@fedoraproject.org> -  0.4.1-1
148- version 0.4.1
149
150* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-3
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
152
153* Sat Apr 18 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.4.0-2
154- add patch0 to fix bug 496035
155
156* Thu Mar 26 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.4.0-1
157- version 0.4.0
158- drop patch0 (upstream)
159
160* Thu Mar 12 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.3.4-3
161- backport fix from upstream for bug #489820
162
163* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.4-2
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
165
166* Tue Nov 11 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.4-1
167- version 0.3.4
168
169* Sat Aug 23 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.3-2
170- rebase patch for version 0.3.3
171
172* Tue Aug 12 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.3-1
173- version 0.3.3
174
175* Mon Jul 21 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.2-1
176- version 0.3.2
177
178* Sun Mar 16 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.1-1
179- version 0.3.1
180- drop xdg patch, keepassx now uses QDesktopServices
181
182* Wed Mar 05 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-3.a
183- version 0.3.0a
184
185* Wed Mar 05 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-2
186- patch for gcc 4.3
187
188* Sun Mar 02 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-1
189- version 0.3.0
190- drop helpwindow patch (feature dropped upstream)
191
192* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.2-5
193- Autorebuild for GCC 4.3
194
195* Sun Oct 07 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-4
196- use xdg-open instead of htmlview
197
198* Sat Aug 25 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-3
199- fix license tag
200- rebuild for BuildID
201
202* Wed Jun 27 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-2
203- fix help button
204- use htmlview instead of the hardcoded konqueror
205
206* Sun Mar 04 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-1
207- initial package
Note: See TracBrowser for help on using the repository browser.