source: projects/specs/trunk/k/keepalived/keepalived-vl.spec @ 7617

Revision 7617, 5.6 KB checked in by daisuke, 11 years ago (diff)

keepalived: new package

Line 
1Summary: HA monitor built upon LVS, VRRP and services poller
2Name: keepalived
3Version: 1.2.7
4Release: 1%{?_dist_release}
5License: GPL
6Group: Applications/System
7URL: http://www.keepalived.org/
8
9Source0: http://www.keepalived.org/software/keepalived-%{version}.tar.gz
10
11Patch0: keepalived-1.2.7-dont-respawn-children.patch
12Patch1: keepalived-1.2.7-cleanup-duplicate-option-code.patch
13Patch2: keepalived-1.2.7-generate-usage-message-from-popt.patch
14Patch3: keepalived-1.2.7-update-keepalived-man-page.patch
15Patch4: keepalived-1.2.7-fix-pointer-arithmetic-vrrp-packet.patch
16Patch8: keepalived-1.2.7-fix-primary-ip-address-comparison.patch
17Patch5: keepalived-1.2.7-fix-ssl-certificate-load.patch
18Patch6: keepalived-1.2.7-fix-error-message.patch
19Patch7: keepalived-1.2.7-update-gpl-license.patch
20Patch9: keepalived-1.2.7-remove-debug-messages.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23BuildRequires: openssl-devel
24BuildRequires: kernel-devel
25BuildRequires: popt-devel
26BuildRequires: libnl-devel
27BuildRequires: net-snmp-devel
28BuildRequires: rpm-devel
29BuildRequires: tcp_wrappers
30
31Requires(post): /sbin/chkconfig
32Requires(preun): /sbin/service, /sbin/chkconfig
33Requires(postun): /sbin/service
34
35%description
36The main goal of the keepalived project is to add a strong & robust keepalive
37facility to the Linux Virtual Server project. This project is written in C with
38multilayer TCP/IP stack checks. Keepalived implements a framework based on
39three family checks : Layer3, Layer4 & Layer5/7. This framework gives the
40daemon the ability to check the state of an LVS server pool. When one of the
41servers of the LVS server pool is down, keepalived informs the linux kernel via
42a setsockopt call to remove this server entry from the LVS topology. In
43addition keepalived implements an independent VRRPv2 stack to handle director
44failover. So in short keepalived is a userspace daemon for LVS cluster nodes
45healthchecks and LVS directors failover.
46
47
48%prep
49%setup
50
51
52%build
53%configure --enable-snmp
54%{__make} %{?_smp_mflags} STRIP=/bin/true
55
56
57%install
58%{__rm} -rf %{buildroot}
59%{__make} install DESTDIR=%{buildroot}
60# Remove "samples", as we include them in %%doc
61%{__rm} -rf %{buildroot}%{_sysconfdir}/keepalived/samples/
62
63mkdir -p %{buildroot}%{_datadir}/snmp/mibs/
64%{__install} -p -m 0644 doc/KEEPALIVED-MIB %{buildroot}%{_datadir}/snmp/mibs/KEEPALIVED-MIB.txt
65
66
67%check
68# A build could silently have LVS support disabled if the kernel includes can't
69# be properly found, we need to avoid that.
70if ! grep -q "IPVS_SUPPORT='_WITH_LVS_'" config.log; then
71    echo "ERROR: We do not want keeepalived lacking LVS support."
72    exit 1
73fi
74
75
76%clean
77%{__rm} -rf %{buildroot}
78
79
80%post
81/sbin/chkconfig --add keepalived
82
83%preun
84if [ $1 -eq 0 ]; then
85    /sbin/service keepalived stop &>/dev/null || :
86    /sbin/chkconfig --del keepalived
87fi
88
89%postun
90if [ $1 -ge 1 ]; then
91    /sbin/service keepalived condrestart &>/dev/null || :
92fi
93
94
95%files
96%defattr(-, root, root, -)
97%doc AUTHOR ChangeLog CONTRIBUTORS COPYING README TODO
98%doc doc/keepalived.conf.SYNOPSIS doc/samples/
99%dir %{_sysconfdir}/keepalived/
100%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/keepalived/keepalived.conf
101%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/sysconfig/keepalived
102%{_sysconfdir}/rc.d/init.d/keepalived
103%{_bindir}/genhash
104%attr(0755,root,root) %{_sbindir}/keepalived
105%{_datadir}/snmp/mibs/KEEPALIVED-MIB.txt
106%{_mandir}/man1/genhash.1*
107%{_mandir}/man5/keepalived.conf.5*
108%{_mandir}/man8/keepalived.8*
109
110
111%changelog
112* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
113- initial build for Vine Linux
114
115* Thu Sep 13 2007 Alexandre Cassen <acassen@linux-vs.org> 1.1.14
116- Merge work done by freshrpms.net... Thanks guys !!! ;)
117
118* Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-5
119- Add missing scriplet requirements.
120
121* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-4
122- Add missing \n to the kernel define, for when multiple kernels are installed.
123- Pass STRIP=/bin/true to "make" in order to get a useful debuginfo package.
124
125* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-3
126- Add %%check section to make sure any build without LVS support will fail.
127
128* Mon Feb  5 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-2
129- Use our own init script, include a sysconfig entry used by it for options.
130
131* Thu Jan 25 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-1
132- Update to 1.1.13.
133- Change mode of configuration file to 0600.
134- Don't include all of "doc" since it meant re-including all man pages.
135- Don't include samples in the main configuration path, they're in %%doc.
136- Include patch to add an optional label to interfaces.
137
138* Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 1.1.12-1.2
139- Rebuild for Fedora Core 5.
140
141* Sun Mar 12 2006 Dag Wieers <dag@wieers.com> - 1.1.12-1
142- Updated to release 1.1.12.
143
144* Fri Mar 04 2005 Dag Wieers <dag@wieers.com> - 1.1.11-1
145- Updated to release 1.1.11.
146
147* Wed Feb 23 2005 Dag Wieers <dag@wieers.com> - 1.1.10-2
148- Fixed IPVS/LVS support. (Joe Sauer)
149
150* Tue Feb 15 2005 Dag Wieers <dag@wieers.com> - 1.1.10-1
151- Updated to release 1.1.10.
152
153* Mon Feb 07 2005 Dag Wieers <dag@wieers.com> - 1.1.9-1
154- Updated to release 1.1.9.
155
156* Sun Oct 17 2004 Dag Wieers <dag@wieers.com> - 1.1.7-2
157- Fixes to build with kernel IPVS support. (Tim Verhoeven)
158
159* Fri Sep 24 2004 Dag Wieers <dag@wieers.com> - 1.1.7-1
160- Updated to release 1.1.7. (Mathieu Lubrano)
161
162* Mon Feb 23 2004 Dag Wieers <dag@wieers.com> - 1.1.6-0
163- Updated to release 1.1.6.
164
165* Mon Jan 26 2004 Dag Wieers <dag@wieers.com> - 1.1.5-0
166- Updated to release 1.1.5.
167
168* Mon Dec 29 2003 Dag Wieers <dag@wieers.com> - 1.1.4-0
169- Updated to release 1.1.4.
170
171* Fri Jun 06 2003 Dag Wieers <dag@wieers.com> - 1.0.3-0
172- Initial package. (using DAR)
173
Note: See TracBrowser for help on using the repository browser.