source: projects/specs/trunk/k/keepalived/keepalived-vl.spec @ 12366

Revision 12366, 6.0 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

gnutls-3.6.13-1

keepalived-2.0.20-1

nsd-4.3.0-2

samba-4.12.1-1

zabbix-4.0.19-1

Line 
1%bcond_with systemd
2
3Summary: HA monitor built upon LVS, VRRP and services poller
4Name: keepalived
5Version: 2.0.20
6Release: 1%{?_dist_release}%{?with_systemd:.systemd}
7License: GPL
8Group: Applications/System
9URL: http://www.keepalived.org/
10
11Vendor: Project Vine
12Distribution: Vine Linux
13
14Source0: https://www.keepalived.org/software/keepalived-%{version}.tar.gz
15Source1: keepalived.service
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: openssl-devel
19BuildRequires: libnl3-devel
20BuildRequires: ipset-devel
21BuildRequires: iptables-devel
22BuildRequires: libnfnetlink-devel
23BuildRequires: net-snmp-devel
24
25%if %{with systemd}
26BuildRequires: systemd-units
27%{?systemd_requires}
28%else
29Requires(post): /sbin/chkconfig
30Requires(preun): /sbin/service, /sbin/chkconfig
31Requires(postun): /sbin/service
32%endif
33
34%description
35The main goal of the keepalived project is to add a strong & robust keepalive
36facility to the Linux Virtual Server project. This project is written in C with
37multilayer TCP/IP stack checks. Keepalived implements a framework based on
38three family checks : Layer3, Layer4 & Layer5/7. This framework gives the
39daemon the ability to check the state of an LVS server pool. When one of the
40servers of the LVS server pool is down, keepalived informs the linux kernel via
41a setsockopt call to remove this server entry from the LVS topology. In
42addition keepalived implements an independent VRRPv2 stack to handle director
43failover. So in short keepalived is a userspace daemon for LVS cluster nodes
44healthchecks and LVS directors failover.
45
46
47%prep
48%setup
49
50
51%build
52%configure \
53%if %{with systemd}
54        --with-init=systemd \
55%else
56        --with-init=SYSV \
57%endif
58        --enable-snmp  --enable-snmp-rfc \
59        --enable-sha1
60%{__make} %{?_smp_mflags} STRIP=/bin/true
61
62
63%install
64%{__rm} -rf %{buildroot}
65%{__make} install DESTDIR=%{buildroot}
66
67# Remove "samples", as we include them in %%doc
68%{__rm} -rf %{buildroot}%{_sysconfdir}/keepalived/samples/
69
70%{__rm} -rf %{buildroot}%{_docdir}/keepalived
71
72mkdir -p %{buildroot}%{_libexecdir}/keepalived
73
74%if %{with systemd}
75rm -rf %{buildroot}%{_initrddir}/
76%{__install} -p -D -m 0644 %{SOURCE1} %{buildroot}%{_unitdir}/keepalived.service
77%endif
78
79
80%clean
81%{__rm} -rf %{buildroot}
82
83
84%post
85%if %{with systemd}
86%systemd_post keepalived.service
87%else
88/sbin/chkconfig --add keepalived
89%endif
90
91%preun
92%if %{with systemd}
93%systemd_preun keepalived.service
94%else
95if [ $1 -eq 0 ]; then
96    /sbin/service keepalived stop &>/dev/null || :
97    /sbin/chkconfig --del keepalived
98fi
99%endif
100
101%postun
102%if %{with systemd}
103%systemd_postun_with_restart keepalived.service
104%else
105if [ $1 -ge 1 ]; then
106    /sbin/service keepalived condrestart &>/dev/null || :
107fi
108%endif
109
110
111%files
112%defattr(-, root, root, -)
113%license COPYING
114%doc AUTHOR ChangeLog CONTRIBUTORS README TODO
115%doc doc/keepalived.conf.SYNOPSIS doc/samples/keepalived.conf.*
116%attr(0755,root,root) %{_bindir}/genhash
117%attr(0755,root,root) %{_sbindir}/keepalived
118%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/keepalived/keepalived.conf
119%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/sysconfig/keepalived
120%if %{with systemd}
121%{_unitdir}/keepalived.service
122%else
123%{_sysconfdir}/rc.d/init.d/keepalived
124%endif
125%dir %{_sysconfdir}/keepalived/
126%dir %{_libexecdir}/keepalived/
127%{_datadir}/snmp/mibs/*
128%{_mandir}/man1/genhash.1*
129%{_mandir}/man5/keepalived.conf.5*
130%{_mandir}/man8/keepalived.8*
131
132%changelog
133* Sun Apr 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.20-1
134- new upstream release.
135- added systemd stuff (disabled as default).
136
137* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.18-1
138- new upstream release.
139
140* Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.8-1
141- new upstream release.
142
143* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.19-1
144- new upstream release.
145
146* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
147- initial build for Vine Linux
148
149* Thu Sep 13 2007 Alexandre Cassen <acassen@linux-vs.org> 1.1.14
150- Merge work done by freshrpms.net... Thanks guys !!! ;)
151
152* Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-5
153- Add missing scriplet requirements.
154
155* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-4
156- Add missing \n to the kernel define, for when multiple kernels are installed.
157- Pass STRIP=/bin/true to "make" in order to get a useful debuginfo package.
158
159* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-3
160- Add %%check section to make sure any build without LVS support will fail.
161
162* Mon Feb  5 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-2
163- Use our own init script, include a sysconfig entry used by it for options.
164
165* Thu Jan 25 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-1
166- Update to 1.1.13.
167- Change mode of configuration file to 0600.
168- Don't include all of "doc" since it meant re-including all man pages.
169- Don't include samples in the main configuration path, they're in %%doc.
170- Include patch to add an optional label to interfaces.
171
172* Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 1.1.12-1.2
173- Rebuild for Fedora Core 5.
174
175* Sun Mar 12 2006 Dag Wieers <dag@wieers.com> - 1.1.12-1
176- Updated to release 1.1.12.
177
178* Fri Mar 04 2005 Dag Wieers <dag@wieers.com> - 1.1.11-1
179- Updated to release 1.1.11.
180
181* Wed Feb 23 2005 Dag Wieers <dag@wieers.com> - 1.1.10-2
182- Fixed IPVS/LVS support. (Joe Sauer)
183
184* Tue Feb 15 2005 Dag Wieers <dag@wieers.com> - 1.1.10-1
185- Updated to release 1.1.10.
186
187* Mon Feb 07 2005 Dag Wieers <dag@wieers.com> - 1.1.9-1
188- Updated to release 1.1.9.
189
190* Sun Oct 17 2004 Dag Wieers <dag@wieers.com> - 1.1.7-2
191- Fixes to build with kernel IPVS support. (Tim Verhoeven)
192
193* Fri Sep 24 2004 Dag Wieers <dag@wieers.com> - 1.1.7-1
194- Updated to release 1.1.7. (Mathieu Lubrano)
195
196* Mon Feb 23 2004 Dag Wieers <dag@wieers.com> - 1.1.6-0
197- Updated to release 1.1.6.
198
199* Mon Jan 26 2004 Dag Wieers <dag@wieers.com> - 1.1.5-0
200- Updated to release 1.1.5.
201
202* Mon Dec 29 2003 Dag Wieers <dag@wieers.com> - 1.1.4-0
203- Updated to release 1.1.4.
204
205* Fri Jun 06 2003 Dag Wieers <dag@wieers.com> - 1.0.3-0
206- Initial package. (using DAR)
207
Note: See TracBrowser for help on using the repository browser.