source: projects/specs/trunk/k/keepalived/keepalived-vl.spec @ 11879

Revision 11879, 5.1 KB checked in by tomop, 5 years ago (diff)

keepalived-2.0.8-1

Line 
1Summary: HA monitor built upon LVS, VRRP and services poller
2Name: keepalived
3Version: 2.0.8
4Release: 1%{?_dist_release}
5License: GPL
6Group: Applications/System
7URL: http://www.keepalived.org/
8
9Vendor: Project Vine
10Distribution: Vine Linux
11
12Source0: http://www.keepalived.org/software/keepalived-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: openssl-devel
16BuildRequires: libnl3-devel
17BuildRequires: ipset-devel
18BuildRequires: iptables-devel
19BuildRequires: libnfnetlink-devel
20BuildRequires: net-snmp-devel
21
22Requires(post): /sbin/chkconfig
23Requires(preun): /sbin/service, /sbin/chkconfig
24Requires(postun): /sbin/service
25
26%description
27The main goal of the keepalived project is to add a strong & robust keepalive
28facility to the Linux Virtual Server project. This project is written in C with
29multilayer TCP/IP stack checks. Keepalived implements a framework based on
30three family checks : Layer3, Layer4 & Layer5/7. This framework gives the
31daemon the ability to check the state of an LVS server pool. When one of the
32servers of the LVS server pool is down, keepalived informs the linux kernel via
33a setsockopt call to remove this server entry from the LVS topology. In
34addition keepalived implements an independent VRRPv2 stack to handle director
35failover. So in short keepalived is a userspace daemon for LVS cluster nodes
36healthchecks and LVS directors failover.
37
38
39%prep
40%setup
41
42
43%build
44%configure \
45        --with-init=SYSV \
46        --enable-snmp  --enable-snmp-rfc \
47        --enable-sha1
48%{__make} %{?_smp_mflags} STRIP=/bin/true
49
50
51%install
52%{__rm} -rf %{buildroot}
53%{__make} install DESTDIR=%{buildroot}
54
55# Remove "samples", as we include them in %%doc
56%{__rm} -rf %{buildroot}%{_sysconfdir}/keepalived/samples/
57
58%{__rm} -rf %{buildroot}%{_docdir}/keepalived
59
60mkdir -p %{buildroot}%{_libexecdir}/keepalived
61
62%clean
63%{__rm} -rf %{buildroot}
64
65
66%post
67/sbin/chkconfig --add keepalived
68
69%preun
70if [ $1 -eq 0 ]; then
71    /sbin/service keepalived stop &>/dev/null || :
72    /sbin/chkconfig --del keepalived
73fi
74
75%postun
76if [ $1 -ge 1 ]; then
77    /sbin/service keepalived condrestart &>/dev/null || :
78fi
79
80
81%files
82%defattr(-, root, root, -)
83%doc AUTHOR ChangeLog CONTRIBUTORS COPYING README TODO
84%doc doc/keepalived.conf.SYNOPSIS doc/samples/keepalived.conf.*
85%attr(0755,root,root) %{_bindir}/genhash
86%attr(0755,root,root) %{_sbindir}/keepalived
87%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/keepalived/keepalived.conf
88%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/sysconfig/keepalived
89%{_sysconfdir}/rc.d/init.d/keepalived
90%dir %{_sysconfdir}/keepalived/
91%dir %{_libexecdir}/keepalived/
92%{_datadir}/snmp/mibs/*
93%{_mandir}/man1/genhash.1*
94%{_mandir}/man5/keepalived.conf.5*
95%{_mandir}/man8/keepalived.8*
96
97%changelog
98* Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.8-1
99- new upstream release.
100
101* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.19-1
102- new upstream release.
103
104* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
105- initial build for Vine Linux
106
107* Thu Sep 13 2007 Alexandre Cassen <acassen@linux-vs.org> 1.1.14
108- Merge work done by freshrpms.net... Thanks guys !!! ;)
109
110* Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-5
111- Add missing scriplet requirements.
112
113* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-4
114- Add missing \n to the kernel define, for when multiple kernels are installed.
115- Pass STRIP=/bin/true to "make" in order to get a useful debuginfo package.
116
117* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-3
118- Add %%check section to make sure any build without LVS support will fail.
119
120* Mon Feb  5 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-2
121- Use our own init script, include a sysconfig entry used by it for options.
122
123* Thu Jan 25 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-1
124- Update to 1.1.13.
125- Change mode of configuration file to 0600.
126- Don't include all of "doc" since it meant re-including all man pages.
127- Don't include samples in the main configuration path, they're in %%doc.
128- Include patch to add an optional label to interfaces.
129
130* Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 1.1.12-1.2
131- Rebuild for Fedora Core 5.
132
133* Sun Mar 12 2006 Dag Wieers <dag@wieers.com> - 1.1.12-1
134- Updated to release 1.1.12.
135
136* Fri Mar 04 2005 Dag Wieers <dag@wieers.com> - 1.1.11-1
137- Updated to release 1.1.11.
138
139* Wed Feb 23 2005 Dag Wieers <dag@wieers.com> - 1.1.10-2
140- Fixed IPVS/LVS support. (Joe Sauer)
141
142* Tue Feb 15 2005 Dag Wieers <dag@wieers.com> - 1.1.10-1
143- Updated to release 1.1.10.
144
145* Mon Feb 07 2005 Dag Wieers <dag@wieers.com> - 1.1.9-1
146- Updated to release 1.1.9.
147
148* Sun Oct 17 2004 Dag Wieers <dag@wieers.com> - 1.1.7-2
149- Fixes to build with kernel IPVS support. (Tim Verhoeven)
150
151* Fri Sep 24 2004 Dag Wieers <dag@wieers.com> - 1.1.7-1
152- Updated to release 1.1.7. (Mathieu Lubrano)
153
154* Mon Feb 23 2004 Dag Wieers <dag@wieers.com> - 1.1.6-0
155- Updated to release 1.1.6.
156
157* Mon Jan 26 2004 Dag Wieers <dag@wieers.com> - 1.1.5-0
158- Updated to release 1.1.5.
159
160* Mon Dec 29 2003 Dag Wieers <dag@wieers.com> - 1.1.4-0
161- Updated to release 1.1.4.
162
163* Fri Jun 06 2003 Dag Wieers <dag@wieers.com> - 1.0.3-0
164- Initial package. (using DAR)
165
Note: See TracBrowser for help on using the repository browser.