source: projects/specs/trunk/k/keepalived/keepalived-vl.spec @ 10084

Revision 10084, 5.6 KB checked in by tomop, 8 years ago (diff)

keepalived-1.2.19-1

Line 
1Summary: HA monitor built upon LVS, VRRP and services poller
2Name: keepalived
3Version: 1.2.19
4Release: 1%{?_dist_release}
5License: GPL
6Group: Applications/System
7URL: http://www.keepalived.org/
8
9Source0: http://www.keepalived.org/software/keepalived-%{version}.tar.gz
10
11Patch0: keepalived-1.2.7-dont-respawn-children.patch
12Patch1: keepalived-1.2.7-cleanup-duplicate-option-code.patch
13Patch2: keepalived-1.2.7-generate-usage-message-from-popt.patch
14Patch3: keepalived-1.2.7-update-keepalived-man-page.patch
15Patch4: keepalived-1.2.7-fix-pointer-arithmetic-vrrp-packet.patch
16Patch8: keepalived-1.2.7-fix-primary-ip-address-comparison.patch
17Patch5: keepalived-1.2.7-fix-ssl-certificate-load.patch
18Patch6: keepalived-1.2.7-fix-error-message.patch
19Patch7: keepalived-1.2.7-update-gpl-license.patch
20Patch9: keepalived-1.2.7-remove-debug-messages.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23BuildRequires: openssl-devel
24BuildRequires: kernel-devel
25BuildRequires: popt-devel
26BuildRequires: libnl-devel
27BuildRequires: net-snmp-devel
28BuildRequires: rpm-devel
29BuildRequires: tcp_wrappers
30
31Requires(post): /sbin/chkconfig
32Requires(preun): /sbin/service, /sbin/chkconfig
33Requires(postun): /sbin/service
34
35%description
36The main goal of the keepalived project is to add a strong & robust keepalive
37facility to the Linux Virtual Server project. This project is written in C with
38multilayer TCP/IP stack checks. Keepalived implements a framework based on
39three family checks : Layer3, Layer4 & Layer5/7. This framework gives the
40daemon the ability to check the state of an LVS server pool. When one of the
41servers of the LVS server pool is down, keepalived informs the linux kernel via
42a setsockopt call to remove this server entry from the LVS topology. In
43addition keepalived implements an independent VRRPv2 stack to handle director
44failover. So in short keepalived is a userspace daemon for LVS cluster nodes
45healthchecks and LVS directors failover.
46
47
48%prep
49%setup
50
51
52%build
53%configure \
54        --enable-snmp \
55        --enable-sha1
56%{__make} %{?_smp_mflags} STRIP=/bin/true
57
58
59%install
60%{__rm} -rf %{buildroot}
61%{__make} install DESTDIR=%{buildroot}
62# Remove "samples", as we include them in %%doc
63%{__rm} -rf %{buildroot}%{_sysconfdir}/keepalived/samples/
64
65%check
66# A build could silently have LVS support disabled if the kernel includes can't
67# be properly found, we need to avoid that.
68if ! grep -q "IPVS_SUPPORT='_WITH_LVS_'" config.log; then
69    echo "ERROR: We do not want keeepalived lacking LVS support."
70    exit 1
71fi
72
73
74%clean
75%{__rm} -rf %{buildroot}
76
77
78%post
79/sbin/chkconfig --add keepalived
80
81%preun
82if [ $1 -eq 0 ]; then
83    /sbin/service keepalived stop &>/dev/null || :
84    /sbin/chkconfig --del keepalived
85fi
86
87%postun
88if [ $1 -ge 1 ]; then
89    /sbin/service keepalived condrestart &>/dev/null || :
90fi
91
92
93%files
94%defattr(-, root, root, -)
95%doc AUTHOR ChangeLog CONTRIBUTORS COPYING README TODO
96%doc doc/keepalived.conf.SYNOPSIS doc/samples/
97%dir %{_sysconfdir}/keepalived/
98%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/keepalived/keepalived.conf
99%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/sysconfig/keepalived
100%{_sysconfdir}/rc.d/init.d/keepalived
101%{_bindir}/genhash
102%attr(0755,root,root) %{_sbindir}/keepalived
103%{_datadir}/snmp/mibs/*
104%{_mandir}/man1/genhash.1*
105%{_mandir}/man5/keepalived.conf.5*
106%{_mandir}/man8/keepalived.8*
107
108
109%changelog
110* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.19-1
111- new upstream release.
112
113* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
114- initial build for Vine Linux
115
116* Thu Sep 13 2007 Alexandre Cassen <acassen@linux-vs.org> 1.1.14
117- Merge work done by freshrpms.net... Thanks guys !!! ;)
118
119* Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-5
120- Add missing scriplet requirements.
121
122* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-4
123- Add missing \n to the kernel define, for when multiple kernels are installed.
124- Pass STRIP=/bin/true to "make" in order to get a useful debuginfo package.
125
126* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-3
127- Add %%check section to make sure any build without LVS support will fail.
128
129* Mon Feb  5 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-2
130- Use our own init script, include a sysconfig entry used by it for options.
131
132* Thu Jan 25 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-1
133- Update to 1.1.13.
134- Change mode of configuration file to 0600.
135- Don't include all of "doc" since it meant re-including all man pages.
136- Don't include samples in the main configuration path, they're in %%doc.
137- Include patch to add an optional label to interfaces.
138
139* Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 1.1.12-1.2
140- Rebuild for Fedora Core 5.
141
142* Sun Mar 12 2006 Dag Wieers <dag@wieers.com> - 1.1.12-1
143- Updated to release 1.1.12.
144
145* Fri Mar 04 2005 Dag Wieers <dag@wieers.com> - 1.1.11-1
146- Updated to release 1.1.11.
147
148* Wed Feb 23 2005 Dag Wieers <dag@wieers.com> - 1.1.10-2
149- Fixed IPVS/LVS support. (Joe Sauer)
150
151* Tue Feb 15 2005 Dag Wieers <dag@wieers.com> - 1.1.10-1
152- Updated to release 1.1.10.
153
154* Mon Feb 07 2005 Dag Wieers <dag@wieers.com> - 1.1.9-1
155- Updated to release 1.1.9.
156
157* Sun Oct 17 2004 Dag Wieers <dag@wieers.com> - 1.1.7-2
158- Fixes to build with kernel IPVS support. (Tim Verhoeven)
159
160* Fri Sep 24 2004 Dag Wieers <dag@wieers.com> - 1.1.7-1
161- Updated to release 1.1.7. (Mathieu Lubrano)
162
163* Mon Feb 23 2004 Dag Wieers <dag@wieers.com> - 1.1.6-0
164- Updated to release 1.1.6.
165
166* Mon Jan 26 2004 Dag Wieers <dag@wieers.com> - 1.1.5-0
167- Updated to release 1.1.5.
168
169* Mon Dec 29 2003 Dag Wieers <dag@wieers.com> - 1.1.4-0
170- Updated to release 1.1.4.
171
172* Fri Jun 06 2003 Dag Wieers <dag@wieers.com> - 1.0.3-0
173- Initial package. (using DAR)
174
Note: See TracBrowser for help on using the repository browser.