source: projects/specs/trunk/k/keepalived/keepalived-vl.spec @ 12552

Revision 12552, 6.2 KB checked in by tomop, 3 years ago (diff)

keepalived-2.2.1-1

RevLine 
[12366]1%bcond_with systemd
2
[7617]3Summary: HA monitor built upon LVS, VRRP and services poller
4Name: keepalived
[12552]5Version: 2.2.1
[12366]6Release: 1%{?_dist_release}%{?with_systemd:.systemd}
[12486]7Group: network
[11879]8Vendor: Project Vine
9Distribution: Vine Linux
10
[12486]11License: GPL
12URL: http://www.keepalived.org/
[12190]13Source0: https://www.keepalived.org/software/keepalived-%{version}.tar.gz
[12366]14Source1: keepalived.service
[7617]15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: openssl-devel
[11879]18BuildRequires: libnl3-devel
19BuildRequires: ipset-devel
20BuildRequires: iptables-devel
21BuildRequires: libnfnetlink-devel
[7617]22BuildRequires: net-snmp-devel
23
[12366]24%if %{with systemd}
25BuildRequires: systemd-units
26%{?systemd_requires}
27%else
[7617]28Requires(post): /sbin/chkconfig
29Requires(preun): /sbin/service, /sbin/chkconfig
30Requires(postun): /sbin/service
[12366]31%endif
[7617]32
33%description
34The main goal of the keepalived project is to add a strong & robust keepalive
35facility to the Linux Virtual Server project. This project is written in C with
36multilayer TCP/IP stack checks. Keepalived implements a framework based on
37three family checks : Layer3, Layer4 & Layer5/7. This framework gives the
38daemon the ability to check the state of an LVS server pool. When one of the
39servers of the LVS server pool is down, keepalived informs the linux kernel via
40a setsockopt call to remove this server entry from the LVS topology. In
41addition keepalived implements an independent VRRPv2 stack to handle director
42failover. So in short keepalived is a userspace daemon for LVS cluster nodes
43healthchecks and LVS directors failover.
44
45
[12486]46%debug_package
47
48
[7617]49%prep
50%setup
51
52
53%build
[10084]54%configure \
[12366]55%if %{with systemd}
56        --with-init=systemd \
57%else
[11879]58        --with-init=SYSV \
[12366]59%endif
[11879]60        --enable-snmp  --enable-snmp-rfc \
[10084]61        --enable-sha1
[7617]62%{__make} %{?_smp_mflags} STRIP=/bin/true
63
64
65%install
66%{__rm} -rf %{buildroot}
67%{__make} install DESTDIR=%{buildroot}
[11879]68
[7617]69# Remove "samples", as we include them in %%doc
70%{__rm} -rf %{buildroot}%{_sysconfdir}/keepalived/samples/
71
[11879]72%{__rm} -rf %{buildroot}%{_docdir}/keepalived
[7617]73
[11879]74mkdir -p %{buildroot}%{_libexecdir}/keepalived
[7617]75
[12366]76%if %{with systemd}
77rm -rf %{buildroot}%{_initrddir}/
78%{__install} -p -D -m 0644 %{SOURCE1} %{buildroot}%{_unitdir}/keepalived.service
79%endif
80
81
[7617]82%clean
83%{__rm} -rf %{buildroot}
84
85
86%post
[12366]87%if %{with systemd}
88%systemd_post keepalived.service
89%else
[7617]90/sbin/chkconfig --add keepalived
[12366]91%endif
[7617]92
93%preun
[12366]94%if %{with systemd}
95%systemd_preun keepalived.service
96%else
[12486]97if [ $1 -eq 0 -o -x /bin/systemctl ]; then
[7617]98    /sbin/service keepalived stop &>/dev/null || :
99    /sbin/chkconfig --del keepalived
100fi
[12366]101%endif
[7617]102
103%postun
[12366]104%if %{with systemd}
105%systemd_postun_with_restart keepalived.service
106%else
[7617]107if [ $1 -ge 1 ]; then
108    /sbin/service keepalived condrestart &>/dev/null || :
109fi
[12366]110%endif
[7617]111
112
113%files
114%defattr(-, root, root, -)
[12190]115%license COPYING
116%doc AUTHOR ChangeLog CONTRIBUTORS README TODO
[11879]117%doc doc/keepalived.conf.SYNOPSIS doc/samples/keepalived.conf.*
118%attr(0755,root,root) %{_bindir}/genhash
119%attr(0755,root,root) %{_sbindir}/keepalived
[7617]120%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/keepalived/keepalived.conf
121%attr(0644, root, root) %config(noreplace) %{_sysconfdir}/sysconfig/keepalived
[12366]122%if %{with systemd}
123%{_unitdir}/keepalived.service
124%else
[7617]125%{_sysconfdir}/rc.d/init.d/keepalived
[12366]126%endif
[11879]127%dir %{_sysconfdir}/keepalived/
128%dir %{_libexecdir}/keepalived/
[10084]129%{_datadir}/snmp/mibs/*
[7617]130%{_mandir}/man1/genhash.1*
131%{_mandir}/man5/keepalived.conf.5*
132%{_mandir}/man8/keepalived.8*
133
[12552]134
[7617]135%changelog
[12552]136* Fri Feb 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
137- new upstream release.
138
[12486]139* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.5-1
140- new upstream release.
141
[12366]142* Sun Apr 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.20-1
143- new upstream release.
144- added systemd stuff (disabled as default).
145
[12190]146* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.18-1
147- new upstream release.
148
[11879]149* Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.8-1
150- new upstream release.
151
[10084]152* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.19-1
153- new upstream release.
154
[7617]155* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
156- initial build for Vine Linux
157
158* Thu Sep 13 2007 Alexandre Cassen <acassen@linux-vs.org> 1.1.14
159- Merge work done by freshrpms.net... Thanks guys !!! ;)
160
161* Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-5
162- Add missing scriplet requirements.
163
164* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-4
165- Add missing \n to the kernel define, for when multiple kernels are installed.
166- Pass STRIP=/bin/true to "make" in order to get a useful debuginfo package.
167
168* Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-3
169- Add %%check section to make sure any build without LVS support will fail.
170
171* Mon Feb  5 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-2
172- Use our own init script, include a sysconfig entry used by it for options.
173
174* Thu Jan 25 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-1
175- Update to 1.1.13.
176- Change mode of configuration file to 0600.
177- Don't include all of "doc" since it meant re-including all man pages.
178- Don't include samples in the main configuration path, they're in %%doc.
179- Include patch to add an optional label to interfaces.
180
181* Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 1.1.12-1.2
182- Rebuild for Fedora Core 5.
183
184* Sun Mar 12 2006 Dag Wieers <dag@wieers.com> - 1.1.12-1
185- Updated to release 1.1.12.
186
187* Fri Mar 04 2005 Dag Wieers <dag@wieers.com> - 1.1.11-1
188- Updated to release 1.1.11.
189
190* Wed Feb 23 2005 Dag Wieers <dag@wieers.com> - 1.1.10-2
191- Fixed IPVS/LVS support. (Joe Sauer)
192
193* Tue Feb 15 2005 Dag Wieers <dag@wieers.com> - 1.1.10-1
194- Updated to release 1.1.10.
195
196* Mon Feb 07 2005 Dag Wieers <dag@wieers.com> - 1.1.9-1
197- Updated to release 1.1.9.
198
199* Sun Oct 17 2004 Dag Wieers <dag@wieers.com> - 1.1.7-2
200- Fixes to build with kernel IPVS support. (Tim Verhoeven)
201
202* Fri Sep 24 2004 Dag Wieers <dag@wieers.com> - 1.1.7-1
203- Updated to release 1.1.7. (Mathieu Lubrano)
204
205* Mon Feb 23 2004 Dag Wieers <dag@wieers.com> - 1.1.6-0
206- Updated to release 1.1.6.
207
208* Mon Jan 26 2004 Dag Wieers <dag@wieers.com> - 1.1.5-0
209- Updated to release 1.1.5.
210
211* Mon Dec 29 2003 Dag Wieers <dag@wieers.com> - 1.1.4-0
212- Updated to release 1.1.4.
213
214* Fri Jun 06 2003 Dag Wieers <dag@wieers.com> - 1.0.3-0
215- Initial package. (using DAR)
216
Note: See TracBrowser for help on using the repository browser.