source: projects/specs/trunk/k/kdf/kdf-vl.spec @ 10563

Revision 10563, 2.5 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:    kdf
2Summary: File device viewer
3Summary(ja): ファイルデバイスビューアー
4Version: 4.14.3
5Release: 2%{?_dist_release}
6
7License: GPLv2
8Group:   Applications/Accessories
9URL:     https://www.kde.org/
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: kdelibs-devel >= %{version}
16BuildRequires: soprano-devel
17
18# when split occurred
19Conflicts: kdeutils < 4.8.0
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25Kdiskfree is displays the available file devices (hard drive
26partitions, floppy and CD drives, USB sticks, etc) along with
27information on their capacity, free space, type and mount point.
28It also allows you to mount and unmount drives and view them in
29a file manager.
30
31
32%prep
33%setup -q
34
35
36%build
37mkdir -p %{_target_platform}
38pushd %{_target_platform}
39%cmake \
40    -DCMAKE_BUILD_TYPE=release \
41    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
42    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
43    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
44    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
45    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
46    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
47    ..
48popd
49
50make %{?_smp_mflags} -C %{_target_platform}
51
52
53%install
54rm -rf %{buildroot}
55
56make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
57
58
59%post
60/sbin/ldconfig
61touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
62touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
63
64%posttrans
65update-desktop-database -q &> /dev/null ||:
66gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
67gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
68
69%postun
70if [ $1 -eq 0 ] ; then
71  /sbin/ldconfig
72  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
73  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
74  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
75  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
76  update-desktop-database -q &> /dev/null ||:
77fi
78
79
80%files
81%doc COPYING
82%{_bindir}/%{name}
83%{_bindir}/kwikdisk
84%{_libdir}/kde4/*.so
85%{_datadir}/applications/kde4/%{name}.desktop
86%{_datadir}/applications/kde4/kwikdisk.desktop
87%{_datadir}/icons/hicolor/*/*/*
88%{_datadir}/icons/oxygen/*/*/*
89%{_datadir}/kde4/apps/%{name}
90%{_datadir}/kde4/services/*.desktop
91%{_docdir}/HTML/en/%{name}
92%{_docdir}/HTML/en/kcontrol
93
94%changelog
95* Fri Jul 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
96- rebuild with gcc-5.4.0
97
98* Fri Jan 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
99- initila build
Note: See TracBrowser for help on using the repository browser.