source: projects/specs/trunk/k/kdewebdev/kdewebdev-vl.spec @ 10763

Revision 10763, 8.4 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name: kdewebdev
2Summary: KDE Web development applications
3Summary(ja): KDE Web 開発アプリケーション集
4Version: 3.5.10
5Release: 5%{?_dist_release}
6
7License: GPLv2
8URL: http://kdewebdev.org/
9Group: Applications/Editors
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
12Source1: http://download.sourceforge.net/quanta/css.tar.bz2
13Source2: http://download.sourceforge.net/quanta/html.tar.bz2
14Source3: http://download.sourceforge.net/quanta/php_manual_en_20030401.tar.bz2
15Source4: http://download.sourceforge.net/quanta/javascript.tar.bz2
16Source5: hi48-app-kxsldbg.png
17
18Patch0: javascript.patch
19Patch1: kdewebdev-3.5.4-kxsldbg-icons.patch
20##Patch2: arts-acinclude.patch
21# fixes crash in kimagemapeditor when using freehand tool
22Patch3: kdewebdev-3.5.10-fix-freehand-crash.patch
23# fixes using a temporary as a lvalue in KafkaPart (FTBFS with g++ 4.6, probably
24# silently did the wrong thing before)
25Patch4: kdewebdev-3.5.10-gcc46.patch
26# docbParseFile is dropped in libxml2-2.9 amd later
27Patch6: kdewebdev-3.5.10-docbParseFile.patch
28
29# fixes to common KDE 3 autotools machinery
30# tweak autoconfigury so that it builds with autoconf 2.64 or 2.65
31Patch300: kde3-acinclude.patch
32# remove flawed and obsolete automake version check in admin/cvs.sh
33Patch301: kde3-automake-version.patch
34# fix build failure with automake 1.13: add the --add-missing --copy flags
35# also add --force-missing to get aarch64 support (#925029/#925627)
36Patch302: kde3-automake-add-missing.patch
37
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: automake libtool
41BuildRequires: desktop-file-utils
42BuildRequires: kdelibs3-devel >= %{version}
43BuildRequires: libxslt-devel >= 1.0.18
44BuildRequires: libxml2-devel >= 2.6.0
45BuildRequires: perl
46Requires: tidy
47
48Provides: kdewebdev3 = %{version}-%{release}
49
50Obsoletes: quanta < %{version}-%{release}
51Provides:  quanta = %{version}-%{release}
52
53%define kommander_ver 1.2.2
54#Obsoletes: kommander < %{kommander_ver}-%{release}
55Provides:  kommander = %{kommander_ver}-%{release}
56
57%description
58The kdewebdev package contains Quanta Plus and other applications,
59which are useful for web development. They are runtime dependencies
60of Quanta Plus, and it is highly recommended that you install them.
61
62The extra applications are:
63* kfilereplace: batch search and replace tool
64* kimagemapeditor: HTML image map editor
65* klinkstatus: link checker
66* kommander: visual dialog building tool
67* kxsldbg: xslt Debugger
68* quanta+: web development
69
70
71%package devel
72Summary: Development files for kdewebdev
73Summary(ja): kdewebdev の開発用ファイル
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76Requires: kdelibs3-devel
77Provides: kdewebdev3-devel = %{version}-%{release}
78
79%description devel
80Development files for kdewebdev.
81
82
83%prep
84%setup -q -a 1 -a 2 -a 3 -a 4
85%patch0 -p0 -b .javascript
86%patch1 -p1 -b .kxsldbg-icons
87##patch2 -p1 -b .autoconf
88%patch3 -p1 -b .fix-freehand-crash
89%patch4 -p1 -b .gcc46
90%patch6 -p1 -b .docbParseFile
91
92install -m644 -p %{SOURCE5} kxsldbg/
93
94%patch300 -p1 -b .acinclude
95%patch301 -p1 -b .automake-version
96%patch302 -p1 -b .automake-add-missing
97make -f admin/Makefile.common cvs
98
99
100%build
101unset QTDIR && . /etc/profile.d/qt.sh
102
103%configure \
104    --with-qt-libraries=$QTDIR/lib \
105    --includedir=%{_includedir}/kde \
106    --disable-rpath \
107    --enable-new-ldflags \
108    --disable-debug --disable-warnings \
109    --disable-dependency-tracking --enable-final
110
111make %{?_smp_mflags}
112
113%install
114rm -rf $RPM_BUILD_ROOT
115make DESTDIR=$RPM_BUILD_ROOT install
116
117## package separately?  Why doesn't upstream include this? -- Rex
118# install docs
119for i in css html javascript ; do
120   pushd $i
121   ./install.sh <<EOF
122$RPM_BUILD_ROOT%{_datadir}/apps/quanta/doc
123EOF
124   popd
125   rm -rf $i
126done
127cp -a php php.docrc $RPM_BUILD_ROOT%{_datadir}/apps/quanta/doc/
128
129# Make symlinks relative
130pushd $RPM_BUILD_ROOT%{_datadir}/doc/HTML/en
131for i in *; do
132    if [ -d $i -a -L $i/common ]; then
133        rm -f $RPM_BUILD_ROOT%{_datadir}/doc/HTML/en/$i/common
134        ln -sf ../common $RPM_BUILD_ROOT%{_datadir}/doc/HTML/en/$i
135    fi
136done
137popd
138
139# rpmdocs
140for dir in k* quanta; do
141  for file in AUTHORS ChangeLog README TODO ; do
142    test -s  "$dir/$file" && install -p -m644 -D "$dir/$file" "rpmdocs/$dir/$file"
143  done
144done
145
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%post
151/sbin/ldconfig
152for f in crystalsvg hicolor locolor ; do
153  touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
154done
155
156%postun
157/sbin/ldconfig
158if [ $1 -eq 0 ] ; then
159for f in crystalsvg hicolor locolor ; do
160  touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
161  gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
162done
163update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
164fi
165
166%posttrans
167for f in crystalsvg hicolor locolor ; do
168  gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
169done
170update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
171
172
173%files
174%defattr(-,root,root)
175%doc %{_datadir}/doc/HTML/en/*
176%{_bindir}/*
177%{_libdir}/lib*.so.*
178%{_libdir}/lib*.la
179%{_libdir}/kde3/*
180%{_datadir}/applications/*
181%{_datadir}/applnk
182%{_datadir}/apps/*
183%{_datadir}/config.kcfg/*
184%{_datadir}/icons/*
185%{_datadir}/mimelnk/*
186%{_datadir}/services/*
187%{_datadir}/servicetypes/*
188
189%files devel
190%defattr(-,root,root)
191%{_includedir}/kde/*
192%{_libdir}/*.so
193
194%changelog
195* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 3.5.10-5
196- rebuild with gcc-5.4.0
197
198* Sat Oct 25 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.10-4
199- added Patch3, 4 and 6 from fc
200- added Patch300-302 from fc instead of Patch2
201
202* Thu Dec 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-3
203- fixed summary
204
205* Sat Jul 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-2
206- added BR: arts-devel
207
208* Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
209- updated to 3.5.10 based on FC
210- updated %%post and %%postun section, added %%posttrans section
211- built with new toolchain
212
213* Wed May 13 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
214- applied new versioning policy, spec in UTF-8
215- added Japanese summary
216- changed Group to Applictions/Development
217
218* Sun Nov 25 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
219- added --with-qt-libraries option
220
221* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
222- rebuild for VineSeed
223
224* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
225- new upstream release
226
227* Wed Jun 27 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
228- rebuild for VineSeed
229
230* Tue Jun 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
231- new upstream release
232- added --enable-libsuffix option
233
234* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
235- rebuild for VineSeed
236
237* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
238- new upstream release
239
240* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
241- rebuild for VineSeed
242
243* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
244- new upstream release
245
246* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
247- rebuild for VineSeed
248
249* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
250- new upstream release
251
252* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
253- rebuild for VineSeed
254
255* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
256- new upstream release
257
258* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
259- rebuild for VineSeed
260
261* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
262- new upstream release
263
264* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
265- rebuild for VineSeed
266
267* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
268- new upstream release
269
270* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
271- new upstream release
272
273* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
274- new upstream release
275- delete Patch0
276
277* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
278- new upstream release
279- add Patch0
280
281* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
282- rebuild for VineSeed
283
284* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
285- new upstream release
286
287* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
288- build for VineSeed
289- add --disable-rpath to configure option
290
291* Tue Jun  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
292- new upstream release
293- remove patch0
294
295* Mon Apr 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
296- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.