source: projects/specs/trunk/k/kdevplatform/kdevplatform-vl.spec @ 8034

Revision 8034, 5.5 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release or rebuild with libboost-1.54.0

Line 
1%define kde KDE4
2
3Name:           kdevplatform
4Summary:        Libraries for use by %{kde} development tools
5Summary(ja):    %{kde} 開発ツールが使用するライブラリ
6Version:        1.4.1
7Release:        2%{?_dist_release}
8
9Group:          Development/Tools
10License:        GPLv2
11URL:            http://www.kdevelop.org/
12
13Source0:        ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.4.0/src/kdevplatform-%{version}.tar.bz2
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  libboost-devel
17BuildRequires:  gettext
18BuildRequires:  kdelibs-devel >= 4.6
19BuildRequires:  kdesdk-devel >= 4.6
20BuildRequires:  pcre-devel
21BuildRequires:  subversion-devel
22BuildRequires:  apr-util-devel
23BuildRequires:  soprano-devel
24BuildRequires:  qjson-devel
25
26Requires: %{name}-libs = %{version}-%{release}
27Requires(postun): gtk2
28Requires(posttrans): gtk2
29
30%description
31%{kde} Development platform, the foundations upon which
32KDevelop and Quanta are built.
33
34%package libs
35Summary: Runtime libraries for %{name}
36Summary(ja): %{name} のランタイムライブラリ
37Group:   System Environment/Libraries
38Requires: kdelibs4
39
40%description libs
41%{summary}.
42
43%package devel
44Summary:  Developer files for %{name}
45Summary(ja): %{name} の開発用ファイル
46Group:    Development/Libraries
47Requires: %{name}-libs = %{version}-%{release}
48Requires: libboost-devel
49Requires: commoncpp2-devel
50Requires: kdelibs4-devel
51Requires: subversion-devel
52
53%description devel
54%{summary}.
55
56
57%prep
58%setup -q -n kdevplatform-%{version}
59
60
61%build
62mkdir -p %{_target_platform}
63pushd %{_target_platform}
64%cmake \
65    -DCMAKE_BUILD_TYPE=release \
66    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
67    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
68    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
69    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
70    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
71    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
72    ..
73popd
74
75make %{?_smp_mflags} -C %{_target_platform}
76
77
78%install
79rm -rf %{buildroot}
80
81make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
82
83%find_lang %{name} --all-name --with-kde
84
85
86%clean
87rm -rf %{buildroot}
88
89
90%post
91touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
92
93%posttrans
94gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
95
96%postun
97if [ $1 -eq 0 ] ; then
98    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
99    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
100fi
101
102%post libs -p /sbin/ldconfig
103
104%postun libs -p /sbin/ldconfig
105
106
107%files -f %{name}.lang
108%defattr(-,root,root,-)
109%doc COPYING.PLUGINS COPYING.SRC
110%{_bindir}/kdev_dbus_socket_transformer
111%{_bindir}/kdev_format_source.sh
112%{_bindir}/kdevplatform_shell_environment.sh
113%{_datadir}/kde4/apps/kdev*/
114%{_datadir}/kde4/services/*.desktop
115%{_datadir}/kde4/servicetypes/*.desktop
116%{_datadir}/icons/hicolor/*/*/*
117
118%files libs
119%defattr(-,root,root,-)
120%{_libdir}/lib*.so.*
121%{_libdir}/kde4/*.so
122
123%files devel
124%defattr(-,root,root,-)
125%{_libdir}/lib*.so
126%{_includedir}/kde4/kdevplatform/
127%{_libdir}/cmake/kdevplatform/
128
129
130%changelog
131* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-2
132- rebuild with libboost-1.54.0
133
134* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-1
135- new upstream release
136
137* Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
138- new upstream release
139- add BuildRequires: qjson-devel
140
141* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-1
142- new upstream release
143
144* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.3-1
145- new upstream release
146
147* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.0-2
148- add BuildRequires: soprano-devel
149
150* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
151- new upstream release
152
153* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.1.2-1
154- new upstream release
155- added Japanese summary
156
157* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
158- removed R: kdevplatform from libs package
159
160* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
161- Initial build for Vine Linux
162
163* Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-1
164- kdevplatform-1.0.0
165
166* Sat Apr 17 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.10.2-1
167- kdevplatform-0.10.2
168
169* Thu Apr 08 2010 Rex Dieter <rdieter@fedoraproject.org. - 0.10.0-1
170- kdevplatform-0.10.0
171
172* Mon Mar 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.99-1
173- kdevplatform-0.9.99
174
175* Mon Feb 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.98-1
176- kdevplatform-0.9.98
177
178* Sat Jan 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.97-2
179- rebuild (boost)
180- BR: kdelibs4-devel
181
182* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> 0.9.97-1
183- kdevplatform-0.9.97
184- kdevplatform: file conflict with kdelibs (FindKDevPlatform.cmake) (#541690)
185
186* Sun Nov 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.95-0.6.20091015svn1035382
187- rebuild (fc13+, qt-4.6.0-rc1)
188
189* Thu Oct 15 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.5.20091015svn1035382
190- New snapshot
191
192* Sun Oct 11 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.4.beta5
193- Fix finding Kompare includes
194
195* Tue Sep 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.3.beta5
196- Use official release
197
198* Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.2
199- Add icon scriptlets
200
201* Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.1
202- Update tarball
203
204* Fri May 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.93-0.1
205- 1.0 Beta 3
206
207* Sat Feb 21 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.91-0.2.20090221svn929301
208- Post KDevplatform 1.0 Beta 1 snapshot
209
210* Fri Jan 09 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.85-1
211- 0.9.85 snapshot
Note: See TracBrowser for help on using the repository browser.