source: projects/specs/trunk/k/kdevplatform/kdevplatform-vl.spec @ 9226

Revision 9226, 6.0 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

RevLine 
[2775]1%define kde KDE4
2
[1069]3Name:           kdevplatform
[2775]4Summary:        Libraries for use by %{kde} development tools
5Summary(ja):    %{kde} 開発ツールが使用するライブラリ
[9226]6Version:        1.7.0
[8154]7Release:        1%{?_dist_release}
[1069]8
9Group:          Development/Tools
10License:        GPLv2
[2775]11URL:            http://www.kdevelop.org/
12
[9226]13Source0:        ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.7.0/src/kdevplatform-%{version}.tar.xz
[2775]14
[1069]15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  libboost-devel
17BuildRequires:  gettext
[6774]18BuildRequires:  kdelibs-devel >= 4.6
19BuildRequires:  kdesdk-devel >= 4.6
[1069]20BuildRequires:  pcre-devel
21BuildRequires:  subversion-devel
22BuildRequires:  apr-util-devel
[3876]23BuildRequires:  soprano-devel
[6968]24BuildRequires:  qjson-devel
[8154]25BuildRequires:  grantlee-devel
[1069]26
27Requires: %{name}-libs = %{version}-%{release}
28Requires(postun): gtk2
29Requires(posttrans): gtk2
30
[8154]31Vendor: Project Vine
32Distribution: Vine Linux
33
[1069]34%description
[2775]35%{kde} Development platform, the foundations upon which
[1069]36KDevelop and Quanta are built.
37
38%package libs
39Summary: Runtime libraries for %{name}
[2775]40Summary(ja): %{name} のランタイムライブラリ
[1069]41Group:   System Environment/Libraries
[9226]42Requires: kdelibs
[1069]43
44%description libs
45%{summary}.
46
47%package devel
[2775]48Summary:  Developer files for %{name}
49Summary(ja): %{name} の開発用ファイル
[1069]50Group:    Development/Libraries
51Requires: %{name}-libs = %{version}-%{release}
52Requires: libboost-devel
53Requires: commoncpp2-devel
[9226]54Requires: kdelibs-devel
[1069]55Requires: subversion-devel
56
57%description devel
58%{summary}.
59
60
61%prep
62%setup -q -n kdevplatform-%{version}
63
64
65%build
66mkdir -p %{_target_platform}
67pushd %{_target_platform}
68%cmake \
69    -DCMAKE_BUILD_TYPE=release \
70    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
71    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
72    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
73    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
74    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
75    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
76    ..
77popd
78
79make %{?_smp_mflags} -C %{_target_platform}
80
81
82%install
83rm -rf %{buildroot}
84
85make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
86
87%find_lang %{name} --all-name --with-kde
88
89
90%clean
91rm -rf %{buildroot}
92
93
94%post
95touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
96
[2775]97%posttrans
98gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
[1069]99
100%postun
101if [ $1 -eq 0 ] ; then
102    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
103    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
104fi
105
[2775]106%post libs -p /sbin/ldconfig
107
[1069]108%postun libs -p /sbin/ldconfig
109
110
111%files -f %{name}.lang
112%defattr(-,root,root,-)
113%doc COPYING.PLUGINS COPYING.SRC
[6774]114%{_bindir}/kdev_dbus_socket_transformer
[8154]115%{_bindir}/kdev_format_source
[6774]116%{_bindir}/kdevplatform_shell_environment.sh
[9226]117%{_libdir}/kde4/imports/org/kde/%{name}
[8154]118%{_libdir}/kde4/plugins/grantlee/0.3/kdev_filters.so
119%{_datadir}/config/kdevappwizard.knsrc
120%{_datadir}/config/kdevfiletemplates.knsrc
[1069]121%{_datadir}/kde4/apps/kdev*/
[9226]122%{_datadir}/kde4/apps/plasma/plasmoids
[1069]123%{_datadir}/kde4/services/*.desktop
124%{_datadir}/kde4/servicetypes/*.desktop
125%{_datadir}/icons/hicolor/*/*/*
126
127%files libs
128%defattr(-,root,root,-)
129%{_libdir}/lib*.so.*
130%{_libdir}/kde4/*.so
131
132%files devel
133%defattr(-,root,root,-)
134%{_libdir}/lib*.so
[9226]135%{_includedir}/kde4/%{name}/
136%{_libdir}/cmake/%{name}/
[1069]137
138
139%changelog
[9226]140* Sun Jan 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.7.0-1
141- new upstream release
142
[8154]143* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.0-1
144- new upstream release
145- add BuildRequires: grentlee-devel
146
[8034]147* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-2
148- rebuild with libboost-1.54.0
149
[7065]150* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-1
151- new upstream release
152
[6968]153* Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
154- new upstream release
155- add BuildRequires: qjson-devel
156
[6774]157* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-1
158- new upstream release
159
[4232]160* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.3-1
161- new upstream release
162
[3876]163* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.0-2
164- add BuildRequires: soprano-devel
165
[2775]166* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
167- new upstream release
168
169* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.1.2-1
170- new upstream release
171- added Japanese summary
172
[1069]173* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
174- removed R: kdevplatform from libs package
175
176* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
177- Initial build for Vine Linux
178
179* Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-1
180- kdevplatform-1.0.0
181
182* Sat Apr 17 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.10.2-1
183- kdevplatform-0.10.2
184
185* Thu Apr 08 2010 Rex Dieter <rdieter@fedoraproject.org. - 0.10.0-1
186- kdevplatform-0.10.0
187
188* Mon Mar 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.99-1
189- kdevplatform-0.9.99
190
191* Mon Feb 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.98-1
192- kdevplatform-0.9.98
193
194* Sat Jan 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.97-2
195- rebuild (boost)
196- BR: kdelibs4-devel
197
198* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> 0.9.97-1
199- kdevplatform-0.9.97
200- kdevplatform: file conflict with kdelibs (FindKDevPlatform.cmake) (#541690)
201
202* Sun Nov 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.95-0.6.20091015svn1035382
203- rebuild (fc13+, qt-4.6.0-rc1)
204
205* Thu Oct 15 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.5.20091015svn1035382
206- New snapshot
207
208* Sun Oct 11 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.4.beta5
209- Fix finding Kompare includes
210
211* Tue Sep 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.3.beta5
212- Use official release
213
214* Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.2
215- Add icon scriptlets
216
217* Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.1
218- Update tarball
219
220* Fri May 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.93-0.1
221- 1.0 Beta 3
222
223* Sat Feb 21 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.91-0.2.20090221svn929301
224- Post KDevplatform 1.0 Beta 1 snapshot
225
226* Fri Jan 09 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.85-1
227- 0.9.85 snapshot
Note: See TracBrowser for help on using the repository browser.