source: projects/specs/trunk/k/kdesdk/kdesdk-vl.spec @ 521

Revision 521, 14.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: kdesdk
2Version: 4.3.3
3Release: 1%{?_dist_release}
4Summary: The KDE Software Development Kit (SDK)
5Summary(ja): KDE ソフトウェア開発キット
6Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
7
8URL: http://www.kde.org/
9License: GPLv2
10Group: Applications/Development
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: kdepimlibs-devel >= %{version}
14BuildRequires: plasma-devel >= %{version}
15BuildRequires: strigi-devel
16BuildRequires: flex
17BuildRequires: apr-devel
18BuildRequires: libxml2-devel
19BuildRequires: libxslt-devel
20BuildRequires: libtool-ltdl-devel
21BuildRequires: subversion-devel
22BuildRequires: libboost-devel
23BuildRequires: libical-devel
24# for libiberty (used by kmtrace for cp_demangle)
25# IMPORTANT: check licensing from time to time, currently libiberty is still
26#            GPLv2+/LGPLv2+
27BuildRequires: binutils
28
29Requires: kdepimlibs >= %{version}
30Requires: %{name}-libs = %{version}-%{release}
31
32Provides:      kaider = %{version}-%{release}
33Obsoletes:     kaider < %{version}-%{release}
34
35
36%description
37This is a collection of applications and tools used by KDE developers.
38It also has example code for use in learning KDE programming or starting
39a new KDE application.
40
41* cervisia: a CVS frontend
42* kate: advanced text editor
43* kbugbuster: a tool to manage the KDE bug report system
44* kcachegrind: a browser for data produced by profiling tools (e.g. cachegrind)
45* kompare: diff tool
46* kuiviewer: displays designer's UI files
47* lokalize: computer-aided translation system focusing on productivity and performance
48* umbrello: UML modeller and UML diagram tool
49
50%package libs
51Summary: Runtime libraries for %{name}
52Group:   System Environment/Libraries
53
54%description libs
55%{summary}.
56
57%package devel
58Summary: Development files for kdesdk.
59Group: Development/Libraries
60Requires: %{name}-libs = %{version}-%{release}
61Requires: kdepimlibs-devel
62
63%description devel
64Development files (headers) for kdesdk.
65
66%package utils
67Summary: Text utilities from %{name}
68Group:   Applications/Text
69
70%description utils
71%{summary}, including:
72po2xml
73split2po
74swappo
75xml2pot
76
77
78%prep
79%setup -q
80
81%build
82mkdir -p %{_target_platform}
83pushd %{_target_platform}
84unset QTDIR || : ; . /etc/profile.d/qt4.sh
85%cmake \
86    -DCMAKE_BUILD_TYPE=release \
87    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
88    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
89    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
90    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
91    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
92    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
93    ..
94popd
95
96make %{?_smp_mflags} -C %{_target_platform}
97
98%install
99rm -rf $RPM_BUILD_ROOT
100make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
101
102# unpackaged files
103rm -f $RPM_BUILD_ROOT%{_libdir}/libantlr.so
104# This one fits better into krazy2 (it requires krazy2), and the version in
105# kdesdk does not understand lib64.
106rm -f $RPM_BUILD_ROOT%{_bindir}/krazy-licensecheck
107
108# move devel symlinks
109mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
110pushd $RPM_BUILD_ROOT%{_libdir}
111for i in lib*.so
112do
113  case "$i" in
114    libkateinterfaces.so)
115      linktarget=`readlink "$i"`
116      rm -f "$i"
117      ln -sf "../../$linktarget" "kde4/devel/$i"
118      ;;
119  esac
120done
121popd
122
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post
128touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
129touch --no-create %{_datadir}/icons/locolor &> /dev/null ||:
130touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
131
132%posttrans
133gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
134gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null ||:
135gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
136update-desktop-database -q &> /dev/null ||:
137
138
139%postun
140if [ $1 -eq 0 ] ; then
141  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
142  touch --no-create %{_datadir}/icons/locolor &> /dev/null ||:
143  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
144  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
145  gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null ||:
146  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
147  update-desktop-database -q &> /dev/null ||:
148fi
149
150%post libs -p /sbin/ldconfig
151
152%postun libs -p /sbin/ldconfig
153
154
155%files
156%defattr(-,root,root)
157%doc COPYING README kdepalettes
158%doc /usr/share/doc/HTML/en/*
159%{_bindir}/*
160# -utils
161%exclude %{_bindir}/po2xml
162%exclude %{_bindir}/split2po
163%exclude %{_bindir}/swappo
164%exclude %{_bindir}/xml2pot
165%{_datadir}/config/*
166%{_datadir}/kde4/apps/cervisia
167%{_datadir}/kde4/apps/cervisiapart
168%{_datadir}/kde4/apps/kabc
169%{_datadir}/kde4/apps/katepart
170%{_datadir}/kde4/apps/kate
171%{_datadir}/kde4/apps/kbugbuster
172%{_datadir}/kde4/apps/kcachegrind
173%{_datadir}/kde4/apps/kconf_update
174%{_datadir}/kde4/apps/kio_perldoc
175%{_datadir}/kde4/apps/kdevappwizard
176#{_datadir}/kde4/apps/kmtrace
177%{_datadir}/kde4/apps/kompare
178%{_datadir}/kde4/apps/kpartloader
179%{_datadir}/kde4/apps/kuiviewer
180%{_datadir}/kde4/apps/kuiviewerpart
181%{_datadir}/kde4/apps/lokalize
182%{_datadir}/kde4/apps/umbrello
183%{_datadir}/applications/kde4/*
184%{_datadir}/config.kcfg/*
185%{_datadir}/dbus-1/interfaces/*
186%{_datadir}/kde4/services/*
187%{_datadir}/kde4/servicetypes/*
188%{_datadir}/icons/hicolor/*/*/*
189%{_datadir}/icons/locolor/*/*/*
190%{_datadir}/icons/oxygen/*/*/*
191%{_mandir}/man1/*
192%{_libdir}/libkdeinit4*.so
193%{_libdir}/libkomparedialogpages.so
194%{_libdir}/libkomparediff2.so
195%{_libdir}/strigi/*.so
196%{_datadir}/strigi/fieldproperties/
197%{_libdir}/kde4/*.so
198# -devel
199%exclude %{_libdir}/kde4/devel/
200
201%files libs
202%defattr(-,root,root,-)
203%{_libdir}/lib*.so.*
204# -utils
205%exclude %{_libdir}/libantlr.so.*
206
207%files devel
208%defattr(-,root,root)
209%{_includedir}/kde4/*
210%{_libdir}/lib*.so
211%exclude %{_libdir}/libkomparedialogpages.so
212%exclude %{_libdir}/libkomparediff2.so
213%{_libdir}/kde4/devel/lib*.so
214
215%files utils
216%defattr(-,root,root,-)
217%{_bindir}/po2xml
218%{_bindir}/split2po
219%{_bindir}/swappo
220%{_bindir}/xml2pot
221%{_libdir}/libantlr.so.*
222
223%changelog
224* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
225- new upstream release
226
227* Mon Oct 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
228- new upstream release
229
230* Thu Sep 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
231- new upstream release
232
233* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
234- new upstream release
235
236* Wed May 13 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
237- applied new versioning policy
238- changed Group to Applications/Development
239
240* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
241- rebuild for VineSeed
242
243* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
244- new upstream release
245- disable subversion support
246
247* Wed Jun 27 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
248- build for VineSeed
249- added --with-qt-libraries configure option
250
251* Tue Jun 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
252- new upstream release
253- add Patch0 to build kioslave/svn
254
255* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
256- rebuild for VineSeed
257
258* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
259- new upstream release
260
261* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
262- rebuild for VineSeed
263
264* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
265- new upstream release
266
267* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
268- rebuild for VineSeed
269
270* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
271- new upstream release
272- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
273- add --with-svn-include=%%{_includedir}/subversion-1
274
275* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
276- rebuild for VineSeed
277
278* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
279- new upstream release
280
281* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
282- rebuild for VineSeed
283
284* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
285- new upstream release
286- add BuildPrereq: expat-devel
287- add Requires: kdebindings >= %%{version}
288
289* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
290- rebuild for VineSeed
291
292* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
293- new upstream release
294- add BuildPrereq: apache2-devel subversion-devel
295- add Requires: apache2-apr subversion
296
297* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
298- new upstream release
299
300* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
301- new upstream release
302- delete Patch0
303
304* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
305- new upstream release
306- add Patch0
307- update %%files
308
309* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
310- rebuild for VineSeed
311
312* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
313- new upstream release
314
315* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
316- build for VineSeed
317- add --disable-rpath to configure option
318
319* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
320- new upstream release
321- use %%{?_smp_mflags} for make option
322
323* Sat Mar 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
324- rebuild for VineSeed
325
326* Sat Mar 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
327- new upstream release
328- clean up changelog to use (double-percent) everywhere
329
330* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
331- rebuild for VineSeed
332
333* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
334- new upstream release
335
336* Fri Nov 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl2
337- rebuild with db4-4.2.52-6vl3 (VineSeed)
338
339* Tue Nov  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
340- source upgrade
341- update %%files
342- add BuildPrereq: kdepim-devel >= %%{version} libart_lgpl-devel
343- add Requires: kdepim >= %%{version}
344
345* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
346- rebuild with qt32
347
348* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
349- source upgrade
350- remove lines about vine26
351
352* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
353- source upgrade
354
355* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
356- source upgrade
357
358* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
359- rebuild for VineSeedPlus
360
361* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
362- source upgrade
363- build for VinePlus/2.6
364- (VinePlus/2.6) BuildPrereq: autoconf258
365
366* Thu Jan  8 2004 Tomoya TAKA <taka@vinelinux.org> 3.1.4-0vl4
367- remove alpha fron ExcludeArch
368
369* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
370- build for VineSeed with new toolchain and qt-3.2.3
371
372* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
373- rebuild with qt-3.2.1-0.26vl3
374
375* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
376- rebuild with qt-3.2.1-0vl3
377
378* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
379- build with gcc-3.2.3
380
381* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
382- source upgrade
383- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
384
385* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
386- rebuild for Vine2.6
387
388* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
389- source upgrade
390- change spec to build with gcc295
391- change make option for SMP and add script
392
393* Sat Jun 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
394- source upgrade (MD5SUMS = 279b42135756e0e3640cf5f6612f572d)
395- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
396- change spec to build both VineSeed and Vine2.5/2.6
397- change spec to make monolithic package only
398- remove Source900 and Patch0
399- revised description
400- change spec to build with g++-2.95.3
401
402* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
403- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
404
405* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
406- source upgrade
407- BuildPrereq: autoconf253 objprelink2
408- remove kbugbuster
409
410* Mon Jul 15 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
411- source upgrade
412
413* Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-5vl1
414- merged with rawhide 3.0.0-5
415- add configure option `--with-xinerama --enable-final'
416- add BuildPrereq: autoconf252 automake15
417- add %%define monolithic 1
418- There is Vine's previous changes, hacked for Vine
419 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
420  - build for VineSeed
421  - objprelink (i386 only)
422  - add Requires and BuildPrereq
423
424* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-5
425- Rename libraries
426
427* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-4
428- Fix bug #62259
429
430* Sun Mar 31 2002 Than Ngo <than@redhat.com> 3.0.0-3
431- fix bug #62388
432
433* Wed Mar 27 2002 Than Ngo <than@redhat.com> 3.0.0-2
434- final
435
436* Tue Mar 26 2002 Than Ngo <than@redhat.com> 3.0.0-0.cvs20020326.1
437- update
438
439* Sun Mar 24 2002 Than Ngo <than@redhat.com> 3.0.0-0.cvs20020324.1
440- update
441- fix bug #61671, #61670, #61656
442- add more buildrequires
443
444* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
445- automated rebuild
446
447* Wed Jan  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020102.1
448- Update
449- Split in subpackages
450
451* Mon Aug  6 2001 Than Ngo <than@redhat.com> 2.2-1
452- update to 2.2 release
453
454* Sat Aug  04 2001 Than Ngo <than@redhat.com> 2.2-0.cvs20010804.1
455- update
456- fix bug #50665
457
458* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010724.1
459- Remove extractrc (it's in kdevelop)
460- remove ia64 workarounds
461
462* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.1
463- update
464
465* Wed Feb 21 2001 Than Ngo <than@redhat.com>
466- 2.1-respin
467- fix dangling symlink
468
469* Tue Feb 20 2001 Than Ngo <than@redhat.com>
470- update to 2.1
471
472* Fri Feb 16 2001 Than Ngo <than@redhat.com>
473- fix to build against glibc
474- obsolete ktranslator kless (from powertools)
475- clean up specfile
476- add missing %%post and %%postun (ldconfig)
477
478* Tue Feb  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
479- Rebuild to get rid of libkdefakes.so.0 requirement
480- Obsolete kbabel (from Powertools)
481
482* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
483- initial RPM
Note: See TracBrowser for help on using the repository browser.