source: projects/specs/trunk/k/kdesdk/kdesdk-vl.spec @ 1263

Revision 1263, 14.6 KB checked in by inagaki, 14 years ago (diff)

updated: kdebase, kdenetwork, kdeaccessibility, kdesdk

Line 
1Name: kdesdk
2Summary: The KDE Software Development Kit (SDK)
3Summary(ja): KDE ソフトウェア開発キット
4Version: 4.4.3
5Release: 2%{?_dist_release}
6
7Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
8
9URL: http://www.kde.org/
10License: GPLv2
11Group: Applications/Development
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: kdepimlibs-devel >= %{version}
15BuildRequires: plasma-devel >= %{version}
16BuildRequires: strigi-devel
17BuildRequires: flex
18BuildRequires: apr-devel
19BuildRequires: libxml2-devel
20BuildRequires: libxslt-devel
21BuildRequires: libtool-ltdl-devel
22BuildRequires: subversion-devel
23BuildRequires: libboost-devel
24BuildRequires: libical-devel
25# for libiberty (used by kmtrace for cp_demangle)
26# IMPORTANT: check licensing from time to time, currently libiberty is still
27#            GPLv2+/LGPLv2+
28BuildRequires: binutils-devel
29BuildRequires: hunspell-devel
30
31Requires: kdepimlibs >= %{version}
32Requires: %{name}-libs = %{version}-%{release}
33
34Provides:      kaider = %{version}-%{release}
35Obsoletes:     kaider < %{version}-%{release}
36
37
38%description
39This is a collection of applications and tools used by KDE developers.
40It also has example code for use in learning KDE programming or starting
41a new KDE application.
42
43* cervisia: a CVS frontend
44* kate: advanced text editor
45* kbugbuster: a tool to manage the KDE bug report system
46* kcachegrind: a browser for data produced by profiling tools (e.g. cachegrind)
47* kompare: diff tool
48* kuiviewer: displays designer's UI files
49* lokalize: computer-aided translation system focusing on productivity and performance
50* umbrello: UML modeller and UML diagram tool
51
52%package libs
53Summary: Runtime libraries for %{name}
54Group:   System Environment/Libraries
55
56%description libs
57%{summary}.
58
59%package devel
60Summary: Development files for kdesdk.
61Group: Development/Libraries
62Requires: %{name}-libs = %{version}-%{release}
63Requires: kdepimlibs-devel
64
65%description devel
66Development files (headers) for kdesdk.
67
68%package utils
69Summary: Text utilities from %{name}
70Group:   Applications/Text
71
72%description utils
73%{summary}, including:
74po2xml
75split2po
76swappo
77xml2pot
78
79
80%prep
81%setup -q
82
83%build
84mkdir -p %{_target_platform}
85pushd %{_target_platform}
86unset QTDIR || : ; . /etc/profile.d/qt4.sh
87%cmake \
88    -DCMAKE_BUILD_TYPE=release \
89    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
90    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
91    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
92    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
93    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
94    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
95    ..
96popd
97
98make %{?_smp_mflags} -C %{_target_platform}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
103
104# unpackaged files
105rm -f $RPM_BUILD_ROOT%{_libdir}/libantlr.so
106# This one fits better into krazy2 (it requires krazy2), and the version in
107# kdesdk does not understand lib64.
108rm -f $RPM_BUILD_ROOT%{_bindir}/krazy-licensecheck
109
110# move devel symlinks
111mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
112pushd $RPM_BUILD_ROOT%{_libdir}
113for i in lib*.so
114do
115  case "$i" in
116    libkateinterfaces.so)
117      linktarget=`readlink "$i"`
118      rm -f "$i"
119      ln -sf "../../$linktarget" "kde4/devel/$i"
120      ;;
121  esac
122done
123popd
124
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
131touch --no-create %{_datadir}/icons/locolor &> /dev/null ||:
132touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
133
134%posttrans
135gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
136gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null ||:
137gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
138update-desktop-database -q &> /dev/null ||:
139
140
141%postun
142if [ $1 -eq 0 ] ; then
143  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
144  touch --no-create %{_datadir}/icons/locolor &> /dev/null ||:
145  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
146  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
147  gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null ||:
148  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
149  update-desktop-database -q &> /dev/null ||:
150fi
151
152%post libs -p /sbin/ldconfig
153
154%postun libs -p /sbin/ldconfig
155
156
157%files
158%defattr(-,root,root)
159%doc COPYING README kdepalettes
160%doc /usr/share/doc/HTML/en/*
161%{_bindir}/*
162# -utils
163%exclude %{_bindir}/po2xml
164%exclude %{_bindir}/split2po
165%exclude %{_bindir}/swappo
166%exclude %{_bindir}/xml2pot
167%{_datadir}/config/*
168%{_datadir}/kde4/apps/cervisia
169%{_datadir}/kde4/apps/cervisiapart
170%{_datadir}/kde4/apps/kabc
171%{_datadir}/kde4/apps/katepart
172%{_datadir}/kde4/apps/kate
173%{_datadir}/kde4/apps/kbugbuster
174%{_datadir}/kde4/apps/kcachegrind
175%{_datadir}/kde4/apps/kconf_update
176%{_datadir}/kde4/apps/kio_perldoc
177%{_datadir}/kde4/apps/kdevappwizard
178%{_datadir}/kde4/apps/kmtrace
179%{_datadir}/kde4/apps/kompare
180%{_datadir}/kde4/apps/kpartloader
181%{_datadir}/kde4/apps/ktexteditor_snippets
182%{_datadir}/kde4/apps/kuiviewer
183%{_datadir}/kde4/apps/kuiviewerpart
184%{_datadir}/kde4/apps/lokalize
185%{_datadir}/kde4/apps/umbrello
186%{_datadir}/applications/kde4/*
187%{_datadir}/config.kcfg/*
188%{_datadir}/dbus-1/interfaces/*
189%{_datadir}/kde4/services/*
190%{_datadir}/kde4/servicetypes/*
191%{_datadir}/mime/packages/kateplugin_katesnippets_tng.xml
192%{_datadir}/icons/hicolor/*/*/*
193%{_datadir}/icons/locolor/*/*/*
194%{_datadir}/icons/oxygen/*/*/*
195%{_mandir}/man1/*
196%{_libdir}/libkdeinit4*.so
197%{_libdir}/libkomparedialogpages.so
198%{_libdir}/libkomparediff2.so
199%{_libdir}/strigi/*.so
200%{_datadir}/strigi/fieldproperties/
201%{_libdir}/kde4/*.so
202# -devel
203%exclude %{_libdir}/kde4/devel/
204
205%files libs
206%defattr(-,root,root,-)
207%{_libdir}/lib*.so.*
208# -utils
209%exclude %{_libdir}/libantlr.so.*
210
211%files devel
212%defattr(-,root,root)
213%{_includedir}/kde4/*
214%{_libdir}/lib*.so
215%exclude %{_libdir}/libkomparedialogpages.so
216%exclude %{_libdir}/libkomparediff2.so
217%{_libdir}/kde4/devel/lib*.so
218
219%files utils
220%defattr(-,root,root,-)
221%{_bindir}/po2xml
222%{_bindir}/split2po
223%{_bindir}/swappo
224%{_bindir}/xml2pot
225%{_libdir}/libantlr.so.*
226
227%changelog
228* Tue Jun 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-2
229- added BR: binutils-devel instead of binutils
230
231* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
232- new upstream release
233
234* Sat Mar 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
235- new upstream release
236- built with new toolchain
237
238* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
239- new upstream release
240
241* Mon Oct 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
242- new upstream release
243
244* Thu Sep 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
245- new upstream release
246
247* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
248- new upstream release
249
250* Wed May 13 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
251- applied new versioning policy
252- changed Group to Applications/Development
253
254* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
255- rebuild for VineSeed
256
257* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
258- new upstream release
259- disable subversion support
260
261* Wed Jun 27 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
262- build for VineSeed
263- added --with-qt-libraries configure option
264
265* Tue Jun 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
266- new upstream release
267- add Patch0 to build kioslave/svn
268
269* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
270- rebuild for VineSeed
271
272* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
273- new upstream release
274
275* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
276- rebuild for VineSeed
277
278* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
279- new upstream release
280
281* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
282- rebuild for VineSeed
283
284* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
285- new upstream release
286- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
287- add --with-svn-include=%%{_includedir}/subversion-1
288
289* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
290- rebuild for VineSeed
291
292* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
293- new upstream release
294
295* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
296- rebuild for VineSeed
297
298* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
299- new upstream release
300- add BuildPrereq: expat-devel
301- add Requires: kdebindings >= %%{version}
302
303* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
304- rebuild for VineSeed
305
306* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
307- new upstream release
308- add BuildPrereq: apache2-devel subversion-devel
309- add Requires: apache2-apr subversion
310
311* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
312- new upstream release
313
314* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
315- new upstream release
316- delete Patch0
317
318* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
319- new upstream release
320- add Patch0
321- update %%files
322
323* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
324- rebuild for VineSeed
325
326* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
327- new upstream release
328
329* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
330- build for VineSeed
331- add --disable-rpath to configure option
332
333* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
334- new upstream release
335- use %%{?_smp_mflags} for make option
336
337* Sat Mar 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
338- rebuild for VineSeed
339
340* Sat Mar 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
341- new upstream release
342- clean up changelog to use (double-percent) everywhere
343
344* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
345- rebuild for VineSeed
346
347* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
348- new upstream release
349
350* Fri Nov 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl2
351- rebuild with db4-4.2.52-6vl3 (VineSeed)
352
353* Tue Nov  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
354- source upgrade
355- update %%files
356- add BuildPrereq: kdepim-devel >= %%{version} libart_lgpl-devel
357- add Requires: kdepim >= %%{version}
358
359* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
360- rebuild with qt32
361
362* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
363- source upgrade
364- remove lines about vine26
365
366* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
367- source upgrade
368
369* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
370- source upgrade
371
372* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
373- rebuild for VineSeedPlus
374
375* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
376- source upgrade
377- build for VinePlus/2.6
378- (VinePlus/2.6) BuildPrereq: autoconf258
379
380* Thu Jan  8 2004 Tomoya TAKA <taka@vinelinux.org> 3.1.4-0vl4
381- remove alpha fron ExcludeArch
382
383* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
384- build for VineSeed with new toolchain and qt-3.2.3
385
386* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
387- rebuild with qt-3.2.1-0.26vl3
388
389* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
390- rebuild with qt-3.2.1-0vl3
391
392* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
393- build with gcc-3.2.3
394
395* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
396- source upgrade
397- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
398
399* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
400- rebuild for Vine2.6
401
402* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
403- source upgrade
404- change spec to build with gcc295
405- change make option for SMP and add script
406
407* Sat Jun 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
408- source upgrade (MD5SUMS = 279b42135756e0e3640cf5f6612f572d)
409- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
410- change spec to build both VineSeed and Vine2.5/2.6
411- change spec to make monolithic package only
412- remove Source900 and Patch0
413- revised description
414- change spec to build with g++-2.95.3
415
416* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
417- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
418
419* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
420- source upgrade
421- BuildPrereq: autoconf253 objprelink2
422- remove kbugbuster
423
424* Mon Jul 15 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
425- source upgrade
426
427* Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-5vl1
428- merged with rawhide 3.0.0-5
429- add configure option `--with-xinerama --enable-final'
430- add BuildPrereq: autoconf252 automake15
431- add %%define monolithic 1
432- There is Vine's previous changes, hacked for Vine
433 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
434  - build for VineSeed
435  - objprelink (i386 only)
436  - add Requires and BuildPrereq
437
438* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-5
439- Rename libraries
440
441* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-4
442- Fix bug #62259
443
444* Sun Mar 31 2002 Than Ngo <than@redhat.com> 3.0.0-3
445- fix bug #62388
446
447* Wed Mar 27 2002 Than Ngo <than@redhat.com> 3.0.0-2
448- final
449
450* Tue Mar 26 2002 Than Ngo <than@redhat.com> 3.0.0-0.cvs20020326.1
451- update
452
453* Sun Mar 24 2002 Than Ngo <than@redhat.com> 3.0.0-0.cvs20020324.1
454- update
455- fix bug #61671, #61670, #61656
456- add more buildrequires
457
458* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
459- automated rebuild
460
461* Wed Jan  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020102.1
462- Update
463- Split in subpackages
464
465* Mon Aug  6 2001 Than Ngo <than@redhat.com> 2.2-1
466- update to 2.2 release
467
468* Sat Aug  04 2001 Than Ngo <than@redhat.com> 2.2-0.cvs20010804.1
469- update
470- fix bug #50665
471
472* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010724.1
473- Remove extractrc (it's in kdevelop)
474- remove ia64 workarounds
475
476* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.1
477- update
478
479* Wed Feb 21 2001 Than Ngo <than@redhat.com>
480- 2.1-respin
481- fix dangling symlink
482
483* Tue Feb 20 2001 Than Ngo <than@redhat.com>
484- update to 2.1
485
486* Fri Feb 16 2001 Than Ngo <than@redhat.com>
487- fix to build against glibc
488- obsolete ktranslator kless (from powertools)
489- clean up specfile
490- add missing %%post and %%postun (ldconfig)
491
492* Tue Feb  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
493- Rebuild to get rid of libkdefakes.so.0 requirement
494- Obsolete kbabel (from Powertools)
495
496* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
497- initial RPM
Note: See TracBrowser for help on using the repository browser.