source: projects/specs/trunk/k/kdepim3/kdepim3-vl.spec @ 10547

Revision 10547, 18.2 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name: kdepim3
2Summary: Compatibility support for kdepim3
3Version: 3.5.10
4Release: 4%{?_dist_release}
5
6URL: http://www.kde.org/
7Group: Applications/Productivity
8License: GPLv2
9
10Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
11Patch0: kdepim-3.5.10-gcc.patch
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: bison
15BuildRequires: desktop-file-utils
16BuildRequires: flex
17BuildRequires: kdelibs3-devel >= %{version}
18BuildRequires: libart_lgpl-devel
19BuildRequires: cyrus-sasl-devel
20BuildRequires: gpgme-devel
21BuildRequires: libXpm-devel libXScrnSaver-devel
22BuildRequires: zlib-devel
23BuildRequires: python-devel
24#BuildRequires: libmal-devel
25#BuildRequires: pilot-link-devel >= 0.9.5
26
27%description
28%{summary}, including libkcal.
29
30%package libs
31Summary: Runtime files for %{name}
32Summary(ja): %{name} のランタイムライブラリ
33Group: System Environment/Libraries
34Requires: kdelibs3 >= %{version}
35
36%description libs
37%{summary}, including libkcal.
38
39%package devel
40Summary: Development files for %{name}
41Summary(ja): %{name} の開発用ファイル
42Group: Development/Libraries
43Requires: %{name}-libs = %{version}-%{release}
44Requires: kdelibs3-devel
45
46%description devel
47Development files for %{name}.
48Install %{name}-devel if you want to write or compile %{name} plugins.
49
50%prep
51%setup -q -n kdepim-%{version}
52%patch0 -p1 -b .gcc47
53
54%build
55unset QTDIR || : ; . /etc/profile.d/qt.sh
56
57%configure \
58    --with-qt-libraries=$QTDIR/lib \
59    --enable-new-ldflags \
60    --disable-dependency-tracking \
61    --disable-rpath \
62    --disable-debug --disable-warnings \
63    --enable-final \
64    --includedir=%{_includedir}/kde \
65    --with-gpg=%{_bindir}/gpg \
66    --with-gpgsm=%{_bindir}/gpgsm \
67    --with-sasl \
68    --without-gnokii \
69    --without-mal \
70    --without-pilot-link
71
72for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
73make %{?_smp_mflags} -C ${lib}
74done
75
76%install
77rm -rf $RPM_BUILD_ROOT
78for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
79    make install DESTDIR=$RPM_BUILD_ROOT -C $lib
80done
81
82#unpackaged files
83rm -f  $RPM_BUILD_ROOT%{_libdir}/lib*.la
84rm -f  $RPM_BUILD_ROOT%{_libdir}/libkdepim*
85rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/libkdepim/
86rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/kdepimwidgets/
87rm -f  $RPM_BUILD_ROOT%{_libdir}/kde3/plugins/designer/*
88rm -f  $RPM_BUILD_ROOT%{_libdir}/lib{kmime,ktnef}.so
89rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/ktnef/
90rm -rf $RPM_BUILD_ROOT%{_datadir}/applications
91rm -rf $RPM_BUILD_ROOT%{_datadir}/icons
92rm -rf $RPM_BUILD_ROOT%{_datadir}/mimelnk
93rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/ktnef
94rm -f  $RPM_BUILD_ROOT%{_bindir}/ktnef
95
96
97%post libs -p /sbin/ldconfig
98
99%postun libs -p /sbin/ldconfig
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%files libs
105%defattr(-,root,root)
106%doc README korganizer/COPYING
107%{_datadir}/config.kcfg/pimemoticons.kcfg
108%{_datadir}/apps/libical/
109%{_datadir}/services/kresources/kcal*
110%{_libdir}/libkcal.so.2*
111%{_libdir}/kde3/kcal*
112%{_libdir}/libkmime.so.2*
113%{_libdir}/libktnef.so.1*
114
115%files devel
116%defattr(-,root,root)
117%{_includedir}/kde/kdepimmacros.h
118%{_includedir}/kde/libemailfunctions
119%{_includedir}/kde/libkcal
120%{_libdir}/libkcal.so
121
122%changelog
123* Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.10-4
124- rebuild with gcc-5.4.0
125
126* Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-3
127- added Patch0 from fc
128- not link to libmal and pilot-link
129
130* Sat May 26 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-2
131- rebuilt with rpm-4.8.1-3
132- added BR: arts-devel
133
134* Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
135- updated to 3.5.10
136- built with new toolchain
137
138* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
139- renamed kdepim3
140
141* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
142- applied new versioning policy, spec in UTF-8
143- added Japnaese summary
144
145* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
146- rebuild for VineSeed
147
148* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
149- new upstream release
150
151* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
152- rebuild for VineSeed
153
154* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
155- new upstream release
156- remove all patches
157
158* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
159- new upstream release
160- add Patch0, 1 , 2 and 3
161
162* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
163- added --with-qt-libraries and --enable-libsuffix option
164
165* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
166- rebuild for VineSeed
167
168* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
169- new upstream release
170
171* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
172- rebuild with pilot-link-0.12.0-0vl1
173
174* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
175- rebuild for VineSeed
176
177* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
178- new upstream release
179
180* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
181- rebuild for VineSeed
182
183* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
184- new upstream release
185
186* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
187- rebuild for VineSeed
188
189* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
190- new upstream release
191
192* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
193- rebuild for VineSeed
194
195* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
196- new upstream release
197- delete BuildPrereq: libmal-devel and Requires: libmal
198
199* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
200- rebuild for VineSeed
201
202* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
203- new upstream release
204
205* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
206- new upstream release
207
208* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
209- new upstream release
210- delete all patches
211- add Requires: kdeaccessibility  >= %%{version}
212- add --enable-indexlib to configure option
213
214* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
215- new upstream release
216- remove Patch0
217- add Patch0 - Patch1
218
219* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
220- rebuild for VineSeed
221
222* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
223- new upstream release
224- remove Patch0
225- add BuildPrereq: gpgme-devel >= 0.4.5
226- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
227
228* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
229- rebuild for VineSeed
230- add --disable-rpath to configure option
231
232* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
233- new upstream release (delete old patch and add new security patch)
234- use %%{?_smp_mflags} for make option
235
236* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
237- rebuild for VineSeed
238
239* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
240- new upstream release
241- add patch0
242
243* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
244- new upstream release (3.4.0-rc1)
245
246* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
247- new upstream release
248
249* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
250- new upstream release
251
252* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
253- rebuild for VineSeed
254
255* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
256- new upstream release
257
258* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
259- source upgrade
260- update %%files
261- all sub-packages are integrated into main package (exclude devel)
262
263* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
264- rebuild with qt32
265
266* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
267- source upgrade
268- remove lines about vine26
269
270* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
271- source upgrade
272- update %%files
273
274* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
275- source upgrade
276- update %%description
277- add Obsoletes: kdenetwork < 3.2.0
278
279* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
280- rebuild for VineSeedPlus
281
282* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
283- source upgrade
284- build for VinePlus/2.6
285- (VinePlus/2.6) BuildPrereq: autoconf258
286- remove Patch
287
288* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
289- build for VineSeed with new toolchain and qt-3.2.3
290- add configure option --with-xinerama --enable-final
291
292* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
293- rebuild with qt-3.2.1-0.26vl3
294
295* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
296- rebuild with qt-3.2.1-0vl3
297
298* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
299- build with gcc-3.2.3
300
301* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
302- source upgrade
303- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
304
305* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
306- rebuild for Vine2.6
307
308* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
309- source upgrade
310- change spec to build with gcc295
311- change make option for SMP and add script
312- add BuildPrereq: libmal-devel
313- add Requires: libmal for pilot
314
315* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
316- source upgrade
317- remove Patch800 (included in this source)
318- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
319
320* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
321- source upgrade
322- change spec to build both VineSeed and Vine2.5/2.6
323- revised description and files section
324- remove source900
325- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
326- add patch800 (Kdeveloper:02753)
327
328* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
329- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
330
331* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
332- source upgrade
333
334* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
335- rebuild with qt-3.0.5-0vl1
336- BuildPrereq: autoconf253 objprelink2
337
338* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
339- source upgrade
340
341* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
342- source upgrade
343- add BuildPrereq: autoconf252 automake15
344
345* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
346- merged with rawhide 3.0.1-1
347- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
348- add Requires: for each package
349- There is Vine's previous changes, hacked for Vine
350 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
351  - build for VineSeed
352  - delete Epoch
353  - objprelink (i386 only)
354
355* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
356- 3.0.1
357- fixed bug #67303
358
359* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
360- automated rebuild
361
362* Thu May 23 2002 Tim Powers <timp@redhat.com>
363- automated rebuild
364
365* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
366- Rename libraries
367
368* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
369- Fix #61901
370
371* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
372- final
373
374* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
375- Update
376- Fix build on ia64
377
378* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
379- Update, fixes korganizer (#50006)
380
381* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
382- Update to get rid of abbrowser (moved to kdebase)
383
384* Thu Feb 22 2001 Than Ngo <than@redhat.com>
385- add missing ldconfig in %post anf %postun again
386- clean up specfile
387
388* Wed Feb 21 2001 Than Ngo <than@redhat.com>
389- 2.1-respin
390- fix dangling symlink
391- remove excludearch ia64, some hacks to build on ia64
392
393* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
394- 2.1
395
396* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
397- Update
398
399* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
400- Update
401
402* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
403- Update to CVS
404- Enable building kpilot
405- Obsolete kpilot
406- Don't exclude ia64, use -O0 on ia64
407- Disable building kpilot on ia64 (compiler breakage)
408
409* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
410- 2.0 final
411
412* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
413- 2.0
414
415* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
416- new CVS
417- fix installation of fonts
418
419* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
420- new CVS snapshot
421- fix up spec file
422
423* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
424- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
425  there's no need to keep them separate to avoid the dependency.
426
427* Mon Aug 21 2000 Than Ngo <than@redhat.com>
428- fix gnome-session so that KDE2 can be started from gdm
429- pam/kde2 instead pam/kde to avoid problem with KDE1
430- don't requires qt-GL, It's now in qt
431
432* Sun Aug 20 2000 Than Ngo <than@redhat.com>
433- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
434  at the same time
435- add missing ldconfig in %post anf %postun
436- fix for reading config files in /etc/X11/xdm, add Xsession to requires
437
438* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
439- Fix keytable in konsole (Bug #15682)
440
441* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
442- rebuild, now that kdelibs2 works on alpha
443- use the same ugly hack to get kdebase to compile
444- remove ksysguard on alpha (even more compiler problems)
445
446* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
447- new snapshot (fixed libGL detection in CVS)
448
449* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
450- move to /usr/lib/kde2
451- new snapshot
452
453* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
454- fix the --xdmdir arg to be correct (oops)
455
456* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
457- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
458
459* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
460- new snapshot
461- some fixes to spec file
462
463* Tue Jul 18 2000 Than Ngo <than@redhat.de>
464- rebuilt against glibc-2.1.92-14, gcc-2.96-40
465
466* Sun Jul 16 2000 Than Ngo <than@redhat.de>
467- use new snapshot
468- disable Motif
469
470* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
471- use gcc 2.96
472- new snapshot
473
474* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
475- Epoch 3
476- Update to current
477- Use egcs++
478
479* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
480- Update (I put the fixes directly to CVS rather than collecting them
481  in the spec)
482
483* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
484- remove man2html; we get that from man
485- new snapshot
486
487* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
488- new snapshot
489- ExcludeArch ia64 for now
490- remove gnome .desktop file, we get it from gnome-core now.
491
492* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
493- remove dependency on xpm (now in XFree86)
494
495* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
496- new snapshot
497- move it to /usr, where it belongs
498
499* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
500- Build the OpenGL screensavers, and move them to a separate package
501- Improve the spec file (BuildPrereqs etc.)
502
503* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
504- remove patch #3 (obsoleted by kwin)
505
506* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
507- 2.0 CVS snapshot
508- fix compilation
509
510* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
511- clean up files in /tmp from startkde
512- mark doc files as such
513
514* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
515- start autorun if present in startkde
516- check for configured soundcard before running sound services
517
518* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
519- made kdelnks display Name property if they are of type Link
520
521* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
522- moved png handling here (from kdelibs)
523- changed low color icon directory name to locolor
524
525* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
526- added optional session management to logout dialog
527- include GNOME menus
528
529* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
530- added link to /etc/X11/applnk, .directory file
531- included lowcolor icon sub-package
532- enable .desktop file access
533
534* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
535- customized startkde script to set up user environment if not present.
536- mention kthememgr in description.
537
538* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
539- upgraded to 1.1.2 release
540- kvt is back
541- kde icon included
542- linux console fonts included
543
544* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
545- PAM console logout problem solved.
546
547* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
548- now includes screensaver password security fix
549
550* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
551- snapshot, includes kde 1.1.1 + fixes
552- kvt removed for security reasons.  It is a steaming pile of...
553
554* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
555- last snapshot before release
556
557* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
558- today's snapshot makes kfm a bit nicer and some other fixes
559- moved default rc files to kdesupport
560
561* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
562- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
563
564* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
565- built with today's snapshot -- had to rebuild to fix pam problems.
566
567* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
568- new snapshot fixes mimetype video/x-flic problem
569
570* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
571- latest stable snapshot
572
573* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
574- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
575- this previous connection and autoselect kdebase for upgrade).
576
577* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
578- moved gdm patch
579
580* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
581- added gdm session control file
582
583* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
584- added pam-console stuff to kde pam file
585
586* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
587- Injected new description and group.
588
589* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
590- upgraded to KDE 1.1 final.
591
592* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
593- updated macros for RPM 3.0, removed red hat logo.
594
595* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
596- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.