source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 7294

Revision 7294, 22.9 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.9.5

Line 
1Name: kdepim
2Summary: PIM (Personal Information Manager) for KDE
3Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
4Version: 4.9.5
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Productivity
9URL: http://pim.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.xz
12
13## upstream
14
15# KDE.org patches
16# KDE.gr.jp patches
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: akonadi-devel
20BuildRequires: bison flex
21BuildRequires: libboost-devel
22BuildRequires: cyrus-sasl-devel
23BuildRequires: dblatex
24BuildRequires: desktop-file-utils
25BuildRequires: grantlee-devel
26BuildRequires: gnokii-devel
27BuildRequires: gpgme-devel
28BuildRequires: kdepimlibs-devel >= %{version}
29BuildRequires: libassuan-devel
30BuildRequires: libical-devel
31BuildRequires: libindicate-qt-devel
32BuildRequires: libXpm-devel libXScrnSaver-devel
33# TODO: libmapi from http://www.openchange.org/
34#BuildRequires: libmapi-devel
35BuildRequires: libxslt-devel
36# libmal currently not used, recheck with kdepim-4.3
37BuildRequires: pilot-link-devel >= 0.12.4
38BuildRequires: python-devel
39BuildRequires: shared-desktop-ontologies-devel >= 0.6.51
40BuildRequires: soprano-devel
41BuildRequires: prison-devel
42BuildRequires: qca2-devel
43BuildRequires: zlib-devel
44Requires: %{name}-libs = %{version}-%{release}
45Requires: kdepim-runtime >= %{version}
46
47Obsoletes: kdepim4 < %{version}-%{release}
48Provides: kdepim4 = %{version}-%{release}
49
50Conflicts: kdepim3
51Conflicts: kdeutils3
52
53%description
54A PIM (Personal Information Manager) for KDE.
55
56What it is
57----------
58* kmail: email client
59* knode: newsreader
60* knotes: sticky notes for the desktop
61* kontact: integrated PIM management
62* korganizer: journal, appointments, events, todos
63%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
64
65%package libs
66Summary: %{name} runtime libraries
67Summary(ja): %{name} のラインタイムライブラリ
68Group:   System Environment/Libraries
69Requires: kdelibs4 >= %{version}
70
71%description libs
72%{summary}.
73
74%package devel
75Summary: Development files for kdepim
76Summary(ja): %{name} の開発用ファイル
77Group: Development/Libraries
78Requires: %{name}-libs = %{version}-%{release}
79Requires: kdelibs4-devel
80Obsoletes: kdepim4-devel < %{version}-%{release}
81Provides:  kdepim4-devel = %{version}-%{release}
82Conflicts: kdepim3-devel
83
84%description devel
85Development files for %{name}.
86Install %{name}-devel if you want to write or compile %{name} plugins.
87
88%prep
89%setup -q -n kdepim-%{version}
90
91%build
92mkdir -p %{_target_platform}
93pushd %{_target_platform}
94%cmake \
95    -DCMAKE_BUILD_TYPE=release \
96    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
97    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
98    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
99    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
100    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
101    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
102    -DKDEPIM_BUILD_MOBILE:BOOL=OFF \
103    ..
104popd
105
106make %{?_smp_mflags} -C %{_target_platform}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
111
112# make symlinks relative
113mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
114pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
115for i in *; do
116    if [ -d $i -a -L $i/common ]; then
117        rm -f $i/common
118        ln -nfs ../common $i
119    fi
120done
121popd
122
123%check
124for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
125    desktop-file-validate $f
126done
127
128%post
129touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
130touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
131
132%posttrans
133gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
134gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
135update-desktop-database -q &> /dev/null ||:
136
137%postun
138if [ $1 -eq 0 ] ; then
139  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
140  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
141  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
142  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
143  update-desktop-database -q &> /dev/null ||:
144fi
145
146%post libs -p /sbin/ldconfig
147
148%postun libs -p /sbin/ldconfig
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%files
154%defattr(-,root,root)
155%config %{_sysconfdir}/dbus-1/system.d/org.kde.kalarmrtcwake.conf
156%{_bindir}/*
157%{_libdir}/kde4/*.so
158#{_libdir}/kde4/imports/*
159%{_libdir}/strigi/*.so
160%{_libdir}/akonadi/*
161%{_libexecdir}/kde4/kalarm_helper
162%{_datadir}/akonadi/*
163%{_datadir}/applications/kde4/*.desktop
164%{_datadir}/kde4/apps/akregator
165%{_datadir}/kde4/apps/akregator_sharemicroblog_plugin/*.rc
166%{_datadir}/kde4/apps/akonadiconsole/*
167%{_datadir}/kde4/apps/akonadi_archivemail_agent
168%{_datadir}/kde4/apps/akonadi_mailfilter_agent
169%{_datadir}/kde4/apps/backupmail
170%{_datadir}/kde4/apps/blogilo/*
171%{_datadir}/kde4/apps/desktoptheme/*
172%{_datadir}/kde4/apps/kaddressbook
173#{_datadir}/kde4/apps/kaddressbook-mobile
174%{_datadir}/kde4/apps/kalarm
175%{_datadir}/kde4/apps/kconf_update/*
176%{_datadir}/kde4/apps/kdepimwidgets
177%{_datadir}/kde4/apps/kjots
178%{_datadir}/kde4/apps/kleopatra
179%{_datadir}/kde4/apps/kmail
180#{_datadir}/kde4/apps/kmail-mobile
181%{_datadir}/kde4/apps/kmailcvt
182%{_datadir}/kde4/apps/kmail2
183%{_datadir}/kde4/apps/knode
184%{_datadir}/kde4/apps/knotes
185%{_datadir}/kde4/apps/kontact
186#{_datadir}/kde4/apps/kontact-touch
187%{_datadir}/kde4/apps/kontactsummary
188%{_datadir}/kde4/apps/korgac
189%{_datadir}/kde4/apps/korganizer
190#{_datadir}/kde4/apps/korganizer-mobile
191#{_datadir}/kde4/apps/kpilot
192%{_datadir}/kde4/apps/ktimetracker
193%{_datadir}/kde4/apps/ktnef
194%{_datadir}/kde4/apps/kwatchgnupg
195#{_datadir}/kde4/apps/libkdepim
196%{_datadir}/kde4/apps/libkleopatra
197%{_datadir}/kde4/apps/libmessageviewer
198%{_datadir}/kde4/apps/messagelist
199%{_datadir}/kde4/apps/messageviewer
200#{_datadir}/kde4/apps/mobileui
201#{_datadir}/kde4/apps/notes-mobile
202#{_datadir}/kde4/apps/tasks-mobile
203%{_datadir}/dbus-1/interfaces/*.xml
204%{_datadir}/dbus-1/system-services/*
205%{_datadir}/autostart/*
206#{_datadir}/akonadi/*
207%{_datadir}/config/*
208%{_datadir}/config.kcfg/*
209%{_datadir}/icons/hicolor/*/*/*
210%{_datadir}/icons/locolor/*/*/*
211%{_datadir}/icons/oxygen/*/*/*
212%{_datadir}/kde4/services/*
213%{_datadir}/kde4/servicetypes/*
214%{_datadir}/polkit-1/actions/*.policy
215%{_datadir}/ontology/kde/messagetag.*
216%doc %{_docdir}/HTML/*/*
217%{_mandir}/man1/*
218
219%files libs
220%defattr(-,root,root)
221%{_libdir}/lib*.so.*
222%{_libdir}/kde4/plugins/accessible/*.so
223%{_libdir}/kde4/plugins/designer/*.so
224#{_datadir}/locale/*/LC_MESSAGES/*
225
226%files devel
227%defattr(-,root,root)
228#{_includedir}/kde4/*
229%{_libdir}/lib*.so
230#exclude %{_libdir}/libkpilot_*.so
231
232%changelog
233* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
234- new upstream release
235
236* Fri Nov 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
237- new upstream release
238
239* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
240- new upstream release
241
242* Wed Sep 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
243- new upstream release
244
245* Sat Aug 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
246- new upstream release
247- add BuildRequires: prison-devel
248- remove old patches
249
250* Sat Aug  6 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
251- new upstream release
252
253* Wed Jun 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
254- new upstream release
255- added BR: grantlee-devel
256
257* Sat May 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.11.1-1
258- new upstream release
259
260* Fri Feb 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.10-1
261- new upstream release
262- added BR: libindicate-qt-devel
263
264* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.6-1
265- new upstream release
266- built with rpm-4.8.1
267
268* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-2
269- rebuilt for VineSeed
270
271* Mon Jul  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
272- new upstream release
273- added Conflicts: kdepim3, kdeutils3
274
275* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
276- new upstream release
277
278* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
279- new upstream release
280
281* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
282- new upstream release
283
284* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
285- new upstream release
286- built with new toolchain
287
288* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
289- new upstream release
290
291* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
292- new upstream release
293- dropped Patch100 (merged into upstream)
294- used %%cmake macro
295
296* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
297- new upstream release
298
299* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
300- applied new versioning policy, spec in UTF-8
301- added Japnaese summary
302
303* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
304- rebuild for VineSeed
305
306* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
307- new upstream release
308
309* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
310- rebuild for VineSeed
311
312* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
313- new upstream release
314- remove all patches
315
316* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
317- new upstream release
318- add Patch0, 1 , 2 and 3
319
320* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
321- added --with-qt-libraries and --enable-libsuffix option
322
323* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
324- rebuild for VineSeed
325
326* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
327- new upstream release
328
329* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
330- rebuild with pilot-link-0.12.0-0vl1
331
332* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
333- rebuild for VineSeed
334
335* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
336- new upstream release
337
338* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
339- rebuild for VineSeed
340
341* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
342- new upstream release
343
344* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
345- rebuild for VineSeed
346
347* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
348- new upstream release
349
350* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
351- rebuild for VineSeed
352
353* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
354- new upstream release
355- delete BuildPrereq: libmal-devel and Requires: libmal
356
357* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
358- rebuild for VineSeed
359
360* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
361- new upstream release
362
363* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
364- new upstream release
365
366* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
367- new upstream release
368- delete all patches
369- add Requires: kdeaccessibility  >= %%{version}
370- add --enable-indexlib to configure option
371
372* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
373- new upstream release
374- remove Patch0
375- add Patch0 - Patch1
376
377* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
378- rebuild for VineSeed
379
380* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
381- new upstream release
382- remove Patch0
383- add BuildPrereq: gpgme-devel >= 0.4.5
384- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
385
386* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
387- rebuild for VineSeed
388- add --disable-rpath to configure option
389
390* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
391- new upstream release (delete old patch and add new security patch)
392- use %%{?_smp_mflags} for make option
393
394* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
395- rebuild for VineSeed
396
397* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
398- new upstream release
399- add patch0
400
401* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
402- new upstream release (3.4.0-rc1)
403
404* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
405- new upstream release
406
407* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
408- new upstream release
409
410* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
411- rebuild for VineSeed
412
413* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
414- new upstream release
415
416* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
417- source upgrade
418- update %%files
419- all sub-packages are integrated into main package (exclude devel)
420
421* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
422- rebuild with qt32
423
424* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
425- source upgrade
426- remove lines about vine26
427
428* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
429- source upgrade
430- update %%files
431
432* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
433- source upgrade
434- update %%description
435- add Obsoletes: kdenetwork < 3.2.0
436
437* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
438- rebuild for VineSeedPlus
439
440* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
441- source upgrade
442- build for VinePlus/2.6
443- (VinePlus/2.6) BuildPrereq: autoconf258
444- remove Patch
445
446* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
447- build for VineSeed with new toolchain and qt-3.2.3
448- add configure option --with-xinerama --enable-final
449
450* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
451- rebuild with qt-3.2.1-0.26vl3
452
453* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
454- rebuild with qt-3.2.1-0vl3
455
456* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
457- build with gcc-3.2.3
458
459* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
460- source upgrade
461- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
462
463* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
464- rebuild for Vine2.6
465
466* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
467- source upgrade
468- change spec to build with gcc295
469- change make option for SMP and add script
470- add BuildPrereq: libmal-devel
471- add Requires: libmal for pilot
472
473* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
474- source upgrade
475- remove Patch800 (included in this source)
476- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
477
478* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
479- source upgrade
480- change spec to build both VineSeed and Vine2.5/2.6
481- revised description and files section
482- remove source900
483- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
484- add patch800 (Kdeveloper:02753)
485
486* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
487- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
488
489* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
490- source upgrade
491
492* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
493- rebuild with qt-3.0.5-0vl1
494- BuildPrereq: autoconf253 objprelink2
495
496* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
497- source upgrade
498
499* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
500- source upgrade
501- add BuildPrereq: autoconf252 automake15
502
503* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
504- merged with rawhide 3.0.1-1
505- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
506- add Requires: for each package
507- There is Vine's previous changes, hacked for Vine
508 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
509  - build for VineSeed
510  - delete Epoch
511  - objprelink (i386 only)
512
513* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
514- 3.0.1
515- fixed bug #67303
516
517* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
518- automated rebuild
519
520* Thu May 23 2002 Tim Powers <timp@redhat.com>
521- automated rebuild
522
523* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
524- Rename libraries
525
526* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
527- Fix #61901
528
529* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
530- final
531
532* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
533- Update
534- Fix build on ia64
535
536* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
537- Update, fixes korganizer (#50006)
538
539* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
540- Update to get rid of abbrowser (moved to kdebase)
541
542* Thu Feb 22 2001 Than Ngo <than@redhat.com>
543- add missing ldconfig in %post anf %postun again
544- clean up specfile
545
546* Wed Feb 21 2001 Than Ngo <than@redhat.com>
547- 2.1-respin
548- fix dangling symlink
549- remove excludearch ia64, some hacks to build on ia64
550
551* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
552- 2.1
553
554* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
555- Update
556
557* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
558- Update
559
560* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
561- Update to CVS
562- Enable building kpilot
563- Obsolete kpilot
564- Don't exclude ia64, use -O0 on ia64
565- Disable building kpilot on ia64 (compiler breakage)
566
567* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
568- 2.0 final
569
570* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
571- 2.0
572
573* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
574- new CVS
575- fix installation of fonts
576
577* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
578- new CVS snapshot
579- fix up spec file
580
581* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
582- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
583  there's no need to keep them separate to avoid the dependency.
584
585* Mon Aug 21 2000 Than Ngo <than@redhat.com>
586- fix gnome-session so that KDE2 can be started from gdm
587- pam/kde2 instead pam/kde to avoid problem with KDE1
588- don't requires qt-GL, It's now in qt
589
590* Sun Aug 20 2000 Than Ngo <than@redhat.com>
591- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
592  at the same time
593- add missing ldconfig in %post anf %postun
594- fix for reading config files in /etc/X11/xdm, add Xsession to requires
595
596* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
597- Fix keytable in konsole (Bug #15682)
598
599* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
600- rebuild, now that kdelibs2 works on alpha
601- use the same ugly hack to get kdebase to compile
602- remove ksysguard on alpha (even more compiler problems)
603
604* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
605- new snapshot (fixed libGL detection in CVS)
606
607* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
608- move to /usr/lib/kde2
609- new snapshot
610
611* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
612- fix the --xdmdir arg to be correct (oops)
613
614* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
615- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
616
617* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
618- new snapshot
619- some fixes to spec file
620
621* Tue Jul 18 2000 Than Ngo <than@redhat.de>
622- rebuilt against glibc-2.1.92-14, gcc-2.96-40
623
624* Sun Jul 16 2000 Than Ngo <than@redhat.de>
625- use new snapshot
626- disable Motif
627
628* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
629- use gcc 2.96
630- new snapshot
631
632* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
633- Epoch 3
634- Update to current
635- Use egcs++
636
637* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
638- Update (I put the fixes directly to CVS rather than collecting them
639  in the spec)
640
641* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
642- remove man2html; we get that from man
643- new snapshot
644
645* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
646- new snapshot
647- ExcludeArch ia64 for now
648- remove gnome .desktop file, we get it from gnome-core now.
649
650* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
651- remove dependency on xpm (now in XFree86)
652
653* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
654- new snapshot
655- move it to /usr, where it belongs
656
657* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
658- Build the OpenGL screensavers, and move them to a separate package
659- Improve the spec file (BuildPrereqs etc.)
660
661* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
662- remove patch #3 (obsoleted by kwin)
663
664* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
665- 2.0 CVS snapshot
666- fix compilation
667
668* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
669- clean up files in /tmp from startkde
670- mark doc files as such
671
672* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
673- start autorun if present in startkde
674- check for configured soundcard before running sound services
675
676* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
677- made kdelnks display Name property if they are of type Link
678
679* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
680- moved png handling here (from kdelibs)
681- changed low color icon directory name to locolor
682
683* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
684- added optional session management to logout dialog
685- include GNOME menus
686
687* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
688- added link to /etc/X11/applnk, .directory file
689- included lowcolor icon sub-package
690- enable .desktop file access
691
692* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
693- customized startkde script to set up user environment if not present.
694- mention kthememgr in description.
695
696* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
697- upgraded to 1.1.2 release
698- kvt is back
699- kde icon included
700- linux console fonts included
701
702* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
703- PAM console logout problem solved.
704
705* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
706- now includes screensaver password security fix
707
708* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
709- snapshot, includes kde 1.1.1 + fixes
710- kvt removed for security reasons.  It is a steaming pile of...
711
712* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
713- last snapshot before release
714
715* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
716- today's snapshot makes kfm a bit nicer and some other fixes
717- moved default rc files to kdesupport
718
719* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
720- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
721
722* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
723- built with today's snapshot -- had to rebuild to fix pam problems.
724
725* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
726- new snapshot fixes mimetype video/x-flic problem
727
728* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
729- latest stable snapshot
730
731* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
732- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
733- this previous connection and autoselect kdebase for upgrade).
734
735* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
736- moved gdm patch
737
738* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
739- added gdm session control file
740
741* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
742- added pam-console stuff to kde pam file
743
744* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
745- Injected new description and group.
746
747* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
748- upgraded to KDE 1.1 final.
749
750* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
751- updated macros for RPM 3.0, removed red hat logo.
752
753* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
754- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.