source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 7105

Revision 7105, 22.8 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.3, etc

Line 
1Name: kdepim
2Summary: PIM (Personal Information Manager) for KDE
3Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
4Version: 4.9.3
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Productivity
9URL: http://pim.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.xz
12
13## upstream
14
15# KDE.org patches
16# KDE.gr.jp patches
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: akonadi-devel
20BuildRequires: bison flex
21BuildRequires: libboost-devel
22BuildRequires: cyrus-sasl-devel
23BuildRequires: dblatex
24BuildRequires: desktop-file-utils
25BuildRequires: grantlee-devel
26BuildRequires: gnokii-devel
27BuildRequires: gpgme-devel
28BuildRequires: kdepimlibs-devel >= %{version}
29BuildRequires: libassuan-devel
30BuildRequires: libical-devel
31BuildRequires: libindicate-qt-devel
32BuildRequires: libXpm-devel libXScrnSaver-devel
33# TODO: libmapi from http://www.openchange.org/
34#BuildRequires: libmapi-devel
35BuildRequires: libxslt-devel
36# libmal currently not used, recheck with kdepim-4.3
37BuildRequires: pilot-link-devel >= 0.12.4
38BuildRequires: python-devel
39BuildRequires: shared-desktop-ontologies-devel >= 0.6.51
40BuildRequires: soprano-devel
41BuildRequires: prison-devel
42BuildRequires: qca2-devel
43BuildRequires: zlib-devel
44Requires: %{name}-libs = %{version}-%{release}
45Requires: kdepim-runtime >= %{version}
46
47Obsoletes: kdepim4 < %{version}-%{release}
48Provides: kdepim4 = %{version}-%{release}
49
50Conflicts: kdepim3
51Conflicts: kdeutils3
52
53%description
54A PIM (Personal Information Manager) for KDE.
55
56What it is
57----------
58* kmail: email client
59* knode: newsreader
60* knotes: sticky notes for the desktop
61* kontact: integrated PIM management
62* korganizer: journal, appointments, events, todos
63%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
64
65%package libs
66Summary: %{name} runtime libraries
67Summary(ja): %{name} のラインタイムライブラリ
68Group:   System Environment/Libraries
69Requires: kdelibs4 >= %{version}
70
71%description libs
72%{summary}.
73
74%package devel
75Summary: Development files for kdepim
76Summary(ja): %{name} の開発用ファイル
77Group: Development/Libraries
78Requires: %{name}-libs = %{version}-%{release}
79Requires: kdelibs4-devel
80Obsoletes: kdepim4-devel < %{version}-%{release}
81Provides:  kdepim4-devel = %{version}-%{release}
82Conflicts: kdepim3-devel
83
84%description devel
85Development files for %{name}.
86Install %{name}-devel if you want to write or compile %{name} plugins.
87
88%prep
89%setup -q -n kdepim-%{version}
90
91%build
92mkdir -p %{_target_platform}
93pushd %{_target_platform}
94%cmake \
95    -DCMAKE_BUILD_TYPE=release \
96    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
97    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
98    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
99    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
100    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
101    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
102    -DKDEPIM_BUILD_MOBILE:BOOL=OFF \
103    ..
104popd
105
106make %{?_smp_mflags} -C %{_target_platform}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
111
112# make symlinks relative
113mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
114pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
115for i in *; do
116    if [ -d $i -a -L $i/common ]; then
117        rm -f $i/common
118        ln -nfs ../common $i
119    fi
120done
121popd
122
123%check
124for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
125    desktop-file-validate $f
126done
127
128%post
129touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
130touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
131
132%posttrans
133gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
134gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
135update-desktop-database -q &> /dev/null ||:
136
137%postun
138if [ $1 -eq 0 ] ; then
139  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
140  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
141  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
142  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
143  update-desktop-database -q &> /dev/null ||:
144fi
145
146%post libs -p /sbin/ldconfig
147
148%postun libs -p /sbin/ldconfig
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%files
154%defattr(-,root,root)
155%config %{_sysconfdir}/dbus-1/system.d/org.kde.kalarmrtcwake.conf
156%{_bindir}/*
157%{_libdir}/kde4/*.so
158#{_libdir}/kde4/imports/*
159%{_libdir}/strigi/*.so
160%{_libdir}/akonadi/*
161%{_libexecdir}/kde4/kalarm_helper
162%{_datadir}/akonadi/*
163%{_datadir}/applications/kde4/*.desktop
164%{_datadir}/kde4/apps/akregator
165%{_datadir}/kde4/apps/akregator_sharemicroblog_plugin/*.rc
166%{_datadir}/kde4/apps/akonadiconsole/*
167%{_datadir}/kde4/apps/akonadi_archivemail_agent
168%{_datadir}/kde4/apps/akonadi_mailfilter_agent
169%{_datadir}/kde4/apps/backupmail
170%{_datadir}/kde4/apps/blogilo/*
171%{_datadir}/kde4/apps/desktoptheme/*
172%{_datadir}/kde4/apps/kaddressbook
173#{_datadir}/kde4/apps/kaddressbook-mobile
174%{_datadir}/kde4/apps/kalarm
175%{_datadir}/kde4/apps/kconf_update/*
176%{_datadir}/kde4/apps/kdepimwidgets
177%{_datadir}/kde4/apps/kjots
178%{_datadir}/kde4/apps/kleopatra
179%{_datadir}/kde4/apps/kmail
180#{_datadir}/kde4/apps/kmail-mobile
181%{_datadir}/kde4/apps/kmailcvt
182%{_datadir}/kde4/apps/kmail2
183%{_datadir}/kde4/apps/knode
184%{_datadir}/kde4/apps/knotes
185%{_datadir}/kde4/apps/kontact
186#{_datadir}/kde4/apps/kontact-touch
187%{_datadir}/kde4/apps/kontactsummary
188%{_datadir}/kde4/apps/korgac
189%{_datadir}/kde4/apps/korganizer
190#{_datadir}/kde4/apps/korganizer-mobile
191#{_datadir}/kde4/apps/kpilot
192%{_datadir}/kde4/apps/ktimetracker
193%{_datadir}/kde4/apps/ktnef
194%{_datadir}/kde4/apps/kwatchgnupg
195#{_datadir}/kde4/apps/libkdepim
196%{_datadir}/kde4/apps/libkleopatra
197%{_datadir}/kde4/apps/libmessageviewer
198%{_datadir}/kde4/apps/messagelist
199%{_datadir}/kde4/apps/messageviewer
200#{_datadir}/kde4/apps/mobileui
201#{_datadir}/kde4/apps/notes-mobile
202#{_datadir}/kde4/apps/tasks-mobile
203%{_datadir}/dbus-1/interfaces/*.xml
204%{_datadir}/dbus-1/system-services/*
205%{_datadir}/autostart/*
206#{_datadir}/akonadi/*
207%{_datadir}/config/*
208%{_datadir}/config.kcfg/*
209%{_datadir}/icons/hicolor/*/*/*
210%{_datadir}/icons/locolor/*/*/*
211%{_datadir}/icons/oxygen/*/*/*
212%{_datadir}/kde4/services/*
213%{_datadir}/kde4/servicetypes/*
214%{_datadir}/polkit-1/actions/*.policy
215%{_datadir}/ontology/kde/messagetag.*
216%doc %{_docdir}/HTML/*/*
217%{_mandir}/man1/*
218
219%files libs
220%defattr(-,root,root)
221%{_libdir}/lib*.so.*
222%{_libdir}/kde4/plugins/accessible/*.so
223%{_libdir}/kde4/plugins/designer/*.so
224#{_datadir}/locale/*/LC_MESSAGES/*
225
226%files devel
227%defattr(-,root,root)
228#{_includedir}/kde4/*
229%{_libdir}/lib*.so
230#exclude %{_libdir}/libkpilot_*.so
231
232%changelog
233* Fri Nov 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
234- new upstream release
235
236* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
237- new upstream release
238
239* Wed Sep 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
240- new upstream release
241
242* Sat Aug 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
243- new upstream release
244- add BuildRequires: prison-devel
245- remove old patches
246
247* Sat Aug  6 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
248- new upstream release
249
250* Wed Jun 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
251- new upstream release
252- added BR: grantlee-devel
253
254* Sat May 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.11.1-1
255- new upstream release
256
257* Fri Feb 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.10-1
258- new upstream release
259- added BR: libindicate-qt-devel
260
261* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.6-1
262- new upstream release
263- built with rpm-4.8.1
264
265* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-2
266- rebuilt for VineSeed
267
268* Mon Jul  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
269- new upstream release
270- added Conflicts: kdepim3, kdeutils3
271
272* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
273- new upstream release
274
275* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
276- new upstream release
277
278* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
279- new upstream release
280
281* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
282- new upstream release
283- built with new toolchain
284
285* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
286- new upstream release
287
288* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
289- new upstream release
290- dropped Patch100 (merged into upstream)
291- used %%cmake macro
292
293* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
294- new upstream release
295
296* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
297- applied new versioning policy, spec in UTF-8
298- added Japnaese summary
299
300* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
301- rebuild for VineSeed
302
303* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
304- new upstream release
305
306* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
307- rebuild for VineSeed
308
309* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
310- new upstream release
311- remove all patches
312
313* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
314- new upstream release
315- add Patch0, 1 , 2 and 3
316
317* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
318- added --with-qt-libraries and --enable-libsuffix option
319
320* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
321- rebuild for VineSeed
322
323* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
324- new upstream release
325
326* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
327- rebuild with pilot-link-0.12.0-0vl1
328
329* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
330- rebuild for VineSeed
331
332* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
333- new upstream release
334
335* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
336- rebuild for VineSeed
337
338* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
339- new upstream release
340
341* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
342- rebuild for VineSeed
343
344* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
345- new upstream release
346
347* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
348- rebuild for VineSeed
349
350* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
351- new upstream release
352- delete BuildPrereq: libmal-devel and Requires: libmal
353
354* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
355- rebuild for VineSeed
356
357* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
358- new upstream release
359
360* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
361- new upstream release
362
363* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
364- new upstream release
365- delete all patches
366- add Requires: kdeaccessibility  >= %%{version}
367- add --enable-indexlib to configure option
368
369* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
370- new upstream release
371- remove Patch0
372- add Patch0 - Patch1
373
374* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
375- rebuild for VineSeed
376
377* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
378- new upstream release
379- remove Patch0
380- add BuildPrereq: gpgme-devel >= 0.4.5
381- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
382
383* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
384- rebuild for VineSeed
385- add --disable-rpath to configure option
386
387* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
388- new upstream release (delete old patch and add new security patch)
389- use %%{?_smp_mflags} for make option
390
391* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
392- rebuild for VineSeed
393
394* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
395- new upstream release
396- add patch0
397
398* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
399- new upstream release (3.4.0-rc1)
400
401* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
402- new upstream release
403
404* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
405- new upstream release
406
407* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
408- rebuild for VineSeed
409
410* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
411- new upstream release
412
413* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
414- source upgrade
415- update %%files
416- all sub-packages are integrated into main package (exclude devel)
417
418* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
419- rebuild with qt32
420
421* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
422- source upgrade
423- remove lines about vine26
424
425* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
426- source upgrade
427- update %%files
428
429* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
430- source upgrade
431- update %%description
432- add Obsoletes: kdenetwork < 3.2.0
433
434* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
435- rebuild for VineSeedPlus
436
437* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
438- source upgrade
439- build for VinePlus/2.6
440- (VinePlus/2.6) BuildPrereq: autoconf258
441- remove Patch
442
443* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
444- build for VineSeed with new toolchain and qt-3.2.3
445- add configure option --with-xinerama --enable-final
446
447* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
448- rebuild with qt-3.2.1-0.26vl3
449
450* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
451- rebuild with qt-3.2.1-0vl3
452
453* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
454- build with gcc-3.2.3
455
456* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
457- source upgrade
458- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
459
460* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
461- rebuild for Vine2.6
462
463* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
464- source upgrade
465- change spec to build with gcc295
466- change make option for SMP and add script
467- add BuildPrereq: libmal-devel
468- add Requires: libmal for pilot
469
470* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
471- source upgrade
472- remove Patch800 (included in this source)
473- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
474
475* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
476- source upgrade
477- change spec to build both VineSeed and Vine2.5/2.6
478- revised description and files section
479- remove source900
480- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
481- add patch800 (Kdeveloper:02753)
482
483* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
484- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
485
486* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
487- source upgrade
488
489* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
490- rebuild with qt-3.0.5-0vl1
491- BuildPrereq: autoconf253 objprelink2
492
493* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
494- source upgrade
495
496* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
497- source upgrade
498- add BuildPrereq: autoconf252 automake15
499
500* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
501- merged with rawhide 3.0.1-1
502- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
503- add Requires: for each package
504- There is Vine's previous changes, hacked for Vine
505 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
506  - build for VineSeed
507  - delete Epoch
508  - objprelink (i386 only)
509
510* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
511- 3.0.1
512- fixed bug #67303
513
514* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
515- automated rebuild
516
517* Thu May 23 2002 Tim Powers <timp@redhat.com>
518- automated rebuild
519
520* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
521- Rename libraries
522
523* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
524- Fix #61901
525
526* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
527- final
528
529* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
530- Update
531- Fix build on ia64
532
533* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
534- Update, fixes korganizer (#50006)
535
536* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
537- Update to get rid of abbrowser (moved to kdebase)
538
539* Thu Feb 22 2001 Than Ngo <than@redhat.com>
540- add missing ldconfig in %post anf %postun again
541- clean up specfile
542
543* Wed Feb 21 2001 Than Ngo <than@redhat.com>
544- 2.1-respin
545- fix dangling symlink
546- remove excludearch ia64, some hacks to build on ia64
547
548* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
549- 2.1
550
551* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
552- Update
553
554* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
555- Update
556
557* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
558- Update to CVS
559- Enable building kpilot
560- Obsolete kpilot
561- Don't exclude ia64, use -O0 on ia64
562- Disable building kpilot on ia64 (compiler breakage)
563
564* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
565- 2.0 final
566
567* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
568- 2.0
569
570* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
571- new CVS
572- fix installation of fonts
573
574* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
575- new CVS snapshot
576- fix up spec file
577
578* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
579- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
580  there's no need to keep them separate to avoid the dependency.
581
582* Mon Aug 21 2000 Than Ngo <than@redhat.com>
583- fix gnome-session so that KDE2 can be started from gdm
584- pam/kde2 instead pam/kde to avoid problem with KDE1
585- don't requires qt-GL, It's now in qt
586
587* Sun Aug 20 2000 Than Ngo <than@redhat.com>
588- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
589  at the same time
590- add missing ldconfig in %post anf %postun
591- fix for reading config files in /etc/X11/xdm, add Xsession to requires
592
593* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
594- Fix keytable in konsole (Bug #15682)
595
596* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
597- rebuild, now that kdelibs2 works on alpha
598- use the same ugly hack to get kdebase to compile
599- remove ksysguard on alpha (even more compiler problems)
600
601* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
602- new snapshot (fixed libGL detection in CVS)
603
604* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
605- move to /usr/lib/kde2
606- new snapshot
607
608* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
609- fix the --xdmdir arg to be correct (oops)
610
611* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
612- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
613
614* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
615- new snapshot
616- some fixes to spec file
617
618* Tue Jul 18 2000 Than Ngo <than@redhat.de>
619- rebuilt against glibc-2.1.92-14, gcc-2.96-40
620
621* Sun Jul 16 2000 Than Ngo <than@redhat.de>
622- use new snapshot
623- disable Motif
624
625* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
626- use gcc 2.96
627- new snapshot
628
629* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
630- Epoch 3
631- Update to current
632- Use egcs++
633
634* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
635- Update (I put the fixes directly to CVS rather than collecting them
636  in the spec)
637
638* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
639- remove man2html; we get that from man
640- new snapshot
641
642* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
643- new snapshot
644- ExcludeArch ia64 for now
645- remove gnome .desktop file, we get it from gnome-core now.
646
647* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
648- remove dependency on xpm (now in XFree86)
649
650* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
651- new snapshot
652- move it to /usr, where it belongs
653
654* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
655- Build the OpenGL screensavers, and move them to a separate package
656- Improve the spec file (BuildPrereqs etc.)
657
658* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
659- remove patch #3 (obsoleted by kwin)
660
661* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
662- 2.0 CVS snapshot
663- fix compilation
664
665* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
666- clean up files in /tmp from startkde
667- mark doc files as such
668
669* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
670- start autorun if present in startkde
671- check for configured soundcard before running sound services
672
673* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
674- made kdelnks display Name property if they are of type Link
675
676* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
677- moved png handling here (from kdelibs)
678- changed low color icon directory name to locolor
679
680* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
681- added optional session management to logout dialog
682- include GNOME menus
683
684* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
685- added link to /etc/X11/applnk, .directory file
686- included lowcolor icon sub-package
687- enable .desktop file access
688
689* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
690- customized startkde script to set up user environment if not present.
691- mention kthememgr in description.
692
693* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
694- upgraded to 1.1.2 release
695- kvt is back
696- kde icon included
697- linux console fonts included
698
699* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
700- PAM console logout problem solved.
701
702* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
703- now includes screensaver password security fix
704
705* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
706- snapshot, includes kde 1.1.1 + fixes
707- kvt removed for security reasons.  It is a steaming pile of...
708
709* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
710- last snapshot before release
711
712* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
713- today's snapshot makes kfm a bit nicer and some other fixes
714- moved default rc files to kdesupport
715
716* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
717- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
718
719* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
720- built with today's snapshot -- had to rebuild to fix pam problems.
721
722* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
723- new snapshot fixes mimetype video/x-flic problem
724
725* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
726- latest stable snapshot
727
728* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
729- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
730- this previous connection and autoselect kdebase for upgrade).
731
732* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
733- moved gdm patch
734
735* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
736- added gdm session control file
737
738* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
739- added pam-console stuff to kde pam file
740
741* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
742- Injected new description and group.
743
744* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
745- upgraded to KDE 1.1 final.
746
747* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
748- updated macros for RPM 3.0, removed red hat logo.
749
750* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
751- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.