source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 6797

Revision 6797, 22.6 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.1

Line 
1Name: kdepim
2Summary: PIM (Personal Information Manager) for KDE
3Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
4Version: 4.9.1
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Productivity
9URL: http://pim.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.xz
12
13## upstream
14
15# KDE.org patches
16# KDE.gr.jp patches
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: akonadi-devel
20BuildRequires: bison flex
21BuildRequires: libboost-devel
22BuildRequires: cyrus-sasl-devel
23BuildRequires: dblatex
24BuildRequires: desktop-file-utils
25BuildRequires: grantlee-devel
26BuildRequires: gnokii-devel
27BuildRequires: gpgme-devel
28BuildRequires: kdepimlibs-devel >= %{version}
29BuildRequires: libassuan-devel
30BuildRequires: libical-devel
31BuildRequires: libindicate-qt-devel
32BuildRequires: libXpm-devel libXScrnSaver-devel
33# TODO: libmapi from http://www.openchange.org/
34#BuildRequires: libmapi-devel
35BuildRequires: libxslt-devel
36# libmal currently not used, recheck with kdepim-4.3
37BuildRequires: pilot-link-devel >= 0.12.4
38BuildRequires: python-devel
39BuildRequires: shared-desktop-ontologies-devel >= 0.6.51
40BuildRequires: soprano-devel
41BuildRequires: prison-devel
42BuildRequires: qca2-devel
43BuildRequires: zlib-devel
44Requires: %{name}-libs = %{version}-%{release}
45Requires: kdepim-runtime >= %{version}
46
47Obsoletes: kdepim4 < %{version}-%{release}
48Provides: kdepim4 = %{version}-%{release}
49
50Conflicts: kdepim3
51Conflicts: kdeutils3
52
53%description
54A PIM (Personal Information Manager) for KDE.
55
56What it is
57----------
58* kmail: email client
59* knode: newsreader
60* knotes: sticky notes for the desktop
61* kontact: integrated PIM management
62* korganizer: journal, appointments, events, todos
63%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
64
65%package libs
66Summary: %{name} runtime libraries
67Summary(ja): %{name} のラインタイムライブラリ
68Group:   System Environment/Libraries
69Requires: kdelibs4 >= %{version}
70
71%description libs
72%{summary}.
73
74%package devel
75Summary: Development files for kdepim
76Summary(ja): %{name} の開発用ファイル
77Group: Development/Libraries
78Requires: %{name}-libs = %{version}-%{release}
79Requires: kdelibs4-devel
80Obsoletes: kdepim4-devel < %{version}-%{release}
81Provides:  kdepim4-devel = %{version}-%{release}
82Conflicts: kdepim3-devel
83
84%description devel
85Development files for %{name}.
86Install %{name}-devel if you want to write or compile %{name} plugins.
87
88%prep
89%setup -q -n kdepim-%{version}
90
91%build
92mkdir -p %{_target_platform}
93pushd %{_target_platform}
94%cmake \
95    -DCMAKE_BUILD_TYPE=release \
96    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
97    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
98    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
99    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
100    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
101    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
102    -DKDEPIM_BUILD_MOBILE:BOOL=OFF \
103    ..
104popd
105
106make %{?_smp_mflags} -C %{_target_platform}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
111
112# make symlinks relative
113mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
114pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
115for i in *; do
116    if [ -d $i -a -L $i/common ]; then
117        rm -f $i/common
118        ln -nfs ../common $i
119    fi
120done
121popd
122
123%check
124for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
125    desktop-file-validate $f
126done
127
128%post
129touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
130touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
131
132%posttrans
133gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
134gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
135update-desktop-database -q &> /dev/null ||:
136
137%postun
138if [ $1 -eq 0 ] ; then
139  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
140  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
141  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
142  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
143  update-desktop-database -q &> /dev/null ||:
144fi
145
146%post libs -p /sbin/ldconfig
147
148%postun libs -p /sbin/ldconfig
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%files
154%defattr(-,root,root)
155%config %{_sysconfdir}/dbus-1/system.d/org.kde.kalarmrtcwake.conf
156%{_bindir}/*
157%{_libdir}/kde4/*.so
158#{_libdir}/kde4/imports/*
159%{_libdir}/strigi/*.so
160%{_libdir}/akonadi/*
161%{_libexecdir}/kde4/kalarm_helper
162%{_datadir}/akonadi/*
163%{_datadir}/applications/kde4/*.desktop
164%{_datadir}/kde4/apps/akregator
165%{_datadir}/kde4/apps/akregator_sharemicroblog_plugin/*.rc
166%{_datadir}/kde4/apps/akonadiconsole/*
167%{_datadir}/kde4/apps/akonadi_archivemail_agent
168%{_datadir}/kde4/apps/akonadi_mailfilter_agent
169%{_datadir}/kde4/apps/backupmail
170%{_datadir}/kde4/apps/blogilo/*
171%{_datadir}/kde4/apps/desktoptheme/*
172%{_datadir}/kde4/apps/kaddressbook
173#{_datadir}/kde4/apps/kaddressbook-mobile
174%{_datadir}/kde4/apps/kalarm
175%{_datadir}/kde4/apps/kconf_update/*
176%{_datadir}/kde4/apps/kdepimwidgets
177%{_datadir}/kde4/apps/kjots
178%{_datadir}/kde4/apps/kleopatra
179%{_datadir}/kde4/apps/kmail
180#{_datadir}/kde4/apps/kmail-mobile
181%{_datadir}/kde4/apps/kmailcvt
182%{_datadir}/kde4/apps/kmail2
183%{_datadir}/kde4/apps/knode
184%{_datadir}/kde4/apps/knotes
185%{_datadir}/kde4/apps/kontact
186#{_datadir}/kde4/apps/kontact-touch
187%{_datadir}/kde4/apps/kontactsummary
188%{_datadir}/kde4/apps/korgac
189%{_datadir}/kde4/apps/korganizer
190#{_datadir}/kde4/apps/korganizer-mobile
191#{_datadir}/kde4/apps/kpilot
192%{_datadir}/kde4/apps/ktimetracker
193%{_datadir}/kde4/apps/ktnef
194%{_datadir}/kde4/apps/kwatchgnupg
195#{_datadir}/kde4/apps/libkdepim
196%{_datadir}/kde4/apps/libkleopatra
197%{_datadir}/kde4/apps/libmessageviewer
198%{_datadir}/kde4/apps/messagelist
199%{_datadir}/kde4/apps/messageviewer
200#{_datadir}/kde4/apps/mobileui
201#{_datadir}/kde4/apps/notes-mobile
202#{_datadir}/kde4/apps/tasks-mobile
203%{_datadir}/dbus-1/interfaces/*.xml
204%{_datadir}/dbus-1/system-services/*
205%{_datadir}/autostart/*
206#{_datadir}/akonadi/*
207%{_datadir}/config/*
208%{_datadir}/config.kcfg/*
209%{_datadir}/icons/hicolor/*/*/*
210%{_datadir}/icons/locolor/*/*/*
211%{_datadir}/icons/oxygen/*/*/*
212%{_datadir}/kde4/services/*
213%{_datadir}/kde4/servicetypes/*
214%{_datadir}/polkit-1/actions/*.policy
215%{_datadir}/ontology/kde/messagetag.*
216%doc %{_docdir}/HTML/*/*
217%{_mandir}/man1/*
218
219%files libs
220%defattr(-,root,root)
221%{_libdir}/lib*.so.*
222%{_libdir}/kde4/plugins/accessible/*.so
223%{_libdir}/kde4/plugins/designer/*.so
224#{_datadir}/locale/*/LC_MESSAGES/*
225
226%files devel
227%defattr(-,root,root)
228#{_includedir}/kde4/*
229%{_libdir}/lib*.so
230#exclude %{_libdir}/libkpilot_*.so
231
232%changelog
233* Wed Sep 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
234- new upstream release
235
236* Sat Aug 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
237- new upstream release
238- add BuildRequires: prison-devel
239- remove old patches
240
241* Sat Aug  6 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
242- new upstream release
243
244* Wed Jun 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
245- new upstream release
246- added BR: grantlee-devel
247
248* Sat May 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.11.1-1
249- new upstream release
250
251* Fri Feb 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.10-1
252- new upstream release
253- added BR: libindicate-qt-devel
254
255* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.6-1
256- new upstream release
257- built with rpm-4.8.1
258
259* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-2
260- rebuilt for VineSeed
261
262* Mon Jul  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
263- new upstream release
264- added Conflicts: kdepim3, kdeutils3
265
266* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
267- new upstream release
268
269* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
270- new upstream release
271
272* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
273- new upstream release
274
275* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
276- new upstream release
277- built with new toolchain
278
279* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
280- new upstream release
281
282* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
283- new upstream release
284- dropped Patch100 (merged into upstream)
285- used %%cmake macro
286
287* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
288- new upstream release
289
290* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
291- applied new versioning policy, spec in UTF-8
292- added Japnaese summary
293
294* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
295- rebuild for VineSeed
296
297* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
298- new upstream release
299
300* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
301- rebuild for VineSeed
302
303* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
304- new upstream release
305- remove all patches
306
307* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
308- new upstream release
309- add Patch0, 1 , 2 and 3
310
311* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
312- added --with-qt-libraries and --enable-libsuffix option
313
314* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
315- rebuild for VineSeed
316
317* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
318- new upstream release
319
320* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
321- rebuild with pilot-link-0.12.0-0vl1
322
323* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
324- rebuild for VineSeed
325
326* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
327- new upstream release
328
329* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
330- rebuild for VineSeed
331
332* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
333- new upstream release
334
335* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
336- rebuild for VineSeed
337
338* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
339- new upstream release
340
341* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
342- rebuild for VineSeed
343
344* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
345- new upstream release
346- delete BuildPrereq: libmal-devel and Requires: libmal
347
348* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
349- rebuild for VineSeed
350
351* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
352- new upstream release
353
354* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
355- new upstream release
356
357* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
358- new upstream release
359- delete all patches
360- add Requires: kdeaccessibility  >= %%{version}
361- add --enable-indexlib to configure option
362
363* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
364- new upstream release
365- remove Patch0
366- add Patch0 - Patch1
367
368* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
369- rebuild for VineSeed
370
371* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
372- new upstream release
373- remove Patch0
374- add BuildPrereq: gpgme-devel >= 0.4.5
375- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
376
377* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
378- rebuild for VineSeed
379- add --disable-rpath to configure option
380
381* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
382- new upstream release (delete old patch and add new security patch)
383- use %%{?_smp_mflags} for make option
384
385* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
386- rebuild for VineSeed
387
388* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
389- new upstream release
390- add patch0
391
392* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
393- new upstream release (3.4.0-rc1)
394
395* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
396- new upstream release
397
398* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
399- new upstream release
400
401* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
402- rebuild for VineSeed
403
404* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
405- new upstream release
406
407* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
408- source upgrade
409- update %%files
410- all sub-packages are integrated into main package (exclude devel)
411
412* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
413- rebuild with qt32
414
415* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
416- source upgrade
417- remove lines about vine26
418
419* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
420- source upgrade
421- update %%files
422
423* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
424- source upgrade
425- update %%description
426- add Obsoletes: kdenetwork < 3.2.0
427
428* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
429- rebuild for VineSeedPlus
430
431* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
432- source upgrade
433- build for VinePlus/2.6
434- (VinePlus/2.6) BuildPrereq: autoconf258
435- remove Patch
436
437* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
438- build for VineSeed with new toolchain and qt-3.2.3
439- add configure option --with-xinerama --enable-final
440
441* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
442- rebuild with qt-3.2.1-0.26vl3
443
444* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
445- rebuild with qt-3.2.1-0vl3
446
447* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
448- build with gcc-3.2.3
449
450* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
451- source upgrade
452- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
453
454* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
455- rebuild for Vine2.6
456
457* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
458- source upgrade
459- change spec to build with gcc295
460- change make option for SMP and add script
461- add BuildPrereq: libmal-devel
462- add Requires: libmal for pilot
463
464* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
465- source upgrade
466- remove Patch800 (included in this source)
467- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
468
469* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
470- source upgrade
471- change spec to build both VineSeed and Vine2.5/2.6
472- revised description and files section
473- remove source900
474- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
475- add patch800 (Kdeveloper:02753)
476
477* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
478- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
479
480* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
481- source upgrade
482
483* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
484- rebuild with qt-3.0.5-0vl1
485- BuildPrereq: autoconf253 objprelink2
486
487* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
488- source upgrade
489
490* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
491- source upgrade
492- add BuildPrereq: autoconf252 automake15
493
494* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
495- merged with rawhide 3.0.1-1
496- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
497- add Requires: for each package
498- There is Vine's previous changes, hacked for Vine
499 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
500  - build for VineSeed
501  - delete Epoch
502  - objprelink (i386 only)
503
504* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
505- 3.0.1
506- fixed bug #67303
507
508* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
509- automated rebuild
510
511* Thu May 23 2002 Tim Powers <timp@redhat.com>
512- automated rebuild
513
514* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
515- Rename libraries
516
517* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
518- Fix #61901
519
520* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
521- final
522
523* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
524- Update
525- Fix build on ia64
526
527* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
528- Update, fixes korganizer (#50006)
529
530* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
531- Update to get rid of abbrowser (moved to kdebase)
532
533* Thu Feb 22 2001 Than Ngo <than@redhat.com>
534- add missing ldconfig in %post anf %postun again
535- clean up specfile
536
537* Wed Feb 21 2001 Than Ngo <than@redhat.com>
538- 2.1-respin
539- fix dangling symlink
540- remove excludearch ia64, some hacks to build on ia64
541
542* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
543- 2.1
544
545* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
546- Update
547
548* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
549- Update
550
551* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
552- Update to CVS
553- Enable building kpilot
554- Obsolete kpilot
555- Don't exclude ia64, use -O0 on ia64
556- Disable building kpilot on ia64 (compiler breakage)
557
558* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
559- 2.0 final
560
561* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
562- 2.0
563
564* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
565- new CVS
566- fix installation of fonts
567
568* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
569- new CVS snapshot
570- fix up spec file
571
572* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
573- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
574  there's no need to keep them separate to avoid the dependency.
575
576* Mon Aug 21 2000 Than Ngo <than@redhat.com>
577- fix gnome-session so that KDE2 can be started from gdm
578- pam/kde2 instead pam/kde to avoid problem with KDE1
579- don't requires qt-GL, It's now in qt
580
581* Sun Aug 20 2000 Than Ngo <than@redhat.com>
582- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
583  at the same time
584- add missing ldconfig in %post anf %postun
585- fix for reading config files in /etc/X11/xdm, add Xsession to requires
586
587* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
588- Fix keytable in konsole (Bug #15682)
589
590* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
591- rebuild, now that kdelibs2 works on alpha
592- use the same ugly hack to get kdebase to compile
593- remove ksysguard on alpha (even more compiler problems)
594
595* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
596- new snapshot (fixed libGL detection in CVS)
597
598* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
599- move to /usr/lib/kde2
600- new snapshot
601
602* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
603- fix the --xdmdir arg to be correct (oops)
604
605* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
606- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
607
608* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
609- new snapshot
610- some fixes to spec file
611
612* Tue Jul 18 2000 Than Ngo <than@redhat.de>
613- rebuilt against glibc-2.1.92-14, gcc-2.96-40
614
615* Sun Jul 16 2000 Than Ngo <than@redhat.de>
616- use new snapshot
617- disable Motif
618
619* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
620- use gcc 2.96
621- new snapshot
622
623* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
624- Epoch 3
625- Update to current
626- Use egcs++
627
628* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
629- Update (I put the fixes directly to CVS rather than collecting them
630  in the spec)
631
632* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
633- remove man2html; we get that from man
634- new snapshot
635
636* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
637- new snapshot
638- ExcludeArch ia64 for now
639- remove gnome .desktop file, we get it from gnome-core now.
640
641* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
642- remove dependency on xpm (now in XFree86)
643
644* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
645- new snapshot
646- move it to /usr, where it belongs
647
648* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
649- Build the OpenGL screensavers, and move them to a separate package
650- Improve the spec file (BuildPrereqs etc.)
651
652* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
653- remove patch #3 (obsoleted by kwin)
654
655* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
656- 2.0 CVS snapshot
657- fix compilation
658
659* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
660- clean up files in /tmp from startkde
661- mark doc files as such
662
663* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
664- start autorun if present in startkde
665- check for configured soundcard before running sound services
666
667* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
668- made kdelnks display Name property if they are of type Link
669
670* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
671- moved png handling here (from kdelibs)
672- changed low color icon directory name to locolor
673
674* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
675- added optional session management to logout dialog
676- include GNOME menus
677
678* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
679- added link to /etc/X11/applnk, .directory file
680- included lowcolor icon sub-package
681- enable .desktop file access
682
683* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
684- customized startkde script to set up user environment if not present.
685- mention kthememgr in description.
686
687* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
688- upgraded to 1.1.2 release
689- kvt is back
690- kde icon included
691- linux console fonts included
692
693* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
694- PAM console logout problem solved.
695
696* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
697- now includes screensaver password security fix
698
699* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
700- snapshot, includes kde 1.1.1 + fixes
701- kvt removed for security reasons.  It is a steaming pile of...
702
703* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
704- last snapshot before release
705
706* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
707- today's snapshot makes kfm a bit nicer and some other fixes
708- moved default rc files to kdesupport
709
710* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
711- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
712
713* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
714- built with today's snapshot -- had to rebuild to fix pam problems.
715
716* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
717- new snapshot fixes mimetype video/x-flic problem
718
719* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
720- latest stable snapshot
721
722* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
723- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
724- this previous connection and autoselect kdebase for upgrade).
725
726* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
727- moved gdm patch
728
729* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
730- added gdm session control file
731
732* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
733- added pam-console stuff to kde pam file
734
735* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
736- Injected new description and group.
737
738* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
739- upgraded to KDE 1.1 final.
740
741* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
742- updated macros for RPM 3.0, removed red hat logo.
743
744* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
745- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.