source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 4662

Revision 4662, 22.4 KB checked in by inagaki, 13 years ago (diff)

update: KDE SC 4.7.0
added : kate, konsole

Line 
1Name: kdepim
2Summary: PIM (Personal Information Manager) for KDE
3Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
4Version: 4.7.0
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Productivity
9URL: http://pim.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
12
13Patch0:  kdepim-4.1.80-libqgpgme-link-fix.patch
14# http://bugzilla.redhat.com/show_bug.cgi?id=496988
15Patch1:  kdepim-4.3.1-kmail-saveAttachments.patch
16## upstream
17
18# KDE.org patches
19# KDE.gr.jp patches
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: akonadi-devel
23BuildRequires: bison flex
24BuildRequires: libboost-devel
25BuildRequires: cyrus-sasl-devel
26BuildRequires: dblatex
27BuildRequires: desktop-file-utils
28BuildRequires: grantlee-devel
29BuildRequires: gnokii-devel
30BuildRequires: gpgme-devel
31BuildRequires: kdepimlibs-devel >= %{version}
32BuildRequires: libassuan-devel
33BuildRequires: libical-devel
34BuildRequires: libindicate-qt-devel
35BuildRequires: libXpm-devel libXScrnSaver-devel
36# TODO: libmapi from http://www.openchange.org/
37#BuildRequires: libmapi-devel
38BuildRequires: libxslt-devel
39# libmal currently not used, recheck with kdepim-4.3
40BuildRequires: pilot-link-devel >= 0.12.4
41BuildRequires: python-devel
42BuildRequires: shared-desktop-ontologies-devel >= 0.6.51
43BuildRequires: soprano-devel
44BuildRequires: qca2-devel
45BuildRequires: zlib-devel
46Requires: %{name}-libs = %{version}-%{release}
47Requires: kdepim-runtime >= %{version}
48
49Obsoletes: kdepim4 < %{version}-%{release}
50Provides: kdepim4 = %{version}-%{release}
51
52Conflicts: kdepim3
53Conflicts: kdeutils3
54
55%description
56A PIM (Personal Information Manager) for KDE.
57
58What it is
59----------
60* kmail: email client
61* knode: newsreader
62* knotes: sticky notes for the desktop
63* kontact: integrated PIM management
64* korganizer: journal, appointments, events, todos
65%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
66
67%package libs
68Summary: %{name} runtime libraries
69Summary(ja): %{name} のラインタイムライブラリ
70Group:   System Environment/Libraries
71Requires: kdelibs4 >= %{version}
72
73%description libs
74%{summary}.
75
76%package devel
77Summary: Development files for kdepim
78Summary(ja): %{name} の開発用ファイル
79Group: Development/Libraries
80Requires: %{name}-libs = %{version}-%{release}
81Requires: kdelibs4-devel
82Obsoletes: kdepim4-devel < %{version}-%{release}
83Provides:  kdepim4-devel = %{version}-%{release}
84Conflicts: kdepim3-devel
85
86%description devel
87Development files for %{name}.
88Install %{name}-devel if you want to write or compile %{name} plugins.
89
90%prep
91%setup -q -n kdepim-%{version}
92%patch0 -p1 -b .libqgpgme-link-fix
93#patch1 -p0 -b .kmail-saveAttachments
94
95%build
96mkdir -p %{_target_platform}
97pushd %{_target_platform}
98unset QTDIR || : ; . /etc/profile.d/qt4.sh
99%cmake \
100    -DCMAKE_BUILD_TYPE=release \
101    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
102    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
103    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
104    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
105    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
106    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
107    ..
108popd
109
110make %{?_smp_mflags} -C %{_target_platform}
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
115
116# make symlinks relative
117mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
118pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
119for i in *; do
120    if [ -d $i -a -L $i/common ]; then
121        rm -f $i/common
122        ln -nfs ../common $i
123    fi
124done
125popd
126
127%check
128for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
129    desktop-file-validate $f
130done
131
132%post
133touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
134touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
135
136%posttrans
137gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
138gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
139update-desktop-database -q &> /dev/null ||:
140
141%postun
142if [ $1 -eq 0 ] ; then
143  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
144  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
145  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
146  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
147  update-desktop-database -q &> /dev/null ||:
148fi
149
150%post libs -p /sbin/ldconfig
151
152%postun libs -p /sbin/ldconfig
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%files
158%defattr(-,root,root)
159%config %{_sysconfdir}/dbus-1/system.d/org.kde.kalarmrtcwake.conf
160%{_bindir}/*
161%{_libdir}/kde4/*.so
162%{_libdir}/kde4/imports/*
163%{_libdir}/strigi/*.so
164%{_libdir}/akonadi/*
165%{_libexecdir}/kde4/kalarm_helper
166%{_datadir}/akonadi/*
167%{_datadir}/applications/kde4/*.desktop
168%{_datadir}/kde4/apps/akregator
169%{_datadir}/kde4/apps/akregator_sharemicroblog_plugin/*.rc
170%{_datadir}/kde4/apps/akonadiconsole/*
171%{_datadir}/kde4/apps/blogilo/*
172%{_datadir}/kde4/apps/desktoptheme/*
173%{_datadir}/kde4/apps/kaddressbook
174%{_datadir}/kde4/apps/kaddressbook-mobile
175%{_datadir}/kde4/apps/kalarm
176%{_datadir}/kde4/apps/kconf_update/*
177%{_datadir}/kde4/apps/kdepimwidgets
178%{_datadir}/kde4/apps/kjots
179%{_datadir}/kde4/apps/kleopatra
180%{_datadir}/kde4/apps/kmail
181%{_datadir}/kde4/apps/kmail-mobile
182%{_datadir}/kde4/apps/kmailcvt
183%{_datadir}/kde4/apps/kmail2
184%{_datadir}/kde4/apps/knode
185%{_datadir}/kde4/apps/knotes
186#{_datadir}/kde4/apps/konsolekalendar
187%{_datadir}/kde4/apps/kontact
188%{_datadir}/kde4/apps/kontact-touch
189%{_datadir}/kde4/apps/kontactsummary
190%{_datadir}/kde4/apps/korgac
191%{_datadir}/kde4/apps/korganizer
192%{_datadir}/kde4/apps/korganizer-mobile
193#{_datadir}/kde4/apps/kpilot
194%{_datadir}/kde4/apps/ktimetracker
195%{_datadir}/kde4/apps/kwatchgnupg
196#{_datadir}/kde4/apps/libkdepim
197%{_datadir}/kde4/apps/libkleopatra
198%{_datadir}/kde4/apps/libmessageviewer
199%{_datadir}/kde4/apps/messagelist
200%{_datadir}/kde4/apps/messageviewer
201%{_datadir}/kde4/apps/mobileui
202%{_datadir}/kde4/apps/notes-mobile
203%{_datadir}/kde4/apps/tasks-mobile
204%{_datadir}/dbus-1/interfaces/*.xml
205%{_datadir}/dbus-1/system-services/*
206%{_datadir}/autostart/*
207#{_datadir}/akonadi/*
208%{_datadir}/config/*
209%{_datadir}/config.kcfg/*
210%{_datadir}/icons/hicolor/*/*/*
211%{_datadir}/icons/oxygen/*/*/*
212%{_datadir}/kde4/services/*
213%{_datadir}/kde4/servicetypes/*
214%{_datadir}/polkit-1/actions/*.policy
215%doc %{_docdir}/HTML/*/*
216%{_mandir}/man1/*
217
218%files libs
219%defattr(-,root,root)
220%{_libdir}/lib*.so.*
221%{_libdir}/kde4/plugins/designer/*.so
222#{_datadir}/locale/*/LC_MESSAGES/*
223
224%files devel
225%defattr(-,root,root)
226#{_includedir}/kde4/*
227%{_libdir}/lib*.so
228#exclude %{_libdir}/libkpilot_*.so
229
230%changelog
231* Sat Aug  6 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
232- new upstream release
233
234* Wed Jun 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
235- new upstream release
236- added BR: grantlee-devel
237
238* Sat May 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.11.1-1
239- new upstream release
240
241* Fri Feb 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.10-1
242- new upstream release
243- added BR: libindicate-qt-devel
244
245* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.6-1
246- new upstream release
247- built with rpm-4.8.1
248
249* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-2
250- rebuilt for VineSeed
251
252* Mon Jul  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
253- new upstream release
254- added Conflicts: kdepim3, kdeutils3
255
256* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
257- new upstream release
258
259* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
260- new upstream release
261
262* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
263- new upstream release
264
265* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
266- new upstream release
267- built with new toolchain
268
269* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
270- new upstream release
271
272* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
273- new upstream release
274- dropped Patch100 (merged into upstream)
275- used %%cmake macro
276
277* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
278- new upstream release
279
280* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
281- applied new versioning policy, spec in UTF-8
282- added Japnaese summary
283
284* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
285- rebuild for VineSeed
286
287* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
288- new upstream release
289
290* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
291- rebuild for VineSeed
292
293* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
294- new upstream release
295- remove all patches
296
297* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
298- new upstream release
299- add Patch0, 1 , 2 and 3
300
301* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
302- added --with-qt-libraries and --enable-libsuffix option
303
304* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
305- rebuild for VineSeed
306
307* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
308- new upstream release
309
310* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
311- rebuild with pilot-link-0.12.0-0vl1
312
313* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
314- rebuild for VineSeed
315
316* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
317- new upstream release
318
319* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
320- rebuild for VineSeed
321
322* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
323- new upstream release
324
325* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
326- rebuild for VineSeed
327
328* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
329- new upstream release
330
331* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
332- rebuild for VineSeed
333
334* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
335- new upstream release
336- delete BuildPrereq: libmal-devel and Requires: libmal
337
338* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
339- rebuild for VineSeed
340
341* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
342- new upstream release
343
344* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
345- new upstream release
346
347* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
348- new upstream release
349- delete all patches
350- add Requires: kdeaccessibility  >= %%{version}
351- add --enable-indexlib to configure option
352
353* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
354- new upstream release
355- remove Patch0
356- add Patch0 - Patch1
357
358* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
359- rebuild for VineSeed
360
361* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
362- new upstream release
363- remove Patch0
364- add BuildPrereq: gpgme-devel >= 0.4.5
365- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
366
367* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
368- rebuild for VineSeed
369- add --disable-rpath to configure option
370
371* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
372- new upstream release (delete old patch and add new security patch)
373- use %%{?_smp_mflags} for make option
374
375* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
376- rebuild for VineSeed
377
378* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
379- new upstream release
380- add patch0
381
382* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
383- new upstream release (3.4.0-rc1)
384
385* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
386- new upstream release
387
388* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
389- new upstream release
390
391* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
392- rebuild for VineSeed
393
394* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
395- new upstream release
396
397* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
398- source upgrade
399- update %%files
400- all sub-packages are integrated into main package (exclude devel)
401
402* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
403- rebuild with qt32
404
405* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
406- source upgrade
407- remove lines about vine26
408
409* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
410- source upgrade
411- update %%files
412
413* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
414- source upgrade
415- update %%description
416- add Obsoletes: kdenetwork < 3.2.0
417
418* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
419- rebuild for VineSeedPlus
420
421* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
422- source upgrade
423- build for VinePlus/2.6
424- (VinePlus/2.6) BuildPrereq: autoconf258
425- remove Patch
426
427* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
428- build for VineSeed with new toolchain and qt-3.2.3
429- add configure option --with-xinerama --enable-final
430
431* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
432- rebuild with qt-3.2.1-0.26vl3
433
434* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
435- rebuild with qt-3.2.1-0vl3
436
437* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
438- build with gcc-3.2.3
439
440* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
441- source upgrade
442- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
443
444* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
445- rebuild for Vine2.6
446
447* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
448- source upgrade
449- change spec to build with gcc295
450- change make option for SMP and add script
451- add BuildPrereq: libmal-devel
452- add Requires: libmal for pilot
453
454* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
455- source upgrade
456- remove Patch800 (included in this source)
457- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
458
459* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
460- source upgrade
461- change spec to build both VineSeed and Vine2.5/2.6
462- revised description and files section
463- remove source900
464- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
465- add patch800 (Kdeveloper:02753)
466
467* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
468- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
469
470* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
471- source upgrade
472
473* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
474- rebuild with qt-3.0.5-0vl1
475- BuildPrereq: autoconf253 objprelink2
476
477* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
478- source upgrade
479
480* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
481- source upgrade
482- add BuildPrereq: autoconf252 automake15
483
484* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
485- merged with rawhide 3.0.1-1
486- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
487- add Requires: for each package
488- There is Vine's previous changes, hacked for Vine
489 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
490  - build for VineSeed
491  - delete Epoch
492  - objprelink (i386 only)
493
494* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
495- 3.0.1
496- fixed bug #67303
497
498* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
499- automated rebuild
500
501* Thu May 23 2002 Tim Powers <timp@redhat.com>
502- automated rebuild
503
504* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
505- Rename libraries
506
507* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
508- Fix #61901
509
510* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
511- final
512
513* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
514- Update
515- Fix build on ia64
516
517* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
518- Update, fixes korganizer (#50006)
519
520* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
521- Update to get rid of abbrowser (moved to kdebase)
522
523* Thu Feb 22 2001 Than Ngo <than@redhat.com>
524- add missing ldconfig in %post anf %postun again
525- clean up specfile
526
527* Wed Feb 21 2001 Than Ngo <than@redhat.com>
528- 2.1-respin
529- fix dangling symlink
530- remove excludearch ia64, some hacks to build on ia64
531
532* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
533- 2.1
534
535* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
536- Update
537
538* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
539- Update
540
541* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- Update to CVS
543- Enable building kpilot
544- Obsolete kpilot
545- Don't exclude ia64, use -O0 on ia64
546- Disable building kpilot on ia64 (compiler breakage)
547
548* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
549- 2.0 final
550
551* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
552- 2.0
553
554* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
555- new CVS
556- fix installation of fonts
557
558* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
559- new CVS snapshot
560- fix up spec file
561
562* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
563- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
564  there's no need to keep them separate to avoid the dependency.
565
566* Mon Aug 21 2000 Than Ngo <than@redhat.com>
567- fix gnome-session so that KDE2 can be started from gdm
568- pam/kde2 instead pam/kde to avoid problem with KDE1
569- don't requires qt-GL, It's now in qt
570
571* Sun Aug 20 2000 Than Ngo <than@redhat.com>
572- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
573  at the same time
574- add missing ldconfig in %post anf %postun
575- fix for reading config files in /etc/X11/xdm, add Xsession to requires
576
577* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
578- Fix keytable in konsole (Bug #15682)
579
580* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
581- rebuild, now that kdelibs2 works on alpha
582- use the same ugly hack to get kdebase to compile
583- remove ksysguard on alpha (even more compiler problems)
584
585* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
586- new snapshot (fixed libGL detection in CVS)
587
588* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
589- move to /usr/lib/kde2
590- new snapshot
591
592* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
593- fix the --xdmdir arg to be correct (oops)
594
595* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
596- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
597
598* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
599- new snapshot
600- some fixes to spec file
601
602* Tue Jul 18 2000 Than Ngo <than@redhat.de>
603- rebuilt against glibc-2.1.92-14, gcc-2.96-40
604
605* Sun Jul 16 2000 Than Ngo <than@redhat.de>
606- use new snapshot
607- disable Motif
608
609* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
610- use gcc 2.96
611- new snapshot
612
613* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
614- Epoch 3
615- Update to current
616- Use egcs++
617
618* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
619- Update (I put the fixes directly to CVS rather than collecting them
620  in the spec)
621
622* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
623- remove man2html; we get that from man
624- new snapshot
625
626* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
627- new snapshot
628- ExcludeArch ia64 for now
629- remove gnome .desktop file, we get it from gnome-core now.
630
631* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
632- remove dependency on xpm (now in XFree86)
633
634* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
635- new snapshot
636- move it to /usr, where it belongs
637
638* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
639- Build the OpenGL screensavers, and move them to a separate package
640- Improve the spec file (BuildPrereqs etc.)
641
642* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
643- remove patch #3 (obsoleted by kwin)
644
645* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
646- 2.0 CVS snapshot
647- fix compilation
648
649* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
650- clean up files in /tmp from startkde
651- mark doc files as such
652
653* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
654- start autorun if present in startkde
655- check for configured soundcard before running sound services
656
657* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
658- made kdelnks display Name property if they are of type Link
659
660* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
661- moved png handling here (from kdelibs)
662- changed low color icon directory name to locolor
663
664* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
665- added optional session management to logout dialog
666- include GNOME menus
667
668* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
669- added link to /etc/X11/applnk, .directory file
670- included lowcolor icon sub-package
671- enable .desktop file access
672
673* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
674- customized startkde script to set up user environment if not present.
675- mention kthememgr in description.
676
677* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
678- upgraded to 1.1.2 release
679- kvt is back
680- kde icon included
681- linux console fonts included
682
683* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
684- PAM console logout problem solved.
685
686* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
687- now includes screensaver password security fix
688
689* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
690- snapshot, includes kde 1.1.1 + fixes
691- kvt removed for security reasons.  It is a steaming pile of...
692
693* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
694- last snapshot before release
695
696* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
697- today's snapshot makes kfm a bit nicer and some other fixes
698- moved default rc files to kdesupport
699
700* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
701- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
702
703* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
704- built with today's snapshot -- had to rebuild to fix pam problems.
705
706* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
707- new snapshot fixes mimetype video/x-flic problem
708
709* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
710- latest stable snapshot
711
712* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
713- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
714- this previous connection and autoselect kdebase for upgrade).
715
716* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
717- moved gdm patch
718
719* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
720- added gdm session control file
721
722* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
723- added pam-console stuff to kde pam file
724
725* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
726- Injected new description and group.
727
728* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
729- upgraded to KDE 1.1 final.
730
731* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
732- updated macros for RPM 3.0, removed red hat logo.
733
734* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
735- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.