source: projects/specs/trunk/k/kdepim/kdepim-vl.spec @ 816

Revision 816, 20.5 KB checked in by inagaki, 14 years ago (diff)

updated: kdepim

Line 
1%define beta 0
2%define vine4 %(grep -c 4. /etc/vine-release)
3
4Name: kdepim
5Version: 4.4.2
6Release: 1%{?_dist_release}
7Summary: PIM (Personal Information Manager) for KDE
8Summary(ja): KDE の個人情報管理(PIM)アプリケーション集
9Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
10Patch0:  kdepim-4.1.80-libqgpgme-link-fix.patch
11# http://bugzilla.redhat.com/show_bug.cgi?id=496988
12Patch1:  kdepim-4.3.1-kmail-saveAttachments.patch
13## upstream
14
15# KDE.org patches
16# KDE.gr.jp patches
17
18URL: http://www.kde.org/
19Group: Applications/Productivity
20License: GPLv2
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: akonadi-devel
24BuildRequires: bison flex
25BuildRequires: libboost-devel
26BuildRequires: cyrus-sasl-devel
27BuildRequires: desktop-file-utils
28BuildRequires: gnokii-devel
29BuildRequires: gpgme-devel
30BuildRequires: kdepimlibs-devel >= %{version}
31BuildRequires: kdelibs-experimental-devel
32BuildRequires: libassuan-devel
33BuildRequires: libical-devel
34BuildRequires: libXpm-devel libXScrnSaver-devel
35# TODO: libmapi from http://www.openchange.org/
36#BuildRequires: libmapi-devel
37BuildRequires: libxslt-devel
38# libmal currently not used, recheck with kdepim-4.3
39BuildRequires: pilot-link-devel >= 0.12.4
40BuildRequires: python-devel
41BuildRequires: soprano-devel
42BuildRequires: qca2-devel
43BuildRequires: zlib-devel
44
45Provides: kdepim4 = %{version}-%{release}
46Requires: %{name}-libs = %{version}-%{release}
47
48%description
49A PIM (Personal Information Manager) for KDE.
50
51What it is
52----------
53* kmail: email client
54* knode: newsreader
55* knotes: sticky notes for the desktop
56* kontact: integrated PIM management
57* korganizer: journal, appointments, events, todos
58%{?_with_pilot_link:* kpilot: HotSync® software for Palm OS® devices}
59
60%package libs
61Summary: %{name} runtime libraries
62Group:   System Environment/Libraries
63Requires: kdelibs4 >= %{version}
64
65%description libs
66%{summary}.
67
68%package devel
69Summary: Development files for kdepim
70Group: Development/Libraries
71Provides: kdepim4-devel = %{version}-%{release}
72Requires: %{name}-libs = %{version}-%{release}
73Requires: kdelibs4-devel
74
75%description devel
76Development files for %{name}.
77Install %{name}-devel if you want to write or compile %{name} plugins.
78
79%prep
80%setup -q
81%patch0 -p1 -b .libqgpgme-link-fix
82%patch1 -p0 -b .kmail-saveAttachments
83
84%build
85mkdir -p %{_target_platform}
86pushd %{_target_platform}
87unset QTDIR || : ; . /etc/profile.d/qt4.sh
88%cmake \
89    -DCMAKE_BUILD_TYPE=release \
90    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
91    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
92    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
93    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
94    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
95    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
96    ..
97popd
98
99make %{?_smp_mflags} -C %{_target_platform}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
104
105# make symlinks relative
106mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
107pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
108for i in *; do
109   if [ -d $i -a -L $i/common ]; then
110      rm -f $i/common
111      ln -nfs ../common $i
112   fi
113done
114popd
115
116%check
117for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
118  desktop-file-validate $f
119done
120
121%post
122touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
123touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
124
125%posttrans
126gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
127gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
128update-desktop-database -q &> /dev/null ||:
129
130%postun
131if [ $1 -eq 0 ] ; then
132  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
133  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
134  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
135  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
136  update-desktop-database -q &> /dev/null ||:
137fi
138
139%post libs -p /sbin/ldconfig
140
141%postun libs -p /sbin/ldconfig
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%files
147%defattr(-,root,root)
148%{_bindir}/*
149#{_libdir}/libkpilot_*.so
150%{_libdir}/kde4/*.so
151%{_libdir}/strigi/*.so
152%{_libdir}/akonadi/*
153%{_datadir}/applications/kde4/*.desktop
154%{_datadir}/kde4/apps/akregator
155#{_datadir}/kde4/apps/akonadi/*
156%{_datadir}/kde4/apps/akonadiconsole/*
157%{_datadir}/kde4/apps/blogilo/*
158%{_datadir}/kde4/apps/kaddressbook
159%{_datadir}/kde4/apps/kalarm
160%{_datadir}/kde4/apps/kconf_update/*
161%{_datadir}/kde4/apps/kdepimwidgets
162%{_datadir}/kde4/apps/kjots
163%{_datadir}/kde4/apps/kleopatra
164%{_datadir}/kde4/apps/kmail
165%{_datadir}/kde4/apps/kmailcvt
166%{_datadir}/kde4/apps/knode
167%{_datadir}/kde4/apps/knotes
168%{_datadir}/kde4/apps/konsolekalendar
169%{_datadir}/kde4/apps/kontact
170%{_datadir}/kde4/apps/kontactsummary
171%{_datadir}/kde4/apps/korgac
172%{_datadir}/kde4/apps/korganizer
173#{_datadir}/kde4/apps/kpilot
174%{_datadir}/kde4/apps/ktimetracker
175%{_datadir}/kde4/apps/kwatchgnupg
176%{_datadir}/kde4/apps/libkdepim
177%{_datadir}/kde4/apps/libkleopatra
178%{_datadir}/dbus-1/interfaces/*.xml
179%{_datadir}/autostart/*
180#{_datadir}/akonadi/*
181%{_datadir}/config/*
182%{_datadir}/config.kcfg/*
183%{_datadir}/icons/hicolor/*/*/*
184%{_datadir}/icons/oxygen/*/*/*
185%{_datadir}/kde4/services/*
186%{_datadir}/kde4/servicetypes/*
187%doc %{_docdir}/HTML/en/*
188%{_mandir}/man1/*
189
190%files libs
191%defattr(-,root,root)
192%{_libdir}/lib*.so.*
193%{_libdir}/kde4/plugins/designer/*.so
194
195%files devel
196%defattr(-,root,root)
197#{_includedir}/kde4/*
198%{_libdir}/lib*.so
199#exclude %{_libdir}/libkpilot_*.so
200
201%changelog
202* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
203- new upstream release
204
205* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
206- new upstream release
207
208* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
209- new upstream release
210- built with new toolchain
211
212* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
213- new upstream release
214
215* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
216- new upstream release
217- dropped Patch100 (merged into upstream)
218- used %%cmake macro
219
220* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
221- new upstream release
222
223* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
224- applied new versioning policy, spec in UTF-8
225- added Japnaese summary
226
227* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
228- rebuild for VineSeed
229
230* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
231- new upstream release
232
233* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
234- rebuild for VineSeed
235
236* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
237- new upstream release
238- remove all patches
239
240* Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
241- new upstream release
242- add Patch0, 1 , 2 and 3
243
244* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
245- added --with-qt-libraries and --enable-libsuffix option
246
247* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
248- rebuild for VineSeed
249
250* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
251- new upstream release
252
253* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
254- rebuild with pilot-link-0.12.0-0vl1
255
256* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
257- rebuild for VineSeed
258
259* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
260- new upstream release
261
262* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
263- rebuild for VineSeed
264
265* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
266- new upstream release
267
268* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
269- rebuild for VineSeed
270
271* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
272- new upstream release
273
274* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
275- rebuild for VineSeed
276
277* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
278- new upstream release
279- delete BuildPrereq: libmal-devel and Requires: libmal
280
281* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
282- rebuild for VineSeed
283
284* Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
285- new upstream release
286
287* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
288- new upstream release
289
290* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
291- new upstream release
292- delete all patches
293- add Requires: kdeaccessibility  >= %%{version}
294- add --enable-indexlib to configure option
295
296* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
297- new upstream release
298- remove Patch0
299- add Patch0 - Patch1
300
301* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
302- rebuild for VineSeed
303
304* Tue Aug  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
305- new upstream release
306- remove Patch0
307- add BuildPrereq: gpgme-devel >= 0.4.5
308- add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
309
310* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
311- rebuild for VineSeed
312- add --disable-rpath to configure option
313
314* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
315- new upstream release (delete old patch and add new security patch)
316- use %%{?_smp_mflags} for make option
317
318* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
319- rebuild for VineSeed
320
321* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
322- new upstream release
323- add patch0
324
325* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
326- new upstream release (3.4.0-rc1)
327
328* Tue Feb  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
329- new upstream release
330
331* Wed Feb  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
332- new upstream release
333
334* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
335- rebuild for VineSeed
336
337* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
338- new upstream release
339
340* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
341- source upgrade
342- update %%files
343- all sub-packages are integrated into main package (exclude devel)
344
345* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
346- rebuild with qt32
347
348* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
349- source upgrade
350- remove lines about vine26
351
352* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
353- source upgrade
354- update %%files
355
356* Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
357- source upgrade
358- update %%description
359- add Obsoletes: kdenetwork < 3.2.0
360
361* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
362- rebuild for VineSeedPlus
363
364* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
365- source upgrade
366- build for VinePlus/2.6
367- (VinePlus/2.6) BuildPrereq: autoconf258
368- remove Patch
369
370* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
371- build for VineSeed with new toolchain and qt-3.2.3
372- add configure option --with-xinerama --enable-final
373
374* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
375- rebuild with qt-3.2.1-0.26vl3
376
377* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
378- rebuild with qt-3.2.1-0vl3
379
380* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
381- build with gcc-3.2.3
382
383* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
384- source upgrade
385- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
386
387* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
388- rebuild for Vine2.6
389
390* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
391- source upgrade
392- change spec to build with gcc295
393- change make option for SMP and add script
394- add BuildPrereq: libmal-devel
395- add Requires: libmal for pilot
396
397* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
398- source upgrade
399- remove Patch800 (included in this source)
400- built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
401
402* Sat Apr  5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
403- source upgrade
404- change spec to build both VineSeed and Vine2.5/2.6
405- revised description and files section
406- remove source900
407- add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
408- add patch800 (Kdeveloper:02753)
409
410* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
411- objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
412
413* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
414- source upgrade
415
416* Wed Oct  9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
417- rebuild with qt-3.0.5-0vl1
418- BuildPrereq: autoconf253 objprelink2
419
420* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
421- source upgrade
422
423* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
424- source upgrade
425- add BuildPrereq: autoconf252 automake15
426
427* Thu Jul  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
428- merged with rawhide 3.0.1-1
429- change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
430- add Requires: for each package
431- There is Vine's previous changes, hacked for Vine
432 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
433  - build for VineSeed
434  - delete Epoch
435  - objprelink (i386 only)
436
437* Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
438- 3.0.1
439- fixed bug #67303
440
441* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
442- automated rebuild
443
444* Thu May 23 2002 Tim Powers <timp@redhat.com>
445- automated rebuild
446
447* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
448- Rename libraries
449
450* Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
451- Fix #61901
452
453* Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
454- final
455
456* Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
457- Update
458- Fix build on ia64
459
460* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
461- Update, fixes korganizer (#50006)
462
463* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
464- Update to get rid of abbrowser (moved to kdebase)
465
466* Thu Feb 22 2001 Than Ngo <than@redhat.com>
467- add missing ldconfig in %post anf %postun again
468- clean up specfile
469
470* Wed Feb 21 2001 Than Ngo <than@redhat.com>
471- 2.1-respin
472- fix dangling symlink
473- remove excludearch ia64, some hacks to build on ia64
474
475* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
476- 2.1
477
478* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
479- Update
480
481* Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
482- Update
483
484* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
485- Update to CVS
486- Enable building kpilot
487- Obsolete kpilot
488- Don't exclude ia64, use -O0 on ia64
489- Disable building kpilot on ia64 (compiler breakage)
490
491* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
492- 2.0 final
493
494* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
495- 2.0
496
497* Sun Oct  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
498- new CVS
499- fix installation of fonts
500
501* Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
502- new CVS snapshot
503- fix up spec file
504
505* Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
506- get rid of the 3d-screensavers package - now that qt-GL is part of qt,
507  there's no need to keep them separate to avoid the dependency.
508
509* Mon Aug 21 2000 Than Ngo <than@redhat.com>
510- fix gnome-session so that KDE2 can be started from gdm
511- pam/kde2 instead pam/kde to avoid problem with KDE1
512- don't requires qt-GL, It's now in qt
513
514* Sun Aug 20 2000 Than Ngo <than@redhat.com>
515- fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
516  at the same time
517- add missing ldconfig in %post anf %postun
518- fix for reading config files in /etc/X11/xdm, add Xsession to requires
519
520* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
521- Fix keytable in konsole (Bug #15682)
522
523* Sun Aug  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
524- rebuild, now that kdelibs2 works on alpha
525- use the same ugly hack to get kdebase to compile
526- remove ksysguard on alpha (even more compiler problems)
527
528* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
529- new snapshot (fixed libGL detection in CVS)
530
531* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
532- move to /usr/lib/kde2
533- new snapshot
534
535* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
536- fix the --xdmdir arg to be correct (oops)
537
538* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
539- move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
540
541* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- new snapshot
543- some fixes to spec file
544
545* Tue Jul 18 2000 Than Ngo <than@redhat.de>
546- rebuilt against glibc-2.1.92-14, gcc-2.96-40
547
548* Sun Jul 16 2000 Than Ngo <than@redhat.de>
549- use new snapshot
550- disable Motif
551
552* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
553- use gcc 2.96
554- new snapshot
555
556* Sun Jul  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
557- Epoch 3
558- Update to current
559- Use egcs++
560
561* Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
562- Update (I put the fixes directly to CVS rather than collecting them
563  in the spec)
564
565* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
566- remove man2html; we get that from man
567- new snapshot
568
569* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
570- new snapshot
571- ExcludeArch ia64 for now
572- remove gnome .desktop file, we get it from gnome-core now.
573
574* Wed Apr  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
575- remove dependency on xpm (now in XFree86)
576
577* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
578- new snapshot
579- move it to /usr, where it belongs
580
581* Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
582- Build the OpenGL screensavers, and move them to a separate package
583- Improve the spec file (BuildPrereqs etc.)
584
585* Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
586- remove patch #3 (obsoleted by kwin)
587
588* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
589- 2.0 CVS snapshot
590- fix compilation
591
592* Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
593- clean up files in /tmp from startkde
594- mark doc files as such
595
596* Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
597- start autorun if present in startkde
598- check for configured soundcard before running sound services
599
600* Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
601- made kdelnks display Name property if they are of type Link
602
603* Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
604- moved png handling here (from kdelibs)
605- changed low color icon directory name to locolor
606
607* Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
608- added optional session management to logout dialog
609- include GNOME menus
610
611* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
612- added link to /etc/X11/applnk, .directory file
613- included lowcolor icon sub-package
614- enable .desktop file access
615
616* Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
617- customized startkde script to set up user environment if not present.
618- mention kthememgr in description.
619
620* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
621- upgraded to 1.1.2 release
622- kvt is back
623- kde icon included
624- linux console fonts included
625
626* Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
627- PAM console logout problem solved.
628
629* Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
630- now includes screensaver password security fix
631
632* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
633- snapshot, includes kde 1.1.1 + fixes
634- kvt removed for security reasons.  It is a steaming pile of...
635
636* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
637- last snapshot before release
638
639* Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
640- today's snapshot makes kfm a bit nicer and some other fixes
641- moved default rc files to kdesupport
642
643* Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
644- SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
645
646* Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
647- built with today's snapshot -- had to rebuild to fix pam problems.
648
649* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
650- new snapshot fixes mimetype video/x-flic problem
651
652* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
653- latest stable snapshot
654
655* Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
656- removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
657- this previous connection and autoselect kdebase for upgrade).
658
659* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
660- moved gdm patch
661
662* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
663- added gdm session control file
664
665* Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
666- added pam-console stuff to kde pam file
667
668* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
669- Injected new description and group.
670
671* Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
672- upgraded to KDE 1.1 final.
673
674* Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
675- updated macros for RPM 3.0, removed red hat logo.
676
677* Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
678- re-merged from Duncan Haldane's stuff
Note: See TracBrowser for help on using the repository browser.