source: projects/specs/trunk/k/kdepim-runtime/kdepim-runtime-vl.spec @ 521

Revision 521, 3.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define akonadi_version 1.1.95
2
3Name: kdepim-runtime
4Summary: KDE PIM Runtime Environment
5Version: 4.3.3
6Release: 1%{?_dist_release}
7
8License: GPLv2
9Group: Applications/Productivity
10URL: http://www.kde.org/
11Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: akonadi-devel >= %{akonadi_version}
15BuildRequires: desktop-file-utils
16BuildRequires: kdepimlibs-devel >= %{version}
17BuildRequires: kdelibs-experimental-devel >= %{version}
18BuildRequires: zlib-devel
19BuildRequires: soprano-devel
20BuildRequires: libxslt-devel
21BuildRequires: libxml2-devel
22Requires: %{name}-libs = %{version}-%{release}
23
24%description
25%{summary}
26
27
28%package libs
29Summary: %{name} runtime libraries
30Group: System Environment/Libraries
31Requires: %{name} = %{version}-%{release}
32Requires: akonadi >= %{akonadi_version}
33
34%description libs
35%{summary}.
36
37
38%package devel
39Summary: Development files for %{name}
40Group: Development/Libraries
41Requires: %{name}-libs = %{version}-%{release}
42Requires: kdepimlibs-devel >= %{version}
43
44%description devel
45%{summary}.
46Install %{name}-devel if you want to write or compile %{name} plugins.
47
48
49%prep
50%setup -q
51
52%build
53mkdir -p %{_target_platform}
54pushd %{_target_platform}
55unset QTDIR || : ; . /etc/profile.d/qt4.sh
56%cmake \
57    -DCMAKE_BUILD_TYPE=release \
58    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
59    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
60    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
61    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
62    ..
63popd
64
65make %{?_smp_mflags} -C %{_target_platform}
66
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
72
73# make symlinks relative
74mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
75pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
76for i in *; do
77   if [ -d $i -a -L $i/common ]; then
78      rm -f $i/common
79      ln -nfs ../common $i
80   fi
81done
82popd
83
84%check
85for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
86   desktop-file-validate $f
87done
88
89%post
90touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
91
92%posttrans
93gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
94update-mime-database %{_datadir}/mime >& /dev/null ||:
95update-desktop-database -q &> /dev/null ||:
96
97%postun
98if [ $1 -eq 0 ] ; then
99  update-mime-database %{_datadir}/mime &> /dev/null ||:
100  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
101  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
102  update-desktop-database -q &> /dev/null ||:
103fi
104
105%post libs -p /sbin/ldconfig
106
107%postun libs -p /sbin/ldconfig
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112
113%files
114%defattr(-,root,root,-)
115%{_bindir}/*
116%{_libdir}/kde4/*.so
117%{_datadir}/akonadi/agents/*
118%{_datadir}/applications/kde4/*
119%{_datadir}/config/*rc
120%{_datadir}/dbus-1/interfaces/*.xml
121%{_datadir}/kde4/services/*
122%{_datadir}/mime/packages/*
123%{_datadir}/icons/hicolor/*/*/*
124%{_datadir}/kde4/apps/*
125
126%files devel
127%defattr(-,root,root,-)
128%{_includedir}/kde4/akonadi/xml
129%{_libdir}/lib*.so
130
131%files libs
132%defattr(-,root,root,-)
133%{_libdir}/lib*.so.*
134
135%changelog
136* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
137- new upstream release
138
139* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
140- new upstream release
141
142* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
143- new upstream release
144- used %%cmake macro
145
146* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-2
147- Initial build for Vine Linux
148
149* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
150- 4.3.0
151
152* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
153- 4.3rc3
154
155* Sat Jul 11 2009 Than Ngo <than@redhat.com> - 4.2.96-1
156- 4.3rc2
157
158* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
159- -devel: Requires: kdepimlibs-devel
160- Req: akonadi >= 1.1.95
161
162* Mon Jun 29 2009 Than Ngo <than@redhat.com> - 4.2.95-2
163- cleanup
164
165* Fri Jun 26 2009 Than Ngo <than@redhat.com> - 4.2.95-1
166- first try
Note: See TracBrowser for help on using the repository browser.