source: projects/specs/trunk/k/kdepim-runtime/kdepim-runtime-vl.spec @ 962

Revision 962, 4.3 KB checked in by inagaki, 14 years ago (diff)

updated: KDE SC 4.4.3

Line 
1%define akonadi_version 1.2.60
2
3Name: kdepim-runtime
4Summary: KDE PIM Runtime Environment
5Version: 4.4.3
6Release: 1%{?_dist_release}
7
8License: GPLv2
9Group: Applications/Productivity
10URL: http://www.kde.org/
11Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: akonadi-devel >= %{akonadi_version}
15BuildRequires: desktop-file-utils
16BuildRequires: kdepimlibs-devel >= %{version}
17BuildRequires: kdelibs4-devel >= %{version}
18BuildRequires: zlib-devel
19BuildRequires: soprano-devel
20BuildRequires: libxslt-devel
21BuildRequires: libxml2-devel
22Requires: %{name}-libs = %{version}-%{release}
23
24%description
25%{summary}
26
27
28%package libs
29Summary: %{name} runtime libraries
30Group: System Environment/Libraries
31Requires: %{name} = %{version}-%{release}
32Requires: akonadi >= %{akonadi_version}
33
34%description libs
35%{summary}.
36
37
38%package devel
39Summary: Development files for %{name}
40Group: Development/Libraries
41Requires: %{name}-libs = %{version}-%{release}
42Requires: kdepimlibs-devel >= %{version}
43
44%description devel
45%{summary}.
46Install %{name}-devel if you want to write or compile %{name} plugins.
47
48
49%prep
50%setup -q
51
52%build
53mkdir -p %{_target_platform}
54pushd %{_target_platform}
55unset QTDIR || : ; . /etc/profile.d/qt4.sh
56%cmake \
57    -DCMAKE_BUILD_TYPE=release \
58    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
59    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
60    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
61    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
62    ..
63popd
64
65make %{?_smp_mflags} -C %{_target_platform}
66
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
72
73# make symlinks relative
74mkdir -p $RPM_BUILD_ROOT%{_docdir}/HTML/en/common
75pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en
76for i in *; do
77   if [ -d $i -a -L $i/common ]; then
78      rm -f $i/common
79      ln -nfs ../common $i
80   fi
81done
82popd
83
84%check
85for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
86   desktop-file-validate $f
87done
88
89%post
90touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
91
92%posttrans
93gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
94update-mime-database %{_datadir}/mime >& /dev/null ||:
95update-desktop-database -q &> /dev/null ||:
96
97%postun
98if [ $1 -eq 0 ] ; then
99  update-mime-database %{_datadir}/mime &> /dev/null ||:
100  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
101  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
102  update-desktop-database -q &> /dev/null ||:
103fi
104
105%post libs -p /sbin/ldconfig
106
107%postun libs -p /sbin/ldconfig
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112
113%files
114%defattr(-,root,root,-)
115%{_bindir}/*
116%{_libdir}/kde4/*.so
117%{_datadir}/autostart/*
118%{_datadir}/akonadi/agents/*
119%{_datadir}/applications/kde4/*
120%{_datadir}/config/*rc
121%{_datadir}/dbus-1/interfaces/*.xml
122%{_datadir}/kde4/services/*
123%{_datadir}/mime/packages/*
124%{_datadir}/icons/hicolor/*/*/*
125%{_datadir}/kde4/apps/*
126
127%files devel
128%defattr(-,root,root,-)
129#{_includedir}/kde4/akonadi/xml
130%{_libdir}/lib*.so
131
132%files libs
133%defattr(-,root,root,-)
134%{_libdir}/lib*.so.*
135
136%changelog
137* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
138- new upstream release
139
140* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
141- new upstream release
142
143* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
144- new upstream release
145
146* Tue Mar  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
147- new upstream release
148- built with new toolchain
149
150* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
151- new upstream release
152
153* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
154- new upstream release
155
156* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
157- new upstream release
158- used %%cmake macro
159
160* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-2
161- Initial build for Vine Linux
162
163* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
164- 4.3.0
165
166* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
167- 4.3rc3
168
169* Sat Jul 11 2009 Than Ngo <than@redhat.com> - 4.2.96-1
170- 4.3rc2
171
172* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
173- -devel: Requires: kdepimlibs-devel
174- Req: akonadi >= 1.1.95
175
176* Mon Jun 29 2009 Than Ngo <than@redhat.com> - 4.2.95-2
177- cleanup
178
179* Fri Jun 26 2009 Than Ngo <than@redhat.com> - 4.2.95-1
180- first try
Note: See TracBrowser for help on using the repository browser.