source: projects/specs/trunk/k/kdenetwork/kdenetwork-vl.spec @ 6899

Revision 6899, 20.7 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.2

Line 
1Name: kdenetwork
2Summary: KDE Network Applications
3Summary(ja): KDE ネットワークアプリケーション集
4Version: 4.9.2
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Internet
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdenetwork-%{version}.tar.xz
12Source1: krdc-icons.tar.bz2
13Source2: kppp.console
14Source3: kppp.pamd
15
16## upstream me!  -- Rex :)
17Patch1: kdenetwork-4.2.98-kdrc-icon.patch
18# rhbz#540433 - KPPP is unable to add DNS entries to /etc/resolv.conf
19Patch2: kdenetwork-4.3.3-resolv-conf-path.patch
20
21## security patches
22
23# Vine patches
24# Don't build with xmms-devel
25Patch1000: kdenetwork-4.6.0-noxmms.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: alsa-lib-devel
29BuildRequires: expat-devel
30BuildRequires: giflib-devel
31BuildRequires: glib2-devel
32BuildRequires: gmp-devel
33BuildRequires: gpgme-devel
34BuildRequires: kdebase-devel >= %{version}
35BuildRequires: kdebase-workspace-devel >= %{version}
36BuildRequires: kdelibs4-devel >= %{version}
37BuildRequires: kdepimlibs-devel >= %{version}
38BuildRequires: libboost-devel
39BuildRequires: libgadu-devel >= 1.8.0
40BuildRequires: libidn-devel
41BuildRequires: libjpeg-devel
42BuildRequires: libktorrent-devel
43BuildRequires: libmsn-devel >= 4.1
44BuildRequires: libotr-devel
45BuildRequires: libv4l-devel
46BuildRequires: libvncserver-devel
47BuildRequires: libxml2-devel
48BuildRequires: libXpm-devel
49BuildRequires: libXScrnSaver-devel
50BuildRequires: libxslt-devel
51BuildRequires: libXtst-devel
52BuildRequires: meanwhile-devel
53BuildRequires: ortp-devel
54BuildRequires: qca2-devel
55BuildRequires: plasma-devel >= %{version}
56BuildRequires: qimageblitz-devel
57BuildRequires: soprano-devel >= 2.0.97
58BuildRequires: speex-devel
59BuildRequires: sqlite3-devel
60BuildRequires: strigi-devel
61BuildRequires: jasper-devel
62
63Requires: kdebase-runtime >= 4.6
64Requires: %{name}-libs = %{version}-%{release}
65
66# kopete/yahoo
67Requires: jasper
68# kopete/jabber
69Requires: qca-ossl
70## krdc
71Requires: rdesktop
72
73# consolehelper
74Requires: usermode-gtk
75
76Obsoletes: kdenetwork4 < %{version}-%{release}
77Provides: kdenetwork4 = %{version}-%{release}
78
79Obsoletes: kopete <= 0.8.0
80Provides: kopete
81
82Conflicts: kdenetwork3
83
84%description
85Networking applications, including:
86
87* kget: downloader manager
88* kopete: chat client
89* krdc: a client for Desktop Sharing and other VNC servers
90* krfb: Desktop Sharing server, allow others to access your desktop via VNC
91
92%package libs
93Summary: Runtime libraries for %{name}
94Group:   System Environment/Libraries
95
96%description libs
97%{summary}.
98
99%package devel
100Summary: Development files for kdenetwork
101Group: Development/Libraries
102Requires: %{name}-libs = %{version}-%{release}
103Requires: kdelibs4-devel
104
105%description devel
106Development files for kdenetwork. Install kdenetwork-devel if you wish
107to develop or compile KDE networking applications.
108
109%package -n kppp
110Summary: Modem dialer and ppp frontend for KDE
111Summary(ja): KDE 用 ダイアルアップアプリケーション
112Group: Applications/Internet
113Requires: %{name}-libs = %{version}-%{release}
114Requires: ppp
115Obsoletes: kppp4 < %{version}-%{release}
116Provides:  kppp4 = %{version}-%{release}
117
118%description -n kppp
119KPPP is a dialer and front end for pppd. It allows for interactive
120script generation and network setup. It will automate the dialing in
121process to your ISP while letting you conveniently monitor the
122entire process.
123
124Once connected KPPP will provide a rich set of statistics and keep
125track of the time spent online for you.
126
127
128%prep
129%setup -q -n kdenetwork-%{version} -a 1
130%patch1 -p1 -b .icon
131%patch2 -p1 -b .resolv-conf-path
132
133# Vine patches
134%patch1000 -p1 -b .noxmms
135
136%build
137mkdir -p %{_target_platform}
138pushd %{_target_platform}
139%cmake \
140    -DCMAKE_BUILD_TYPE=release \
141    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
142    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
143    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
144    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
145    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
146    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
147    -DMOZPLUGIN_INSTALL_DIR=%{_libdir}/mozilla/plugins \
148    -DLIBGADU_INCLUDE_DIR=%{_includedir} \
149    -DLIBGADU_LIBRARIES=%{_libdir}/libgadu.so \
150    ..
151popd
152
153make -C %{_target_platform}/doc
154make %{?_smp_mflags} -C %{_target_platform}
155
156
157%install
158rm -rf $RPM_BUILD_ROOT
159make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
160
161# Run kppp through consolehelper
162mkdir -p $RPM_BUILD_ROOT%{_sbindir} \
163         $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps \
164         $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
165
166chmod 0755 $RPM_BUILD_ROOT%{_bindir}/kppp
167mv $RPM_BUILD_ROOT%{_bindir}/kppp $RPM_BUILD_ROOT%{_sbindir}
168ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kppp
169
170install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kppp
171install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kppp
172
173
174# move devel symlinks
175mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
176pushd $RPM_BUILD_ROOT%{_libdir}
177for i in lib*.so
178do
179  case "$i" in
180# conflicts with kdenetwork3
181    libkopete.so | libkopete_oscar.so | libkopete_videodevice.so)
182      linktarget=`readlink "$i"`
183      rm -f "$i"
184      ln -sf "../../$linktarget" "kde4/devel/$i"
185      ;;
186  esac
187done
188popd
189
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
196touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
197
198%posttrans
199gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
200gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
201update-desktop-database -q &> /dev/null ||:
202
203%postun
204if [ $1 -eq 0 ] ; then
205  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
206  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
207  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
208  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
209  update-desktop-database -q &> /dev/null ||:
210fi
211
212%post libs -p /sbin/ldconfig
213
214%postun libs -p /sbin/ldconfig
215
216
217%files
218%defattr(-,root,root)
219%{_bindir}/*
220%exclude %{_bindir}/kppp*
221%{_datadir}/kde4/apps/dolphinpart/kpartplugins/kget_plug_in.desktop
222%{_datadir}/kde4/apps/dolphinpart/kpartplugins/kget_plug_in.rc
223%{_datadir}/kde4/apps/kconf_update/*
224%{_datadir}/kde4/apps/kget
225%{_datadir}/kde4/apps/khtml/kpartplugins/kget_plug_in.desktop
226%{_datadir}/kde4/apps/khtml/kpartplugins/kget_plug_in.rc
227%{_datadir}/kde4/apps/kopete*
228%{_datadir}/kde4/apps/krfb
229%{_datadir}/kde4/apps/krdc
230%{_datadir}/kde4/apps/kwebkitpart/kpartplugins/kget_plug_in.desktop
231%{_datadir}/kde4/apps/kwebkitpart/kpartplugins/kget_plug_in.rc
232%{_datadir}/kde4/apps/remoteview
233#{_datadir}/kde4/apps/desktoptheme/default/widgets/kget.svg
234%{_datadir}/config/kopeterc
235%{_datadir}/applications/kde4/*
236%exclude %{_datadir}/applications/kde4/*ppp*.desktop
237%{_datadir}/config.kcfg/*
238%{_datadir}/dbus-1/interfaces/*
239%{_datadir}/dbus-1/services/*
240%{_datadir}/kde4/services/*
241%{_datadir}/kde4/servicetypes/*
242%{_datadir}/sounds/*
243%doc %{_docdir}/HTML/en/*
244%exclude %{_datadir}/doc/HTML/en/kppp
245%{_datadir}/icons/hicolor/*/*/*
246%exclude %{_datadir}/icons/hicolor/*/apps/kppp*
247%{_datadir}/icons/oxygen/*/*/*
248%{_libdir}/kde4/*.so
249%{_libdir}/mozilla/plugins/skypebuttons.so
250%{_libdir}/kde4/plugins/accessible/chatwindowaccessiblewidgetfactory.so
251
252%files libs
253%defattr(-,root,root,-)
254%{_libdir}/libqgroupwise.so
255%{_libdir}/lib*.so.*
256
257%files devel
258%defattr(-,root,root)
259%{_includedir}/kde4/kopete
260%{_includedir}/kde4/krdc
261%{_libdir}/lib*.so
262%{_libdir}/kde4/devel/lib*.so
263%exclude %{_libdir}/libqgroupwise.so
264
265%files -n kppp
266%defattr(-,root,root)
267%doc %{_datadir}/doc/HTML/en/kppp
268%config /etc/security/console.apps/kppp
269%config /etc/pam.d/kppp
270%{_bindir}/kppp*
271%{_sbindir}/kppp
272%{_datadir}/applications/kde4/*ppp*
273%{_datadir}/kde4/apps/kppp
274%{_datadir}/icons/hicolor/*/apps/kppp*
275
276%changelog
277* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
278- new upstream release
279
280* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
281- new upstream release
282
283* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
284- rebuild with libktorrent-1.3.0
285
286* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
287- new upstream release
288
289* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.0-2
290- rebuild with libktorrent-1.1.2
291
292* Fri Aug  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
293- new upstream release
294
295* Sun Jun 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
296- new upstream release
297
298* Wed Apr 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-2
299- add BuildRequires: jasper-devel
300
301* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
302- new upstream release
303
304* Thu Mar  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-2
305- added BR: libXpm-devel, libXScrnSaver-devel
306
307* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
308- new upstream release
309- added Patch1000, build without xmms-devel
310
311* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
312- new upstream release
313
314* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
315- new upstream release
316- added Conflicts: kdenetwork3
317
318* Tue Jun 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-3
319- added BR: libXtst-devel
320
321* Mon May 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-2
322- security fixes: CVE-2010-1000, CVE-2010-1511 (#591966)
323
324* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
325- new upstream release
326
327* Wed Apr 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
328- rebuilt with libmsn-4.1
329
330* Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
331- new upstream release
332
333* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
334- new upstream release
335
336* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
337- new upstream release
338- built with new toolchain
339
340* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
341- new upstream release
342
343* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
344- new upstream release
345
346* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
347- new upstream release
348
349* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
350- applied new versioning policy, spec in UTF-8
351- added Patch0
352
353* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
354- rebuild for VineSeed
355
356* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
357- new upstream release
358
359* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
360- rebuild for VineSeed
361
362* Sat May 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
363- new upstream release
364- add BuildPrereq: speex-devel
365
366* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
367- new upstream release
368- remove BuildPrereq: xmms-devel and Requires: xmms
369
370* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
371- added --with-qt-libraries and --enable-libsuffix option
372- updated kppp.pamd
373
374* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
375- rebuild for VineSeed
376
377* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
378- new upstream release
379
380* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
381- rebuild for VineSeed
382
383* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
384- new upstream release
385
386* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
387- rebuild for VineSeed
388
389* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
390- new upstream release
391
392* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
393- rebuild for VineSeed
394
395* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
396- new upstream release
397
398* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl3
399- rebuild with wireless-tools-28-0vl0.pre15.1
400
401* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
402- rebuild for VineSeed
403
404* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
405- new upstream release
406
407* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
408- rebuild for VineSeed
409
410* Thu Nov 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
411- new upstream release
412
413* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
414- new upstream release
415
416* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
417- new upstream release
418- delete all patches
419
420* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
421- new upstream release
422- add Patch0 - Patch1
423
424* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
425- rebuild for VineSeed
426
427* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
428- new upstream release
429- remove Patch0
430
431* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl4
432- rebuild for VineSeed
433
434* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl3
435- add Patch0 (CAN-2005-1852)
436
437* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
438- build for VineSeed
439- add --disable-rpath to configure option
440
441* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
442- new upstream release
443- use %%{?_smp_mflags} for make option
444
445* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
446- rebuild for VineSeed
447
448* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
449- new upstream release
450- update %%files
451
452* Thu Jan 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
453- new upstream release
454- add BuildPrereq: xmms-devel and Requires: xmms
455
456* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
457- rebuild for VineSeed
458
459* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
460- source upgrade
461- build for Vine Linux 3.1
462
463* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
464- source upgrade
465- update %%files
466
467* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
468- rebuild with qt32
469
470* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
471- source upgrade
472- remove lines about vine26
473
474* Thu May 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
475- move %%{_libdir}/*.so to kdenetwork package
476
477* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
478- source upgrade
479- add URL: http://www.kde.org
480
481* Sat Mar 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
482- rebuild with openssl-0.9.7d
483
484* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
485- source upgrade
486- add Obsoletes: kopete <= 0.8.0 and Provides: kopete
487- add BuildPrereq: wireless-tools-devel
488- add Requires: wireless-toolss-tools-devel
489- add Requires: wireless-tools
490
491* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
492- rebuild for VineSeedPlus
493
494* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
495- source upgrade
496- build for VinePlus/2.6
497- (VinePlus/2.6) BuildPrereq: autoconf258
498
499* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
500- build for VineSeed with new toolchain and qt-3.2.3
501
502* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
503- rebuild with qt-3.2.1-0.26vl3
504
505* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
506- rebuild with qt-3.2.1-0vl3
507
508* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
509- build with gcc-3.2.3
510
511* Mon Sep 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
512- source upgrade
513- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
514
515* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
516- rebuild for Vine2.6
517
518* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
519- source upgrade
520- change spec to build with gcc295
521- change make option for SMP and add script
522
523* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
524- change spec to build with g++-2.95.3
525
526* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
527- source upgrade
528- remove Patch800 (included in this source)
529- add BuildPrereq: zlib-devel libjpeg-devel libpng-devel
530- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
531
532* Fri Apr  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
533- source upgrade
534- add patch800
535
536* Sat Mar  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
537- source upgrade
538- add BuildPrereq: arts >= 1:1.1
539- remove Patch0
540- disable all patches
541- change spec to make monolithic package only
542- Obsoletes: kdenetwork-libs
543
544* Sun Nov 17 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl3
545- add Patch0 (security patch)
546- add export PATH=`pwd`:$PATH to %build and %install section
547
548* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
549- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
550
551* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
552- source upgrade
553- BuildPrereq: autoconf253 objprelink2
554
555* Mon Aug 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp 3.0.3-0vl1
556- source upgrade
557
558* Tue Jul 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl2
559- add Patch801 from kde.gr.jp [Kdeveloper:02384]
560
561* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
562- source upgrade
563
564* Wed May  1 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
565- source update to 3.0
566- add configure option `--with-xinerama --enable-final'
567- add Requires
568- remove knewsticker
569- add Patch800 (from kde.gr.jp) and Patch900
570
571* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
572- merged with rawhide 3.0.0-0.cvs20020306.1
573- source update to cvs-20020329
574- add BuildPrereq: autoconf252 automake15
575- add %define monolithic 1
576- There is Vine's previous changes, hacked for Vine
577 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
578  - update to 2.2.2
579  - update Japanese patches (Patch1 to 5)
580 -- Wed Nov 28 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
581  - build for Vine Seed
582  - add Japanese patches (Patch2 to 6)
583
584* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
585- Rename subpackages
586
587* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.2
588- Rebuild with new kdelibs
589
590* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.1
591- Update
592
593* Tue Jan  8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020108.1
594- Update
595- Integrate ktalk stuff with xinetd
596
597* Tue Dec 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011218.1
598- Update
599- Split into subpackages
600
601* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
602- Update
603- Add build dependencies
604- Work around ia64 breakages
605
606* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010513.1
607- Update to CVS
608- clean up specfile
609- Use %%post -p and %%postun -p
610
611* Wed Feb 21 2001 Than Ngo <than@redhat.com>
612- 2.1-respin
613
614* Mon Feb 19 2001 Than Ngo <than@redhat.com>
615- update 2.1
616- fix dangling symlinks
617
618* Fri Feb  2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
619- Limit CPU usage to 2 CPUs to make asok happy
620
621* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
622- Update
623- Don't require perl, not everyone using ksirc is also using
624  ksirc perl scripting...
625
626* Mon Jan  8 2001 Bernhard Rosenkraenzer <bero@redhat.com>
627- Update (needed because of kdelibs change)
628- Obsolete kdenetwork2 (from 7.0 preview)
629
630* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
631- Update
632
633* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
634- Add missing PAM file, fix group
635
636* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
637- update to HEAD
638
639* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
640- Update CVS (fix kmail segfault with empty identity)
641
642* Tue Oct 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
643- Fix up consolehelper config
644
645* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
646- Update to current KDE_2_0_BRANCH (this should fix up knode)
647- Run kppp through consolehelper (Bug #20021)
648- Split of kppp and kppplog to a separate package, kdenetwork-ppp
649  (RFE #20022)
650
651* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
652- 2.0 final
653
654* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
655- 2.0
656
657* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
658- 1.93
659
660* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
661- new version
662
663* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
664- new snapshot
665- disable keystone for now (compiler problem)
666
667* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
668- new snapshot
669- some fixes to spec file
670
671* Tue Jul 18 2000 Than Ngo <than@redhat.de>
672- rebuilt with glibc-2.1.92-14 and gcc-2.96-40
673
674* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
675- Obsolete ktalk (powertools 6.x)
676- SMPify
677
678* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
679- use gcc 2.96
680- new snapshot
681
682* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
683- Epoch
684
685* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
686- new snapshot
687- ExcludeArch ia64 for now
688
689* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
690- new snapshot
691- move it to /usr, where it belongs
692
693* Mon Oct 25 1999 Bernhard Rosenkraenzer <bero@redhat.de>
694- initial RPM
Note: See TracBrowser for help on using the repository browser.