source: projects/specs/trunk/k/kdenetwork/kdenetwork-vl.spec @ 6725

Revision 6725, 20.5 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.0

Line 
1Name: kdenetwork
2Summary: KDE Network Applications
3Summary(ja): KDE ネットワークアプリケーション集
4Version: 4.9.0
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Internet
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdenetwork-%{version}.tar.xz
12Source1: krdc-icons.tar.bz2
13Source2: kppp.console
14Source3: kppp.pamd
15
16## upstream me!  -- Rex :)
17Patch1: kdenetwork-4.2.98-kdrc-icon.patch
18# rhbz#540433 - KPPP is unable to add DNS entries to /etc/resolv.conf
19Patch2: kdenetwork-4.3.3-resolv-conf-path.patch
20
21## security patches
22
23# Vine patches
24# Don't build with xmms-devel
25Patch1000: kdenetwork-4.6.0-noxmms.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: alsa-lib-devel
29BuildRequires: expat-devel
30BuildRequires: giflib-devel
31BuildRequires: glib2-devel
32BuildRequires: gmp-devel
33BuildRequires: gpgme-devel
34BuildRequires: kdebase-devel >= %{version}
35BuildRequires: kdebase-workspace-devel >= %{version}
36BuildRequires: kdelibs4-devel >= %{version}
37BuildRequires: kdepimlibs-devel >= %{version}
38BuildRequires: libboost-devel
39BuildRequires: libgadu-devel >= 1.8.0
40BuildRequires: libidn-devel
41BuildRequires: libjpeg-devel
42BuildRequires: libktorrent-devel
43BuildRequires: libmsn-devel >= 4.1
44BuildRequires: libotr-devel
45BuildRequires: libv4l-devel
46BuildRequires: libvncserver-devel
47BuildRequires: libxml2-devel
48BuildRequires: libXpm-devel
49BuildRequires: libXScrnSaver-devel
50BuildRequires: libxslt-devel
51BuildRequires: libXtst-devel
52BuildRequires: meanwhile-devel
53BuildRequires: ortp-devel
54BuildRequires: qca2-devel
55BuildRequires: plasma-devel >= %{version}
56BuildRequires: qimageblitz-devel
57BuildRequires: soprano-devel >= 2.0.97
58BuildRequires: speex-devel
59BuildRequires: sqlite3-devel
60BuildRequires: strigi-devel
61BuildRequires: jasper-devel
62
63Requires: kdebase-runtime >= 4.6
64Requires: %{name}-libs = %{version}-%{release}
65
66# kopete/yahoo
67Requires: jasper
68# kopete/jabber
69Requires: qca-ossl
70## krdc
71Requires: rdesktop
72
73# consolehelper
74Requires: usermode-gtk
75
76Obsoletes: kdenetwork4 < %{version}-%{release}
77Provides: kdenetwork4 = %{version}-%{release}
78
79Obsoletes: kopete <= 0.8.0
80Provides: kopete
81
82Conflicts: kdenetwork3
83
84%description
85Networking applications, including:
86
87* kget: downloader manager
88* kopete: chat client
89* krdc: a client for Desktop Sharing and other VNC servers
90* krfb: Desktop Sharing server, allow others to access your desktop via VNC
91
92%package libs
93Summary: Runtime libraries for %{name}
94Group:   System Environment/Libraries
95
96%description libs
97%{summary}.
98
99%package devel
100Summary: Development files for kdenetwork
101Group: Development/Libraries
102Requires: %{name}-libs = %{version}-%{release}
103Requires: kdelibs4-devel
104
105%description devel
106Development files for kdenetwork. Install kdenetwork-devel if you wish
107to develop or compile KDE networking applications.
108
109%package -n kppp
110Summary: Modem dialer and ppp frontend for KDE
111Summary(ja): KDE 用 ダイアルアップアプリケーション
112Group: Applications/Internet
113Requires: %{name}-libs = %{version}-%{release}
114Requires: ppp
115Obsoletes: kppp4 < %{version}-%{release}
116Provides:  kppp4 = %{version}-%{release}
117
118%description -n kppp
119KPPP is a dialer and front end for pppd. It allows for interactive
120script generation and network setup. It will automate the dialing in
121process to your ISP while letting you conveniently monitor the
122entire process.
123
124Once connected KPPP will provide a rich set of statistics and keep
125track of the time spent online for you.
126
127
128%prep
129%setup -q -n kdenetwork-%{version} -a 1
130%patch1 -p1 -b .icon
131%patch2 -p1 -b .resolv-conf-path
132
133# Vine patches
134%patch1000 -p1 -b .noxmms
135
136%build
137mkdir -p %{_target_platform}
138pushd %{_target_platform}
139%cmake \
140    -DCMAKE_BUILD_TYPE=release \
141    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
142    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
143    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
144    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
145    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
146    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
147    -DMOZPLUGIN_INSTALL_DIR=%{_libdir}/mozilla/plugins \
148    -DLIBGADU_INCLUDE_DIR=%{_includedir} \
149    -DLIBGADU_LIBRARIES=%{_libdir}/libgadu.so \
150    ..
151popd
152
153make -C %{_target_platform}/doc
154make %{?_smp_mflags} -C %{_target_platform}
155
156
157%install
158rm -rf $RPM_BUILD_ROOT
159make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
160
161# Run kppp through consolehelper
162mkdir -p $RPM_BUILD_ROOT%{_sbindir} \
163         $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps \
164         $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
165
166chmod 0755 $RPM_BUILD_ROOT%{_bindir}/kppp
167mv $RPM_BUILD_ROOT%{_bindir}/kppp $RPM_BUILD_ROOT%{_sbindir}
168ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kppp
169
170install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kppp
171install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kppp
172
173
174# move devel symlinks
175mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
176pushd $RPM_BUILD_ROOT%{_libdir}
177for i in lib*.so
178do
179  case "$i" in
180# conflicts with kdenetwork3
181    libkopete.so | libkopete_oscar.so | libkopete_videodevice.so)
182      linktarget=`readlink "$i"`
183      rm -f "$i"
184      ln -sf "../../$linktarget" "kde4/devel/$i"
185      ;;
186  esac
187done
188popd
189
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
196touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
197
198%posttrans
199gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
200gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
201update-desktop-database -q &> /dev/null ||:
202
203%postun
204if [ $1 -eq 0 ] ; then
205  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
206  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
207  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
208  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
209  update-desktop-database -q &> /dev/null ||:
210fi
211
212%post libs -p /sbin/ldconfig
213
214%postun libs -p /sbin/ldconfig
215
216
217%files
218%defattr(-,root,root)
219%{_bindir}/*
220%exclude %{_bindir}/kppp*
221%{_datadir}/kde4/apps/dolphinpart/kpartplugins/kget_plug_in.desktop
222%{_datadir}/kde4/apps/dolphinpart/kpartplugins/kget_plug_in.rc
223%{_datadir}/kde4/apps/kconf_update/*
224%{_datadir}/kde4/apps/kget
225%{_datadir}/kde4/apps/khtml/kpartplugins/kget_plug_in.desktop
226%{_datadir}/kde4/apps/khtml/kpartplugins/kget_plug_in.rc
227%{_datadir}/kde4/apps/kopete*
228%{_datadir}/kde4/apps/krfb
229%{_datadir}/kde4/apps/krdc
230%{_datadir}/kde4/apps/kwebkitpart/kpartplugins/kget_plug_in.desktop
231%{_datadir}/kde4/apps/kwebkitpart/kpartplugins/kget_plug_in.rc
232%{_datadir}/kde4/apps/remoteview
233#{_datadir}/kde4/apps/desktoptheme/default/widgets/kget.svg
234%{_datadir}/config/kopeterc
235%{_datadir}/applications/kde4/*
236%exclude %{_datadir}/applications/kde4/*ppp*.desktop
237%{_datadir}/config.kcfg/*
238%{_datadir}/dbus-1/interfaces/*
239%{_datadir}/dbus-1/services/*
240%{_datadir}/kde4/services/*
241%{_datadir}/kde4/servicetypes/*
242%{_datadir}/sounds/*
243%doc %{_docdir}/HTML/en/*
244%exclude %{_datadir}/doc/HTML/en/kppp
245%{_datadir}/icons/hicolor/*/*/*
246%exclude %{_datadir}/icons/hicolor/*/apps/kppp*
247%{_datadir}/icons/oxygen/*/*/*
248%{_libdir}/kde4/*.so
249%{_libdir}/mozilla/plugins/skypebuttons.so
250%{_libdir}/kde4/plugins/accessible/chatwindowaccessiblewidgetfactory.so
251
252%files libs
253%defattr(-,root,root,-)
254%{_libdir}/libqgroupwise.so
255%{_libdir}/lib*.so.*
256
257%files devel
258%defattr(-,root,root)
259%{_includedir}/kde4/kopete
260%{_includedir}/kde4/krdc
261%{_libdir}/lib*.so
262%{_libdir}/kde4/devel/lib*.so
263%exclude %{_libdir}/libqgroupwise.so
264
265%files -n kppp
266%defattr(-,root,root)
267%doc %{_datadir}/doc/HTML/en/kppp
268%config /etc/security/console.apps/kppp
269%config /etc/pam.d/kppp
270%{_bindir}/kppp*
271%{_sbindir}/kppp
272%{_datadir}/applications/kde4/*ppp*
273%{_datadir}/kde4/apps/kppp
274%{_datadir}/icons/hicolor/*/apps/kppp*
275
276%changelog
277* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
278- new upstream release
279
280* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.0-2
281- rebuild with libktorrent-1.1.2
282
283* Fri Aug  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
284- new upstream release
285
286* Sun Jun 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
287- new upstream release
288
289* Wed Apr 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-2
290- add BuildRequires: jasper-devel
291
292* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
293- new upstream release
294
295* Thu Mar  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-2
296- added BR: libXpm-devel, libXScrnSaver-devel
297
298* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
299- new upstream release
300- added Patch1000, build without xmms-devel
301
302* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
303- new upstream release
304
305* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
306- new upstream release
307- added Conflicts: kdenetwork3
308
309* Tue Jun 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-3
310- added BR: libXtst-devel
311
312* Mon May 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-2
313- security fixes: CVE-2010-1000, CVE-2010-1511 (#591966)
314
315* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
316- new upstream release
317
318* Wed Apr 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
319- rebuilt with libmsn-4.1
320
321* Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
322- new upstream release
323
324* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
325- new upstream release
326
327* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
328- new upstream release
329- built with new toolchain
330
331* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
332- new upstream release
333
334* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
335- new upstream release
336
337* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
338- new upstream release
339
340* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
341- applied new versioning policy, spec in UTF-8
342- added Patch0
343
344* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
345- rebuild for VineSeed
346
347* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
348- new upstream release
349
350* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
351- rebuild for VineSeed
352
353* Sat May 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
354- new upstream release
355- add BuildPrereq: speex-devel
356
357* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
358- new upstream release
359- remove BuildPrereq: xmms-devel and Requires: xmms
360
361* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
362- added --with-qt-libraries and --enable-libsuffix option
363- updated kppp.pamd
364
365* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
366- rebuild for VineSeed
367
368* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
369- new upstream release
370
371* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
372- rebuild for VineSeed
373
374* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
375- new upstream release
376
377* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
378- rebuild for VineSeed
379
380* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
381- new upstream release
382
383* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
384- rebuild for VineSeed
385
386* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
387- new upstream release
388
389* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl3
390- rebuild with wireless-tools-28-0vl0.pre15.1
391
392* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
393- rebuild for VineSeed
394
395* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
396- new upstream release
397
398* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
399- rebuild for VineSeed
400
401* Thu Nov 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
402- new upstream release
403
404* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
405- new upstream release
406
407* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
408- new upstream release
409- delete all patches
410
411* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
412- new upstream release
413- add Patch0 - Patch1
414
415* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
416- rebuild for VineSeed
417
418* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
419- new upstream release
420- remove Patch0
421
422* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl4
423- rebuild for VineSeed
424
425* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl3
426- add Patch0 (CAN-2005-1852)
427
428* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
429- build for VineSeed
430- add --disable-rpath to configure option
431
432* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
433- new upstream release
434- use %%{?_smp_mflags} for make option
435
436* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
437- rebuild for VineSeed
438
439* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
440- new upstream release
441- update %%files
442
443* Thu Jan 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
444- new upstream release
445- add BuildPrereq: xmms-devel and Requires: xmms
446
447* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
448- rebuild for VineSeed
449
450* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
451- source upgrade
452- build for Vine Linux 3.1
453
454* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
455- source upgrade
456- update %%files
457
458* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
459- rebuild with qt32
460
461* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
462- source upgrade
463- remove lines about vine26
464
465* Thu May 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
466- move %%{_libdir}/*.so to kdenetwork package
467
468* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
469- source upgrade
470- add URL: http://www.kde.org
471
472* Sat Mar 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
473- rebuild with openssl-0.9.7d
474
475* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
476- source upgrade
477- add Obsoletes: kopete <= 0.8.0 and Provides: kopete
478- add BuildPrereq: wireless-tools-devel
479- add Requires: wireless-toolss-tools-devel
480- add Requires: wireless-tools
481
482* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
483- rebuild for VineSeedPlus
484
485* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
486- source upgrade
487- build for VinePlus/2.6
488- (VinePlus/2.6) BuildPrereq: autoconf258
489
490* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
491- build for VineSeed with new toolchain and qt-3.2.3
492
493* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
494- rebuild with qt-3.2.1-0.26vl3
495
496* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
497- rebuild with qt-3.2.1-0vl3
498
499* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
500- build with gcc-3.2.3
501
502* Mon Sep 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
503- source upgrade
504- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
505
506* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
507- rebuild for Vine2.6
508
509* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
510- source upgrade
511- change spec to build with gcc295
512- change make option for SMP and add script
513
514* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
515- change spec to build with g++-2.95.3
516
517* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
518- source upgrade
519- remove Patch800 (included in this source)
520- add BuildPrereq: zlib-devel libjpeg-devel libpng-devel
521- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
522
523* Fri Apr  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
524- source upgrade
525- add patch800
526
527* Sat Mar  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
528- source upgrade
529- add BuildPrereq: arts >= 1:1.1
530- remove Patch0
531- disable all patches
532- change spec to make monolithic package only
533- Obsoletes: kdenetwork-libs
534
535* Sun Nov 17 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl3
536- add Patch0 (security patch)
537- add export PATH=`pwd`:$PATH to %build and %install section
538
539* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
540- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
541
542* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
543- source upgrade
544- BuildPrereq: autoconf253 objprelink2
545
546* Mon Aug 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp 3.0.3-0vl1
547- source upgrade
548
549* Tue Jul 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl2
550- add Patch801 from kde.gr.jp [Kdeveloper:02384]
551
552* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
553- source upgrade
554
555* Wed May  1 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
556- source update to 3.0
557- add configure option `--with-xinerama --enable-final'
558- add Requires
559- remove knewsticker
560- add Patch800 (from kde.gr.jp) and Patch900
561
562* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
563- merged with rawhide 3.0.0-0.cvs20020306.1
564- source update to cvs-20020329
565- add BuildPrereq: autoconf252 automake15
566- add %define monolithic 1
567- There is Vine's previous changes, hacked for Vine
568 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
569  - update to 2.2.2
570  - update Japanese patches (Patch1 to 5)
571 -- Wed Nov 28 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
572  - build for Vine Seed
573  - add Japanese patches (Patch2 to 6)
574
575* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
576- Rename subpackages
577
578* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.2
579- Rebuild with new kdelibs
580
581* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.1
582- Update
583
584* Tue Jan  8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020108.1
585- Update
586- Integrate ktalk stuff with xinetd
587
588* Tue Dec 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011218.1
589- Update
590- Split into subpackages
591
592* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
593- Update
594- Add build dependencies
595- Work around ia64 breakages
596
597* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010513.1
598- Update to CVS
599- clean up specfile
600- Use %%post -p and %%postun -p
601
602* Wed Feb 21 2001 Than Ngo <than@redhat.com>
603- 2.1-respin
604
605* Mon Feb 19 2001 Than Ngo <than@redhat.com>
606- update 2.1
607- fix dangling symlinks
608
609* Fri Feb  2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
610- Limit CPU usage to 2 CPUs to make asok happy
611
612* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
613- Update
614- Don't require perl, not everyone using ksirc is also using
615  ksirc perl scripting...
616
617* Mon Jan  8 2001 Bernhard Rosenkraenzer <bero@redhat.com>
618- Update (needed because of kdelibs change)
619- Obsolete kdenetwork2 (from 7.0 preview)
620
621* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
622- Update
623
624* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
625- Add missing PAM file, fix group
626
627* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
628- update to HEAD
629
630* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
631- Update CVS (fix kmail segfault with empty identity)
632
633* Tue Oct 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
634- Fix up consolehelper config
635
636* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
637- Update to current KDE_2_0_BRANCH (this should fix up knode)
638- Run kppp through consolehelper (Bug #20021)
639- Split of kppp and kppplog to a separate package, kdenetwork-ppp
640  (RFE #20022)
641
642* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
643- 2.0 final
644
645* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
646- 2.0
647
648* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
649- 1.93
650
651* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
652- new version
653
654* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
655- new snapshot
656- disable keystone for now (compiler problem)
657
658* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
659- new snapshot
660- some fixes to spec file
661
662* Tue Jul 18 2000 Than Ngo <than@redhat.de>
663- rebuilt with glibc-2.1.92-14 and gcc-2.96-40
664
665* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
666- Obsolete ktalk (powertools 6.x)
667- SMPify
668
669* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
670- use gcc 2.96
671- new snapshot
672
673* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
674- Epoch
675
676* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
677- new snapshot
678- ExcludeArch ia64 for now
679
680* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
681- new snapshot
682- move it to /usr, where it belongs
683
684* Mon Oct 25 1999 Bernhard Rosenkraenzer <bero@redhat.de>
685- initial RPM
Note: See TracBrowser for help on using the repository browser.