source: projects/specs/trunk/k/kdenetwork/kdenetwork-vl.spec @ 5356

Revision 5356, 20.4 KB checked in by Takemikaduchi, 12 years ago (diff)

parted-3.0

Line 
1Name: kdenetwork
2Summary: KDE Network Applications
3Summary(ja): KDE ネットワークアプリケーション集
4Version: 4.7.0
5Release: 2%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Internet
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdenetwork-%{version}.tar.bz2
12Source1: krdc-icons.tar.bz2
13Source2: kppp.console
14Source3: kppp.pamd
15
16## upstream me!  -- Rex :)
17Patch1: kdenetwork-4.2.98-kdrc-icon.patch
18# rhbz#540433 - KPPP is unable to add DNS entries to /etc/resolv.conf
19Patch2: kdenetwork-4.3.3-resolv-conf-path.patch
20
21## security patches
22
23# Vine patches
24# Don't build with xmms-devel
25Patch1000: kdenetwork-4.6.0-noxmms.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: alsa-lib-devel
29BuildRequires: expat-devel
30BuildRequires: giflib-devel
31BuildRequires: glib2-devel
32BuildRequires: gmp-devel
33BuildRequires: gpgme-devel
34BuildRequires: kdebase-devel >= %{version}
35BuildRequires: kdebase-workspace-devel >= %{version}
36BuildRequires: kdelibs4-devel >= %{version}
37BuildRequires: kdepimlibs-devel >= %{version}
38BuildRequires: libboost-devel
39BuildRequires: libgadu-devel >= 1.8.0
40BuildRequires: libidn-devel
41BuildRequires: libjpeg-devel
42BuildRequires: libktorrent-devel
43BuildRequires: libmsn-devel >= 4.1
44BuildRequires: libotr-devel
45BuildRequires: libv4l-devel
46BuildRequires: libvncserver-devel
47BuildRequires: libxml2-devel
48BuildRequires: libXpm-devel
49BuildRequires: libXScrnSaver-devel
50BuildRequires: libxslt-devel
51BuildRequires: libXtst-devel
52BuildRequires: meanwhile-devel
53BuildRequires: ortp-devel
54BuildRequires: qca2-devel
55BuildRequires: plasma-devel >= %{version}
56BuildRequires: qimageblitz-devel
57BuildRequires: soprano-devel >= 2.0.97
58BuildRequires: speex-devel
59BuildRequires: sqlite3-devel
60BuildRequires: strigi-devel
61BuildRequires: jasper-devel
62
63Requires: kdebase-runtime >= 4.6
64Requires: %{name}-libs = %{version}-%{release}
65
66# kopete/yahoo
67Requires: jasper
68# kopete/jabber
69Requires: qca-ossl
70## krdc
71Requires: rdesktop
72
73# consolehelper
74Requires: usermode-gtk
75
76Obsoletes: kdenetwork4 < %{version}-%{release}
77Provides: kdenetwork4 = %{version}-%{release}
78
79Obsoletes: kopete <= 0.8.0
80Provides: kopete
81
82Conflicts: kdenetwork3
83
84%description
85Networking applications, including:
86
87* kget: downloader manager
88* kopete: chat client
89* krdc: a client for Desktop Sharing and other VNC servers
90* krfb: Desktop Sharing server, allow others to access your desktop via VNC
91
92%package libs
93Summary: Runtime libraries for %{name}
94Group:   System Environment/Libraries
95
96%description libs
97%{summary}.
98
99%package devel
100Summary: Development files for kdenetwork
101Group: Development/Libraries
102Requires: %{name}-libs = %{version}-%{release}
103Requires: kdelibs4-devel
104
105%description devel
106Development files for kdenetwork. Install kdenetwork-devel if you wish
107to develop or compile KDE networking applications.
108
109%package -n kppp
110Summary: Modem dialer and ppp frontend for KDE
111Summary(ja): KDE 用 ダイアルアップアプリケーション
112Group: Applications/Internet
113Requires: %{name}-libs = %{version}-%{release}
114Requires: ppp
115Obsoletes: kppp4 < %{version}-%{release}
116Provides:  kppp4 = %{version}-%{release}
117
118%description -n kppp
119KPPP is a dialer and front end for pppd. It allows for interactive
120script generation and network setup. It will automate the dialing in
121process to your ISP while letting you conveniently monitor the
122entire process.
123
124Once connected KPPP will provide a rich set of statistics and keep
125track of the time spent online for you.
126
127
128%prep
129%setup -q -n kdenetwork-%{version} -a 1
130%patch1 -p1 -b .icon
131%patch2 -p1 -b .resolv-conf-path
132
133# Vine patches
134%patch1000 -p1 -b .noxmms
135
136%build
137mkdir -p %{_target_platform}
138pushd %{_target_platform}
139unset QTDIR || : ; . /etc/profile.d/qt4.sh
140%cmake \
141    -DCMAKE_BUILD_TYPE=release \
142    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
143    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
144    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
145    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
146    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
147    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
148    -DMOZPLUGIN_INSTALL_DIR=%{_libdir}/mozilla/plugins \
149    -DLIBGADU_INCLUDE_DIR=%{_includedir} \
150    -DLIBGADU_LIBRARIES=%{_libdir}/libgadu.so \
151    ..
152popd
153
154make -C %{_target_platform}/doc
155make %{?_smp_mflags} -C %{_target_platform}
156
157
158%install
159rm -rf $RPM_BUILD_ROOT
160make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
161
162# Run kppp through consolehelper
163mkdir -p $RPM_BUILD_ROOT%{_sbindir} \
164         $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps \
165         $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
166
167chmod 0755 $RPM_BUILD_ROOT%{_bindir}/kppp
168mv $RPM_BUILD_ROOT%{_bindir}/kppp $RPM_BUILD_ROOT%{_sbindir}
169ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kppp
170
171install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kppp
172install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kppp
173
174
175# move devel symlinks
176mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
177pushd $RPM_BUILD_ROOT%{_libdir}
178for i in lib*.so
179do
180  case "$i" in
181# conflicts with kdenetwork3
182    libkopete.so | libkopete_oscar.so | libkopete_videodevice.so)
183      linktarget=`readlink "$i"`
184      rm -f "$i"
185      ln -sf "../../$linktarget" "kde4/devel/$i"
186      ;;
187  esac
188done
189popd
190
191
192%clean
193rm -rf $RPM_BUILD_ROOT
194
195%post
196touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
197touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
198
199%posttrans
200gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
201gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
202update-desktop-database -q &> /dev/null ||:
203
204%postun
205if [ $1 -eq 0 ] ; then
206  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
207  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
208  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
209  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
210  update-desktop-database -q &> /dev/null ||:
211fi
212
213%post libs -p /sbin/ldconfig
214
215%postun libs -p /sbin/ldconfig
216
217
218%files
219%defattr(-,root,root)
220%{_bindir}/*
221%exclude %{_bindir}/kppp*
222%{_datadir}/kde4/apps/dolphinpart/kpartplugins/kget_plug_in.desktop
223%{_datadir}/kde4/apps/dolphinpart/kpartplugins/kget_plug_in.rc
224%{_datadir}/kde4/apps/kconf_update/*
225%{_datadir}/kde4/apps/kget
226%{_datadir}/kde4/apps/khtml/kpartplugins/kget_plug_in.desktop
227%{_datadir}/kde4/apps/khtml/kpartplugins/kget_plug_in.rc
228%{_datadir}/kde4/apps/kopete*
229%{_datadir}/kde4/apps/krfb
230%{_datadir}/kde4/apps/krdc
231%{_datadir}/kde4/apps/kwebkitpart/kpartplugins/kget_plug_in.desktop
232%{_datadir}/kde4/apps/kwebkitpart/kpartplugins/kget_plug_in.rc
233%{_datadir}/kde4/apps/remoteview
234#{_datadir}/kde4/apps/desktoptheme/default/widgets/kget.svg
235%{_datadir}/config/kopeterc
236%{_datadir}/applications/kde4/*
237%exclude %{_datadir}/applications/kde4/*ppp*.desktop
238%{_datadir}/config.kcfg/*
239%{_datadir}/dbus-1/interfaces/*
240%{_datadir}/dbus-1/services/*
241%{_datadir}/kde4/services/*
242%{_datadir}/kde4/servicetypes/*
243%{_datadir}/sounds/*
244%doc %{_docdir}/HTML/en/*
245%exclude %{_datadir}/doc/HTML/en/kppp
246%{_datadir}/icons/hicolor/*/*/*
247%exclude %{_datadir}/icons/hicolor/*/apps/kppp*
248%{_datadir}/icons/oxygen/*/*/*
249%{_libdir}/kde4/*.so
250%{_libdir}/mozilla/plugins/skypebuttons.so
251
252%files libs
253%defattr(-,root,root,-)
254%{_libdir}/libqgroupwise.so
255%{_libdir}/lib*.so.*
256
257%files devel
258%defattr(-,root,root)
259%{_includedir}/kde4/kopete
260%{_includedir}/kde4/krdc
261%{_libdir}/lib*.so
262%{_libdir}/kde4/devel/lib*.so
263%exclude %{_libdir}/libqgroupwise.so
264
265%files -n kppp
266%defattr(-,root,root)
267%doc %{_datadir}/doc/HTML/en/kppp
268%config /etc/security/console.apps/kppp
269%config /etc/pam.d/kppp
270%{_bindir}/kppp*
271%{_sbindir}/kppp
272%{_datadir}/applications/kde4/*ppp*
273%{_datadir}/kde4/apps/kppp
274%{_datadir}/icons/hicolor/*/apps/kppp*
275
276%changelog
277* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.0-2
278- rebuild with libktorrent-1.1.2
279
280* Fri Aug  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
281- new upstream release
282
283* Sun Jun 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
284- new upstream release
285
286* Wed Apr 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-2
287- add BuildRequires: jasper-devel
288
289* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
290- new upstream release
291
292* Thu Mar  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-2
293- added BR: libXpm-devel, libXScrnSaver-devel
294
295* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
296- new upstream release
297- added Patch1000, build without xmms-devel
298
299* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
300- new upstream release
301
302* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
303- new upstream release
304- added Conflicts: kdenetwork3
305
306* Tue Jun 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-3
307- added BR: libXtst-devel
308
309* Mon May 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-2
310- security fixes: CVE-2010-1000, CVE-2010-1511 (#591966)
311
312* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
313- new upstream release
314
315* Wed Apr 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
316- rebuilt with libmsn-4.1
317
318* Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
319- new upstream release
320
321* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
322- new upstream release
323
324* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
325- new upstream release
326- built with new toolchain
327
328* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
329- new upstream release
330
331* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
332- new upstream release
333
334* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
335- new upstream release
336
337* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
338- applied new versioning policy, spec in UTF-8
339- added Patch0
340
341* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
342- rebuild for VineSeed
343
344* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
345- new upstream release
346
347* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
348- rebuild for VineSeed
349
350* Sat May 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
351- new upstream release
352- add BuildPrereq: speex-devel
353
354* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
355- new upstream release
356- remove BuildPrereq: xmms-devel and Requires: xmms
357
358* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
359- added --with-qt-libraries and --enable-libsuffix option
360- updated kppp.pamd
361
362* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
363- rebuild for VineSeed
364
365* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
366- new upstream release
367
368* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
369- rebuild for VineSeed
370
371* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
372- new upstream release
373
374* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
375- rebuild for VineSeed
376
377* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
378- new upstream release
379
380* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
381- rebuild for VineSeed
382
383* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
384- new upstream release
385
386* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl3
387- rebuild with wireless-tools-28-0vl0.pre15.1
388
389* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
390- rebuild for VineSeed
391
392* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
393- new upstream release
394
395* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
396- rebuild for VineSeed
397
398* Thu Nov 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
399- new upstream release
400
401* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
402- new upstream release
403
404* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
405- new upstream release
406- delete all patches
407
408* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
409- new upstream release
410- add Patch0 - Patch1
411
412* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
413- rebuild for VineSeed
414
415* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
416- new upstream release
417- remove Patch0
418
419* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl4
420- rebuild for VineSeed
421
422* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl3
423- add Patch0 (CAN-2005-1852)
424
425* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
426- build for VineSeed
427- add --disable-rpath to configure option
428
429* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
430- new upstream release
431- use %%{?_smp_mflags} for make option
432
433* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
434- rebuild for VineSeed
435
436* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
437- new upstream release
438- update %%files
439
440* Thu Jan 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
441- new upstream release
442- add BuildPrereq: xmms-devel and Requires: xmms
443
444* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
445- rebuild for VineSeed
446
447* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
448- source upgrade
449- build for Vine Linux 3.1
450
451* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
452- source upgrade
453- update %%files
454
455* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
456- rebuild with qt32
457
458* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
459- source upgrade
460- remove lines about vine26
461
462* Thu May 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
463- move %%{_libdir}/*.so to kdenetwork package
464
465* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
466- source upgrade
467- add URL: http://www.kde.org
468
469* Sat Mar 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
470- rebuild with openssl-0.9.7d
471
472* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
473- source upgrade
474- add Obsoletes: kopete <= 0.8.0 and Provides: kopete
475- add BuildPrereq: wireless-tools-devel
476- add Requires: wireless-toolss-tools-devel
477- add Requires: wireless-tools
478
479* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
480- rebuild for VineSeedPlus
481
482* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
483- source upgrade
484- build for VinePlus/2.6
485- (VinePlus/2.6) BuildPrereq: autoconf258
486
487* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
488- build for VineSeed with new toolchain and qt-3.2.3
489
490* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
491- rebuild with qt-3.2.1-0.26vl3
492
493* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
494- rebuild with qt-3.2.1-0vl3
495
496* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
497- build with gcc-3.2.3
498
499* Mon Sep 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
500- source upgrade
501- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
502
503* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
504- rebuild for Vine2.6
505
506* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
507- source upgrade
508- change spec to build with gcc295
509- change make option for SMP and add script
510
511* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
512- change spec to build with g++-2.95.3
513
514* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
515- source upgrade
516- remove Patch800 (included in this source)
517- add BuildPrereq: zlib-devel libjpeg-devel libpng-devel
518- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
519
520* Fri Apr  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
521- source upgrade
522- add patch800
523
524* Sat Mar  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
525- source upgrade
526- add BuildPrereq: arts >= 1:1.1
527- remove Patch0
528- disable all patches
529- change spec to make monolithic package only
530- Obsoletes: kdenetwork-libs
531
532* Sun Nov 17 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl3
533- add Patch0 (security patch)
534- add export PATH=`pwd`:$PATH to %build and %install section
535
536* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
537- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
538
539* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
540- source upgrade
541- BuildPrereq: autoconf253 objprelink2
542
543* Mon Aug 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp 3.0.3-0vl1
544- source upgrade
545
546* Tue Jul 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl2
547- add Patch801 from kde.gr.jp [Kdeveloper:02384]
548
549* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
550- source upgrade
551
552* Wed May  1 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
553- source update to 3.0
554- add configure option `--with-xinerama --enable-final'
555- add Requires
556- remove knewsticker
557- add Patch800 (from kde.gr.jp) and Patch900
558
559* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
560- merged with rawhide 3.0.0-0.cvs20020306.1
561- source update to cvs-20020329
562- add BuildPrereq: autoconf252 automake15
563- add %define monolithic 1
564- There is Vine's previous changes, hacked for Vine
565 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
566  - update to 2.2.2
567  - update Japanese patches (Patch1 to 5)
568 -- Wed Nov 28 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
569  - build for Vine Seed
570  - add Japanese patches (Patch2 to 6)
571
572* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
573- Rename subpackages
574
575* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.2
576- Rebuild with new kdelibs
577
578* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.1
579- Update
580
581* Tue Jan  8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020108.1
582- Update
583- Integrate ktalk stuff with xinetd
584
585* Tue Dec 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011218.1
586- Update
587- Split into subpackages
588
589* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
590- Update
591- Add build dependencies
592- Work around ia64 breakages
593
594* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010513.1
595- Update to CVS
596- clean up specfile
597- Use %%post -p and %%postun -p
598
599* Wed Feb 21 2001 Than Ngo <than@redhat.com>
600- 2.1-respin
601
602* Mon Feb 19 2001 Than Ngo <than@redhat.com>
603- update 2.1
604- fix dangling symlinks
605
606* Fri Feb  2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
607- Limit CPU usage to 2 CPUs to make asok happy
608
609* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
610- Update
611- Don't require perl, not everyone using ksirc is also using
612  ksirc perl scripting...
613
614* Mon Jan  8 2001 Bernhard Rosenkraenzer <bero@redhat.com>
615- Update (needed because of kdelibs change)
616- Obsolete kdenetwork2 (from 7.0 preview)
617
618* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
619- Update
620
621* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
622- Add missing PAM file, fix group
623
624* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
625- update to HEAD
626
627* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
628- Update CVS (fix kmail segfault with empty identity)
629
630* Tue Oct 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
631- Fix up consolehelper config
632
633* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
634- Update to current KDE_2_0_BRANCH (this should fix up knode)
635- Run kppp through consolehelper (Bug #20021)
636- Split of kppp and kppplog to a separate package, kdenetwork-ppp
637  (RFE #20022)
638
639* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
640- 2.0 final
641
642* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
643- 2.0
644
645* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
646- 1.93
647
648* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
649- new version
650
651* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
652- new snapshot
653- disable keystone for now (compiler problem)
654
655* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
656- new snapshot
657- some fixes to spec file
658
659* Tue Jul 18 2000 Than Ngo <than@redhat.de>
660- rebuilt with glibc-2.1.92-14 and gcc-2.96-40
661
662* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
663- Obsolete ktalk (powertools 6.x)
664- SMPify
665
666* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
667- use gcc 2.96
668- new snapshot
669
670* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
671- Epoch
672
673* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
674- new snapshot
675- ExcludeArch ia64 for now
676
677* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
678- new snapshot
679- move it to /usr, where it belongs
680
681* Mon Oct 25 1999 Bernhard Rosenkraenzer <bero@redhat.de>
682- initial RPM
Note: See TracBrowser for help on using the repository browser.