source: projects/specs/trunk/k/kdenetwork/kdenetwork-vl.spec @ 1263

Revision 1263, 17.9 KB checked in by inagaki, 14 years ago (diff)

updated: kdebase, kdenetwork, kdeaccessibility, kdesdk

Line 
1Name: kdenetwork
2Summary: K Desktop Environment - Network Applications
3Summary(ja): K デスクトップ環境 - ネットワークアプリケーション集
4Version: 4.4.3
5Release: 3%{?_dist_release}
6
7Group: Applications/Internet
8License: GPLv2
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
12Source1: krdc-icons.tar.bz2
13Source2: kppp.pamd
14
15## upstream me!  -- Rex :)
16Patch1: kdenetwork-4.2.98-kdrc-icon.patch
17# rhbz#540433 - KPPP is unable to add DNS entries to /etc/resolv.conf
18Patch2: kdenetwork-4.3.3-resolv-conf-path.patch
19
20## security patches
21# rhbz#591966 -  CVE-2010-1000 CVE-2010-1511 kdenetwork: improper sanitization
22# of metalink attribute for downloading files
23Patch100: kdenetwork-4.4.3-cve-2010-1000_1511.patch
24
25# Vine patches
26Patch1000: kdenetwork-3.5.8-kopete-fs.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: libboost-devel
30BuildRequires: giflib-devel
31BuildRequires: glib2-devel
32BuildRequires: gmp-devel
33BuildRequires: kdelibs4-devel >= %{version}
34BuildRequires: kdepimlibs-devel >= %{version}
35BuildRequires: libgadu-devel >= 1.8.0
36BuildRequires: libidn-devel
37BuildRequires: libmsn-devel >= 4.0-0.beta2
38BuildRequires: libotr-devel
39BuildRequires: libvncserver-devel
40BuildRequires: libxslt-devel libxml2-devel
41BuildRequires: libXtst-devel
42BuildRequires: meanwhile-devel
43BuildRequires: openldap-devel
44BuildRequires: openslp-devel
45BuildRequires: ortp-devel
46BuildRequires: pcre-devel
47BuildRequires: qca2-devel
48BuildRequires: plasma-devel >= %{version}
49BuildRequires: qimageblitz-devel
50BuildRequires: soprano-devel >= 2.0.97
51BuildRequires: speex-devel
52BuildRequires: sqlite3-devel
53BuildRequires: libv4l-devel
54BuildRequires: xmms-devel
55
56Requires: kdepimlibs >= %{version}
57Requires: %{name}-libs = %{version}-%{release}
58
59Obsoletes: kopete <= 0.8.0
60Provides: kopete
61
62%description
63Networking applications for the K Desktop Environment.
64
65%package libs
66Summary: Runtime libraries for %{name}
67Group:   System Environment/Libraries
68
69%description libs
70%{summary}.
71
72%package devel
73Summary: Development files for kdenetwork
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76Requires: kdelibs4-devel
77
78%description devel
79Development files for kdenetwork. Install kdenetwork-devel if you wish
80to develop or compile KDE networking applications.
81
82%package -n kppp
83Summary: K Desktop Environment - PPP Network Applications
84Summary(ja): K デスクトップ環境 - PPP 通信アプリケーション
85Group: Applications/Internet
86Requires: %{name}-libs = %{version}-%{release}
87Requires: ppp
88
89%description -n kppp
90PPP Networking applications for the K Desktop Environment.
91
92Install kppp if you intend to use KDE on a machine using
93PPP networking.
94
95%prep
96%setup -q -a 1
97%patch1 -p1 -b .icon
98%patch2 -p1 -b .resolv-conf-path
99%patch100 -p0 -b .cve-2010-1000_1511
100
101# Vine patches
102%patch1000 -p1 -b .kopete
103
104%build
105mkdir -p %{_target_platform}
106pushd %{_target_platform}
107unset QTDIR || : ; . /etc/profile.d/qt4.sh
108%cmake \
109    -DCMAKE_BUILD_TYPE=release \
110    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
111    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
112    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
113    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
114    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
115    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
116    -DMOZPLUGIN_INSTALL_DIR=%{_libdir}/mozilla/plugins \
117    -DLIBGADU_INCLUDE_DIR=%{_includedir} \
118    -DLIBGADU_LIBRARIES=%{_libdir}/libgadu.so \
119    ..
120popd
121
122make %{?_smp_mflags} -C %{_target_platform}
123
124
125%install
126rm -rf $RPM_BUILD_ROOT
127make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
128
129mkdir -p $RPM_BUILD_ROOT/etc/pam.d
130cp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/kppp
131
132# Run kppp through consolehelper
133mkdir -p $RPM_BUILD_ROOT%{_sbindir}
134mv $RPM_BUILD_ROOT%{_bindir}/kppp $RPM_BUILD_ROOT%{_sbindir}
135ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kppp
136mkdir -p $RPM_BUILD_ROOT/etc/security/console.apps
137cat >$RPM_BUILD_ROOT/etc/security/console.apps/kppp <<EOF
138USER=root
139PROGRAM=%{_sbindir}/kppp
140SESSION=true
141EOF
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%post
147touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
148touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
149
150%posttrans
151gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
152gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
153update-desktop-database -q &> /dev/null ||:
154
155%postun
156if [ $1 -eq 0 ] ; then
157  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
158  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
159  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
160  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
161  update-desktop-database -q &> /dev/null ||:
162fi
163
164%post libs -p /sbin/ldconfig
165
166%postun libs -p /sbin/ldconfig
167
168
169%files
170%defattr(-,root,root)
171%{_bindir}/*
172%exclude %{_bindir}/kppp*
173%{_datadir}/kde4/apps/kconf_update/*
174%{_datadir}/kde4/apps/kget
175%{_datadir}/kde4/apps/khtml/kpartplugins/kget_plug_in.rc
176%{_datadir}/kde4/apps/kopete*
177%{_datadir}/kde4/apps/krfb
178%{_datadir}/kde4/apps/krdc
179%{_datadir}/kde4/apps/remoteview
180#{_datadir}/kde4/apps/desktoptheme/default/widgets/kget.svg
181%{_datadir}/config/kopeterc
182%{_datadir}/applications/kde4/*
183%exclude %{_datadir}/applications/kde4/*ppp*.desktop
184%{_datadir}/config.kcfg/*
185%{_datadir}/dbus-1/interfaces/*
186%{_datadir}/dbus-1/services/*
187%{_datadir}/kde4/services/*
188%{_datadir}/kde4/servicetypes/*
189%{_datadir}/sounds/*
190%doc %{_docdir}/HTML/en/*
191%exclude %{_datadir}/doc/HTML/en/kppp
192%{_datadir}/icons/hicolor/*/*/*
193%{_datadir}/icons/oxygen/*/*/*
194%{_libdir}/kde4/*.so
195%{_libdir}/mozilla/plugins/skypebuttons.so
196
197%files libs
198%defattr(-,root,root,-)
199%{_libdir}/libqgroupwise.so
200%{_libdir}/lib*.so.*
201
202%files devel
203%defattr(-,root,root)
204%{_includedir}/kde4/kopete
205%{_includedir}/kde4/krdc
206%{_libdir}/lib*.so
207%exclude %{_libdir}/libqgroupwise.so
208
209%files -n kppp
210%defattr(-,root,root)
211%doc %{_datadir}/doc/HTML/en/kppp
212%config /etc/security/console.apps/kppp
213%config /etc/pam.d/kppp
214%{_bindir}/kppp*
215%{_sbindir}/kppp
216%{_datadir}/applications/kde4/*ppp*
217%{_datadir}/kde4/apps/kppp
218
219%changelog
220* Tue Jun 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-3
221- added BR: libXtst-devel
222
223* Mon May 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-2
224- security fixes: CVE-2010-1000, CVE-2010-1511 (#591966)
225
226* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
227- new upstream release
228
229* Wed Apr 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
230- rebuilt with libmsn-4.1
231
232* Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
233- new upstream release
234
235* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
236- new upstream release
237
238* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
239- new upstream release
240- built with new toolchain
241
242* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
243- new upstream release
244
245* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
246- new upstream release
247
248* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
249- new upstream release
250
251* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
252- applied new versioning policy, spec in UTF-8
253- added Patch0
254
255* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
256- rebuild for VineSeed
257
258* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
259- new upstream release
260
261* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
262- rebuild for VineSeed
263
264* Sat May 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
265- new upstream release
266- add BuildPrereq: speex-devel
267
268* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
269- new upstream release
270- remove BuildPrereq: xmms-devel and Requires: xmms
271
272* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
273- added --with-qt-libraries and --enable-libsuffix option
274- updated kppp.pamd
275
276* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
277- rebuild for VineSeed
278
279* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
280- new upstream release
281
282* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
283- rebuild for VineSeed
284
285* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
286- new upstream release
287
288* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
289- rebuild for VineSeed
290
291* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
292- new upstream release
293
294* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
295- rebuild for VineSeed
296
297* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
298- new upstream release
299
300* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl3
301- rebuild with wireless-tools-28-0vl0.pre15.1
302
303* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
304- rebuild for VineSeed
305
306* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
307- new upstream release
308
309* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
310- rebuild for VineSeed
311
312* Thu Nov 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
313- new upstream release
314
315* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
316- new upstream release
317
318* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
319- new upstream release
320- delete all patches
321
322* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
323- new upstream release
324- add Patch0 - Patch1
325
326* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
327- rebuild for VineSeed
328
329* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
330- new upstream release
331- remove Patch0
332
333* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl4
334- rebuild for VineSeed
335
336* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl3
337- add Patch0 (CAN-2005-1852)
338
339* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
340- build for VineSeed
341- add --disable-rpath to configure option
342
343* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
344- new upstream release
345- use %%{?_smp_mflags} for make option
346
347* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
348- rebuild for VineSeed
349
350* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
351- new upstream release
352- update %%files
353
354* Thu Jan 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
355- new upstream release
356- add BuildPrereq: xmms-devel and Requires: xmms
357
358* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
359- rebuild for VineSeed
360
361* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
362- source upgrade
363- build for Vine Linux 3.1
364
365* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
366- source upgrade
367- update %%files
368
369* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
370- rebuild with qt32
371
372* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
373- source upgrade
374- remove lines about vine26
375
376* Thu May 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
377- move %%{_libdir}/*.so to kdenetwork package
378
379* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
380- source upgrade
381- add URL: http://www.kde.org
382
383* Sat Mar 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
384- rebuild with openssl-0.9.7d
385
386* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
387- source upgrade
388- add Obsoletes: kopete <= 0.8.0 and Provides: kopete
389- add BuildPrereq: wireless-tools-devel
390- add Requires: wireless-toolss-tools-devel
391- add Requires: wireless-tools
392
393* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
394- rebuild for VineSeedPlus
395
396* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
397- source upgrade
398- build for VinePlus/2.6
399- (VinePlus/2.6) BuildPrereq: autoconf258
400
401* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
402- build for VineSeed with new toolchain and qt-3.2.3
403
404* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
405- rebuild with qt-3.2.1-0.26vl3
406
407* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
408- rebuild with qt-3.2.1-0vl3
409
410* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
411- build with gcc-3.2.3
412
413* Mon Sep 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
414- source upgrade
415- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
416
417* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
418- rebuild for Vine2.6
419
420* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
421- source upgrade
422- change spec to build with gcc295
423- change make option for SMP and add script
424
425* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
426- change spec to build with g++-2.95.3
427
428* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
429- source upgrade
430- remove Patch800 (included in this source)
431- add BuildPrereq: zlib-devel libjpeg-devel libpng-devel
432- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
433
434* Fri Apr  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
435- source upgrade
436- add patch800
437
438* Sat Mar  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
439- source upgrade
440- add BuildPrereq: arts >= 1:1.1
441- remove Patch0
442- disable all patches
443- change spec to make monolithic package only
444- Obsoletes: kdenetwork-libs
445
446* Sun Nov 17 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl3
447- add Patch0 (security patch)
448- add export PATH=`pwd`:$PATH to %build and %install section
449
450* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
451- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
452
453* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
454- source upgrade
455- BuildPrereq: autoconf253 objprelink2
456
457* Mon Aug 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp 3.0.3-0vl1
458- source upgrade
459
460* Tue Jul 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl2
461- add Patch801 from kde.gr.jp [Kdeveloper:02384]
462
463* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
464- source upgrade
465
466* Wed May  1 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
467- source update to 3.0
468- add configure option `--with-xinerama --enable-final'
469- add Requires
470- remove knewsticker
471- add Patch800 (from kde.gr.jp) and Patch900
472
473* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
474- merged with rawhide 3.0.0-0.cvs20020306.1
475- source update to cvs-20020329
476- add BuildPrereq: autoconf252 automake15
477- add %define monolithic 1
478- There is Vine's previous changes, hacked for Vine
479 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
480  - update to 2.2.2
481  - update Japanese patches (Patch1 to 5)
482 -- Wed Nov 28 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
483  - build for Vine Seed
484  - add Japanese patches (Patch2 to 6)
485
486* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
487- Rename subpackages
488
489* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.2
490- Rebuild with new kdelibs
491
492* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.1
493- Update
494
495* Tue Jan  8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020108.1
496- Update
497- Integrate ktalk stuff with xinetd
498
499* Tue Dec 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011218.1
500- Update
501- Split into subpackages
502
503* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
504- Update
505- Add build dependencies
506- Work around ia64 breakages
507
508* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010513.1
509- Update to CVS
510- clean up specfile
511- Use %%post -p and %%postun -p
512
513* Wed Feb 21 2001 Than Ngo <than@redhat.com>
514- 2.1-respin
515
516* Mon Feb 19 2001 Than Ngo <than@redhat.com>
517- update 2.1
518- fix dangling symlinks
519
520* Fri Feb  2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
521- Limit CPU usage to 2 CPUs to make asok happy
522
523* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
524- Update
525- Don't require perl, not everyone using ksirc is also using
526  ksirc perl scripting...
527
528* Mon Jan  8 2001 Bernhard Rosenkraenzer <bero@redhat.com>
529- Update (needed because of kdelibs change)
530- Obsolete kdenetwork2 (from 7.0 preview)
531
532* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
533- Update
534
535* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
536- Add missing PAM file, fix group
537
538* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
539- update to HEAD
540
541* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- Update CVS (fix kmail segfault with empty identity)
543
544* Tue Oct 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
545- Fix up consolehelper config
546
547* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
548- Update to current KDE_2_0_BRANCH (this should fix up knode)
549- Run kppp through consolehelper (Bug #20021)
550- Split of kppp and kppplog to a separate package, kdenetwork-ppp
551  (RFE #20022)
552
553* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
554- 2.0 final
555
556* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
557- 2.0
558
559* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
560- 1.93
561
562* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
563- new version
564
565* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
566- new snapshot
567- disable keystone for now (compiler problem)
568
569* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
570- new snapshot
571- some fixes to spec file
572
573* Tue Jul 18 2000 Than Ngo <than@redhat.de>
574- rebuilt with glibc-2.1.92-14 and gcc-2.96-40
575
576* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
577- Obsolete ktalk (powertools 6.x)
578- SMPify
579
580* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
581- use gcc 2.96
582- new snapshot
583
584* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
585- Epoch
586
587* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
588- new snapshot
589- ExcludeArch ia64 for now
590
591* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
592- new snapshot
593- move it to /usr, where it belongs
594
595* Mon Oct 25 1999 Bernhard Rosenkraenzer <bero@redhat.de>
596- initial RPM
Note: See TracBrowser for help on using the repository browser.