source: projects/specs/trunk/k/kdenetwork/kdenetwork-vl.spec @ 1032

Revision 1032, 17.7 KB checked in by inagaki, 14 years ago (diff)

updated: kdenetwork

Line 
1Name: kdenetwork
2Version: 4.4.3
3Release: 2%{?_dist_release}
4Summary: K Desktop Environment - Network Applications
5Summary(ja): K デスクトップ環境 - ネットワークアプリケーション集
6Group: Applications/Internet
7License: GPLv2
8URL: http://www.kde.org/
9
10Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
11Source1: krdc-icons.tar.bz2
12Source2: kppp.pamd
13
14## upstream me!  -- Rex :)
15Patch1: kdenetwork-4.2.98-kdrc-icon.patch
16# rhbz#540433 - KPPP is unable to add DNS entries to /etc/resolv.conf
17Patch2: kdenetwork-4.3.3-resolv-conf-path.patch
18
19## security patches
20# rhbz#591966 -  CVE-2010-1000 CVE-2010-1511 kdenetwork: improper sanitization
21# of metalink attribute for downloading files
22Patch100: kdenetwork-4.4.3-cve-2010-1000_1511.patch
23
24# Vine patches
25Patch1000: kdenetwork-3.5.8-kopete-fs.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: libboost-devel
29BuildRequires: giflib-devel
30BuildRequires: glib2-devel
31BuildRequires: gmp-devel
32BuildRequires: kdelibs4-devel >= %{version}
33BuildRequires: kdepimlibs-devel >= %{version}
34BuildRequires: libgadu-devel >= 1.8.0
35BuildRequires: libidn-devel
36BuildRequires: libmsn-devel >= 4.0-0.beta2
37BuildRequires: libotr-devel
38BuildRequires: libvncserver-devel
39BuildRequires: libxslt-devel libxml2-devel
40BuildRequires: meanwhile-devel
41BuildRequires: openldap-devel
42BuildRequires: openslp-devel
43BuildRequires: ortp-devel
44BuildRequires: pcre-devel
45BuildRequires: qca2-devel
46BuildRequires: plasma-devel >= %{version}
47BuildRequires: qimageblitz-devel
48BuildRequires: soprano-devel >= 2.0.97
49BuildRequires: speex-devel
50BuildRequires: sqlite3-devel
51BuildRequires: libv4l-devel
52BuildRequires: xmms-devel
53
54Requires: kdepimlibs >= %{version}
55Requires: %{name}-libs = %{version}-%{release}
56
57Obsoletes: kopete <= 0.8.0
58Provides: kopete
59
60%description
61Networking applications for the K Desktop Environment.
62
63%package libs
64Summary: Runtime libraries for %{name}
65Group:   System Environment/Libraries
66
67%description libs
68%{summary}.
69
70%package devel
71Summary: Development files for kdenetwork
72Group: Development/Libraries
73Requires: %{name} = %{version}-%{release}
74Requires: kdelibs4-devel
75
76%description devel
77Development files for kdenetwork. Install kdenetwork-devel if you wish
78to develop or compile KDE networking applications.
79
80%package -n kppp
81Summary: K Desktop Environment - PPP Network Applications
82Summary(ja): K デスクトップ環境 - PPP 通信アプリケーション
83Group: Applications/Internet
84Requires: %{name}-libs = %{version}-%{release}
85Requires: ppp
86
87%description -n kppp
88PPP Networking applications for the K Desktop Environment.
89
90Install kppp if you intend to use KDE on a machine using
91PPP networking.
92
93%prep
94%setup -q -a 1
95%patch1 -p1 -b .icon
96%patch2 -p1 -b .resolv-conf-path
97%patch100 -p0 -b .cve-2010-1000_1511
98
99# Vine patches
100%patch1000 -p1 -b .kopete
101
102%build
103mkdir -p %{_target_platform}
104pushd %{_target_platform}
105unset QTDIR || : ; . /etc/profile.d/qt4.sh
106%cmake \
107    -DCMAKE_BUILD_TYPE=release \
108    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
109    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
110    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
111    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
112    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
113    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
114    -DMOZPLUGIN_INSTALL_DIR=%{_libdir}/mozilla/plugins \
115    -DLIBGADU_INCLUDE_DIR=%{_includedir} \
116    -DLIBGADU_LIBRARIES=%{_libdir}/libgadu.so \
117    ..
118popd
119
120make %{?_smp_mflags} -C %{_target_platform}
121
122
123%install
124rm -rf $RPM_BUILD_ROOT
125make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
126
127mkdir -p $RPM_BUILD_ROOT/etc/pam.d
128cp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/kppp
129
130# Run kppp through consolehelper
131mkdir -p $RPM_BUILD_ROOT%{_sbindir}
132mv $RPM_BUILD_ROOT%{_bindir}/kppp $RPM_BUILD_ROOT%{_sbindir}
133ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kppp
134mkdir -p $RPM_BUILD_ROOT/etc/security/console.apps
135cat >$RPM_BUILD_ROOT/etc/security/console.apps/kppp <<EOF
136USER=root
137PROGRAM=%{_sbindir}/kppp
138SESSION=true
139EOF
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%post
145touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
146touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
147
148%posttrans
149gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
150gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
151update-desktop-database -q &> /dev/null ||:
152
153%postun
154if [ $1 -eq 0 ] ; then
155  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
156  touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
157  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
158  gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
159  update-desktop-database -q &> /dev/null ||:
160fi
161
162%post libs -p /sbin/ldconfig
163
164%postun libs -p /sbin/ldconfig
165
166
167%files
168%defattr(-,root,root)
169%{_bindir}/*
170%exclude %{_bindir}/kppp*
171%{_datadir}/kde4/apps/kconf_update/*
172%{_datadir}/kde4/apps/kget
173%{_datadir}/kde4/apps/khtml/kpartplugins/kget_plug_in.rc
174%{_datadir}/kde4/apps/kopete*
175%{_datadir}/kde4/apps/krfb
176%{_datadir}/kde4/apps/krdc
177%{_datadir}/kde4/apps/remoteview
178#{_datadir}/kde4/apps/desktoptheme/default/widgets/kget.svg
179%{_datadir}/config/kopeterc
180%{_datadir}/applications/kde4/*
181%exclude %{_datadir}/applications/kde4/*ppp*.desktop
182%{_datadir}/config.kcfg/*
183%{_datadir}/dbus-1/interfaces/*
184%{_datadir}/dbus-1/services/*
185%{_datadir}/kde4/services/*
186%{_datadir}/kde4/servicetypes/*
187%{_datadir}/sounds/*
188%doc %{_docdir}/HTML/en/*
189%exclude %{_datadir}/doc/HTML/en/kppp
190%{_datadir}/icons/hicolor/*/*/*
191%{_datadir}/icons/oxygen/*/*/*
192%{_libdir}/kde4/*.so
193%{_libdir}/mozilla/plugins/skypebuttons.so
194
195%files libs
196%defattr(-,root,root,-)
197%{_libdir}/libqgroupwise.so
198%{_libdir}/lib*.so.*
199
200%files devel
201%defattr(-,root,root)
202%{_includedir}/kde4/kopete
203%{_includedir}/kde4/krdc
204%{_libdir}/lib*.so
205%exclude %{_libdir}/libqgroupwise.so
206
207%files -n kppp
208%defattr(-,root,root)
209%doc %{_datadir}/doc/HTML/en/kppp
210%config /etc/security/console.apps/kppp
211%config /etc/pam.d/kppp
212%{_bindir}/kppp*
213%{_sbindir}/kppp
214%{_datadir}/applications/kde4/*ppp*
215%{_datadir}/kde4/apps/kppp
216
217%changelog
218* Mon May 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-2
219- security fixes: CVE-2010-1000, CVE-2010-1511 (#591966)
220
221* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
222- new upstream release
223
224* Wed Apr 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
225- rebuilt with libmsn-4.1
226
227* Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
228- new upstream release
229
230* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
231- new upstream release
232
233* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
234- new upstream release
235- built with new toolchain
236
237* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
238- new upstream release
239
240* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
241- new upstream release
242
243* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
244- new upstream release
245
246* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
247- applied new versioning policy, spec in UTF-8
248- added Patch0
249
250* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
251- rebuild for VineSeed
252
253* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
254- new upstream release
255
256* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
257- rebuild for VineSeed
258
259* Sat May 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
260- new upstream release
261- add BuildPrereq: speex-devel
262
263* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
264- new upstream release
265- remove BuildPrereq: xmms-devel and Requires: xmms
266
267* Fri Nov 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
268- added --with-qt-libraries and --enable-libsuffix option
269- updated kppp.pamd
270
271* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
272- rebuild for VineSeed
273
274* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
275- new upstream release
276
277* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
278- rebuild for VineSeed
279
280* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
281- new upstream release
282
283* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
284- rebuild for VineSeed
285
286* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
287- new upstream release
288
289* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
290- rebuild for VineSeed
291
292* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
293- new upstream release
294
295* Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl3
296- rebuild with wireless-tools-28-0vl0.pre15.1
297
298* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
299- rebuild for VineSeed
300
301* Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
302- new upstream release
303
304* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
305- rebuild for VineSeed
306
307* Thu Nov 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
308- new upstream release
309
310* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
311- new upstream release
312
313* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
314- new upstream release
315- delete all patches
316
317* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
318- new upstream release
319- add Patch0 - Patch1
320
321* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
322- rebuild for VineSeed
323
324* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
325- new upstream release
326- remove Patch0
327
328* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl4
329- rebuild for VineSeed
330
331* Thu Jul 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl3
332- add Patch0 (CAN-2005-1852)
333
334* Mon Jul  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
335- build for VineSeed
336- add --disable-rpath to configure option
337
338* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
339- new upstream release
340- use %%{?_smp_mflags} for make option
341
342* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
343- rebuild for VineSeed
344
345* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
346- new upstream release
347- update %%files
348
349* Thu Jan 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
350- new upstream release
351- add BuildPrereq: xmms-devel and Requires: xmms
352
353* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
354- rebuild for VineSeed
355
356* Wed Dec 29 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
357- source upgrade
358- build for Vine Linux 3.1
359
360* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
361- source upgrade
362- update %%files
363
364* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
365- rebuild with qt32
366
367* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
368- source upgrade
369- remove lines about vine26
370
371* Thu May 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
372- move %%{_libdir}/*.so to kdenetwork package
373
374* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
375- source upgrade
376- add URL: http://www.kde.org
377
378* Sat Mar 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
379- rebuild with openssl-0.9.7d
380
381* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
382- source upgrade
383- add Obsoletes: kopete <= 0.8.0 and Provides: kopete
384- add BuildPrereq: wireless-tools-devel
385- add Requires: wireless-toolss-tools-devel
386- add Requires: wireless-tools
387
388* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
389- rebuild for VineSeedPlus
390
391* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
392- source upgrade
393- build for VinePlus/2.6
394- (VinePlus/2.6) BuildPrereq: autoconf258
395
396* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
397- build for VineSeed with new toolchain and qt-3.2.3
398
399* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
400- rebuild with qt-3.2.1-0.26vl3
401
402* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
403- rebuild with qt-3.2.1-0vl3
404
405* Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
406- build with gcc-3.2.3
407
408* Mon Sep 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
409- source upgrade
410- BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
411
412* Sat Aug  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
413- rebuild for Vine2.6
414
415* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
416- source upgrade
417- change spec to build with gcc295
418- change make option for SMP and add script
419
420* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
421- change spec to build with g++-2.95.3
422
423* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
424- source upgrade
425- remove Patch800 (included in this source)
426- add BuildPrereq: zlib-devel libjpeg-devel libpng-devel
427- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
428
429* Fri Apr  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
430- source upgrade
431- add patch800
432
433* Sat Mar  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
434- source upgrade
435- add BuildPrereq: arts >= 1:1.1
436- remove Patch0
437- disable all patches
438- change spec to make monolithic package only
439- Obsoletes: kdenetwork-libs
440
441* Sun Nov 17 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl3
442- add Patch0 (security patch)
443- add export PATH=`pwd`:$PATH to %build and %install section
444
445* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
446- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
447
448* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
449- source upgrade
450- BuildPrereq: autoconf253 objprelink2
451
452* Mon Aug 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp 3.0.3-0vl1
453- source upgrade
454
455* Tue Jul 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl2
456- add Patch801 from kde.gr.jp [Kdeveloper:02384]
457
458* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
459- source upgrade
460
461* Wed May  1 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
462- source update to 3.0
463- add configure option `--with-xinerama --enable-final'
464- add Requires
465- remove knewsticker
466- add Patch800 (from kde.gr.jp) and Patch900
467
468* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
469- merged with rawhide 3.0.0-0.cvs20020306.1
470- source update to cvs-20020329
471- add BuildPrereq: autoconf252 automake15
472- add %define monolithic 1
473- There is Vine's previous changes, hacked for Vine
474 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
475  - update to 2.2.2
476  - update Japanese patches (Patch1 to 5)
477 -- Wed Nov 28 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
478  - build for Vine Seed
479  - add Japanese patches (Patch2 to 6)
480
481* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
482- Rename subpackages
483
484* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.2
485- Rebuild with new kdelibs
486
487* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020129.1
488- Update
489
490* Tue Jan  8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020108.1
491- Update
492- Integrate ktalk stuff with xinetd
493
494* Tue Dec 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011218.1
495- Update
496- Split into subpackages
497
498* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
499- Update
500- Add build dependencies
501- Work around ia64 breakages
502
503* Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010513.1
504- Update to CVS
505- clean up specfile
506- Use %%post -p and %%postun -p
507
508* Wed Feb 21 2001 Than Ngo <than@redhat.com>
509- 2.1-respin
510
511* Mon Feb 19 2001 Than Ngo <than@redhat.com>
512- update 2.1
513- fix dangling symlinks
514
515* Fri Feb  2 2001 Bernhard Rosenkraenzer <bero@redhat.com>
516- Limit CPU usage to 2 CPUs to make asok happy
517
518* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
519- Update
520- Don't require perl, not everyone using ksirc is also using
521  ksirc perl scripting...
522
523* Mon Jan  8 2001 Bernhard Rosenkraenzer <bero@redhat.com>
524- Update (needed because of kdelibs change)
525- Obsolete kdenetwork2 (from 7.0 preview)
526
527* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
528- Update
529
530* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
531- Add missing PAM file, fix group
532
533* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
534- update to HEAD
535
536* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
537- Update CVS (fix kmail segfault with empty identity)
538
539* Tue Oct 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
540- Fix up consolehelper config
541
542* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
543- Update to current KDE_2_0_BRANCH (this should fix up knode)
544- Run kppp through consolehelper (Bug #20021)
545- Split of kppp and kppplog to a separate package, kdenetwork-ppp
546  (RFE #20022)
547
548* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
549- 2.0 final
550
551* Wed Oct  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
552- 2.0
553
554* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
555- 1.93
556
557* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
558- new version
559
560* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
561- new snapshot
562- disable keystone for now (compiler problem)
563
564* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
565- new snapshot
566- some fixes to spec file
567
568* Tue Jul 18 2000 Than Ngo <than@redhat.de>
569- rebuilt with glibc-2.1.92-14 and gcc-2.96-40
570
571* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
572- Obsolete ktalk (powertools 6.x)
573- SMPify
574
575* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
576- use gcc 2.96
577- new snapshot
578
579* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
580- Epoch
581
582* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
583- new snapshot
584- ExcludeArch ia64 for now
585
586* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
587- new snapshot
588- move it to /usr, where it belongs
589
590* Mon Oct 25 1999 Bernhard Rosenkraenzer <bero@redhat.de>
591- initial RPM
Note: See TracBrowser for help on using the repository browser.