source: projects/specs/trunk/k/kdegraphics/kdegraphics-vl.spec @ 2774

Revision 2774, 19.9 KB checked in by inagaki, 13 years ago (diff)

update: KDE 4.6.0
NEW: nepomukcontroller, openal-soft

Line 
1Name: kdegraphics
2Summary: KDE Graphics Applications
3Summary(ja): KDE グラフィックアプリケーション集
4Version: 4.6.0
5Release: 1%{?_dist_release}
6
7Group: Applications/Graphics
8License: GPLv2
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegraphics-%{version}.tar.bz2
12
13## upstreamable patches
14# okular.desktop : Categories=-Office,+VectorGraphics (http://bugzilla.redhat.com/591089)
15Patch50: kdegraphics-4.5.1-okular_dt.patch
16# don't hardcode paths in OkularConfig.cmake
17Patch51: kdegraphics-4.5.80-OkularConfig-dont-hardcode-paths.patch
18
19# Security fix
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: kdelibs4-devel >= %{version}
23BuildRequires: kdepimlibs-devel >= %{version}
24BuildRequires: chmlib-devel
25BuildRequires: djvulibre-devel
26BuildRequires: ebook-tools-devel
27BuildRequires: exiv2-devel
28BuildRequires: giflib-devel
29BuildRequires: lcms-devel
30BuildRequires: libgphoto2-devel
31BuildRequires: libspectre-devel
32BuildRequires: libtiff-devel
33BuildRequires: libXxf86vm-devel
34BuildRequires: pcre-devel
35BuildRequires: poppler-qt4-devel
36BuildRequires: qca2-devel
37BuildRequires: qimageblitz-devel
38BuildRequires: sane-devel
39BuildRequires: soprano-devel
40
41Requires: %{name}-libs = %{version}-%{release}
42# used by okular
43Requires: kio_msits = %{version}-%{release}
44Requires: cups
45
46Obsoletes: kdegraphics4 < %{version}-%{release}
47Obsoletes: kdegraphics-extras < 4.0.0
48Obsoletes: gwenview < 2
49Provides: gwenview = 2
50Provides: kdegraphics4 = %{version}-%{release}
51Conflicts: kdegraphics3
52
53Vendor: Project Vine
54Distribution: Vine Linux
55Packager: inagaki
56
57%description
58Graphics applications for KDE.
59
60What it is
61----------
62* gwenview (an image viewer)
63* kamera (digital camera support)
64* kcolorchooser (a color chooser)
65* kolourpaint4 (an easy-to-use paint program)
66* kruler (screen ruler and color measurement tool)
67* ksnapshot (screen capture utility)
68* okular (a document viewer)
69
70%description -l ja
71KDE 向けのグラフィックアプリケーション集です.
72
73以下のアプリケーションを含んでいます.
74----------
75* gwenview (画像ビューア)
76* kamera (デジタル・カメラのサポート)
77* kcolorchooser (色選択ツール)
78* kolourpaint4 (簡単に操作できるペイントプログラム)
79* kruler (スクリーン上で用いる定規、色測定ツール)
80* ksnapshot (スクリーンショットを撮るためのツール)
81* okular (ドキュメントビューア)
82
83%package libs
84Summary: Runtime libraries for %{name}
85Summary(ja): %{name} のランタイムライブラリ
86Group:   System Environment/Libraries
87Obsoletes: libkdcraw < 0.2.0, libkexiv2 < 0.4.0, libkipi < 0.2.0
88Requires: kdelibs4 >= %{version}
89
90%description libs
91%{summary}.
92
93%description -l ja libs
94%{summary}.
95
96%package devel
97Summary: Development files for kdegraphics
98Summary(ja): %{name} の開発用ファイル
99Group: Development/Libraries
100Requires: %{name}-libs = %{version}-%{release}
101Requires: kdelibs4-devel
102Obsoletes: libkdcraw-devel < 0.4.0
103Obsoletes: libkexiv2-devel < 0.4.0
104Obsoletes: libkipi-devel < 0.2.0
105Obsoletes: kdegraphics4-devel < %{version}-%{release}
106Provides:  libkdcraw-devel = 0.4.0-2
107Provides:  libkexiv2-devel = 0.5.0-1
108Provides:  libkipi-devel = 0.3.0-1
109Provides:  kdegraphics4-devel = %{version}-%{release}
110
111%description devel
112Header files for developing applications using kdegraphics.
113Install kdegraphics-devel if you wish to develop or compile
114applications using kdegraphics.
115
116%package -n kio_msits
117Summary: A kioslave for displaying WinHelp files
118Group: System Environment/Libraries
119
120%description -n kio_msits
121%{summary}.
122
123
124%prep
125%setup -q -n kdegraphics-%{version}
126%patch50 -p1 -b .okular_dt
127%patch51 -p1 -b .OkularConfig
128
129# security fix
130
131
132%build
133mkdir -p %{_target_platform}
134pushd %{_target_platform}
135unset QTDIR || : ; . /etc/profile.d/qt4.sh
136%cmake \
137    -DCMAKE_BUILD_TYPE=release \
138    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
139    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
140    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
141    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
142    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
143    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
144    ..
145popd
146
147make %{?_smp_mflags} -C %{_target_platform}
148
149%install
150rm -rf $RPM_BUILD_ROOT
151make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
152
153%post
154touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
155
156%posttrans
157gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
158update-desktop-database -q &> /dev/null ||:
159
160%postun
161if [ $1 -eq 0 ] ; then
162    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
163    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
164    update-desktop-database -q &> /dev/null ||:
165fi
166
167%post libs
168/sbin/ldconfig
169touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
170
171%posttrans libs
172gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
173
174%postun libs
175/sbin/ldconfig
176if [ $1 -eq 0 ] ; then
177    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
178    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
179fi
180
181%clean
182rm -rf $RPM_BUILD_ROOT
183
184%files
185%defattr(-,root,root)
186%doc COPYING README
187%doc %{_datadir}/doc/HTML/en/*
188%{_bindir}/*
189#{_datadir}/config/*
190%{_datadir}/applications/kde4/*
191%{_datadir}/config.kcfg/*
192%{_datadir}/kde4/services/*.desktop
193%{_datadir}/kde4/services/camera.protocol
194%{_libdir}/kde4/kcm_kamera.so
195%{_libdir}/kde4/kio_kamera.so
196%{_datadir}/kde4/services/ServiceMenus/slideshow.desktop
197%{_datadir}/kde4/servicetypes/okularGenerator.desktop
198%{_datadir}/kde4/apps/okular
199%{_datadir}/kde4/apps/kgamma
200%{_datadir}/kde4/apps/gvpart
201%{_datadir}/kde4/apps/gwenview
202%{_datadir}/kde4/apps/kolourpaint
203%{_datadir}/kde4/apps/kruler
204%{_datadir}/kde4/apps/solid/actions/*
205%{_datadir}/kde4/apps/svgpart
206%{_libdir}/kde4/gsthumbnail.so
207%{_libdir}/kde4/gvpart.so
208%{_libdir}/kde4/ksaneplugin.so
209%{_libdir}/kde4/kcm_kgamma.so
210%{_libdir}/kde4/mobithumbnail.so
211%{_libdir}/kde4/okularGenerator_*.so
212%{_libdir}/kde4/okularpart.so
213%{_libdir}/kde4/rawthumbnail.so
214%{_libdir}/kde4/svgpart.so
215%{_datadir}/dbus-1/interfaces/*.xml
216%{_datadir}/icons/hicolor/*/apps/gwenview.*
217%{_datadir}/icons/hicolor/*/apps/kcolorchooser.*
218#{_datadir}/icons/hicolor/*/apps/kgamma.*
219%{_datadir}/icons/hicolor/*/apps/kolourpaint.*
220%{_datadir}/icons/hicolor/*/apps/kruler.*
221%{_datadir}/icons/hicolor/*/apps/ksnapshot.*
222%{_datadir}/icons/hicolor/*/apps/okular.*
223%{_datadir}/icons/hicolor/*/actions/*
224
225%files libs
226%defattr(-,root,root)
227%{_datadir}/kde4/apps/kipi
228%{_datadir}/kde4/apps/libkdcraw
229%{_datadir}/kde4/apps/libkexiv2
230%{_datadir}/icons/hicolor/*/apps/kipi.*
231%{_datadir}/icons/hicolor/*/apps/kdcraw.*
232%{_datadir}/kde4/servicetypes/kipiplugin.desktop
233%{_libdir}/libgwenviewlib.so.*
234%{_libdir}/libkdcraw.so.*
235%{_libdir}/libkexiv2.so.*
236%{_libdir}/libkipi.so.*
237%{_libdir}/libkolourpaint_lgpl.so.*
238%{_libdir}/libksane.so.*
239%{_libdir}/libokularcore.so.*
240%{_libdir}/strigi/strigiea_dvi.so
241%{_libdir}/strigi/strigiea_tiff.so
242%{_libdir}/strigi/strigila_mobi.so
243
244%files devel
245%defattr(-,root,root)
246%{_includedir}/kde4/libkdcraw
247%{_includedir}/kde4/libkexiv2
248%{_includedir}/kde4/libkipi
249%{_includedir}/kde4/libksane
250%{_includedir}/kde4/okular
251%{_libdir}/lib*.so
252%{_libdir}/cmake/Okular/OkularConfig*.cmake
253%{_datadir}/kde4/apps/cmake/modules/FindKSane.cmake
254%{_libdir}/pkgconfig/*.pc
255
256%files -n kio_msits
257%defattr(-,root,root,-)
258%{_libdir}/kde4/kio_msits.so
259%{_datadir}/kde4/services/msits.protocol
260
261%changelog
262* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
263- new upstream release
264- added Patch50 and 51 from Fedora
265
266* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
267- rebuilt with rpm-4.8.1 for pkg-config
268
269* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
270- new upstream release
271- dropt Patch100 (merged into upstream)
272
273* Sun Aug 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
274- added Patch100 for CVE-2010-2575
275- updated Japanese summary
276- added Japanese description
277
278* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
279- new upstream release
280
281* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
282- new upstream release
283- added Conflicts: kdegraphics3
284
285* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
286- new upstream release
287
288* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
289- rebuilt with exiv2-0.19
290
291* Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
292- new upstream release
293
294* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
295- new upstream release
296
297* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
298- new upstream release
299- built with new toolchain
300
301* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
302- new upstream release
303
304* Tue Nov  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
305- rebuilt with poppler-qt4-devel 0.12.1
306
307* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
308- new upstream release
309
310* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
311- new upstream release
312- used %cmake macro
313
314* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
315- new upstream release
316- changed Group to Applications/Graphics
317
318* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-3
319- rebuilt with kdelibs-3.5.8-2
320- added Japanese summary, spec in UTF-8
321- added %%post, %%postun section
322
323* Wed Apr 29 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 3.5.8-2vl4
324- add Patch100 (CVE-2009-0166,CVE-2009-1180)
325- add Patch101 (CVE-2009-1182,CVE-2009-1183)
326- add BuildPrereq: arts-devel gamin-devel libidn-devel libart_lgpl-devel
327- applied vine versioning policy.
328
329* Thu Oct 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
330- rebuild for VineSeed
331
332* Thu Oct 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
333- new upstream release
334- drop Patch0
335- add Patch1 (CVE-2007-5393)
336
337* Thu Aug  2 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl4
338- add Patch0 (CVE-2007-3387)
339
340* Mon Jul 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.7-0vl3
341- added --with-qt-libraries configure option
342
343* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
344- rebuild for VineSeed
345
346* Sat May 26 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
347- new upstream release
348
349* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
350- new upstream release
351
352* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
353- rebuild for VineSeed
354
355* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
356- new upstream release
357
358* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
359- rebuild for VineSeed
360
361* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
362- new upstream release
363
364* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
365- rebuild for VineSeed
366
367* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
368- new upstream release
369
370* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
371- rebuild for VineSeed
372
373* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
374- new upstream release
375- drop Patch0
376
377* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
378- add BuildPrereq: libexif-devel for VineSeed
379
380* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
381- new upstream release
382- update Patch0
383
384* Thu Jan  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl3
385- rebuild for VineSeed
386
387* Thu Jan  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl3
388- update Patch0 (http://www.kde.org/info/security/advisory-20051207-2.txt)
389
390* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
391- rebuild for VineSeed
392
393* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
394- new upstream release
395- add Patch0 (post-3.5.0-kdegraphics-CAN-2005-3193.diff)
396
397* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
398- new upstream release
399
400* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
401- new upstream release
402- delete all patches
403
404* Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
405- new upstream release
406- add Patch1 - Patch2
407- drop Patch0
408
409* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
410- rebuild for VineSeed
411
412* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
413- new upstream release
414
415* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
416- build for VineSeed
417- add --disable-rpath to configure option
418
419* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
420- new upstream release
421- use %%{?_smp_mflags} for make option
422
423* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
424- rebuild for VineSeed
425
426* Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
427- new upstream release
428- remove patch1 and patch2
429- build kamera, remove source1 and add Requires: gphoto2
430- update %%files
431
432* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl4
433- build for VineSeed
434- add BuildPrereq: libusb-devel
435
436* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl3
437- add Patch2 (http://www.kde.org/info/security/advisory-20050119-1.txt)
438
439* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
440- rebuild for VineSeed
441
442* Sat Jan  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
443- new upstream release
444- add patch1 (http://www.kde.org/info/security/advisory-20041223-1.txt)
445
446* Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
447- source upgrade
448
449* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
450- rebuild with qt32
451
452* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
453- source upgrade
454- remove lines about vine26
455
456* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
457- source upgrade
458- add URL: http://www.kde.org
459- add BuildPrereq: lcms-devel >= 1.09 fribidi-devel >= 0.10.4
460
461* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
462- add patch0 and Requires: xpdf (http://bugs.kde.org/76302)
463
464* Sun Mar 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
465- source upgrade
466
467* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
468- rebuild for VineSeedPlus
469
470* Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
471- source upgrade
472- build for VinePlus/2.6
473- (VinePlus/2.6) BuildPrereq: autoconf258
474
475* Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
476- build for VineSeed with new toolchain and qt-3.2.3
477
478* Sun Nov  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
479- rebuild with qt-3.2.1-0.26vl3
480
481* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
482- rebuild with qt-3.2.1-0vl3
483
484* Tue Sep 23 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
485- source upgrade
486- change spec to build with gcc-3.2.3
487
488* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
489- source upgrade
490- change spec to build with gcc295
491- change make option for SMP and add script
492
493* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
494- source upgrade
495- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
496
497* Sat Apr 12 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1a-0vl1
498- source upgrade
499- change spec to build both VineSeed and Vine2.5/2.6
500- change spec to make monolithic package only
501- revised description and files section
502
503* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
504- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
505
506* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
507- source upgrade
508- BuildPrereq: autoconf253 objprelink2
509
510* Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
511- source upgrade
512
513* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
514- source upgrade
515
516* Wed May  8 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
517- source update to 3.0
518- add BuildPrereq: xpdf
519- some files are divided to kdegraphics-devel
520- kdvi now works
521
522* Sun Mar 31 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
523- merged with rawhide 3.0.0-0.cvs20020306.1
524- source update to cvs-20020329
525- add BuildPrereq: autoconf252 automake15
526- add %define with_kamera 0
527- add %define monolithic 1
528- delete kdvi (it is broken)
529- There is Vine's previous changes, hacked for Vine
530 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
531  - update to 2.2.2
532  - stop removing kpaint (it works now)
533 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
534  - Delete Epoch
535  - Change BuildRequires and Requires
536  - objprelink (i386 only)
537  - Build for VineSeed
538  - remove kpaint (it does not work)
539
540* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
541- Update
542- Rename subpackages
543- Don't build kamera on alpha
544
545* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
546- Update
547- Reorganize package
548
549* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
550- The -devel package has kscan-related files -n only. Since kscan isn't built
551  on s390/s390x, don't build the devel package there.
552
553* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010724.1
554- Add more build dependencies (#48970)
555- Remove ia64 workarounds, no longer needed
556- Update
557
558* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.1
559- Restore -devel package, got lost during the update
560- Fix build on s390/s390x
561- Update
562
563* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.2
564- Make symlinks relative
565- Update
566
567* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
568- 2.1-respin
569
570* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
571- 2.1
572
573* Fri Feb 16 2001 Than Ngo <than@redhat.com>
574- fix to build against glibc
575
576* Tue Feb  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
577- Get rid of libkdefakes.so.0 dependency
578
579* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
580- Update
581
582* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
583- Update
584
585* Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
586- Update
587- Stop excluding ia64
588
589* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
590- Update to HEAD
591
592* Fri Nov  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
593- Update to KDE_2_0_BRANCH
594
595* Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
596- 2.0 final
597
598* Thu Aug 24 2000 Than Ngo <than@redhat.com>
599- update to kdegraphics-1.93
600
601* Sun Aug 20 2000 Than Ngo <than@redhat.com>
602- add missing kdegraphic2 package
603
604* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
605- new version
606
607* Tue Jul 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
608- new snapshot
609- work around compiler bug by disabling kcoloredit for now, FIXME
610
611* Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
612- new snapshot
613- SMPify build
614
615* Sun Jul 16 2000 Than Ngo <than@redhat.de>
616- use gcc 2.96
617- new snapshot
618- fix docdir
619
620* Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
621- Add Epoch - for some reason, rpm thinks 1.1.2 > 1.92.20000623.
622
623* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
624- new snapshot
625- ExcludeArch ia64 for now
626
627* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
628- new snapshot
629- move it to /usr, where it belongs
630
631* Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
632- Fix compilation
633
634* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
635- 2.0 CVS
636
637* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
638- mark doc files as such
639
640* Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
641- upgraded to 1.1.2 release
642
643* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
644- snapshot, includes kde 1.1.1 + fixes
645
646* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
647- last snapshot before release
648
649* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
650- latest stable snapshot
651
652* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
653- Injected new description and group.
654
655* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
656- upgraded to KDE 1.1 final.
657
658* Sat Feb 06 1999 Preston Brown <pbrown@redhat.com>
659- updates to new libstdc++ and rpm standards.
660
661* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
662- re-merged in updates from Duncan Haldane
663
Note: See TracBrowser for help on using the repository browser.