source: projects/specs/trunk/k/kdegames/kdegames-vl.spec @ 7294

Revision 7294, 17.7 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.9.5

Line 
1Name: kdegames
2Summary: KDE Games
3Summary(ja): KDE ゲーム集
4Version: 4.9.5
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Games
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: desktop-file-utils
15BuildRequires: ggz-client-libs-devel
16BuildRequires: kdelibs4-devel >= %{version}
17BuildRequires: libsndfile-devel
18BuildRequires: libXpm-devel
19BuildRequires: openal-soft-devel
20BuildRequires: qca2-devel
21BuildRequires: qhull-devel
22BuildRequires: python-devel
23BuildRequires: PyQt4-devel
24BuildRequires: PyKDE4-devel
25BuildRequires: sqlite3-devel
26BuildRequires: python-twisted
27
28Requires: %{name}-libs = %{version}-%{release}
29Requires: PyKDE4
30Requires: python-twisted
31Requires(post): ggz-client-libs
32Requires(post): desktop-file-utils
33Requires(preun): ggz-client-libs
34Requires(postun): desktop-file-utils
35
36Obsoletes: kdegames4 < %{version}-%{release}
37Provides:  kdegames4 = %{version}-%{release}
38
39Obsoletes: ksudoku < 0.5-1
40Provides:  ksudoku = 0.5-1
41
42Obsoletes: ksirk < %{version}-%{release}
43Provides:  ksirk = %{version}-%{release}
44
45%description
46Games for the K Desktop Environment 4, including:
47* bomber
48* bovo
49* kapman
50* katomic
51* kblackbox
52* kblocks
53* kbounce
54* kbreakout
55* kdiamond
56* kfourinline
57* kgoldrunner
58* killbots
59* kiriki
60* kjumpingcube
61* klines
62* klickety
63* kmahjongg
64* kmines
65* knetwalk
66* kolf
67* kollision
68* konquest
69* kpat
70* kreversi
71* ksame
72* kshisen
73* ksinkships
74* ksirk
75* kspaceduel
76* ksquares
77* ksudoku
78* ktuberling
79* kubrick
80* lskat
81
82%package libs
83Summary: Runtime libraries for %{name}
84Summary(ja): %{name} のランタイムライブラリ
85Group:   System Environment/Libraries
86
87%description libs
88%{summary}.
89
90%package devel
91Summary: Development files for %{name}
92Summary(ja): %{name} の開発用ファイル
93Group: Development/Libraries
94Requires: %{name}-libs = %{version}-%{release}
95Requires: kdelibs4-devel
96Obsoletes: kdegames4-devel < %{version}-%{release}
97Provides:  kdegames4-devel = %{version}-%{release}
98
99%description devel
100Development files for the KDE gaming libraries.
101Install kdegames-devel if you wish to develop or compile games for the
102KDE desktop.
103
104%prep
105%setup -q -n kdegames-%{version}
106
107%build
108mkdir -p %{_target_platform}
109pushd %{_target_platform}
110%cmake \
111    -DCMAKE_BUILD_TYPE=release \
112    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
113    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
114    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
115    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
116    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
117    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
118    -DINSTALL_KAJONGG=TRUE \
119    -DSKIP_GGZCONFIG=1 \
120    ..
121popd
122
123make %{?_smp_mflags} -C %{_target_platform}
124
125%install
126rm -rf $RPM_BUILD_ROOT
127make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
128
129# move devel symlinks
130mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
131pushd $RPM_BUILD_ROOT%{_libdir}
132for i in lib*.so
133do
134  case "$i" in
135# conflicts with kdegames3
136    libkdegames.so )
137      linktarget=`readlink "$i"`
138      rm -f "$i"
139      ln -sf "../../$linktarget" "kde4/devel/$i"
140      ;;
141  esac
142done
143popd
144
145
146%check
147for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
148  desktop-file-validate $f
149done
150
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post
156touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
157touch --no-create %{_datadir}/icons/locolor &> /dev/null || :
158touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
159update-mime-database %{_datadir}/mime &> /dev/null || :
160
161%posttrans
162gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
163gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null || :
164gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
165update-desktop-database -q &> /dev/null ||:
166
167%postun
168update-mime-database %{_datadir}/mime &> /dev/null || :
169if [ $1 -eq 0 ] ; then
170    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
171    touch --no-create %{_datadir}/icons/locolor &> /dev/null || :
172    touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
173    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
174    gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null || :
175    gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
176    update-desktop-database -q &> /dev/null ||:
177fi
178
179%post libs -p /sbin/ldconfig
180
181%postun libs -p /sbin/ldconfig
182
183%files
184%defattr(-,root,root)
185%doc AUTHORS README
186%{_bindir}/*
187%{_datadir}/kde4/apps/*
188%{_datadir}/config/*
189%{_datadir}/sounds/*.ogg
190%{_datadir}/sounds/kshisen/*.ogg
191%{_datadir}/sounds/kapman/
192%{_datadir}/applications/kde4/*
193%{_datadir}/config.kcfg/*
194%{_datadir}/kde4/services/kbattleship.protocol
195%{_datadir}/kde4/services/ServiceMenus/palapeli_servicemenu.desktop
196%{_datadir}/kde4/services/pala*.desktop
197%{_datadir}/kde4/servicetypes/libpala-slicerplugin.desktop
198%doc %{_docdir}/HTML/en/*
199%{_datadir}/icons/hicolor/*/*/*
200%{_datadir}/icons/locolor/*/*/*
201%{_datadir}/icons/oxygen/*/*/*
202%{_libdir}/libkcardgame.so
203%{_libdir}/kde4/pala*.so
204%{_datadir}/mime/packages/kpatience.xml
205%{_datadir}/mime/packages/palapeli-mimetypes.xml
206#{_sysconfdir}/ggz.modules.d/kdegames
207
208%files libs
209%defattr(-,root,root,-)
210%doc COPYING
211%{_libdir}/lib*.so.*
212
213%files devel
214%defattr(-,root,root)
215%{_includedir}/kde4/*
216%{_libdir}/lib*.so
217%exclude %{_libdir}/libkcardgame.so
218%{_libdir}/kde4/devel/lib*.so
219%dir %{_libdir}/libpala/
220%{_libdir}/libpala/*.cmake
221%{_libdir}/cmake/KDEGames
222
223%changelog
224* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
225- new upstream release
226
227* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
228- new upstream release
229
230* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
231- new upstream release
232
233* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
234- new upstream release
235
236* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
237- new upstream release
238- add BuildRequires: python-devel, PyQt4-devel, PyKDE4-devel, sqlite3-devel, python-twisted
239
240* Thu Aug  4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
241- new upstream release
242
243* Sun Jun 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
244- new upstream release
245
246* Mon Mar 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
247- new upstream release
248
249* Tue Mar  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-2
250- added BR: libXpm-devel
251
252* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
253- new upstream release
254- added BR: openal-soft-devel, qhull-devel
255
256* Sat Aug 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
257- new upstream release
258
259* Tue Jul  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
260- new upstream release
261- added Conflict: kdegames3
262
263* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
264- new upstream release
265
266* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
267- new upstream release
268- built with new toolchain
269
270* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
271- new upstream release
272
273* Mon Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
274- new upstream release
275
276* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
277- new upstream release
278
279* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
280- new upstream release
281
282* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
283- applied new versioning policy, spec in UTF-8
284
285* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
286- rebuild for VineSeed
287
288* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
289- new upstream release
290
291* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
292- rebuild for VineSeed
293
294* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
295- new upstream release
296
297* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
298- new upstream release
299
300* Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
301- added --with-qt-libraries and --enable-libsuffix option
302
303* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
304- rebuild for VineSeed
305
306* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
307- new upstream release
308
309* Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
310- changed Group to Applications/Games
311- added Japanese summary
312
313* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
314- rebuild for VineSeed
315
316* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
317- new upstream release
318
319* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
320- rebuild for VineSeed
321
322* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
323- new upstream release
324
325* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
326- rebuild for VineSeed
327
328* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
329- new upstream release
330
331* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
332- rebuild for VineSeed
333
334* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
335- new upstream release
336
337* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
338- rebuild for VineSeed
339
340* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
341- new upstream release
342
343* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
344- new upstream release
345
346* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
347- new upstream release
348
349* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
350- new upstream release
351
352* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
353- rebuild for VineSeed
354
355* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
356- new upstream release
357
358* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
359- build for VineSeed
360- add --disable-rpath to configure option
361
362* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
363- new upstream release
364- use %%{?_smp_mflags} for make option
365
366* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
367- rebuild for VineSeed
368
369* Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
370- new upstream release
371
372* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
373- new upstream release (3.4.0-rc1)
374- update %%files
375
376* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
377- rebuild for VineSeed
378
379* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
380- source upgrade
381- build for Vine Linux 3.1
382
383* Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
384- source upgrade
385
386* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
387- rebuild with qt32
388
389* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
390- source upgrade
391- remove lines about vine26
392- add URL: http://www.kde.org/
393
394* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
395- source upgrade
396
397* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
398- move *.so to main package
399
400* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
401- source upgrade
402
403* Thu Feb  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
404- source upgrade
405
406* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
407- rebuild for VineSeedPlus
408
409* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
410- source upgrade
411- build for VinePlus/2.6
412- (VinePlus/2.6) BuildPrereq: autoconf258
413
414* Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
415- build for VineSeed with new toolchain and qt-3.2.3
416
417* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
418- rebuild with qt-3.2.1-0.26vl3
419
420* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
421- rebuild with qt-3.2.1-0vl3
422
423* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
424- source upgrade
425- build with gcc-3.2.3
426
427* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
428- source upgrade
429- change spec to build with gcc295
430- change make option for SMP and add script
431
432* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
433- change spec to build with g++-2.95.3
434
435* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
436- source upgrade
437- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
438
439* Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
440- source upgrade
441- change spec to build both VineSeed and Vine2.5/2.6
442
443* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
444- source upgrade to 3.1-stable
445
446* Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
447- source upgrade to 3.1rc7
448- stop using objprelink2, it does not work with gcc3
449- change spec to make monolithic package only
450- move %{_libdir}/*.la and %{_libdir}/*.so to devel package
451- add %{_libdir}/kde3/*
452- cleanup spec
453
454* Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
455- source upgrade
456
457* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
458- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
459- add Prereq: ldconfig
460- add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
461- add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
462
463* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
464- source upgrade
465- BuildPrereq: autoconf253 objprelink2
466
467* Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
468- source upgrade
469
470* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
471- source upgrade
472
473* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
474- source update to 3.0.1
475
476* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
477- source update to 3.0
478- add configure option `--with-xinerama --enable-final'
479- add kbounce
480
481* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
482- merged with rawhide 3.0.0-0.cvs20020306.1
483- source update to cvs-20020329
484- add BuildPrereq: autoconf252 automake15
485- There is Vine's previous changes, hacked for Vine
486 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
487  - update to 2.2.2
488 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
489  - Delete Epoch
490  - Change BuildRequires and Requires
491  - objprelink (i386 only)
492  - Build for VineSeed
493
494* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
495- Fix packaging glitch in monolithic version
496
497* Tue Mar  5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
498- Make splits a buildtime option (off by default) on request
499
500* Mon Jan  7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
501- Update to work with latest kdelibs changes
502
503* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
504- Update
505- Add missing %{_bindir}/kbattleship
506
507* Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
508- Update
509- Split into several packages (one package per game)
510
511* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
512- Update
513- Work around ia64 breakages
514- Add build requirements (#48977)
515
516* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
517- Fix problem when changing the card type (Bug #28824)
518
519* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
520- 2.1-respin
521
522* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
523- 2.1
524
525* Sun Feb 11 2001 Than Ngo <than@redhat.com>
526- don't use make -j CPU, it's broken
527
528* Thu Feb  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
529- Run ldconfig in %%post and %%postun to make libkdegames happy
530- Replace absolute symlinks with relative symlinks (#24787)
531
532* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
533- Update
534- includedir=/usr/include/kde,
535  now that libkdegames installs kcarddeck.h
536
537* Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
538- Get rid of the gcc bug workaround, it's no longer needed
539
540* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
541- Update
542- Don't exclude ia64
543
544* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
545- Update to HEAD
546
547* Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
548- Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
549
550* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
551- 2.0 final
552
553* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
554- 2.0
555
556* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
557- new CVS
558- work around g++ bugs (in kjumpingcube)
559
560* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
561- 1.93
562
563* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
564- new version
565
566* Wed Jul 19 2000 Than Ngo <than@redhat.de>
567- fix docdir
568- rebuild 16 July snapshot
569
570* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
571- SMPify
572- don't hardcode QTDIR
573
574* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
575- use gcc 2.96
576- new snapshot
577
578* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
579- new snapshot
580- ExcludeArch ia64 for now
581
582* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
583- new snapshot
584- move it to /usr, where it belongs
585
586* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
587- 2.0 snapshot
588
589* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
590- mark doc files as such
591
592* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
593- 1.1.2 release.
594
595* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
596- snapshot, includes kde 1.1.1 + fixes
597
598* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
599- last snapshot before release
600- ripped out asteroids and sirtet
601
602* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
603- latest stable snapshot
604
605* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
606- Injected new description and group.
607
608* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
609- upgraded to KDE 1.1 final.
610
611* Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
612- rebuilt for new libstdc++ etc.
613
614* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
615- re-merged updates from Duncan Haldane, change /opt/kde --> /usr
616
Note: See TracBrowser for help on using the repository browser.